13:01:00 <sgallagh> #startmeeting rolekit (2015-09-15)
13:01:00 <zodbot> Meeting started Tue Sep 15 13:01:00 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:00 <sgallagh> #meetingname rolekitweekly
13:01:00 <sgallagh> #chair sgallagh twoerner nilsph
13:01:00 <sgallagh> #topic init process
13:01:00 <zodbot> The meeting name has been set to 'rolekitweekly'
13:01:00 <zodbot> Current chairs: nilsph sgallagh twoerner
13:01:08 <sgallagh> Hello, folks
13:01:14 <nilsph> hi
13:01:21 <twoerner> .hello twoerner
13:01:23 <zodbot> twoerner: twoerner 'Thomas Woerner' <twoerner@redhat.com>
13:01:28 <sgallagh> .hello sgallagh
13:01:29 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
13:01:36 <nilsph> .hello
13:01:36 <zodbot> nilsph: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
13:01:42 <nilsph> ah
13:01:48 <nilsph> .hello nilsph
13:01:49 <zodbot> nilsph: Sorry, but you don't exist
13:01:53 <sgallagh> (FAS account)
13:01:57 <nilsph> oh thanks, I can go home now
13:02:02 <nilsph> .hello nphilipp
13:02:03 <zodbot> nilsph: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
13:02:03 <sgallagh> /me grins
13:02:12 <sgallagh> OK, we have quorum
13:02:19 <sgallagh> #topic Fedora 23 Status
13:02:23 <nilsph> zodbot: you stupid g*t, you know my IRC nick
13:02:41 <sgallagh> nilsph: It's not that clever with the .hello
13:02:48 <nilsph> obviously
13:03:15 <sgallagh> ok, so first up. We're in Beta Freeze and (wonder of wonders) we actually closed all the Beta targeted issues!
13:03:34 <sgallagh> #info All issues targeted for Fedora 23 Beta were fixed.
13:03:43 <nilsph> yay!
13:04:10 <sgallagh> #info Current issues targeted for Fedora 23 Final have patches under review on Review Board
13:04:29 <sgallagh> #link http://reviewboard-fedoraserver.rhcloud.com/r/
13:05:26 <sgallagh> Once the current reviews land, I'm going to declare 0.4.0 final. Additional bugs discovered after that will go to 0.4.1
13:06:12 <sgallagh> twoerner: What are your thoughts on the D-BUS changes; I'm leaning towards keeping them on master rather than putting them in 0.4.0
13:06:17 <nilsph> sgallagh: NB that the unit files cleanup thingy is only partially solved by the review I submitted yesterday
13:06:18 <sgallagh> Since it's potentially-risky
13:06:31 <sgallagh> nilsph: ok, good to know
13:06:51 <twoerner> sgallagh: the D-Bus changes should be fine even for 0.4.1
13:06:56 <twoerner> in my opinion
13:07:01 <nilsph> sgallagh: I did put that into the description :)
13:07:11 <sgallagh> twoerner: Well, if we're going to make that change, I'd rather do it in a .0
13:07:19 <twoerner> since there is only limited amount of new code
13:07:28 <twoerner> 0.4.0?
13:07:30 <twoerner> :-)
13:07:31 <sgallagh> (In my mind, that's the right place for architecture stuff)
13:07:52 <nilsph> .oO(...0.4.1.0...)
13:07:59 <sgallagh> twoerner: If we test it well enough and are comfortable it doesn't break anything, we can get it in 0.4.0, yes
13:08:07 <sgallagh> I'm just overly-wary at the end of a dev cycle
13:08:23 <sgallagh> /me *really* doesn't want to be the reason for a slip
13:08:41 <twoerner> do you think there will be no slip this time?
13:09:08 <twoerner> that would be surprising somehow
13:09:47 <twoerner> it does not matter if it will make it into 0.4.0
13:10:22 <twoerner> but with the ongoing discussions, it might be good to at least review and push it before ....
13:10:24 <sgallagh> twoerner: Right now, we're on track (I think) to release Beta on time
13:10:30 <sgallagh> Hopefully that carries through
13:10:49 <sgallagh> But yes, I'm going to review it immediately. If you're confident enough, I'll trust you.
13:11:19 <twoerner> just give it some tries..
13:11:21 <sgallagh> It would be nice if we could tell the python-dbus maintainer that they don't have to carry the properties patch any longer either
13:11:29 <sgallagh> Of course
13:11:34 <twoerner> ohh yes
13:11:51 <twoerner> this is the reason I wanted to have this patch ready sooner than later
13:12:03 <sgallagh> /me nods
13:12:25 <sgallagh> OK, I'll do my best to get that patch reviewed after this meeting, before the Server SIG meeting.
13:12:36 <twoerner> thanks
13:12:48 <sgallagh> (After that, I'm booked solid for the next four hours)
13:12:51 <twoerner> please have a look at the dependencies in reviewboard
13:12:54 <sgallagh> Yes
13:13:13 <sgallagh> OK, shall we do a quick bug triage?
13:13:18 <twoerner> yes
13:13:25 <sgallagh> #topic Bug Triage
13:13:40 <sgallagh> #link https://github.com/libre-server/rolekit/issues?q=is%3Aopen+no%3Amilestone+no%3Alabel
13:13:58 <sgallagh> We can start from the lowest issue number and work up
13:14:20 <sgallagh> #topic https://github.com/libre-server/rolekit/issues/40 - Instance name should not contain "/"
13:14:21 <twoerner> hmm.. all opened by me
13:14:24 <sgallagh> heh
13:14:30 <twoerner> all but onw
13:14:31 <twoerner> one
13:15:09 <sgallagh> So, this one I think is going to be a problem eventually
13:15:25 <twoerner> why a problem?
13:15:29 <sgallagh> I'd like to see this fixed for 0.4.0, if possible (But surely not a blocker)
13:15:47 <sgallagh> twoerner: IIRC, it will actually cause additional directories to be created.
13:16:02 <sgallagh> So it's possible that this could be used for an inode-exhaustion attack
13:16:15 <sgallagh> (Though unlikely, since you already need to be root, I guess)
13:16:39 <sgallagh> Still, input validation should be an easy thing to fix, yes?
13:17:00 <twoerner> I think this should be fairly simple to implement
13:17:19 <twoerner> but we need to define the allowed character set
13:17:24 <sgallagh> Also, related to the question at the end: I'd propose limiting it to [A-Za-z_-]
13:17:32 <sgallagh> err, add a dot as well
13:17:47 <sgallagh> [A-Za-z._-]
13:17:53 <twoerner> and @?
13:18:03 <sgallagh> No @
13:18:10 <sgallagh> That would actually cause problems for the systemd services
13:18:16 <twoerner> yes, right
13:18:35 <twoerner> but maybe we can reuse it there
13:18:42 <sgallagh> Hmm?
13:19:25 <sgallagh> twoerner: What did you mean by "reuse it there"?
13:20:24 <twoerner> the @ is used for services for example vncserver
13:20:43 <twoerner> for the display name
13:20:48 <twoerner> :1, :2, ...
13:21:17 <nilsph> it's for "unit factories"
13:21:20 <sgallagh> Right, but I'm saying that allowing a user to specify @ in the role instance name would likely cause systemd to get confused.
13:21:23 <nilsph> not sure if wee need it
13:21:23 <twoerner> so a name of @:1 would be a good name for a vncserver role
13:21:28 <nilsph> sgallagh: yes
13:21:45 <twoerner> but we could do this also in adifferent way..
13:21:54 <sgallagh> If we wanted to implement that ourselves under the hood, that's fine. But I don't want to allow the user to make that decision
13:21:59 <twoerner> ok.. we can add it later on if needed
13:22:16 <nilsph> twoerner: but an instance has its own unit files, so it wouldn't need an @ -- it doesn't need a unit factory
13:23:31 <twoerner> ok.. forget about this
13:24:31 <sgallagh> OK, so [A-Za-z._-] then?
13:24:55 <sgallagh> Oops, [A-Za-z0-9._-]
13:25:13 <nilsph> +1
13:25:21 <twoerner> +1
13:25:36 <sgallagh> #agreed We will restrict instance names to [A-Za-z0-9._-]
13:25:54 <sgallagh> twoerner: Can you do that for 0.4.0/F23 Final?
13:26:50 <twoerner> I think that should be possible
13:26:57 <twoerner> what is the dead line for final?
13:27:00 <sgallagh> Thanks
13:27:17 <sgallagh> twoerner: Oct 10th
13:27:24 <twoerner> ok.. yes
13:28:12 <sgallagh> #agreed Scheduled for Fedora 23 Final
13:28:17 <sgallagh> Moving on
13:28:29 <sgallagh> #topic https://github.com/libre-server/rolekit/issues/45 - Put instances in error state if it is transitional while roled starts
13:29:01 <sgallagh> Short version is that no role should ever be in a transitional state when roled starts up.
13:29:12 <twoerner> yes
13:29:13 <sgallagh> If it is, it indicates that roled must have crashed or been killed during execution.
13:29:40 <sgallagh> So at startup we should forcibly move anything in "transitional" to "error"
13:29:53 <sgallagh> Note: we have to do this before we start accepting requests from D-BUS or we might have a race
13:31:35 <sgallagh> I will look into this one myself for Final.
13:31:54 <sgallagh> Given that there's really no way to clean these up if they break right now, I think it's pretty important to have.
13:32:06 <twoerner> I agree
13:32:21 <sgallagh> I'm prepared to call this a blocker also.
13:32:34 <twoerner> this is a blocker
13:32:42 <twoerner> in my opinion
13:33:03 <nilsph> yup
13:33:03 <nilsph> +1
13:33:07 <twoerner> +1
13:33:07 <sgallagh> #agreed F23 Final Blocker , assigned to sgallagh
13:33:35 <sgallagh> #topic https://github.com/libre-server/rolekit/issues/46 - Use accessors for name and type in roles
13:33:38 <nilsph> I've also seen instances being in "deploying" after restarting the machine, is that covered as well?
13:33:48 <twoerner> it should be simple to do in DBusRole.__init__
13:33:50 <sgallagh> nilsph: Yes
13:33:54 <nilsph> :)
13:34:01 <twoerner> after loading the role instance settings
13:34:17 <sgallagh> twoerner: Mind adding that as a comment to the bug, so it's easy to recall?
13:34:35 <alxgrtnstrngl> sgallagh, sorry to interrupt but what's the timeline for F24?
13:34:50 <sgallagh> OK, so 46 is already under review
13:35:14 <sgallagh> alxgrtnstrngl: We're looking for major functionality to be testable by Jan. 1st 2016
13:35:37 <sgallagh> And to be functionally complete by March 1st
13:35:50 <nilsph> sgallagh: Just out of curiosity, is the reason why we use accessor methods dbus? I mean instead of Python properties.
13:35:53 <alxgrtnstrngl> sgallagh, thanks
13:36:29 <sgallagh> nilsph: Direct that one at twoerner. He wrote the accessors :)
13:36:36 <nilsph> heh
13:37:17 <sgallagh> twoerner: So given that 46 is already under review, shall we just go with F23 Final, nice-to-have?
13:39:29 <twoerner> sgallagh: the patch for 46 made it in already
13:39:39 <twoerner> 40ced6db15614063d15fbc4e82793d8cf9bac1d4
13:39:41 <sgallagh> Oh, right.
13:39:46 <sgallagh> I'll close it then
13:40:19 <twoerner> we can use python properties in the future for this..
13:40:34 <sgallagh> #info Already fixed. Closing issue.
13:40:46 <twoerner> but this needs more verification
13:40:56 <sgallagh> #topic https://github.com/libre-server/rolekit/issues/47 - `rolectl list instances` should color-code instances
13:41:07 <twoerner> especially with the still to generate simplified property handling in the roles
13:41:25 <sgallagh> This is firmly in the nice-to-have camp, but it would be *very* nice to have :)
13:41:41 <twoerner> (r 36)
13:42:01 <twoerner> yes.. 47 is nice to have
13:42:25 <sgallagh> Certainly not necessary in the F23 timeframe though.
13:42:28 <sgallagh> F24 Alpha?
13:42:31 <twoerner> +1
13:43:00 <twoerner> if there is still time left i the end, we could do it earlier
13:43:07 <sgallagh> True enough
13:43:27 <twoerner> s/i the/in the/
13:43:37 <sgallagh> If we somehow finish up early, we can look at pulling some stuff in.
13:43:46 <sgallagh> But I'd prefer to assume we'll have our hands full :)
13:43:55 <twoerner> yes, most likely
13:44:03 <sgallagh> #agreed F24 Alpha, nice-to-have
13:44:25 <sgallagh> #topic https://github.com/libre-server/rolekit/issues/48 - Use class name for RolekitErrors in the log
13:44:40 <sgallagh> This one is also closed
13:44:57 <sgallagh> #info Already pushed upstream
13:45:23 <twoerner> #49 also
13:45:34 <sgallagh> #topic https://github.com/libre-server/rolekit/issues/49 - Create backup of settings in case of role deployment fails
13:45:36 <sgallagh> #info Already pushed upstream
13:45:37 <twoerner> and #50
13:45:55 <twoerner> or not?
13:46:13 <twoerner> nope - #50 is open still
13:46:17 <sgallagh> #topic https://github.com/libre-server/rolekit/issues/50 - Store last error in role instance settings
13:46:32 <sgallagh> I'm on the cusp of marking that one ShipIt.
13:46:55 <sgallagh> It passed visual inspection, but I couldn't test it because of the Vagrant kerfluffle
13:47:11 <twoerner> kerfluffle?
13:47:27 <sgallagh> twoerner: "boondoggle"?
13:47:54 <sgallagh> (Sorry, probably doesn't translate. Just colorful terms for an active mess)
13:50:02 <sgallagh> OK, so F23 Final, nice-to-have?
13:50:31 <nilsph> sgallagh: I told twoerner of our issues yesterday
13:50:45 <twoerner> yes.. I have been there 2 weeks ago alrady
13:50:48 <twoerner> already
13:51:08 <twoerner> and messed up the image in the fist try
13:51:11 <sgallagh> whee
13:51:24 <twoerner> but the second was successful
13:51:39 <twoerner> hopefully there is no need to do this dance again
13:51:51 <twoerner> s/fist/first/
13:52:00 * twoerner misses some characters
13:52:02 <sgallagh> twoerner: Well, unfortunately there's a bunch of stuff wrong with Vagrant on F23 it seems
13:52:12 <sgallagh> I have to recreate the box often
13:52:13 <twoerner> I am on F-22 still
13:52:18 <sgallagh> Yeah, I'm not :)
13:52:28 <sgallagh> Anyway, F23 Final, nice-to-have?
13:53:11 <twoerner> the patch is submitted for review already .. but ok
13:53:46 <sgallagh> twoerner: Right, this is bookkeeping :)
13:54:43 <nilsph> +1 for bookkeeping
13:54:50 <sgallagh> #agreed F23 Final, nice-to-have
13:54:53 <sgallagh> #topic Open Floor
13:54:57 <sgallagh> Anything for open floor this week?
13:55:00 <twoerner> +1
13:56:13 <sgallagh> I'm interpreting that as "no".
13:56:30 <sgallagh> OK, thanks for coming folks. I'll get to work on those reviews right now before the meeting-storm hits.
13:56:46 <twoerner> thanks
13:57:30 <nilsph> thanks
13:58:48 <sgallagh> #endmeeting