00:02:29 <mchua> #startmeeting
00:02:29 <zodbot> Meeting started Sat Mar  3 00:02:29 2012 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:02:35 <mchua> #chair kwurst sdziallas heidie ghislop
00:02:35 <zodbot> Current chairs: ghislop heidie kwurst mchua sdziallas
00:02:43 <mchua> #meetingname SIGCSE 2012 TOS workshop
00:02:43 <zodbot> The meeting name has been set to 'sigcse_2012_tos_workshop'
00:02:49 <mchua> #topic Getting started
00:06:28 <mchua> We're getting started -- not all the registered attendees are here, but that's okay.
00:10:40 <mchua> #topic introductions
00:10:53 <mchua> Kristina - Union College, POSSE alum
00:11:15 <mchua> Joe -- Carnegie Mellon, runs "Technology Consulting in the Global Community"
00:11:30 <mchua> Sambit -- Fayetteville State -- biotech & mobile
00:11:47 <mchua> Jay -- Stanford, just started getting students involved
00:12:00 <mchua> Alyce -- Kalamazoo, encourages students to use, but hasn't gotten them contributing yet
00:12:12 <mchua> Michelle -- Drexel, mainly a user of FOSS
00:12:34 <mchua> David -- U Penn, has used FOSS for years, sees a FOSS project heading in the wrong direction and wants to get in and fix it
00:12:48 <mchua> Myungsook -- California Lutheran, wants to get started contributing
00:13:03 <mchua> Dorothy -- North Carolina A&T, uses FOSS tools in classes for 3-4 years but not contributing yet
00:13:35 <mchua> (feel free to help us take notes here!)
00:13:50 <mchua> #info Lots of people have used FOSS, and had their students use FOSS in classes, but very few have gotten students to contribute.
00:14:57 <mchua> Going over the schedule.
00:15:01 <mchua> #link http://teachingopensource.org/index.php/SIGCSE_2012/Workshop_materials
00:15:26 <kwurst> #link http://openetherpad.org/TOSworkshop2012
00:16:47 <mpurcell> thx
00:17:30 <kwurst> Greg is covering the history of FOSS
00:17:58 <mchua> #info The average FOSS project has 1 contributor.
00:18:11 <kwurst> #topic What is FOSS and TOS
00:18:15 <mchua> #info 50% of FOSS contributions are by employees paid to do it.
00:19:20 * sdziallas is also live tweeting this...
00:23:01 <kwurst> Mel is recording "FOSSisms" on the wall...
00:23:35 <kwurst> #topic FOSS Fieldtrip
00:25:47 <kwurst> #link ohloh.net
00:26:04 <kwurst> #link http://ohloh.net
00:26:35 <kwurst> #link http://sourceforge.net
00:27:33 <mchua> sdziallas: we have a problem -- too many connections to freenode
00:27:33 <kwurst> Heidi is looking at "disaster" projects on Sourceforge
00:27:36 <mchua> sdziallas: can you come out here?
00:27:46 <mchua> sdziallas: i'm out of ideas
00:27:51 <sdziallas> oh, yes. let me come over.
00:28:29 <kwurst> Heidi is narrowing the choices by status
00:28:55 * sdziallas signing off here.
00:29:23 <kwurst> Heidi has found a lot of projects that are in the "beta" stage
00:31:36 <kwurst> Heidi is now showing Ohloh and looking at the Cheese project
00:33:21 <mchua> welcome myungsook!
00:33:56 <kwurst> "Decreasing year-over-year activity" may not be a warning sign - it may just mean that the project is becoming stable.
00:34:21 <kwurst> #info "Decreasing year-over-year activity" may not be a warning sign - it may just mean that the project is becoming stable.
00:41:02 <kwurst> #info Ohloh will let you compare (up to) 3 projects to each other
00:42:00 <kwurst> #info "updated about x hours ago" means the Ohloh data, project commmits
00:43:24 <kwurst> #info "updated about x hours ago" means the Ohloh data, *not* project commits
00:44:48 <mchua> kwurst: I put a list of some tools in the etherpad, in case it helps for your section.
00:45:24 <kwurst> #info You need to hit enter after each project name you put into the Ohloh project comparison
00:46:41 <kwurst> The workshop attendees are exploring Ohloh on their own...
00:51:34 <kwurst> Mel is wallpapering the room with giant post-its
00:55:08 <mchua> A question from myungsook -- for someone who's just getting started, would you choose to contribute to a large project, or a small one?
00:55:31 <mchua> my response: I'd personally choose a large and active one, because they will be more used to getting new people started and will probably have more documentation/tutorials for you.
00:55:45 <mchua> (all those people that make it a "large" project must have been newbies sometime!)
00:56:01 <heidinow> And a large community has more people to help
00:56:02 <mchua> #info Mel's recommendation: choose a large project (not a small one) for your first community.
00:56:05 <mchua> heidinow: +1
00:56:19 <mchua> note for folks following in chat -- I've also listed these in the etherpad.
00:56:24 <mchua> http://openetherpad.org/TOSworkshop2012
00:57:09 <heidinow> kwurst is talking about the usefulness of list archives
00:57:18 <mchua> The archives he's talking about:
00:57:20 <heidinow> They're a really good resource for finding the answers to questions
00:57:20 <mchua> #link http://lists.teachingopensource.org/pipermail/tos/
00:58:11 <heidinow> kwurst is touting the joys of IRC. Yeah!
00:58:48 <mchua> #idea Use IRC for "office hours"
00:59:06 <mchua> Question: is there a one-line command for starting meetings?
00:59:30 <mchua> Answer: Yes, right now we are using Fedora's bot (zodbot)
00:59:34 <mchua> #link http://fedoraproject.org/w/index.php?title=Zodbot&oldid=262493
00:59:51 <mchua> #info You can use bots on IRC to help you keep track of meeting notes (the above link is an example with documentation)
01:03:05 <heidinow> IRC provides a great log of student meetings
01:03:29 <heidinow> IRC logs also provide great examples for students of both professional behavior and collaborative problem solving.
01:04:03 <mchua> #idea IRC logs of open source project meetings provide good artifacts for class discussion of professional behavior
01:04:42 <mchua> #info "Why use this old-fashioned 80's technology?" Because that's where everyone is, *and* low-bandwidth internet connections in some parts of the world means it's the only one that's equally accessible by all.
01:04:55 <mchua> #info "IRC is the water cooler -- it's where people who know things hang out."
01:05:21 <mchua> #info Some projects have their version control systems automatically make announcements into an IRC channel.
01:05:35 <mchua> #info Holding office hours on IRC means students can also see and answer each other's questions.
01:05:53 <mchua> Question: for office hours, do you have your own IRC channel, or do you use a project's existing channel?
01:06:30 <mchua> Answers vary -- you might want to create a "sandbox" channel for your class for them to learn syntax.
01:06:47 <mchua> IRC also used for cross-institutional collaboration, so students from different schools working on the same FOSS project have a way to hang out in realtime.
01:07:10 <mchua> Talking about Etherpad.
01:07:17 <heidinow> mchua is the best logger!
01:07:18 <mchua> #info Etherpad is a brower-based collaborative text editor.
01:07:29 <mchua> sdziallas: you should talk about how your CS class took notes on it.
01:07:52 <mchua> heidinow: (tell sebastian since he's not online -- to mention the FoCS notes)
01:08:14 <mchua> #info people have etherpad instances hosted that you can try
01:08:17 <mchua> #link http://openetherpad.org
01:12:24 <Joe____> I missed the meaning of the sole circle on the wall poster.
01:27:34 <kwurst> #topic break
01:28:16 <kwurst> Everyone is eating cupcakes and editing EtherPad
01:30:56 <kwurst> #topic FOSS culture principles step-back
01:31:53 <kwurst> We are now deciphering Mel's wallpaper designs
01:32:20 <kwurst> #action Take photos of the walls and post them on the wiki
01:33:45 <heidie> Mel has been identifying the FOSSism through out the first part of the workshop.
01:34:16 <heidie> Now she is explaining what these mean and how they relate to education.
01:36:43 <heidie> #info In FOSS, the feature set is continually being developed.
01:37:14 <heidie> #info A release involves first making a set of features happen and then deciding which features in that set should be included in the release.
01:42:50 <kwurst> Mel is filling the big empty circle
01:43:53 <heidie> Example of a Roadmap (OpenMRS): #link https://wiki.openmrs.org/display/docs/Road+Map
01:44:01 <kwurst> The circle represents the amount of time spent on projects
01:44:39 <kwurst> New code is a small slice, more is old code, but ~75% is communication
01:45:13 <kwurst> Climbing the "contributor mountain"
01:46:43 <kwurst> #link http://quaid.fedorapeople.org/TOS/Practical_Open_Source_Software_Exploration/html/sn-Introduction_to_Free_and_Open_Source_Software-Climbing_Contributor_Mountain.html
01:47:32 <kwurst> The link above is from the Teaching Open Source textbook: Practical Open Source Software Exploration
01:48:28 <kwurst> #link http://teachingopensource.org/index.php/Textbook
01:50:31 <heidie> Student reluctance to admit lack of knowledge can be a barrier to moving from user to seeker.
01:52:02 <kwurst> The solution(?) is to be a broken record - keep reminding them to ask the community when they get stuck
01:55:02 <JBB_> It is important for OS community to recognize this issue and not contribute to it by being snarky when newbies post dumb questions - I have seen this numerous times and its a killer
01:58:28 <kwurst> #topic Course examples (Greg, Heidi, Karl, and Sebastian - Mel leads backchannel notes)
01:59:14 <heidie> kwurst has done two FOSS courses
01:59:23 <heidie> Freshman survey course on openness.
01:59:44 <heidie> Tried to have students create their own community using a wiki.
02:00:03 <heidie> Then worked on editing Wikipedia
02:00:22 <heidie> This worked generally well, except students didn't fully understand rules.
02:01:25 <heidie> Also did a software development course. First time students self-selected projects but there could have been more communication with the community.
02:01:37 <heidie> Second time around (now), entire class in one project.
02:02:17 <heidie> Easier to interact with single community and students have a vested interest in listening to other students discuss progress on the project.
02:04:42 <kwurst> heidie has taught software development twice using FOSS
02:06:00 <kwurst> The community is doing most of the educating, Heidi is mostly making sure that they are staying on the right path and not asking stupid questions
02:07:33 <kwurst> heidie took her students to the Gnome summit in Boston. They met about 100 of the main Gnome developers.
02:08:38 <kwurst> Her students proposed an unconference session on the caribou keyboard that they wanted to work on. Their session was selected, and got a private hour-long tutorial session from a developer.
02:10:27 <kwurst> This may require that you be more flexible in your schedule to be opportunistic when opportunities arise
02:12:06 <kwurst> ghislop Drexel started with an independent study, then moved on to a class
02:13:23 <mchua> kis also started with a club that met every other week, I think
02:13:24 <heidie> #link http://www.xcitegroup.org/softhum/doku.php?id=f:assignments   Beginning activities, some of which are useful for students with no background in computing
02:13:30 <kwurst> You can have freshman/sophomore students do the FOSS field trip and see how a community works - no coding necessary
02:13:52 <mchua> #info lurking is a great way to start learning -- see how your students understand what they're observing
02:14:04 <kis> that's right. It was a club for female computer science students and other female students interestedin computing.
02:14:44 <mchua> kis: ooh, there's that idea of how FOSS (especially humanitarian FOSS projects, or helping a local nonprofit use FOSS) can help broaden participation.
02:14:45 <kis> And we took a break because I was on sabbatical. But we are going to start again because the students came and asked for it :-)
02:15:02 <mchua> kis: awesome! any chance we can get the students to blog or something? ;)
02:15:07 <ianweller> mchua: ping
02:15:17 <heidie> #link http://www.xcitegroup.org/softhum/doku.php?id=g:getting_started  Getting started...
02:15:35 <kis> That's  a good idea. I will encourage them to blog.
02:15:37 <mchua> ianweller: pong
02:15:55 <kwurst> #link opensouce.com
02:16:00 <ianweller> mchua: would it be off-topic for the meeting to quickly talk about tos.o
02:16:00 <heidie> #link http://www.xcitegroup.org/softhum/doku.php?id=s:initialconversation  Actual student conversation getting started in a project.
02:16:18 <mchua> kis: matt jadud had a nice writeup on that at http://sububi.org/2009/07/27/the-busy-students-guide-to-project-blogging/
02:16:22 <mchua> #link http://sububi.org/2009/07/27/the-busy-students-guide-to-project-blogging/
02:16:49 <mchua> kis: they can set up free wordpress blogs, and then we can get them on Planet TOS if you like
02:17:12 <mchua> kis: i spent most of my semester helping my grad school classmates set up blogs, so I'd be happy to help anyhow I can :)
02:17:43 <mchua> Heidi: "Do the community part first, do the code part second."
02:17:48 <mchua> "as academics, we want to solve the problem."
02:17:56 <mchua> kwurst: struggling to think of a good way to summarize what heidi's saying
02:19:02 <mchua> "what I've found is that if I start my students with the technical part, they don't get involved with the community"
02:19:17 <mchua> "but if they do the community first, then the code part goes faster and they can get help when they need it"
02:19:22 <mchua> #info Do community first, code second.
02:20:49 <mchua> Question: if students are working on small bugs -- why haven't these small bugs already been fixed?
02:21:02 <mchua> Answer: core developers don't have time to fix them -- they're going after the big ones.
02:21:20 <mchua> #info core developers are usually too busy to fix the tiny easy bugs -- which means they're left undone for students to do (and get great gratitude for!)
02:21:35 <kwurst> #topic Course workshopping (individual instructors lead small groups)
02:54:04 <kwurst> #topic wrap-up
02:55:16 <kwurst> heidie is mentioning TOS
02:55:23 <kwurst> #link http://teachingopensource.org
02:55:59 <kwurst> Join the teachingopensource list:
02:56:38 <kwurst> #link: http://teachingopensource.org/index.php/TeachingOpenSource_Mailing_List/Join
02:57:50 <kwurst> #action Post these minutes to the wiki
02:58:12 <kwurst> #action Email the minutes links to the attendees
02:58:25 <kwurst> #action Email the wiki link to the attendees
02:59:13 <kwurst> #action Organizers will update the wiki page with more resources
03:00:11 <kwurst> #endmeeting