04:06:52 <mchua> #startmeeting
04:06:52 <zodbot> Meeting started Mon Nov  9 04:06:52 2009 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:06:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
04:28:36 <ctyler> mchua: yeah, trying to get transbot up. it quit with an error. is it useful, or is the translation too bad?
04:28:47 <ctyler> if it's useful, I'll try to keep it going
04:31:20 <ctyler> .en
04:31:57 <ctyler> ^ just telling transbot what language is used here
04:32:24 <ctyler> please let me know if transbot0 is helpful or not
04:34:08 <transbot0> transbot0 has been kicked by gin0
04:43:20 * ctyler gets transbot0 running again
04:43:31 <ctyler> testing...
04:44:48 <ctyler> configured transbot to respawn if it fails
04:53:21 <transbot0> SCLew has disconnected
04:54:29 <ctyler> mchua: I'm going to bed, if transbot0 is useful, it should stay in the channel. If it is not useful and you want to get rid of it, I think you can just ban it from the channel. I just set it to 60 second between reconnects in case you do need to ban it.
04:59:15 <transbot0> liangsuilong has joined: #teachingopensource-posse-zh
05:00:51 <transbot0> tiansworld has joined: #teachingopensource-posse-zh
05:10:48 <transbot0> tiansworld has disconnected
05:13:38 <transbot0> tiansworld has joined: #teachingopensource-posse-zh
05:16:29 <transbot0> tira has disconnected
05:16:43 <mchua> The amazing Chris Tyler has gotten transbot up between this channel and #teachingopensource-posse-zh
05:17:57 <mchua> Is the translation good?
05:24:25 <hers> nop :p
05:24:37 <mchua> #link http://fpaste.org
05:24:44 <mchua> #link http://pastebin.org
05:25:23 <transbot0> hers> mchua ~ # link get translated too
05:27:08 <transbot0> mchua> hers: huh, interesting!
05:29:13 <transbot0> Kaio has joined: #teachingopensource-posse-zh
05:29:20 <Kaio> testing
05:29:49 <Kaio> hello
05:30:04 <Kaio> h e l l o
05:30:17 <martz927> can paste the URL here?
05:30:20 <harish-upfront> http://fpaste.org/sV3Z/
05:30:23 <harish-upfront> mchua, look at that ^^
05:31:15 <mchua> http://fpaste.org
05:31:18 <mchua> http://pastebin.org
05:31:36 <mchua> What is IRC?
05:31:38 <mchua> Internet Relay Chat
05:31:45 <transbot0> zhangxinyi has joined: #teachingopensource-posse-zh
05:31:47 <mchua> This is the original chatting mechanism between people.
05:32:05 <mchua> IRC lets multiple people talk at once.
05:32:22 <Kaio> sorry I am still reading the website about POSSE
05:32:27 <transbot0> liangsuilong has disconnected
05:32:31 <mchua> The challenge we have in this classroom is that there is a certain port that you usually use to connect to IRC, which is port 6667.
05:32:36 <mchua> Unfortunately, it's been blocked here at NYP.
05:32:37 <transbot0> yipch has joined: #teachingopensource-posse-zh
05:32:44 <mchua> So that is why we are currently using the webchat version of IRC.
05:33:06 <mchua> So the question was "can I see history?"
05:33:13 <mchua> the answer is "usually, yes, but not with webchat"
05:33:20 <mchua> however, we've been logging these channels, so you can read those logs
05:33:49 <mchua> #link http://meetbot.fedoraproject.org/teachingopensource-posse
05:33:55 <mchua> #link meetbot.fedoraproject.org/teachingopensource-posse-zh
05:34:03 <mchua> #link http://meetbot.fedoraproject.org/fedora-zh
05:34:10 <mchua> #link http://meetbot.fedoraproject.org/teachingopensource-posse-zh
05:35:58 <transbot0> martz927 has disconnected
05:36:27 <transbot0> YeLong has disconnected
05:38:09 <harish-upfront> hey everyone, we made a channel
05:38:16 <harish-upfront> you might want to /join #nyp-sg
05:39:22 <transbot0> yipch has quit #teachingopensource-posse-zh
05:42:02 <mchua> #info DELIVERABLE 1: your first post to the posse-apac mailing list
05:42:03 <mchua> #link http://teachingopensource.org/mailman/listinfo/posse-apac
05:43:46 <transbot0> bel5f51 has joined: #teachingopensource-posse-zh
05:44:28 <transbot0> hers> English words, we have http://groups.google.com/group/fedora-cn mailing list
05:45:52 <transbot0> hers> (not an official one, but many fedora contributors do appear there)
05:46:11 <mchua> #link http://planet.fedoraproject.org
05:46:16 <harish-upfront> http://planet.fedoraproject.org/
05:46:20 <transbot0> YeLong has disconnected
05:46:21 <mchua> #link http://teachingopensource.org/index.php/Planet
05:47:17 <YeLong> history
05:57:34 <martz927> knock knock
05:59:34 <mchua> Questions?
05:59:50 <mchua> #info DELIVERABLE #2: Blog post to a Planet (either Fedora or Teaching Open Source)
06:00:01 <tira> Can the blog on planet be created by the owner?
06:00:02 <transbot0> bel5f5 has disconnected
06:00:06 <mchua> tira: yes.
06:00:09 <YeLong> test
06:00:14 <mchua> tira: you can make everything except for your own wiki page.
06:00:18 <martz927> done with mailing list
06:00:22 <martz927> now for blog post
06:00:23 <mchua> martz927: great!
06:00:28 <tira> wiki page must be created by someone else?
06:01:01 <mchua> #info DELIVERABLE #3: A user page on either the TOS or Fedora wiki, *but* you can't edit it yourself, you need to get someone on IRC to make it for you.
06:01:11 <mchua> tira: Yep.
06:01:16 <transbot0> Kaio> Test
06:01:39 <mchua> I'
06:01:44 <mchua> Whoops. Typo.
06:02:34 <harish-upfront> tinyurl.com
06:02:41 <harish-upfront> to create shortened urls
06:02:48 <harish-upfront> a
06:02:48 <harish-upfront> a
06:02:48 <harish-upfront> a
06:02:49 <harish-upfront> a
06:02:50 <harish-upfront> a
06:02:50 <harish-upfront> a
06:02:51 <harish-upfront> d
06:02:52 <harish-upfront> g
06:03:04 <mchua> Ask lots of questions here. :) Keep us updated.
06:03:11 <transbot0> YeLong has disconnected
06:03:15 <mchua> Who's working on setting up a blog?
06:03:29 <transbot0> YeLong_ has disconnected
06:05:03 <Jaric> what we suppose to do in pt 2?
06:06:07 <mchua> Who's working on deliverable #2?
06:06:14 <pohyee-cheong> I am
06:06:14 <transbot0> Long has disconnected
06:06:16 <mchua> And who needs to make a blog?
06:06:20 <pohyee-cheong> I do
06:06:25 <Jaric> I
06:06:25 <mchua> Great. :)
06:06:26 <tira> mchua : can you please help in setting up a blogg?
06:06:30 <Jaric> I
06:06:39 <mchua> Yep. I'm going to be walking people through setting up a blog here.
06:06:54 <mchua> We'll be using Wordpress.
06:07:30 <Kaio> I am a fedora packager, might be I could help?
06:07:36 <transbot0> hers> Chinese blog, then you can blogbus.com register, or yo2.cn the like, can be used to export RSS
06:08:15 <mchua> Kaio: Yes! We won't be doing packaging today, but we're getting people started with their Fedora accounts - getting blogs on Planet, getting user pages on the wiki (for which they'll have to join their first group)
06:08:29 <mchua> Okay, so people making blogs: I'm going to walk you through making one on http://wordpress.com first
06:08:35 <mchua> and then we will talk about other alternatives that you can use.
06:08:54 <mchua> so if you're making a blog right now, head over to http://wordpress.com
06:09:12 <mchua> And click the "sign up now" button
06:09:25 <Kaio> mchua☺ ok, how long does posse last?
06:09:38 <harish-upfront> Kaio: till friday this week
06:09:49 <Kaio> okay, mostly at day time?
06:09:58 <mchua> Kaio: Yes, Singapore daytime.
06:10:00 <harish-upfront> Kaio: yes GMT+8
06:10:30 <Kaio> I am at +10
06:10:39 <mchua> Great, that's not too far off.
06:10:58 <mchua> .fas Kaio
06:10:58 <zodbot> mchua: cchance '' <cchance@redhat.com> - kaio '' <k@kaio.me> - kaiomarcio 'kaio marcio' <kaio.marcio@gmail.com>
06:11:09 <mchua> .fas mchua
06:11:09 <zodbot> mchua: mchua 'Mel Chua' <mel@redhat.com>
06:11:11 <mchua> Kaio: nice to meet you :)
06:11:22 <Kaio> mchua☺ nice to meet you colleague :)
06:11:33 <harish-upfront> .fas harishpillay
06:11:33 <zodbot> harish-upfront: harishpillay 'Harish Pillay' <harish.pillay@gmail.com>
06:11:43 <tira> .fas
06:11:45 <zodbot> tira: (fas <query>) -- Search the Fedora Account System usernames, full names, and email addresses for a match.
06:11:53 <azneita> .fas azneita
06:11:53 <zodbot> azneita: azneita 'Heherson Pagcaliwagan' <herson@azneita.org>
06:12:19 <Kaio> the translation in the another channel is too funny
06:12:28 <mchua> Kaio: I bet. Google translate is hilarious sometimes. :D
06:12:37 <mchua> Okay, blog-making folks, how are you doing?
06:12:52 <tira> .fas mchua
06:12:53 <zodbot> tira: mchua 'Mel Chua' <mel@redhat.com>
06:12:56 <martz927> here is my profile - http://fpaste.org/xiQw/
06:13:13 <martz927> u can use this to update my wiki page
06:13:13 <mchua> When you're making a wordpress.com account, you want to use the "give me a blog" option
06:13:26 <mchua> martz927: now  you just need to persuade someone in this channel to work with you and do it :)
06:13:45 <mchua> anyone here working on their user page, and want to pair up with martz927? ^^^
06:14:33 <transbot0> Kaio has quit #teachingopensource-posse-zh
06:14:41 <transbot0> Jaric has disconnected
06:14:54 <mchua> For amusement, here's my first blog post for POSSE: http://blog.melchua.com/2009/11/08/posse-apac-day-0-whats-up-and-how-can-we-deploy-multilingual-awesome/
06:14:59 <hers> martz927~ I can do that for you
06:15:08 <transbot0> jasonchong has disconnected
06:15:38 <mchua> People making blogs! Notice that you can make blogs in Chinese on wordpress, too.
06:15:39 <mchua> #link http://zh.wordpress.com/signup/
06:15:47 <hers> .fas martz927
06:15:47 <zodbot> hers: 'martz927' Not Found!
06:16:05 <mchua> IMPORTANT: If you are lost at *any* point, TELL US! Ask questions here. Otherwise we won't know.
06:16:14 <martz927> huh?
06:16:15 <mchua> hers, martz927: that's because martz927 hasn't yet created a Fedora account
06:16:22 <hers> mchua~ I'd suggest to use blogbus.com or yo2.cn for Chinese people because wordpress is blocked in china. thanks to GFW.
06:16:26 <martz927> hold on
06:16:33 <mchua> hers: Yikes. Thanks.
06:16:45 <Kaio> hers☺ how about blogspot?
06:16:57 <mchua> I've found blogspot to be blocked in China too.
06:17:14 <Kaio> mchua☺ very bad then
06:17:22 <harish-upfront> livejournal.com is blocked in China as well.
06:17:58 <harish-upfront> GFW = Great China Firewall
06:17:59 <mchua> We'll keep doing this until the hour, and then take a short break to check in (in person) on how everyone is doing.
06:18:04 <mchua> Great Firewall of China.
06:18:16 <mchua> hey harish-upfront, want to trade wiki user pages? ;)
06:18:23 * hers I use livejournal personally. long live LJ.
06:18:25 <mchua> we can set a good example
06:18:29 <martz927> where to register for fedora acct?
06:18:31 <harish-upfront> mchua: sure
06:18:35 <jasonchong> do u guys get dc from here often?
06:18:45 <Kaio> I set up my wordpress on my private server.
06:18:46 <mchua> jasonchong: dc?
06:18:52 <jasonchong> disconnected
06:19:01 <mchua> jasonchong: Oh - no, I haven't gotten disconnected yet.
06:19:08 <harish-upfront> dc == disconnected - not sure.
06:19:14 <mchua> jasonchong: are you getting disconnected a lot?
06:19:27 <mchua> harish-upfront: you're going to have to make an account on http://teachingopensource.posse
06:19:35 <mchua> harish-upfront: on the wiki, I mean
06:19:37 <mchua> harish-upfront: mine is Mchua
06:20:02 <mchua> (bloggers, how are you doing? When you have a blog up, and a first post, then we can get you all hooked into planet)
06:20:03 <martz927> https://admin.fedoraproject.org/accounts/user/new
06:20:40 <mchua> martz927: you found it!
06:23:32 <mchua> harish-upfront: let me know when you have an account
06:24:15 <mchua> martz927: did you find someone to work with on the user page?
06:25:20 <hers> mchua~ do you mean a User:HomePage? what's the account name it will be?
06:25:50 <martz927> not yet
06:25:54 <martz927> fedora acct is martynyap
06:25:59 <martz927> shld be up alrdy
06:26:42 <mchua> hers: ^^ martz927 is working to make his - the catch for the assignment is that they have to make user pages, *but* they're not allowed to edit their own page
06:26:44 <hers> .fas martynyap
06:26:44 <zodbot> hers: 'martynyap' Not Found!
06:26:55 <mchua> hers: it's designed to force everyone to learn how to collaborate on IRC ;)
06:27:00 <martz927> hmmmz
06:27:02 <mchua> hers: ^^ martz927 is working to make his - the catch for the assignment is that they have to make user pages, *but* they're not allowed to edit their own page
06:27:19 <hers> ok.. then if anyone need help, I can lend a hand
06:27:20 <jasonchong> done with blog n fedora account: chongwk              wat else?
06:27:21 <mchua> hm, I wonder where zodbot gets its data from - there might be a time delay in syncing
06:27:32 <mchua> jasonchong: do you have a blog post on Planet Fedora?
06:27:49 <mchua> jasonchong, martz927: the next step is to get your blog on Planet Fedora (and/or on Planet TOS)
06:27:59 <jasonchong> im stil on earth. how to get to planet f?
06:28:05 <transbot0> hers> This translation really terrible
06:28:41 <mchua> jasonchong, martz927: http://fedoraproject.org/wiki/Planet_HowTo may help
06:29:25 <mchua> jasonchong, martz927: I found it by going down to the very bottom of the left sidebar, there is an "add your blog" link
06:29:30 <transbot0> yipch has disconnected
06:30:01 <mchua> jasonchong, martz927: there is also a similar link somewhere on http://teachingopensource.org/index.php/Planet
06:30:07 <mchua> but I won't tell you where it is ;)
06:30:14 <martz927> agreeing to some CLA now
06:30:14 <azneita> http://teachingopensource.com/index.php/User:Azneita
06:31:07 <jaric> fyi, ports 22 and 6667 is opened
06:31:40 <jaric> please test it
06:31:43 <martz927> done
06:32:23 <mchua> jaric: testing
06:32:38 <transbot0> CanoeBerry has disconnected
06:32:56 <martz927> my profile can be updated now - http://fpaste.org/xiQw/
06:33:01 <martz927> my profile can be updated now - http://fpaste.org/xiQw/
06:33:08 <mchua> martz927: link to blog post?
06:33:17 <martz927> soon
06:33:44 <mchua> martz927: it probably won't show up on the Planet until later today, or possibly until your second post, by the way; it sometimes takes an hour or so for Planet to catch up
06:33:55 <mchua> martz927: I'm not sure exactly how often it syncs, but you could ask in the #fedora-admin channel if you want to find out
06:34:07 <mchua> martz927: that's where the Fedora Infrastructure team (our volunteer sysadmins) hang out
06:34:12 <mchua> they are extremely cool.
06:34:32 <martz927> so we skip it?
06:35:42 <harish-upfront> planet.teachingopensource.org takes 24 hrs to get a feed in I think.
06:35:56 <mchua> martz927: Well, you can mark yourself on the whiteboard as *probably* having completed the blog exercise, but we'll have to check tomorrow to see if everyone's gotten a post to show up ;)
06:36:27 <mchua> martz927: but yeah, if you think you are on Planet Fedora or on Planet TOS now (getting on Planet TOS is really easy; you might as well do both) you can move on to do something else
06:36:43 <martz927> k
06:36:45 <mchua> martz927: it sounded like hers is willing to help out with your user page stuff
06:37:05 <mchua> Folks making blogs: how are we doing?
06:37:06 <martz927> thanks!
06:37:13 <harish-upfront> mchua: http://teachingopensource.org/index.php/Roll_Call to add me please
06:37:25 <jaric> sign up, what's next?
06:37:35 <mchua> harish-upfront:  you can add yourself if you make a wiki account, which you'll need to have a user page anyway.
06:37:42 <mchua> jaric: what are you trying to do?
06:38:00 <mchua> jaric: still can't get on irc via port 6667 (using xchat) - any way you'd recommend to test it?
06:38:01 <jaric> which site to create wiki account?
06:38:27 <jaric> will let pohyee knows 6667 not working
06:38:39 <mchua> jaric: http://fedoraproject.org/wiki or http://teachingopensource.org - one or the other or both
06:38:53 <mchua> jaric: (though after you do one, the second one takes almost no time at all - it's pretty much the same thing - and it's good to have both)
06:39:02 <jaric> cool, thankyou mel
06:39:03 <mchua> jaric: I'd probably do the Fedora one first
06:39:05 <mchua> fwiw
06:39:23 <harish-upfront> mchua: http://fpaste.org/ubBV/
06:39:25 <mchua> azneita: Oh hey, Heherson, I'm going to be in Manila this weekend
06:39:43 <mchua> (and on Monday and Tuesday)
06:40:56 <harish-upfront> tira: phone number is for future voice capabilities
06:41:12 <mchua> harish-upfront: and Fedora Talk?
06:41:20 <harish-upfront> mchua: yes
06:41:23 <mchua> harish-upfront: I've never actually used Fedora Talk, since I can't hear
06:41:38 <mchua> so I don't actually know how it works, but if it's something that would be good to demo at some point, I'm game
06:41:53 <mchua> harish-upfront: what username?
06:42:20 <harish-upfront> now folks, look up on the screen. i am trying to run x-chat which is another tool to do IRC, but I cannot connect due to port 6667 not being opened up for us.
06:43:20 * mchua looks
06:43:53 <jasonchong> hmm
06:44:05 <jasonchong> any1 run the ssh and succeed? wat did i missed ssh accountname@fedorapeople.org
06:44:20 <martz927> u need to generate yr ssh keys
06:44:27 <martz927> i think
06:44:32 <jasonchong> how
06:44:42 <martz927> ssh-keygen -t rsa
06:44:56 <harish-upfront> jasonchong: port 22 is blocked.
06:45:06 <jasonchong> nice ^^
06:45:16 <martz927> so we skip it?
06:45:17 <harish-upfront> annoying i'd say.
06:45:20 <harish-upfront> yes for now.
06:45:35 <jasonchong> yea nice=annoying lol
06:46:00 <harish-upfront> I will get my 3g network going but because all the other machines are wired, it is not going to be helpful.
06:46:26 <harish-upfront> i can hack the network to make the route to go through a wired machine which has the 3g dongle.
06:46:32 <jasonchong> -.-'
06:46:54 <harish-upfront> point the default route to a machine in the lab that has the 3g routing setup.  let me work on this.
06:47:44 <martz927> i got the 3g dongle
06:47:51 <martz927> but i cannot auth
06:49:47 <mchua> harish: still need your TOS wiki username, so can haz put userpage stuff in
06:50:22 <martz927> ssh-keygen -t rsa
06:50:59 <hers> .fas martynyap
06:50:59 <zodbot> hers: 'martynyap' Not Found!
06:51:08 <martz927> still dont have?
06:51:11 <transbot0> jaric has disconnected
06:51:16 <hers> martz927~ still not signed the CLA I believe
06:51:23 <martz927> https://fedoraproject.org/wiki/User:Martynyap
06:51:31 <transbot0> harish has disconnected
06:51:34 <martz927> i signed already = ]
06:51:43 <mchua> In about 10 minutes we'll come together and take a break and see how everyone is doing
06:51:47 <hers> ok, see that.
06:51:52 <mchua> and get a chance to stretch our legs and rest our fingers too
06:55:34 <martz927> i upload the id_rsa.pub for which acct?
06:55:40 <martz927> my username or root?
07:03:38 <hers> martz927~ I don't see others as active as you, why?
07:04:01 <martz927> hmmmz ... coz there are 9 pple left?
07:04:02 <martz927> haha
07:04:10 <martz927> alan-san
07:04:13 <transbot0> zodbot has disconnected
07:04:14 <martz927> u're here
07:04:32 <hers> well, you are active since the very beginning, when playing the nick switch game
07:04:48 <jaric_> update your task status here http://spreadsheets.google.com/ccc?key=0AsveKEJesg4udE1sM0xQM1hKdVZxXzYtMlYzSUZVS1E&hl=en_GB
07:05:26 <martz927> anyway i reg my nick already
07:05:31 <martz927> its martz927
07:05:33 <martz927> hehe
07:07:08 <transbot0> pohyee-cheong has disconnected
07:07:18 <transbot0> CanoeBerry__ has disconnected
07:08:26 <aho> Everyone having fun?
07:15:43 <martz927> how to ssh to fedorapeople.org
07:16:21 <azneita> martz927: you have to give fas your ssh key so you can log into fp.o
07:16:41 <martz927> is it the id_rsa.pub file?
07:16:47 <azneita> after that ssh to <your nick>.fedorapeople.org
07:16:52 <azneita> that's right
07:17:06 <martz927> i got a permission denied
07:17:36 <azneita> it would be great if you can fill in all the other fields too
07:18:14 <azneita> from fas application or from your workstation?
07:20:25 <martz927> i upload the id_rsa.pub via fas app
07:20:40 <martz927> than tried to connect to fedorapeople via workstation
07:22:20 <azneita> give fas some time :)
07:22:32 <azneita> i also experienced that my 1st time :)
07:23:12 <transbot0> raeLLL has joined: #teachingopensource-posse-zh
07:23:19 <raeLLL> hello, all
07:23:29 <transbot0> raeLLL> You Well
07:23:31 <transbot0> raeLLL> It was Yao
07:23:43 <transbot0> raeLLL> I do not know is what POSSE
07:24:11 <transbot0> raeLLL> Automatic translation呀?
07:24:31 <transbot0> raeLLL> transbot0: the original is a robot that can automatically translate呀
07:24:57 <raeLLL> transbot0: could you translate to Chinese -zh?
07:25:21 <raeLLL> transbot0: 是不简单
07:25:32 <transbot0> raeLLL> transbot0: simple
07:25:46 <jaric_> POSSE : http://teachingopensource.org/index.php/POSSE_APAC
07:26:04 <martz927> i see
07:29:11 <raeLLL> martz927: I've seen that page, and follow its irc channel to here,
07:29:25 <raeLLL> martz927: could you introduce more about what's going on?
07:29:46 <martz927> there is a class running right now
07:30:09 <martz927> pple from APAC are learning how we can use FOSS tools to teach student
07:30:12 <raeLLL> martz927: that event is starting from today?
07:30:20 <martz927> yups ... just started today
07:30:21 <raeLLL> http://blog.melchua.com/ seems good report,
07:31:05 <raeLLL> and help professors to learn open source?
07:31:24 <martz927> hmmmz
07:31:32 <martz927> wont say help
07:31:55 <raeLLL> Who is      Mel Chua      mel at melchua.com
07:32:20 <martz927> she is talking to the audience now
07:32:56 <raeLLL> martz927: and you are another organizer?
07:33:29 <martz927> nope
07:33:35 <martz927> im the participant
07:33:54 <mchua> harish:  *still* need your username ;)
07:34:08 <harish> harishpillay
07:34:16 <mchua> harish: thank you!
07:34:25 <transbot0> Kaio has disconnected
07:36:27 <raeLLL> http://teachingopensource.org/index.php/POSSE_APAC_Planning , it seems need more volunteers, to do what?
07:36:37 <raeLLL> calling for more participants, to do what?
07:37:36 <raeLLL> if I am to participate, what will I do, to demonstrate some open source projects, or as a student to learn something?
07:37:53 <raeLLL> what kind of participants does it need?
07:38:18 <raeLLL> martz927: mchua
07:38:39 <mchua> raeLLL: We're giving everyone an immersion crash course in contributing to the Fedora community.
07:39:14 <mchua> So folks like azneita and hers have been in the channel helping out and answering questions, giving tips, telling the professors about what it's like to be a Fedora contributor.
07:39:43 <mchua> raeLLL: They're going to start figuring out their projects for the week pretty soon, and it's likely that those projects will need specific help in some domain, but we don't know what those are yet.
07:39:57 <martz927> time for break ... ttyl
07:40:09 <mchua> raeLLL: Some people might want to learn about packaging, some people might want to learn about Docs, or Infra, or using a particular application that they want to bring back to one of their courses, etc.
07:41:59 <mchua> raeLLL: if you've got cool projects that you'd like help with, or that you'd like to share, those would be good things to talk with people in this channel about ;)
07:42:16 <mchua> raeLLL: Does that answer your question?
07:45:23 <mchua> harish: you are done, http://teachingopensource.org/index.php/User:Harishpillay
07:47:43 <raeLLL> mchua: I mean I'm currently in Singapore, and have time to go to that place, Nanyang Polytechnic, to help to demonstrate some cool open source projects, do you need that kind of volunteer?
07:48:09 <raeLLL> mchua: 9-13 Nov, 2009
07:48:36 <mchua> raeLLL: Ooh, that would be awesome. When would you want to come in? Let me check how we can bring guests in.
07:50:07 <mchua> raeLLL: best times would probably be anytime tomorrow, Wednesday morning, you can join us for dinner on Thursday, any combination of the above.
07:50:52 <mchua> raeLLL: It's very informal, we're all improvising a lot, it's a lot of fun :) we'd love to have you join us
07:52:02 <transbot0> Long has disconnected
07:54:06 <raeLLL> mchua: and what kind of projects you expect me to do? I work here @SG as research engineer, also doing something about linux kernel development in spare time,
07:54:25 <raeLLL> mchua: are you one of the organizers?
07:54:37 <raeLLL> mchua: sponsored by Redhat?
07:58:21 <raeLLL> mchua: I noticed so many professors are from China, I came from China, too; and would like to have communications with them,
07:59:19 <raeLLL> mchua: in Mandrain or in English with other ones,
07:59:49 <transbot0> jasonchong has disconnected
08:00:04 <raeLLL> Mandarin
08:01:41 <transbot0> zzabc007 has disconnected
08:09:02 <transbot0> dychen has disconnected
08:09:12 <raeLLL> I support the idea of bringing more concepts of free software and open source to colleages and universities,
08:09:53 <raeLLL> then professors and students will know the value of FOSS,
08:10:33 <raeLLL> after students' graduation, they will introduce FOSS to the society, and the professor will introce it to more students,
08:12:21 <Kaio> I'd suggest Art/Design/Multimedia classes using opensource applications in courses.
08:12:54 <Kaio> But yeah, I wonder if there are hidden deals between universities and software manufacturers.
08:19:04 <mchua> raeLLL: Yes, I'm one of the organizers and I work for Red Hat.
08:19:29 <transbot0> hnws has disconnected
08:19:48 <mchua> raeLLL: Any projects that you're interested in and working on, really.
08:20:02 <transbot0> hnws has joined: #teachingopensource-posse-zh
08:20:25 <mchua> raeLLL: The professors here are interested in a lot of different topics - some teach computer science, some teach digital media, some teach other things
08:21:08 <mchua> raeLLL: the interesting thing is what *you're* interested in, and we can go from there and find ways for you to help
08:21:37 <mchua> Kaio: +1 to Art/Design/Multimedia classes using FOSS - one of the things I'm hoping for is that Mo Duffy and I will be able to pull off a Design POSSE sometime this summer
08:21:48 <mchua> Kaio: Don't know about hidden deals, but there are often pretty public ones...
08:28:05 <mchua> How's everyone doing on their wiki pages? Are people done?
08:28:49 <jasonchong> my wiki: http://en.wikipedia.org/wiki/User:Chongwk
08:30:18 <mchua> jasonchong: You'll want to make an account on either the Teaching Open Source (TOS) or the Fedora wiki - I'd recommend the Fedora one first - so that people within those projects can find out who you are, too.
08:30:41 <tira> mchua: once I have an account on fedora, how do I edit another person's wiki?
08:30:52 <mchua> jasonchong: http://fedoraproject.org/wiki
08:30:54 <mchua> jasonchong: remember, you need to find someone else to pair with on IRC so you can edit each other's pages - we aren't allowed to edit our own user pages for this exercise.
08:30:59 <mchua> jasonchong: You'll want to make an account on either the Teaching Open Source (TOS) or the Fedora wiki - I'd recommend the Fedora one first - so that people within those projects can find out who you are, too.
08:31:05 <mchua> tira: The same way you would edit any other page on the wiki - by clicking on the "edit" tab.
08:31:10 <mchua> jasonchong, tira: perhaps the two of you can pair up
08:31:38 <mchua> SCLew, kinchew, yipch: I see the three of you are also listed on the whiteboard as "need to do wiki page" - how is that coming?
08:31:57 <mchua> perhaps the three of you can also work something out between yourselves (everyone does someone else's page)
08:32:22 <tira> mchua : specificly how do you access the page eg :jasonchong's page on fedora?
08:32:55 <harish-upfront> mchua: https://fedoraproject.org/wiki/Harishpillay needs updating
08:33:07 <mchua> tira: Oh - it probably doesn't exist yet, unless Jason's created a Fedora account.
08:33:11 <mchua> jasonchong: ^^
08:33:43 <jasonchong> i have logged in fedora wiki
08:33:52 <jasonchong> how to make a new page
08:33:53 <jasonchong> i have logged in fedora wiki
08:34:46 <mchua> jasonchong: Ok - do you see your username at the top right of the screen?
08:34:55 <jasonchong> yes
08:35:00 <mchua> jasonchong: it should be * <your user name>    * My talk     * My preferences     * My watchlist     * My contributions     * Log out
08:35:03 <mchua> jasonchong: great, click on that
08:35:21 <mchua> jasonchong: creating a new wiki page is a lot like creating a new IRC channel - start editing it, and if it doesn't exist already it will be automatically created
08:35:45 <martz927> still cannot auth with fedorapeople
08:35:49 <jasonchong> https://fedoraproject.org/wiki/User:Chongwk  need editing
08:35:51 <mchua> jasonchong: once you click on the link with your username, it should take you to http://fedoraproject.org/wiki/User:your-user-name
08:35:58 <mchua> jasonchong: great, tira ^^
08:36:03 <jasonchong> ^^
08:36:08 <mchua> jasonchong, tira, I think you folks can help each other out
08:36:15 <mchua> martz927: hrm. harish-upfront, thoughts?
08:37:35 <harish-upfront> martz927: what's the issue with fedorapeople.org?
08:37:43 <jasonchong> k editted tira wiki...  now ur turn pls xD
08:38:21 <harish-upfront> <@mchua> jasonchong: creating a new wiki page is a lot like creating a new IRC channel - start editing it, and if it doesn't exist already it will be automatically created
08:39:04 <martz927> i can ssh there but cannot auth with my rsa public key
08:39:19 <martz927> shld i regenerate a new one?
08:39:40 <martz927> i do a ssh-keygen -t rsa
08:39:53 <martz927> than upload id_rsa.pub to the FSA acct
08:40:11 <martz927> and do a ssh myusername@fedorapeople.org
08:40:16 <martz927> pls confirm the steps
08:40:20 <mchua> martz927: yeah, that's absolutely right, as far as I can tell
08:40:31 <mchua> martz927: what error does it give you?
08:40:33 <martz927> need to be in root env?
08:40:38 <mchua> harish-upfront: we have port 22 open now, right?
08:40:44 <mchua> martz927: no, you should be able to auth as a normal user
08:40:49 <martz927> im using 3G bb
08:41:08 <harish-upfront> ok. assuming you have created the public keys for ssh then you can upload it via the web.
08:41:18 <martz927> as the default user for f11
08:41:31 <martz927> yup ... i uploaded them already
08:41:34 <tira> jasonchong: where is your profile to edit your wiki?
08:41:49 <martz927> confirm the file is id_rsa.pub
08:41:49 <jasonchong> is on top lol
08:41:56 <jasonchong> kk juz replace tira with chongwk
08:42:11 <jasonchong> https://fedoraproject.org/wiki/User:Chongwk  need editing
08:42:20 <martz927> the f11 username need not be same as the FSA acct?
08:42:28 <harish-upfront> mchua: port 22 is not open yet. we might have to delay that till tomorrow or for people to do so this evening.
08:42:33 <martz927> mine f11 is martyn and fsa is martynyap
08:42:44 <martz927> i using 3G shld work right?
08:42:57 <mchua> martz927: if you're doing ssh martynyap@fedorapeople.org it should work fine
08:43:10 <mchua> martz927: Yep, 3G should work
08:43:11 <harish-upfront> martz927: yes
08:43:16 <mchua> martz927: what error message are you getting?
08:43:24 <jasonchong> i did ssh-keygen -t rsa and press enter 2x to accept default rite?
08:43:28 <mchua> harish-upfront: hrm, okay. maybe we should wrap up in ~10m then a little earlier
08:43:32 <mchua> jasonchong: yep
08:43:40 <martz927> yups
08:43:53 <martz927> maybe shld upload a new rsa file
08:43:56 <jasonchong> but when i do this no response ssh chongwk@fedorapeople.org
08:44:19 <mchua> martz927: Yeah, try that - and if it doesn't work we'll ask in #fedora-admin either today or tomorrow if we run out of town
08:44:36 <mchua> jasonchong: Port 22 is blocked, so ssh doesn't work right now - harish-upfront, can jasonchong borrow your computer for a moment possibly?
08:44:41 <jasonchong> cool, as long as is beyond me, i can sleep better
08:44:43 <harish-upfront> looks like the lack of ssh access is hindering further progress.
08:45:10 <harish-upfront> mchua: i am on the wifi not 3g right now.
08:45:37 <tira> jasonchong: please check your wiki.
08:46:08 <jasonchong> cool edit. tyvm tira
08:46:22 <tira> Can some one help me by editing the wiki at https://fedoraproject.org/wiki/Tiraths? Thank you.
08:46:38 <mchua> tira: I think jasonchong did it?
08:47:13 <jasonchong> i did for tira not tiraths
08:47:20 <jasonchong> anyway tat page is empty atm
08:47:31 <jasonchong> mayb tira u can try edit first?
08:48:12 <mchua> jasonchong: I'll mark you down as needing SSH for FAS
08:48:13 <mchua> martz927: you too
08:48:21 <mchua> and then that's something we can make sure we get to tomorrow
08:48:26 * mchua grumbles at blocked ports
08:48:33 <jasonchong> =.=
08:49:33 <harish-upfront> To load the ssh-rsa key into the Fedora Account System, you need to first login into the fedoraproject.org.
08:49:46 <harish-upfront> once there you will see your acccount and then hit the edit key.
08:50:03 <mchua> I believe that's https://admin.fedoraproject.org/accounts/
08:50:04 <mchua> #link https://admin.fedoraproject.org/accounts/
08:50:13 <mchua> FAS = Fedora Account System
08:50:17 <mchua> you'll see that acronym a lot
08:50:18 <harish-upfront> the edit key next to the "Account Details" line up at the top below the "Your Fedora Account" heading.
08:50:23 <raeLLL> mchua: yes, I've also known something about the desktop, gimp, image manipulatation, or gtk programming,
08:50:30 <mchua> it's the single-sign-on for pretty much everything about Fedora
08:50:35 <harish-upfront> that will bring you to the edit page and ...
08:50:37 <mchua> raeLLL: awesome. when do you want to come by?
08:51:01 <harish-upfront> once there, you will see a line that says "Public RSA SSH Key:".
08:51:25 <martz927> yups ... done that
08:51:45 <tira> jasonchong: you have to first open the page. Then login and now edit the  page.
08:52:04 <harish-upfront> hit the browse button and assuming you have generated your ssh keys, you can then pick that up from your /home/USERNAME/.ssh/id_rsa.pub file.
08:52:25 <harish-upfront> once that is uploaded, you can then ssh USERNAME@fedorapeople.org
08:52:26 <jaric_> hi i uploaded the id_rsa.pub to fedora account setting
08:52:38 <martz927> me too
08:52:40 <tira> mchua : when my account has an SSH key setup, what is the method of login without using password?
08:52:41 <harish-upfront> jaric_: good.
08:52:46 <martz927> but its not working
08:52:48 <jaric_> when i run ssh fedoraproject.org -v
08:52:53 <jaric_> it asked for pw
08:52:58 <harish-upfront> tira: that is not a good idea.
08:53:04 <jaric_> and i got permission denied
08:53:09 <martz927> its gives me a permission denied error
08:53:19 <harish-upfront> tira: you can do the following if you really don't want to access with a password -
08:53:46 <harish-upfront> tira: ssh-copy-id USERNAME@fedorapeople.org
08:54:00 <azneita_afk> jaric: run ssh <your nick>.fedoraproject.org
08:54:26 <jasonchong> omg cant find /home/nyp1/.ssh
08:54:36 <jasonchong> guess im a nub in linux..
08:54:43 <azneita_afk> likewise, give fas some time to sync to fedorapeople.org
08:55:03 <harish-upfront> WE HAVE A PROBLEM PEOPLE - the SSH keys created on these machines will disappear when you move out to your own.
08:55:15 <martz927> now it a different error
08:55:22 <martz927> connection closed by remote host
08:55:33 <jaric_> now encountered error: OpenSSH_5.2p1, OpenSSL 0.9.8k-fips 25 Mar 2009 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * ssh: Could not resolve hostname jaricsng.fedoraproject.org: Name or service not known
08:55:34 <azneita> harish-upfront: that's true :)
08:55:36 <harish-upfront> I would suggest that you create your own ssh keys and not use the ones we have in the lab.
08:55:48 <mchua> harish-upfront: argh, right - but with their FAS account info they can log back into FAS and make and re-upload an SSH key later
08:55:51 <jasonchong> pls walk us thr..
08:56:11 <mchua> harish-upfront: want to take a minute to talk about ssh keys when we bring everyone back together to the front, before we do tomorrow's schedule?
08:56:21 <martz927> i agree
08:56:22 <jasonchong> coolz
08:56:30 <mchua> harish-upfront: and then tomorrow if we have our ports unblocked one of us can do a walkthrough
08:56:41 <harish-upfront> jasonchong: you are not a nub per se, it is setting up the accounts.
08:56:56 <jasonchong> hahaha yea i know, juz wanna b corny
08:57:27 <harish-upfront> jasonchong: we will work on this tomorrow.
08:57:49 <harish-upfront> mchua: ok to talk about ssh keys now and then talk about tomorrow's schedule.
08:58:04 <mchua> harish-upfront: call everyone together when you're ready, it's about time
08:58:15 <mchua> harish-upfront: we need to be downstairs for the bus at 5:30 sharp, that's all
08:58:27 <harish-upfront> mchua: wrap up now?
08:58:41 <mchua> harish-upfront: yeah.
08:59:07 <mchua> harish-upfront: ssh keys, see where people are in terms of progress on their deliverables, remind everyone to BLOG REFLECTIONS!!! on today if they haven't already done so
08:59:20 <mchua> harish-upfront: tomorrow's schedule is what we totally need to leave today with - though feedback is also good
08:59:32 <harish-upfront> mchua: ok
08:59:57 <mchua> Ah  yes, I was going to post these links
08:59:59 <mchua> #link http://fedoraproject.org/wiki/FUDCon:Toronto_2009
09:00:08 <mchua> #link http://fedoraproject.org/wiki/FAD
09:00:14 <mchua> for the record - sorry about the latency on those, folks
09:00:19 <mchua> but those are the in-person gatherings Harish and I mentioned.
09:00:32 * mchua ready to wrap up anytime, just spewing stuff in-channel 'till Harish stands up and says something ;)
09:00:56 * harish-upfront ready here goes
09:00:57 <jaric_> from the site teachingopensoure, the instruction was on using virtualbox with fedora guest POSSE Remix, would be great to have the sound up in the guest OS
09:01:10 <mchua> WRAPPING UP!
09:01:36 <mchua> #topic what's an SSH key?
09:01:41 <mchua> SSH = Secure SHell
09:01:52 <mchua> it's a special key that lets you log in securely from a command line.
09:02:03 <mchua> So you can log in to a remote server.
09:02:48 <mchua> #action mchua send out howto do SSH key info to the mailing list
09:06:27 <transbot0> tiansworld has disconnected
09:10:05 <harish-upfront> tomorrow's schedule"
09:10:12 <harish-upfront> a: setting up a build environment
09:10:40 <harish-upfront> b: how to get source code, edit, patching, submitting patches upstream.
09:11:02 <harish-upfront> fedora 12 coming out next week, perhaps we can help update that page.
09:11:51 <harish-upfront> so, the objective for Tuesday morning, we are proposing that we work on the Fedora 12 webpage.
09:12:44 <harish-upfront> Morning: Get Code, modify code, make patch, submit patch - for the Fedora 12 web page. We can also do Translations of that page as well.
09:12:56 <harish-upfront> code here is not C code but html
09:13:25 <harish-upfront> afternoon: how to report broken stuff.  we will use bugzilla, request-tracker etc.
09:14:50 <harish-upfront> Afternoon: bug report, bugzilla
09:15:28 <harish-upfront> Afternoon: bug reporting, packaging
09:18:23 <transbot0> jasonchong has disconnected
09:21:34 <martz927> bye all
09:21:41 <harish-upfront> bye
09:21:48 <transbot0> martz927 has disconnected
09:22:13 <transbot0> tira has disconnected
09:22:41 <transbot0> harish-upfront has disconnected
09:22:44 <transbot0> kinchew__ has disconnected
09:22:46 <transbot0> jaric_ has disconnected
09:22:54 <transbot0> kinchew has disconnected
09:23:08 <mchua> Thanks folks!
09:23:11 <mchua> #endmeeting