13:32:38 <mchua> #startmeeting
13:32:38 <zodbot> Meeting started Tue Sep 13 13:32:38 2011 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:32:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:32:41 <mchua> #chair heidie
13:32:41 <zodbot> Current chairs: heidie mchua
13:32:42 * heidie waves to dneary as well. Wonderfully helpful comments on TOS list
13:32:48 <mchua> heidie: feel free to go ahead and chair your students if you like as well
13:32:52 * dneary waves back
13:33:00 * mchua waves to Biomech360 and CGodon
13:33:06 <dneary> hi heidie
13:33:19 <mchua> Sean, that you?
13:33:23 <snormoyle> Hi mel!
13:33:32 <mchua> Great to see you again!
13:33:44 <heidie> mchua, not everyone has laptops, but I'm projecting the conversation on the screen
13:33:50 <mchua> Okeydokey, worksforme.
13:33:54 <heidie> :-)
13:34:08 <heidie> mchua, not everyone has read your blog about differences between Cheese and Ekiga
13:34:12 <mchua> dneary: we're doing http://blog.melchua.com/2011/09/12/cheese-vs-ekiga-for-software-engineering-class-responses-to-student-notes/ btw -- your *infinitely* greater amount of GNOME expertise may be uberhelpful.
13:34:23 <mchua> heidie: Oh, that's totally cool, I posted it yesterday so I thought most people would probably not have seen it.
13:34:25 <heidie> However, I've given an assigment for folks to read and blog on what they learned from your blog.
13:34:33 <mchua> Oh gosh. Er... wow.
13:34:34 <dneary> mchua, I'll do my best
13:34:37 <heidie> dneary, Yes! Please chime in!
13:34:40 <dhoude> Hello Mel
13:34:41 <heidie> :-)
13:35:18 <heidie> OK, we're a go on this end Mel.
13:35:35 <heidie> Right. You say some really good things on your post.
13:35:59 <mchua> You folks caught some great things on your first look at those two projects, so writing the post was easy. :)
13:36:02 <dneary> mchua, The Cheese guys are wonderfully helpful
13:36:27 <mchua> oh -- dneary, we may want to introduce ourselves, I'm not sure if Heidi's students know who we are.
13:37:00 <mchua> dneary: (also as a side note -- I tried explaining the Dreyfus model to FOSS hackers in 5 minutes, http://opensource.com/education/11/3/i-cant-bake-croissants-fable-project-documentation -- in case it's helpful.)
13:37:15 <mchua> #link http://blog.melchua.com/2011/09/12/cheese-vs-ekiga-for-software-engineering-class-responses-to-student-notes/
13:37:32 <dneary> mchua, I'm not *really* here, but I'll try to be available if pinged
13:37:36 <heidie> #topic Differences between Cheese and Ekiga projects
13:37:45 <mchua> dneary: gotcha, thanks Dave!
13:38:09 <heidie> mchua, we can assume that we all have a basic understanding of the two projets.
13:38:17 * mchua is Mel Chua, http://blog.melchua.com, Red Hat's resident education geek and also a grad student at Purdue University (where I'm sitting in my wee office right now.)
13:38:18 <dneary> I'm Dave Neary, long-time GNOME contributor, not so much developer (I was a GIMP hacker from 1999 to 2004 or so, including release manager in 2003-04)
13:38:45 <dneary> And now I consult in helping people (typically professional software developers) work with free software community projects
13:39:11 * heidie Asks students to introduce themselves
13:39:24 <snormoyle> Hi, i'm Sean Normoyle from Western New England University. My favorite project that I've worked on was with mchua and heidie this past summer, called "DevilE"
13:40:31 <AHajec> Hi, am Anthony Hajec and am from WNE. I like learning how things work.
13:40:32 <mchua> aubreyja_: Hey, Jason -- we're hanging out with Heidi's students in Software Engineering right now.
13:40:40 * heidie Urges students to jump in!
13:40:49 <Twan_> hi my name is Anthony, I am an Computer Engineer from Western  New England  College. I have done coding for the micro processor.
13:40:50 <dhoude> Hello, I am Devin Houde. I am a senior at Western New England University and this past summer I helped Heidi with the SoftHum wiki.
13:40:55 <mchua> Great to meet you folks!
13:40:56 <Biomech360> I'm David Descoteaux, and the most complicated project I've done is a simple flash game.
13:41:09 <CGodon> Hello, I am Carl Godon from Western New England.  I work for desktop support at the college
13:41:23 <mchua> Twan_: Ooh, microprocessors. Which platform?
13:41:25 * heidie wonders if there is anything simple about flash...
13:41:35 <mchua> CGodon: You'll find that sort of sysadmin experience quite valuable in FOSS.
13:41:37 <TinNguyen> Hi, my name is Tin Nguyen from Western New England, and I am in the Computer Science Major.
13:41:54 <Twan_> the 8088 microprocessor mchua
13:41:55 <mchua> Biomech360: Flash isn't simple, imo. :) Welcome!
13:42:06 <mchua> AHajec: Hopefully we'll be able to help you pop the hood and see how more software works, then.
13:42:31 <mchua> dhoude: thanks for your work on the softhum wiki -- I sometimes point other profs to it so they can see what it looks like when a school does open source, it's a great example.
13:42:40 <mchua> dang, just missed dhoude.
13:42:42 <Biomech360> heidie mchua: It was a single screen game for a project in high school.
13:42:43 <SeanDee> Hi, I'm Sean D.  I am a senior CS major at WNE.  The most programming I have done is for class at college
13:42:51 <heidie> And the wiki happens to be down right now (SoftHum)
13:42:56 <mchua> Aww.
13:43:04 <heidie> Greg is hoping to fix it today.
13:43:04 <ikonified> Hi, my name is Tom Galica and i'm a computer science major at WNE
13:43:15 <heidie> OK, I think we can jump in.
13:43:28 <heidie> mchua, from your perspective, what do you see as the major differences between Cheese and Ekiga?
13:43:34 <dhoude> I'm back. Mel, I saw your last post
13:43:35 <heidie> Your perspective as a FOSS person
13:44:00 <mchua> Well, they're apples and oranges to some extent -- you're looking at two programs that do completely different things.
13:44:38 <mchua> Unless someone has a burning desire to work specifically on a webcam app or a softphone app, I'd look a little less at the *static* version of the code
13:44:45 <mchua> and more at the... first derivative of the code, if you will.
13:44:47 <heidie> Ah, let me provide some background.
13:44:55 <mchua> How fast it's changing, who's working on it now, how likely they are to mentor.
13:44:58 * mchua listens
13:45:01 <heidie> The need to look at cheese is driven by a request for a video magnifier.
13:45:10 <dneary> heidie, Ekiga is a considerably "bigger" application
13:45:24 <dneary> heidie, And adds an extra constraint - the SIP server
13:45:35 <heidie> The A11y community requested a video magnifier that does more than Cheese. That would be able to do high contrast B/W and also to provide a "guideline"
13:45:48 <heidie> ndnear, Ah, thanks, that is very helpful.
13:46:05 <dneary> It's not that complicated, but in terms of the amount of code in Ekiga + its dependencies, the learning curve will be bigger, I think
13:46:14 <mchua> Ok, so you have end customers for Cheese -- which is a big plus there. Have they offered mentoring and testing help and that sort of thing?
13:46:42 <heidie> They have offered testing help and Joanie and API from A11y have offered mentoring help.
13:46:46 <mchua> Oh, that's fantastic.
13:46:53 <heidie> Joanie has been really, really helpful. Have you met her?
13:47:00 <mchua> How about from within Cheese itself, have you gotten to talk with any of the Cheese developers?
13:47:05 <mchua> heidie: Nope, I haven't had the pleasure yet.
13:47:22 <heidie> Not yet. We wanted to do a feasibility study first and see if the project might even fit.
13:47:54 <heidie> Oh, and I posted my VirtualBox question to the Cheese list and got four replies within half a day. So they appear to be helpful and active.
13:48:09 <heidie> mchua, I'll introduce you to Joanie when we next get a chance.
13:48:13 <mchua> awesome.
13:48:22 <mchua> I saw the Cheese list activity and that looked great.
13:48:35 <mchua> #note Cheese additions specifically requested by GNOME a11y, who have offered to help with testing
13:48:39 <mchua> #note Cheese mailing list responsive to questions
13:48:46 <mchua> And Ekiga -- where did that come from?
13:48:57 <dneary> If I could also suggest a potential candidate for a project to contribute to: Shotwell is awesome, and improving (so opportunity for improvements), and is written in an easy to learn language (Vala)
13:48:59 * heidie thinks that students should join the Cheese mailing list.
13:49:00 <mchua> #link http://mail.gnome.org/archives/cheese-list/2011-September/thread.html
13:49:10 <mchua> ...ooh, Shotwell.
13:49:26 <heidie> #link http://mail.gnome.org/mailman/listinfo/cheese-list
13:49:52 <dneary> heidie, For mentoring projects I suggest starting with a chat to the maintainers... trying to learn a project with maintainers you can't work with is really hard
13:50:13 <heidie> Yes, that is definitely next step.
13:50:20 <heidie> mchua, and "shotwell"?
13:50:41 <mchua> Shotwell is a photo management app.
13:51:04 <mchua> I don't use it much myself, but sdziallas adores it.
13:51:23 <mchua> It's also a GNOME project.
13:51:28 <mchua> #link http://yorba.org/shotwell/
13:51:31 <heidie> Oh, got it!
13:51:54 <mchua> So, question -- we're slinging a lot of things at you right now, I think... has anyone in the class gotten to have a realtime conversation with any developers from any of these projects?
13:52:00 <dneary> heidie, I'd be happy to introduce you to Raphael and daniel from Cheese
13:52:04 <heidie> Nope, not yet.
13:52:17 <heidie> dneary, Thanks! I'll take you up on that.
13:52:19 <dneary> mchua, heidie, The Yorba guys are really great too, and very helpful
13:52:34 <mchua> I don't know about the infrastructure of Cheese or Ekiga, but Shotwell has a plugin infrastructure that might be a good place to start.
13:52:49 <mchua> So you can concentrate on a small bit of functionality that hooks into a bigger thing, instead of gaping at thousands of lines of code on day 1.
13:53:08 <dneary> Also, something about Cheese: They've mentored a fair number of developers between Google SoC and Women's Outreach
13:53:10 <heidie> mchua, Ah, thanks! Joanie and I had talked that a plug-in architecture would be good.
13:53:18 <dneary> It would be worth having a chat with former students
13:53:25 <mchua> Oh, I didn't know that (re: Cheese) -- that's great!
13:53:27 <heidie> Ah, good idea dneary!
13:53:37 <dneary> Example: http://live.gnome.org/RalucaPodiuc_Cheese_Empathy
13:54:24 * mchua tries to figure out how to be most helpful
13:54:52 <heidie> #item heidie look at Shotwell
13:55:00 <mchua> heidie: not sure what your next assignment is, but one thing I might suggest is trying to have students track down a live dev and have a half-hour chat with them or so, possibly in groups or with you or an experience FOSSer shadowing them.
13:55:06 <heidie> #item Revision, heidi have students look at Shotwell
13:55:07 <mchua> from each of the three projects.
13:55:14 <heidie> Yes. good idea!
13:55:33 <mchua> I noticed that some of you discovered the IRC channels for Cheese and Ekiga.
13:55:38 <heidie> #item Have students track down a live dev from Cheese and Shotwell and have a half-hour chat with them or so, possibly in groups or with you or an experience FOSSer shadowing them.
13:55:40 <mchua> What are they? We should note them here.
13:55:55 <mchua> (y'all have been a bit quiet, holla up :)
13:56:02 <dneary> Actually, Luciana, one of the Cheese maintainers, was a Women's Outreach graduate from 2010
13:56:29 * heidie asks students to find Cheese IRC link and post
13:56:51 <mchua> Another thing that you could do, as a "dive-right-in" sort of miniproject... some of you mentioned having trouble installing stuff, getting through documentation?
13:56:59 <mchua> That the docs were pretty good, but not necessarily perfect.
13:57:14 <mchua> That's a *great* first fix to have in hand when you walk into a community. "Hey, I fixed your installation docs."
13:57:16 <heidie> mchua, As for the linux box, I was looking at the eeepc 1021 with 1.8Gz dual AMD processor and 4G (8G?) of RAM. Does that sound about right?
13:57:32 <mchua> Because experienced developers almost never ever look at those and realize they're out of date (because they've had the dev version running on their machines since forever.)
13:57:44 * heidie Nods in strong agreement
13:57:56 <mchua> heidie: Oh, that should be more than fine -- the only thing I'd make sure of is webcam compatibility.
13:58:10 <heidie> Right, that is why I went with the 1021, but I'll double check.
13:58:15 <mchua> #note Heidi's looking at the eepc1021 with 1.8Gz dual AMD processor and 4G RAM
13:58:23 <mchua> #action sdziallas sanity-check that for webcam-fu
13:59:04 * heidie thinks I confused "item" with "action" for the meetbot
13:59:26 <mchua> it's okay. :)
13:59:59 <dneary> (Just to put some names on Ekiga, Cheese, Shotwell radar: Ekiga maintainer: Damien Sandras, Cheese maintainers: daniel siegel & Luciana Fujii, Shotwell maintainers: Adam Dingle, Jim Nelson, Lucas Beeler)
14:00:19 <mchua> I've just started lurking on the #ekiga and #gnome channels on irc.gnome.org.
14:00:26 <heidie> dneary, Very helpful.
14:00:27 <mchua> Students -- do you know how to do that?
14:00:30 <dneary> mchua, Try #gnome-hackers too
14:01:01 <mchua> dneary: joined.
14:01:08 <dneary> mchua, #gnome depopulated because of trolls a few years ago and has never really regained its past level of helpfulness
14:01:32 <mchua> dneary: I'm trying to think of a way to give the students a way to lurk on these channels without needing consistent connectivity themselves... are there logs, perchance?
14:01:46 <heidie> dneary, this is what I had observed as well.
14:02:02 <dhoude> #link irc://irc.gnome.org/ekiga
14:02:19 <dneary> mchua, Not that I know
14:02:30 <dneary> mchua, That's my #1 pet peeve with over-using IRC
14:02:40 <dneary> I tend to recommend against over-reliance on IRC
14:03:03 <dneary> Esp in MeeGo, time-zones often keep me from meetings that I think are important
14:03:06 <Biomech360> #link irc.gnome.org/#cheese
14:03:14 <dneary> But the topics never get discussed properly on MLs
14:03:20 <mchua> dhoude and Biomech360 -- awesome, thanks!
14:03:23 <heidie> dneary, are you anywhere close to Springfield MA? I'd love to have you come talk to my class. I can offer travel funding and chocolate chip cookies...
14:03:45 <mchua> dneary: Yeah, the asynchronous vs synchronous communications issue is... an unsolved one, I think.
14:03:48 <dneary> heidie, Lyon, France :)
14:03:59 * mchua is sad she can't make it to Paris next month
14:04:00 <mchua> darn classes.
14:04:03 <dneary> mchua, It's been solved a long time ago
14:04:06 <heidie> Hmmm, that might be a bit far, but sounds like more fun than Springfield MA :-)
14:04:12 <Biomech360> Or... did I inadvertantly create a channel?
14:04:19 <dneary> No async except when absolutely necessary
14:04:22 <dneary> mailing lists
14:04:37 <mchua> dneary: "if it didn't happen on the list, it didn't happen"?
14:05:16 * heidie notes that Mel needs to go to class soon.
14:05:27 <dneary> heidie, I'm sure Springfield is fun
14:05:43 <heidie> dneary, And I'm sure that it isn't as fun as Lyon. :-)
14:05:54 <heidie> Although we do have the BBall hall of fame.
14:06:08 <Biomech360> Yeah, now I'm confused as to if the channel was there.
14:06:09 <mchua> The BBhall of fame is *awesome.*
14:06:15 <mchua> Biomech360: are you the only one in the channel?
14:06:21 <Twan__> "fun" isn't the word that comes to mind when i think Springfield
14:06:48 <mchua> Twan__: I have a video of my (then) 4-year-old brother repeatedly attempting to make the lowest basket at the BBall hall of fame.
14:07:04 <mchua> It's fun. :)
14:07:10 <heidie> Right!
14:07:13 <dneary> Gotta go!
14:07:20 <Twan__> thats awesome! That is fun tho
14:07:21 <mchua> Biomech360: You may have created the channel on the Freenode network -- GNOME uses a different IRC server, irc.gnome.org
14:07:29 <mchua> (instead of irc.freenode.org which is what we're all on right now.)
14:07:40 * heidie Learned how to connect to two different servers on Chatzilla
14:07:42 <dneary> heidie, You have my email address - can you drop me a line re introductions, please?
14:07:48 <Biomech360> mchua the URL is 	irc://irc.gnome.org/cheese at the top
14:07:56 <dneary> mchua, He used the right server
14:08:01 <dneary> Not too many people there
14:08:22 <heidie> dneary, Sure. Do you mean introductions to all students?
14:08:46 <mchua> ahhh, okay -- missed that part of the url.
14:08:51 <dneary> heidie, How about I start with you, and we go from there? :)
14:09:07 <heidie> dneary, Sure, thats fine :-)
14:09:24 * Biomech360 could have sworn there was an official one on the server
14:10:05 <heidie> mchua, dneary, given the focus of our project on video magnification and your understanding of the communiities, do you see Cheese and Shotwell as the two top options?
14:10:46 <heidie> mchua, dneary, and if so, do you have a preference for one over the other?
14:11:01 <mchua> I would see them both as good potential options -- the codebase looks workable-with for a class of this type, it's possible to break out little tasks that you can get done.
14:11:16 <mchua> The preference relies on data we don't yet have (but sounds possible for both projects)
14:11:18 <Twan_> Sorry about keep coming back in, I have a very bad IRC client
14:11:20 <mchua> which is the direct code mentorship (imo).
14:11:28 <heidie> Yes, thank you.
14:11:31 <dneary> heidie, Hmmm
14:11:38 <dneary> Sounds like I'm missing some context
14:12:06 <mchua> From dneary it sounds like both those projects have potentially great mentors, so my next question is "and which one(s) can you actually arrange to check in with on a regular basis"?
14:12:11 <dneary> heidie, What is your end goal?
14:12:29 <heidie> Ah, there are 11 Software Engineering students at Western New England University and they need to experience the major stages of software engineering in a real context.
14:12:46 <dneary> OK
14:12:48 <heidie> So requirements, design (not necessarily original, can reconstruct existing one), implement (minor), test, etc.
14:12:56 <dneary> Right
14:13:04 <heidie> We've been working with accessibility community as they are so very welcoming.
14:13:12 <dneary> And some kind of video aspect is compulsory?
14:13:16 <heidie> And we had a request for software to magnify video feed.
14:13:27 <dneary> Oh
14:13:28 <dneary> OK
14:13:31 <heidie> No, it isn't. It is just the project that was suggested.
14:13:33 <dneary> That's what I was missing
14:13:49 <heidie> So we have been evaluating Cheese and Ekiga as perhaps having a codebase that we could use.
14:13:54 <dneary> I believe that Ekiga allows/enables scaling of video already
14:14:03 <heidie> Sorry, should have filled you in more completely at the beginning.
14:14:06 <dneary> (I may be wrong of course)
14:14:25 <heidie> Ah, so we should look at the feature request and map it to Ekiga existing functionality.
14:14:30 <dneary> Cheese can capture video, so having a magnification aspect there makes sense
14:14:53 <heidie> #action Look at Ekiga and map video magnifier feature requests to existing functionality.
14:14:58 <dneary> Shotwell downloads media from cameras, and stores them in a catalog - so fewer opportunities there, I would guess
14:15:08 <heidie> Ah, thank you, that is helpful.
14:15:29 <dneary> If you try to plan a video from Shotwell, I think it launches the video player Totem
14:15:38 <heidie> Ah, thanks.
14:15:50 <mchua> Shotwell is sort of like... Adobe Lightbox is the closest common equivalent I can think of.
14:15:57 <mchua> (Lightroom? Lightbox?)
14:16:06 <heidie> #action Get more concrete set of use cases for project.
14:16:14 * mchua tinkering with http://openetherpad.org/introduction-email-wne
14:16:20 <AHajec> lightroom
14:16:31 <mchua> AHajec: Thanks -- see, I'm not a photographer myself. :)
14:16:35 * mchua tends to write more than photograph
14:16:53 <mchua> So, I think we need to get you folks in touch with the actual maintainers as fast as possible.
14:17:35 * heidie Thinks that introducing students to the community could have been done last week (week 2/15) rather than this week.
14:17:44 <dneary> mchua, iPhoto is close enough
14:17:51 <heidie> Ah, thank you.
14:18:07 <mchua> heidie: It's good to get background context before launching into a conversation -- this does take a little time and a lot of guts. :)
14:18:09 <heidie> It is now 10:17 and Mel needs to go to class and I need to cover some stuff with my students.
14:18:15 <heidie> :-) Yes.
14:18:41 <heidie> mchua, dneary, I very much appreciate all of the input and your time. It is very helpful!
14:18:50 <Biomech360> Thank you
14:18:55 <dhoude> Thank you.
14:18:57 <SeanDee> Gracias
14:18:58 <CGodon> Thanks for your time
14:18:58 <AHajec> Thank you for the input.
14:18:59 <TinNguyen> Thank you
14:19:02 <snormoyle> mchua, thanks for all the help
14:19:10 <dneary> heidie, Thank you, and you're welcome
14:19:14 <heidie> :-)
14:19:20 <snormoyle> and dneary too
14:19:25 <heidie> We'll be blogging on our progress and keep you posted!
14:19:38 <mchua> awesome!
14:19:40 <Twan_> Thank you for all your help :)
14:19:43 <heidie> mchua, happy class!
14:19:46 <mchua> Thank you all for taking the plunge!
14:19:47 * heidie waves bye...
14:19:49 <mchua> #endmeeting