19:16:11 <kwurst> #startmeeting
19:16:11 <zodbot> Meeting started Mon Jan 30 19:16:11 2012 UTC.  The chair is kwurst. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:16:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:16:23 <davexunit> alright everyone: act natural
19:16:26 <sflynn1976> omg! we're being logged!
19:16:31 <Guest91793> its a trap!
19:16:41 <davexunit> will you please choose a nick
19:16:43 <JamesWSU> so yeah computers
19:16:43 <davexunit> :P
19:16:55 <Guest91793> haha how?
19:17:03 <JamesWSU> ;/nick whatever
19:17:06 <JamesWSU> without the ;
19:17:08 <mkenny2> -->/nick
19:17:12 <davexunit> on the board
19:17:13 <davexunit> it is
19:17:18 <kwurst> The CS 401 class from Worcester State University is holding class today on #teachingopensource
19:17:33 <davexunit> that's my cat's name
19:17:36 <trevaaa> thats better
19:17:42 <blabbecs401_> Fun. Can't keep a connection at this school :/
19:17:47 * kwurst waves at heidie
19:17:58 * kwurst waves at mchua
19:18:02 * heidie waves back at kwurst
19:18:02 * mikeiudi rejoices at finally figuring this out
19:18:02 <davexunit> okay so who would like to edit my glorious wiki page?
19:18:12 <davexunit> \kick mikeiudi
19:18:12 <blabbecs401> davexunit: You and I, let's do it
19:18:13 <davexunit> :P
19:18:18 <blabbecs401> I will PM you
19:18:31 <davexunit> keep it on the main channel
19:18:31 <kwurst> JamesWSU: Which James are you?
19:18:34 <davexunit> rather than pm
19:18:36 <mkenny2> how do u send pms?
19:18:37 <JamesWSU> The good one, Celona.
19:18:47 <davexunit> kwurst will like it on the record i'm sure
19:18:50 <blabbecs401> davexunit: That will just clutter the main channel
19:18:56 <blabbecs401> PMs are part of IRC
19:19:00 <davexunit> kwurst: PMs or no PMS?
19:19:02 <blabbecs401> Pretty sure we are supposed to use it :P
19:19:02 <sflynn1976> left click the user name
19:19:10 <mkenny2> ahh i see now thanks
19:19:51 <blabbecs401> Ok well
19:20:00 <blabbecs401> davexunit: Gimme the link to your user page iw ill get mine for you
19:20:03 <jon_cs401> Celona
19:20:05 <jon_cs401> edit me
19:20:06 <davexunit> okey dokey
19:20:10 <JamesWSU> What
19:20:11 <JamesWSU> wat.
19:20:45 <davexunit> blabbecs401: http://teachingopensource.org/index.php/User:Davexunit
19:20:53 <blabbecs401> davexunit: http://teachingopensource.org/index.php/User:Blabbe
19:21:19 <blabbecs401> davexunit: You are the one who originally recommened irssi right?
19:21:41 * clacroix wave
19:21:44 <davexunit> blabbecs401: yes
19:21:45 <JamesC_WSU> jon
19:21:46 <JamesC_WSU> http://teachingopensource.org/index.php?title=User:JamesCelona&action=edit
19:21:47 <jon_cs401> Celona im going to try to send you my link
19:21:56 <blabbecs401> Ok. "likes irssi for some reason" I will add that to your page :P
19:22:02 <kwurst> davexunit: Right, no PMs. Let's get the full chaotic experience...
19:22:27 <sflynn1976> welcome redsoxxx
19:22:33 <mkenny2> mikeiudi: would you like to edit my page?
19:22:34 <blabbecs401> Ok davexunit what else should I add to your page for you?
19:22:40 <davexunit> blabbecs401: just reading over the assignment quick
19:22:45 * kwurst waves back to clacroix
19:22:55 <mikeiudi> Yes I would thank you mkenny2
19:23:03 <davexunit> kwurst: What information in particular should we add to the wiki page?
19:23:04 <mkenny2> http://teachingopensource.org/index.php/User:Mgrmaverick
19:23:06 <sflynn1976> you need to set up your account on the teaching open source website
19:23:12 <sflynn1976> http://teachingopensource.org/index.php/User:Sflynn1976
19:23:21 <davexunit> oh boy it's like we are all internet friends
19:23:24 <mikeiudi> I enjoy long walks on the beach, music, cigars
19:23:29 <redsoxxx1999> yeah, i already did that
19:23:43 <JamesC_WSU> send me the link, Jon
19:23:45 <mikeiudi> hahaha let me look at the assignment again
19:23:46 <sflynn1976> a cigar and a nice whiskey
19:23:53 <mkenny2> mikeiudi: a cigar guy eh?
19:23:55 <mikeiudi> heck yes @flynn
19:23:56 <davexunit> mikeiudi is a silly man
19:24:16 <davexunit> @flynn? this isn't twitter mikeiudi haha
19:24:23 <danspc> does someone want to edit my page?
19:24:26 <davexunit> no
19:24:32 <cembree> http://teachingopensource.org/index.php/User:Cmembree
19:24:36 <davexunit> :P
19:24:38 <blabbecs401> No one wants to edit your page, just leave (Just kidding :P )
19:24:42 <mkenny2> mikeiudi: paste the link to your wiki page
19:24:52 <blabbecs401> davexunit: You ready to do this/
19:24:54 <JamesC_WSU> send me the link, Jon
19:24:57 <davexunit> blabbecs401: Full name please
19:25:02 <davexunit> i'll start with that
19:25:05 <blabbecs401> Brian Labe. Yours?
19:25:07 <blabbecs401> Er
19:25:08 <blabbecs401> Labbe*
19:25:09 <jon_cs401> http://teachingopensource.org/index.php/User:Jhasenzahl
19:25:13 <davexunit> blabbecs401: David Thompson
19:25:13 <jon_cs401> for you jimmy
19:25:21 <sflynn1976> make sure to validate after you create an account
19:25:36 <sflynn1976> or editing is impossible
19:25:51 <mikeiudi> one sec mkenny2
19:25:59 <davexunit> look at all these smiling faces in here
19:26:08 <JamesC_WSU> What should this wiki contain, Kwurst?
19:26:10 <jon_cs401> did my link work>?
19:26:17 <JamesC_WSU> yes
19:26:20 <trevaaa> http://teachingopensource.org/index.php/User:thodde
19:26:23 <davexunit> blabbecs401: okay now what else to put in here...
19:26:32 <trevaaa> well that didn't work...
19:26:34 <danspc> where do i find my wiki
19:26:37 <blabbecs401> Put in how I am clearly superior since I picked a real IRC client :P
19:26:44 <kwurst> JamesC_WSU: Anything you  want that you are not embarrassed to put on it.
19:26:55 <JamesC_WSU> Jon, use facebook for general information?
19:27:00 <mkenny2> its your user page on teachngopensource.org
19:27:07 <jon_cs401> I sent you the link
19:27:15 <jon_cs401> Yeah
19:27:18 <JamesC_WSU> Yes but, for things like name/birthday etc
19:27:21 <kwurst> JamesC_WSU: You might want to mention the class. Maybe your email address (which I think is obfuscated.)
19:27:26 <sflynn1976> @cembree - you can add that i'm a wonderful person who enjoys video games and pizza
19:27:29 <jon_cs401> Yeah
19:27:32 <jon_cs401> Check yours
19:27:57 <kwurst> blabbecs401: Which IRC client is "real"?
19:28:06 <davexunit> kwurst: the not fake one
19:28:11 <mikeiudi> http://teachingopensource.org/index.php/User:Miudiciani
19:28:11 <blabbecs401> Heh
19:28:15 <CoadyL> who needs someone to edit their page?
19:28:17 <JamesC_WSU> what about my email being unclear?
19:28:21 <davexunit> i dunno \-__-/
19:28:22 <sflynn1976> @embree - validate your user account so i can edit it
19:28:28 <cembree> Ok, Steve... give me a link that I can copy to your paladin's armory :P
19:28:34 <danspc> I do
19:28:37 <danspc> dnpadams
19:28:41 <blabbecs401> I was kidding anyway. I use KVIrc because it's somewhat similar to chatzilla but not attached to a web browser and has some other nice features I don't think chatzilla has
19:28:45 <kwurst> danspc: You need to go to the teachingopensource site, and create an account if you haven't already. I'll send the link.
19:28:47 <ndoe049> l
19:28:51 <davexunit> kwurst: any type of information that we should put on here? just looking for general guidelines
19:29:03 <danspc> how do you paste
19:29:10 <jon_cs401> James do you want the same for your wiki? FB info?
19:29:10 <ndoe049> trevaaa: Edit my page! http://teachingopensource.org/index.php/User:Nathandoe
19:29:15 <kwurst> danspc: http://teachingopensource.org/index.php?title=Special:UserLogin&type=signup
19:29:22 <sflynn1976> http://us.battle.net/wow/en/character/gnomeregan/Druhz/simple
19:29:49 <trevaaa> working on it nathandoe
19:30:08 * kwurst waves at nadia!
19:30:12 <trevaaa> wanna edit mine? http://teachingopensource.org/index.php/User:thodde
19:30:24 <redsoxxx1999> i need someone to edit my page. anyone?
19:30:44 <mattamizer> I'll edit your page redsoxxx
19:30:47 * kwurst waves at Matt - finally!
19:30:52 <redsoxxx1999> thanks matt
19:31:00 <mattamizer> ain't no thang
19:31:04 <mattamizer> what's the address?
19:31:07 <redsoxxx1999> http://teachingopensource.org/index.php/User:Redsoxxx1999
19:31:11 <danspc> teachingopensource.org/index.php/User:Dnpadams
19:31:17 <blabbecs401> davexunit: Why don't we put choice of tools on our pages, want to try that?
19:31:18 <JamesC_WSU> Whats everyone putting in this?
19:31:21 <CoadyL> who still needs someone to edit for them?
19:31:22 * davexunit waves at nzahid and mattamizer \
19:31:26 <JamesC_WSU> Just run of the mill information
19:31:28 <danspc> i do
19:31:31 <mattamizer> groovy, what would you like up there redsoxxx?
19:31:35 <davexunit> blabbecs401: sure, i just put down that you go to wsu and stuff
19:31:37 <CoadyL> @danspc whats the link
19:31:41 <JamesC_WSU> I'm afraid I can't let you do that, Dave.
19:31:47 <redsoxxx1999> it doesnt matter, whatever u think of
19:31:47 <danspc> see above
19:31:50 <mikeiudi> hey Mike Kenny whats your link to your wiki
19:31:54 <ndoe049> Anyone else still need their page edited?
19:32:01 <kwurst> CoadyL: You don't need the "@" in front of a name
19:32:02 <mattamizer> I do
19:32:05 <trevaaa> I do
19:32:14 <mattamizer> want to edit mine Nate?
19:32:14 <ndoe049> mattamizer: whats the link?
19:32:16 <mkenny2> mikeiudi: http://teachingopensource.org/index.php/User:Mgrmaverick
19:32:17 <JamesC_WSU> Jon, What do you have so far?
19:32:22 <danspc> teachin.openCoaddy can you do mine
19:32:27 <sflynn1976> @embree - add this http://sflynn1976.wordpress.com/
19:32:34 <jon_cs401> Not much, check yours
19:32:40 <CoadyL> i got the link dan, are you editing someones already or could you edit mine?
19:32:42 <danspc> Coaddy can you do mine
19:32:46 <jon_cs401> What type of info do you want? FB stuff?
19:32:46 <blabbecs401_> davexunit: I keep getting disconnected
19:32:49 * Dhimitraq waves to mindo
19:32:54 <blabbecs401_> davexunit: Want to try putting choice of tools on the pages?
19:32:55 <JamesC_WSU> Classy, Jon.
19:32:56 <cembree> Steve, what do you think?  Have more you want me to add?
19:32:58 <mattamizer> http://teachingopensource.org/index.php/User:Mattamizer
19:33:02 <danspc> Coadday I cam do yours whats tje link
19:33:12 <kwurst> #info Don't forget that you can put a person's nickname at the beginning of the message to make it easier for them to see.
19:33:13 <davexunit> blabbecs401: sure, i just put down that you go to wsu and stuff
19:33:23 <Dhimitraq> midno http://teachingopensource.org/index.php/User:DJorgji
19:33:27 <mikeiudi> Okay, I am ready to start mkenny2 sorry for the hold up
19:33:33 <CoadyL> http://teachingopensource.org/index.php/User:Clacroix12
19:33:33 <davexunit> blabbecs401_: also, i am putting down contact info
19:33:33 <jon_cs401> @james thanks bro
19:33:39 <blabbecs401_> What no
19:33:44 <davexunit> blabbecs401_: just blog
19:33:48 <mindo> http://teachingopensource.org/index.php/User:Aandrade
19:33:53 <JamesC_WSU> jon_cs401 cool
19:33:55 <blabbecs401_> davexunit: Ok put blog
19:33:59 <blabbecs401_> Don't put email or anything
19:34:02 <jon_cs401> JamesC_WSU: tell me what you want on your wiki
19:34:07 <davexunit> blabbecs401_: nah
19:34:10 <JamesC_WSU> Guess I'll start mentioning sports in yours
19:34:14 <davexunit> blabbecs401_: just send me your blog url
19:34:22 <JamesC_WSU> jon_cs401 look at my facebook page for general
19:34:23 <jon_cs401> I like long walks on the beach
19:34:27 <sflynn1976> @cembree just a few lines are good
19:34:31 <Dhimitraq> mindo: include my wordpress blog @ dhimitraq.wordpress.org
19:34:38 <mattamizer> #davexunit are you using irsii right now?
19:34:40 <blabbecs401_> Ok also put Visual Studio, notepad++, WinSCP, putty, scite, gcc, gdb, valgrind
19:34:41 <sflynn1976> but i need soem info from you
19:34:42 <blabbecs401_> For tools
19:34:53 <CoadyL> danspc what kind of info do you want on yours?
19:34:54 <blabbecs401_> What should I put for you for tools davexunit (I will get you blog in a sec)
19:34:55 <danspc> Coaddy I am on there
19:34:55 <jon_cs401> JamesC_WSU: include a link to my blog too
19:34:59 <nzahid> can someone edit my page, please:http://teachingopensource.org/index.php/User:Nzahid
19:35:05 <jon_cs401> JamesC_WSU: jhasenzahl.wordpress.com
19:35:08 <davexunit> mattamizer: yes, btw don't use # or anything or i won't get notified
19:35:08 <danspc> Coaddy what do you want on there
19:35:15 <trevaaa> @ndoe Your username isn't registered
19:35:16 <JamesC_WSU> Ohh I see, when you put my nick infront it blinks the client
19:35:18 <blabbecs401_> davexunit: http://blabbecs401.wordpress.com/
19:35:18 <mattamizer> word
19:35:28 <mikeiudi> what do you do for work bro?>
19:35:28 <mattamizer> what's the command to notify then?
19:35:33 <Dhimitraq> midno: got a blog link for me to include??
19:35:41 <danspc> Coaddy you can just go to danspc.net & get some stuff from my website
19:35:42 <jon_cs401> JamesC_WSU: so far i know that you wear glasses
19:35:42 <davexunit> just type my nick but don't bother with the extra stuff
19:35:48 <mattamizer> gotcha
19:35:54 <davexunit> blabbecs401_: hmm tools, okay. well vim for starters
19:35:59 <sflynn1976> @embree also you can add my employment w/ papa gino's
19:35:59 <mkenny2> mikeiudi: i work at Umass Medical School
19:35:59 <mattamizer> I'm going to try irsii now that I have IRC working
19:36:01 <mattamizer> brb
19:36:03 <JamesC_WSU> jon_cs401 brool story.
19:36:09 <CoadyL> dan put my blog in there.. http://clacroix12.wordpress.com/
19:36:14 <Dhimitraq> mindo: correction http://dhimitraq.wordpress.com/ not .org
19:36:14 <davexunit> blabbecs401_: debian or arch linux as OS of preference
19:36:18 <Dhimitraq> ops
19:36:22 <ndoe049> trevaaa: I can get to the page...
19:36:31 <cembree> Ok, what do you want?  I'm planning to graduate in May, currently employed at Boston Market, Birthday of May 2nd, I play WoW...
19:36:40 <mkenny2> mikeiudi: we can use facebook info if u want to make it easier
19:36:41 <trevaaa> me too, but it says its not registered. I'll just edit it anyway haha
19:36:41 <jon_cs401> JamesC_WSU: take my Work out of there, i am ashamed of it
19:36:43 <trevaaa> maybe its wrong
19:36:54 <JamesC_WSU> Fine.
19:36:59 <blabbecs401_> davexunit: Ok, for OS for me put Debian and Win 7
19:36:59 <cembree> http://cmembree.wordpress.com/ there's my blog
19:37:09 <JamesC_WSU> 20% of your wiki
19:37:13 <ndoe049> trevaaa: that's weird, let me know if it doesn't work
19:37:14 <danspc> cOADDY ok i WILL USE SOME STUFF FROM THERE
19:37:15 <JamesC_WSU> GONE
19:37:16 <blabbecs401_> davexunit: blog please?
19:37:28 <JamesC_WSU> jon_cs401 blog link, please.
19:37:35 <cembree> http://us.battle.net/wow/en/character/dragonmaw/Bhaz/simple That's my WoW character
19:37:35 <jon_cs401> JamesC_WSU: jhasenzahl.wordpress.com
19:37:42 <trevaaa> @ndoe049 whats your blog address?
19:37:50 <jon_cs401> JamesC_WSU: what class level are you? junior?
19:37:51 <mikeiudi> is there criteria for what we post on the wiki?
19:37:55 <ndoe049> trevaaa: http://nathandoe.wordpress.com/
19:38:05 <JamesC_WSU> trevaaa if you don't put the add the @ it actually alerts them
19:38:14 <trevaaa> thanks
19:38:19 <Dhimitraq> mindo looks like before you can create the wiki you have validate the email you used to register
19:38:31 <JamesC_WSU> trevaa I got you.
19:38:34 <JamesC_WSU> A
19:38:40 <danspc> coAdyl What is your name
19:38:47 <mikeiudi> do you have any hobbies good sir?
19:38:59 <mattamizer> ahh
19:39:05 <mattamizer> this is WAY better than chatzilla
19:39:06 <JamesC_WSU> jon_cs401 should I mention you enjoy sports?
19:39:13 <mattamizer> davexunit thanks for the heads up on this
19:39:14 <davexunit> mattamizer: sure is man
19:39:18 <mindo> i did validate my email, should be fine try again
19:39:21 <JamesC_WSU> mattamizer chatzilla was way more user friendly
19:39:22 <jon_cs401> JamesC_WSU: yeah sure. red sox and pats are my favs
19:39:27 <JamesC_WSU> bruins
19:39:29 <mkenny2> mikeiudi: playing football/baseball, video games, guitar...how about you?
19:39:30 <mattamizer> now to add automation!
19:39:40 <JamesC_WSU> what I wouldn't give for a chat bot right now
19:39:43 <mikeiudi> videogames, diesel pick up trucks, cigars.
19:39:56 <kwurst> JamesC_WSU: What do you want the chat bot to do?
19:40:01 <CoadyL> danspc Coady LaCroix
19:40:05 <trevaaa> @ndoe http://teachingopensource.org/index.php/User:NathanDoe
19:40:14 <kwurst> JamesC_WSU: There is a bot recording this right now...
19:40:22 <JamesC_WSU> I meant to spam
19:40:33 <kwurst> JamesC_WSU: No thank you...
19:40:35 <davexunit> hahaha
19:40:47 <JamesC_WSU> It could be an open source bot?
19:40:48 <ndoe049> trevaaa: thats pretty accurate...
19:40:49 <mkenny2> mikeiudi: what about your blog link?
19:40:49 <davexunit> i have seen some very useful bots around though
19:40:54 <JamesC_WSU> dave, engage.
19:40:59 <mikeiudi> good idea, on it.
19:41:00 <davexunit> bots that post link titles and stuff
19:41:01 <blabbe> davexunit: Ok back
19:41:08 <trevaaa> @james what did you get me?
19:41:09 <blabbe> davexunit: link to your blog please?
19:41:10 <davexunit> blabbe: http://davexunit.wordpress.com
19:41:12 <jon_cs401> JamesC_WSU: blog link sir.
19:41:14 <mikeiudi> http://miudiciani.blogspot.com/
19:41:17 <CoadyL> danspc full name?
19:41:25 <mikeiudi> yours as well please sir. if you would
19:41:25 <kwurst> blabbe: What's going on with your client? Why do you keep dropping out?
19:41:40 <blabbe> It's not my client, I cant stay connected to the WSU network
19:41:41 <JamesC_WSU> jon_cs401 http://jamescelona.wordpress.com
19:41:46 <JamesC_WSU> trevaaa what do you mean?
19:41:47 <kwurst> mchua: Are you on?
19:41:48 <davexunit> strange
19:42:01 <trevaaa> oh nevermind I read it wrong
19:42:07 <trevaaa> you editing my wiki?
19:42:16 <trevaaa> @nate what else would you like in there?
19:42:21 <JamesC_WSU> trevaaa no I am not, sir.
19:42:29 <davexunit> blabbe: funny category. vim or emacs?
19:42:31 <Dhimitraq> mindo mind giving me a link to your blog please?
19:42:34 <JamesC_WSU> jon_cs410 jon what is your minor?
19:42:38 <kwurst> heidie: Are you keeping up with this?
19:42:42 <JamesC_WSU> jon_cs401 jon what is your minor?
19:42:46 <mkenny2> mikeiudi: http://michaelkenny2.wordpress.com/
19:42:46 <blabbe> davexunit: Well, I tend to not do text editing from CLI, but if I do, vim
19:42:49 <mindo> Dhimitraq: http://armindoa.wordpress.com/
19:42:57 <kwurst> heidie: Did you have your students to this exercise last semester?
19:42:59 <davexunit> blabbe: okay then text editor of choice?
19:43:03 <jon_cs401> JamesC_WSU: It was going to be math but i dont think im actually going to make it
19:43:07 <heidie> kwurst, sort of
19:43:09 <JamesC_WSU> so math
19:43:14 <mkenny2> mikeiudi: how about your job sir?
19:43:15 <blabbe> davexunit: notepad++ on windows, SCiTE on linux
19:43:15 <kwurst> davexunit: EMACS!
19:43:17 <CoadyL> danspc: whats your full name, and any other stuff you want on here thats not in the blog?
19:43:27 <davexunit> kwurst: haha i know that already
19:43:39 <davexunit> kwurst: i won't look down on you too much for that :P
19:43:40 <blabbe> davexunit: What else should I put for tools for you?
19:43:43 <kwurst> davexunit: EMACS or death!
19:43:46 <trevaaa> http://teachingopensource.org/index.php/User:Thodde
19:43:53 <danspc> coAdyl Dan Adams I am a self employed PC tech
19:43:54 <davexunit> blabbe: hmm one sec let me think
19:43:55 <Dhimitraq> mindo what's you age?
19:44:07 <JamesC_WSU> jon_cs401 http://teachingopensource.org/index.php/User:Jhasenzahl look how pretty it is
19:44:09 <mikeiudi> mkenny2: I work as a PCA for someone with Muscular Dystrophy
19:44:10 <mindo> Dhimitraq: 23
19:44:15 <blabbe> davexunit: Did you see the list of tools I gave you for me earlier?
19:44:18 <davexunit> blabbe: so vim for text editing. make/autotools for build system of choice
19:44:24 <mindo> Dhimitraq: Power level over 9000!
19:44:25 <danspc> coAdyl I enjoy guitar, carpentry, and computers (duh)
19:44:27 <davexunit> blabbe: i saw the os preference
19:44:37 <kwurst> #info You can type part of someone's name and hit TAB to complete it - less typing.
19:44:54 <davexunit> protip ^
19:44:57 <jon_cs401> JamesC_WSU: check out your page also and give me feedback
19:44:58 <JamesC_WSU> kwurst: thank god
19:45:01 <danspc> coAdyl My website is danspc.net
19:45:08 <blabbe> davexunit: Ok. Visual Studio, Notepad++, GCC, valgrind, GDB, SciTE, WinSCP, Putty
19:45:08 <JamesC_WSU> jon_cs401: relink
19:45:20 <jon_cs401> JamesC_WSU: dont be lazy http://teachingopensource.org/index.php/User:JamesCelona
19:45:22 <blabbe> Those are the tools I use on a regular basis
19:45:22 <mattamizer> EMACS FTW
19:45:29 <danspc> coAdyl How about u more info
19:45:29 <CoadyL> danspc: alright ill put all of that in, gimme a few then ill give you some stuff to put in mine
19:45:33 <davexunit> visual studio :(
19:45:40 <jon_cs401> JamesC_WSU: typo on personally
19:45:40 <kwurst> #info TAB completion also helps avoid typing errors...
19:45:42 <sflynn1976> cembree: looks good. ty
19:45:43 <blabbe> visual studio is the cadillac of IDEs
19:45:45 <trevaaa> vim <- thats whats up
19:45:46 <Dhimitraq> mindo ohh nooo--not that
19:45:54 <mikeiudi> mkenny2: what year student are you?
19:46:04 <blabbe> intellisense is the cruise control of programmers :P
19:46:09 <mattamizer> anyone find any cool FOSS projects yet?
19:46:12 <Guest84109> http://teachingopensource.org/index.php/User:Nzahid
19:46:14 <mkenny2> mikeiudi: junior, how about yourself?
19:46:19 <kwurst> Does everyone have someone that they are working with to edit their page? Anyone not have a partner?
19:46:20 <davexunit> mattamizer: yes
19:46:23 <mikeiudi> mkenny2: I am technically a senior, by credits a junior
19:46:28 <Joe_G> Does anyone have a page that needs to be edited?
19:46:28 <blabbe> I use visual studio for C++ on windows and C# on windows. For everything else I use notepad++ on windows, SCiTE on linux
19:46:37 <JamesC_WSU> jon_cs401: what other languages do you know aside from C/java
19:46:51 <mattamizer> Guest84109: Register your nick by typing /nick <yourname>
19:46:53 <davexunit> blabbe: what kind of FOSS projects interest you? gonna put a section about that
19:47:09 <mattamizer> davexunit: what'd you find?
19:47:14 <blabbe> Irrlicht, it's a cross platform multi-API rendering engine
19:47:18 <jon_cs401> JamesC_WSU: c/c++, java, html/css, visual basic
19:47:22 <trevaaa> I think I need someone to edit mine
19:47:29 <kwurst> Joe_G: Are you looking for someone to edit your page? Or someone's page to edit? Or both?
19:47:32 <jon_cs401> JamesC_WSU: do you like how ive written yours or do you want it more structured
19:47:35 <davexunit> mattamizer: mediawiki, gimp, ummm some others... lol,
19:47:41 <mkenny2> mikeiudi: page looks good so far anything else?
19:47:44 <blabbe> http://irrlicht.sourceforge.net
19:47:51 <JamesC_WSU> jon_cs401: it's yours to edit
19:47:52 <davexunit> blabbe: yeah i've seen irrlicht
19:47:52 <jon_cs401> JamesC_WSU: dont forget the Red Sox also
19:47:54 <heidie> kwurst, We didn't do this exact exercise. We had a conversation with mchua about two different FOSS projects to join.
19:48:01 <davexunit> i used ogre3d though and never tried irrlicht
19:48:21 <jon_cs401> JamesC_WSU: also let me know what types of activities you like
19:48:22 <davexunit> blabbe: how about in general? what types of software are you interested in developing?
19:48:23 <Joe_G> Kwurst: I am confused. I created a page but there is nothing on it. shouldn't I edit someone's for now?
19:48:25 <jon_cs401> JamesC_WSU: motorcycle?
19:48:30 <blabbe> davexunit: Irrlicht is basically like ogre only with a much more nicely designed API. Their capabilities are pretty close
19:48:30 <JamesC_WSU> jon_
19:48:33 <blabbe> davexunit: Game
19:48:35 <blabbe> Games*
19:48:37 <JamesC_WSU> jon_cs401: brotorcylcle
19:48:39 <kwurst> Joe_G: Ask for someone to edit your page
19:48:42 <JamesC_WSU> jon_cs401: brotorcycle*
19:48:53 <mattamizer> davexunit: gimp would be AWESOME to work on
19:48:53 <blabbe> kwurst: I sent you an email about irrlicht last monday, have you had a chance to check it out yet?
19:49:05 <mikeiudi> mkenny2: dream vehicle?
19:49:12 <kwurst> Joe_G: And you should ask if anyone needs their page edited.
19:49:12 <blabbe> Heh GIMP is a pain to USE imagine what it would be like to work on the code for it :P
19:49:12 <jochy> anyone bet on the superbowl yet?
19:49:21 <davexunit> i <3 gimp though...
19:49:27 <davexunit> well then how about INKSCAPE?
19:49:31 <mattamizer> jochy: nope. the game will be too close for me to bet money haha
19:49:32 <mkenny2> mikeiudi: hmmm.... Ashton Martin Vanquish...you?
19:49:36 <jon_cs401> JamesC_WSU: i am going to put that
19:49:36 <trevaaa> I think I still need someone to edit mine: http://teachingopensource.org/index.php/User:Thodde
19:49:41 <jon_cs401> JamesC_WSU: but i need more info
19:49:42 <davexunit> too bad
19:49:47 <blabbe> davexunit: What else should I put for tools?
19:49:49 <davexunit> cry moar trevaaa
19:49:53 <nzahid> Joe_G: I can edit your page. Here's mine if you could edit it for me:  http://teachingopensource.org/index.php/User:Nzahid
19:49:54 <mattamizer> rofl
19:50:00 <trevaaa> I can't possibly be crying any harder
19:50:01 <mikeiudi> mkenny2: Chevy Silverado 2500 Duramax Diesel
19:50:03 <blabbe> davexunit: And what should I* put for projects that interest you?
19:50:15 <mattamizer> mikeiudi: how is that a dream vehicle? lol
19:50:18 <kwurst> #info You can set up your IRC client to automatically set your nickname for each channel you use. It should be somewhere in your settings.
19:50:18 <JamesC_WSU> jon_cs401:  it's a 93 Suzuki GS500E been riding for little over a year now
19:50:20 <davexunit> blabbe: ummmm that might really be it. i just like being in the terminal. i live in vim basically.
19:50:33 <davexunit> blabbe: put down GNU Screen because I use that a ton
19:50:39 <mattamizer> davexunit: emacs is better, just sayin
19:50:42 <jon_cs401> JamesC_WSU: you dont go by any nickname just james right?
19:50:45 <blabbe> davexunit: So do you play dwarf fortress in ascii mode?
19:50:50 <kwurst> davexunit: Is vim better than straight vi?
19:50:50 <mattamizer> haha
19:50:55 <trevaaa> yes
19:50:57 <danspc> coAdyl How are you doing
19:50:59 <davexunit> kwurst: by leaps and bounds
19:51:06 <kwurst> davexunit: How?
19:51:08 <mikeiudi> mattamaizer: how is that NOT a dream vehicle?
19:51:12 <CoadyL> danspc: im a senior at wsu, computer science major(obviously), like to play video games, mostly MMOs and FPSs
19:51:18 <JamesC_WSU> jon_cs401: I have a few but I'd like to be known as James.
19:51:33 <jon_cs401> JamesC_WSU: I can understand that, James.
19:51:34 <davexunit> kwurst: plugins, syntax highlighting (did vi have this), easier to use i think
19:51:44 <davexunit> kwurst: i have all sorts of trouble using plain vi
19:51:45 <mikeiudi> mattamazier: oh I get it, my real dream vehicle is a bright pink dodge neon
19:51:49 <CoadyL> danspc: i also play soccer and like to golf, im attempting to learn how to play the keyboard
19:51:56 <JamesC_WSU> jon_cs401: what are your hobbies?
19:51:56 * mkenny2 laughs
19:51:58 <davexunit> kwurst: whereas vim is much nicer
19:52:05 <blabbe> Yeah I don't like vi. Might be that I am not used to it, but on a fresh debian install, first thing I add is vim :P
19:52:13 <mkenny2> i use to have a dodge neon... pretty beast
19:52:17 <blabbe> But I only use vim til I get xfce and scite installed ;)
19:52:21 <mattamizer> mikeiudi: lol
19:52:21 <davexunit> it IS Vi IMproved after all ;)
19:52:24 <CoadyL> danspc: anything else you want me to put in yours?
19:52:32 <Dhimitraq> mindo any info you want include other than wroking for EMC corp your driving habits and blog?
19:52:33 <blabbe> kwurst: Did you get a chance to look at irrlicht yet?
19:52:33 <mikeiudi> mattamizer: whats your dream vehicle then?
19:52:35 <kwurst> #info If you want to keep your nickname for yourself, and not let anyone else use it, you can register it: http://freenode.net/faq.shtml#registering
19:52:47 <blabbe> davexunit: What should I put for open source projects you are interesed in
19:52:50 <jon_cs401> JamesC_WSU: playing poker, playing video games, building computers
19:52:51 <danspc> coAdyl FPPs?
19:52:55 <JamesC_WSU> mattamizer if it's anything other than a brotorcycle we're in trouble.
19:52:58 <CoadyL> first person shooters*
19:53:03 <danspc> Oh
19:53:06 <long> so how can I edit someone else page?
19:53:08 <jon_cs401> JamesC_WSU: check your page again and give me some feedback http://teachingopensource.org/index.php/User:JamesCelona
19:53:11 <kwurst> blabbe: No, not yet.
19:53:14 <davexunit> blabbe: back to the wiki: software i am interested in. Game development as well: SFML, cocos2d, and Ogre3D are the high level libraries I have used
19:53:18 <mindo> Dhimitraq: hmm let me think for a moment, what do you want on yours? I just have your blog and your name, whats your Bday?
19:53:29 <blabbe> Haha you use like all the stuff I used to use lol
19:53:30 <mattamizer> JamesC_WSU: I totally want a brotorcycle
19:53:36 <Dhimitraq> mindo any hobbies?
19:53:42 <blabbe> SFML I moved to GLFW/OpenGL, Ogre I moved to Irrlicht
19:53:42 <JamesC_WSU> mattamizer:  that a boy
19:53:45 <davexunit> blabbe: Also, web development tools such as nodejs are very interesting to me
19:53:46 <blabbe> I never used cocos2d though
19:53:54 <ErkanYilmaz> long  - a wiki page has always a edit or create button/field (except the page is protected)
19:53:56 <kwurst> blabbe: To be honest, I'm not personally interested, because I don't know much about rendering engines. But if others are interested, we could consider it.
19:54:04 <Joe_G> @nzahid I will once I figure out how to use it
19:54:06 <davexunit> blabbe: you'd have it. it's in python :P
19:54:15 <mattamizer> blabbe: have you programmed with OpenGL? As I understand it, it's a nightmare
19:54:16 <davexunit> blabbe: i used to use glfw/opengl
19:54:18 <blabbe> davexunit: Ahh that explais why I did't usd it
19:54:19 <mikeiudi> anyone been playing on hellokitty.com lately? great games.
19:54:21 <nzahid> @Joe_G: Ok.
19:54:22 <mkenny2> mikeiudi: want to see what ur page looks like so far?
19:54:27 <blabbe> mattamizer: It's only a nightmare to people who don't know how to use it :P
19:54:36 <mindo> the question is who isnt on hellokitty.com really
19:54:36 <kwurst> Joe_G: Do you need help figuring out how to do something?
19:54:38 <danspc> coAdyl I got some off your FB page that should do it in 1 min
19:54:40 <mattamizer> blabbe: hahaha, fair
19:54:40 <davexunit> blabbe: but i like to not have to reinvent the wheel so much and SFML gives me all the basics
19:54:42 <mikeiudi> mkenny2: going to check right now, you save it?
19:54:45 <blabbe> Approximately 97% of all OpenGL complaints are made about stuff that has been removed from OpenGL years ago
19:55:06 <mattamizer> approx. 62% of statistics are made up on the spot
19:55:12 <blabbe> What is funny is that since OpenGL became the way it is now, DirectX is becoming more like OpenGL :P
19:55:20 <davexunit> blabbe: other FOSS that I like: anything that can replace a proprietary piece of software basically.
19:55:24 <mattamizer> eff DirectX
19:55:26 <kwurst> Anyone stuck? Need help?
19:55:29 <JamesC_WSU> jon_cs401:  http://teachingopensource.org/index.php/User:Jhasenzahl
19:55:30 <mkenny2> mikeiudi: just did how about mine?
19:55:33 <Joe_G> @ kwurst yes I am completely confused now
19:55:39 <mattamizer> I think it was Gabe Newell that said DirectX is killing PC gaming
19:55:41 <Dhimitraq> mindo I am 21 year old that likes programing and hate being bored; so  I try to keep busy all the time I enjoy strategy video games because I enjoy theorycraft/mathcraft and because I am competitive and there is always a winner --run on sentence ftw
19:55:42 <mindo> Dhimitraq: Hmm golf, working on cars, and computers are pretty much it
19:55:43 <blabbe> mattamizer: "The trouble with quotes on the internet is that it is hard to verify them" -- Abraham lincoln
19:55:44 <kwurst> Joe_G: What are you trying to do?
19:55:52 <mattamizer> blabbe: Touche
19:55:58 <blabbe> mattamizer: OpenGL or DirectX, pick one :P
19:55:59 <davexunit> i don't use directx because windows only proprietary stuff.
19:56:07 <Joe_G> @ kwurst to edit someones page but I cant find it?
19:56:08 <mikeiudi> mkenny2: I like it sir, very well said. contrite.
19:56:09 <mkenny2> mikeiudi: am I suppose to refer to you in first person or third
19:56:10 <mattamizer> blabbe: I love things that use OpenGL
19:56:20 <mattamizer> blabbe: mostly because I can use them on Linux
19:56:25 <davexunit> blabbe: What are your preferred programming languages?
19:56:25 <jon_cs401> JamesC_WSU: my wiki reads like a nigerian scam letter
19:56:26 <mindo> Dhimitraq: oh and of course LoL
19:56:31 <mikeiudi> mkenny2: I have not the slightest idea. also I hope you are reading my text in a british accent.
19:56:36 <kwurst> Joe_G: Ask them to send you the URL to their page, then open it in your browser.
19:56:36 <blabbe> davexunit: C++ is the only one I don't hate right now :P
19:56:36 <JamesC_WSU> jon_cs401:  LOL
19:56:45 <blabbe> JavaScript is alright as well
19:56:48 <davexunit> >c++
19:56:50 <blabbe> Ruby is meh
19:56:50 <davexunit> >don't hate
19:56:52 <davexunit> pick one
19:56:53 <JamesC_WSU> jon_cs401: please sent money
19:57:01 <davexunit> just kidding. C++ is okay.
19:57:04 <mattamizer> is it? back in the day JavaScript was super slow
19:57:05 <Joe_G> @kwust I have the url they sent it to me but I have no clue how to edit it
19:57:13 <davexunit> so i'll just down C++, javascript, and ruby then
19:57:15 <mattamizer> but I haven't used it in > 10 years
19:57:23 <jon_cs401> JamesC_WSU: you are never going to put in the fact that i like the red sox are oyu
19:57:25 <kwurst> davexunit: Does facebook let you list programming languages now? It keeps asking me what languages I know, but won't accept things like Java and Python.
19:57:31 <mkenny2> mikeiudi: i think we've finished this part of the assignment
19:57:36 <mikeiudi> mkenny2: would you like me to add anyting else to your page?
19:57:38 <JamesC_WSU> jon_cs401: what?
19:57:40 <mattamizer> kwurst: lulz
19:57:47 <jon_cs401> JamesC_WSU: nvm
19:57:49 <davexunit> kwurst: i have no idea. i hope so
19:57:51 <mikeiudi> mkenny2: I concur sir.
19:58:00 <long> send me your URL, Joe. Let me try to edit it
19:58:00 <blabbe> kwurst: Heh was that an anti Java / anti Python joke? If so you get +1 :P
19:58:01 <davexunit> ou KNOW?
19:58:03 <mattamizer> turns out we could work on 7zip
19:58:04 <davexunit> what
19:58:09 <kwurst> long: I was told that I missed your question.
19:58:15 <danspc> kwurst how long does it have to be
19:58:18 <jon_cs401> JamesC_WSU: take out that i am a math minor because i dont think i will actually achieve that
19:58:20 <davexunit> blabbe: perhaps better question: which languages do you know?
19:58:27 <Dhimitraq> kwurst facebook might hate those languages ? ^^
19:58:32 <long> @kwurst: I think i know what we're supposed to do no
19:58:33 <JamesC_WSU> jon_cs401: Wiki's are ever evolving
19:58:34 <davexunit> blabbe: that you can actually work with, even if it hurts
19:58:35 <long> *now
19:58:43 <Joe_G> @long which joe are you referring to me?
19:58:47 <kwurst> danspc: Not very long. I just want you to get a feel for editing the wiki.
19:58:48 <jon_cs401> JamesC_WSU: that makes no sense
19:58:48 <mattamizer> davexunit: that's what she said
19:58:55 <mikeiudi> davexunit: do you have any FOSS projects that you would consider for our group to tackle?
19:59:00 <JamesC_WSU> jon_cs401:  Quw?
19:59:04 <davexunit> mattamizer: your call is being monitored for quality assurance
19:59:05 <JamesC_WSU> que*
19:59:10 <blabbe> davexunit: C++, Ruby, PHP, JavaScript, a couple flavors of BASIC, and I know some python, c#, actionscript
19:59:11 <kwurst> long: Are you editing someone else's page yet?
19:59:14 <long> @Joe_G:u mind send me your page?
19:59:23 <mattamizer> davexunit: at least there's no cheesy hold music
19:59:25 <kwurst> long: Is someone editing your page?
19:59:33 <danspc> kwurst yes I saved it
19:59:46 <jon_cs401> JamesC_WSU: it says Majoring in Comp Scie and Minoring in Math, but im not minoring in anything
20:00:02 <mikeiudi> mkenny2: dave is probs the leader in our group, best programmer out of us I think...
20:00:03 <davexunit> blabbe: C, C++, Java, Python, Perl, PHP, Javascript, QBASIC (ha!), Freebasic (obscure)
20:00:04 <Joe_G> @long http://teachingopensource.org/index.php/User:Jgaval1 here ya go but someone is already editing my page
20:00:09 <jon_cs401> JamesC_WSU: also be a pro and make the blog an actual link pls
20:00:10 <long> @kwurst:umm..no to both of those questions
20:00:23 <kwurst> danspc: When you think you've had enough practice, and the person you are working with doesn't have more for you to edit, you can stop.
20:00:24 <JamesC_WSU> jon_cs401:  you're asking a lot
20:00:41 <jon_cs401> JamesC_WSU: id hate to be in your group
20:00:44 <trevaaa> I still don't have anyone editing mine haha
20:00:45 <CoadyL> danspc: take a look at your page, let me know if you want anything else in there. its pretty basic so far
20:00:47 <mkenny2> mikeiudi: this is true
20:00:51 <nzahid> @Joe_G after opening the link in your browser, click on User Page to edit it.
20:00:55 <trevaaa> http://teachingopensource.org/index.php/User:Thodde
20:01:02 <nzahid> @Joe_G what do you want me to add to your page?
20:01:09 <kwurst> danspc: It looks like long needs someone to work with, if you are done with the one you are working on.
20:01:14 <JamesC_WSU> jon_cs401: you hurt me
20:01:16 <mikeiudi> mkenny2: I am going to look at the next part of the week2 assignments then, get a head start
20:01:27 <mkenny2> mikeiudi: good idea
20:01:30 <kwurst> long: Ask for someone to work on your page
20:01:34 <mindo> Dhimitraq: when do you plan on graduating?
20:01:47 <ErkanYilmaz> long could match with trevaaa
20:01:47 <kwurst> long: Ask if anyone needs you to work on their page
20:01:52 <JamesC_WSU> jon_cs401: what are your hobbies, dreams, fears
20:01:53 <jon_cs401> JamesC_WSU: when are you graduating and what other hobbies do you have?
20:01:56 <trevaaa> that would be perfect
20:01:58 <mattamizer> kwurst: so we need to submit the FOSS writeups today?
20:02:01 <jon_cs401> JamesC_WSU: jinx
20:02:02 <jochy> long: you can work on mine
20:02:19 <JamesC_WSU> jon_cs401: Graduating in a year, hobbies: reddit, gaming, studying
20:02:21 <davexunit> blabbe: http://teachingopensource.org/index.php/User:Blabbe what i have so far
20:02:21 <Joe_G> @nzahid you can add whatever you like
20:02:22 <kwurst> Anyone who is mostly done? Please work with long
20:02:41 <jon_cs401> JamesC_WSU: tabletop gaming? do you like to be the DM?
20:02:44 <Dhimitraq> midno 2013 is my expected date I think I ll be able to graduate then.
20:02:45 <long> alright, can some1 edit mine, http://teachingopensource.org/index.php/User:Lnguyen11
20:02:52 <kwurst> mattamizer: No, the writeups are due next Monday, but you can start on it today, if you're tired of IRC and Wiki.
20:02:54 <JamesC_WSU> jon_cs401: Mostly console/PC
20:02:54 <mattamizer> kwurst: ok, so we should spend more time editing the other person's wiki?
20:02:54 <Joe_G> @nzahid to tell you the truth I am not sure what we are suppose to put on the page
20:03:03 <jon_cs401> JamesC_WSU: studying cant be a hobby of yours
20:03:06 <blabbe> davexunit: Heh you make me look like a crazy fool, I only use GCC on linux. I use the visual studio compiler on windows :P
20:03:11 <trevaaa> long: I can edit yours, can you get mine?
20:03:12 <JamesC_WSU> jon_cs401: I'm really good at it
20:03:17 <trevaaa> http://teachingopensource.org/index.php/User:Thodde
20:03:22 <blabbe> davexunit: http://teachingopensource.org/index.php/User:Davexunit
20:03:23 <long> @trevaaa:sure
20:03:31 <davexunit> blabbe: crazy fool? NOOOOO
20:03:35 <nzahid> Joe_G: what is your major? what are your hobbies?
20:03:39 <mattamizer> redsoxxx1999: give me some info that you want on your wiki, I don't have a lot up there
20:03:39 <kwurst> mattamizer: Yes, you should edit someone else's as well as having them edit yours.
20:03:52 <blabbe> davexunit: Using GCC on windows? That's crazy talk! :P
20:03:58 <JamesC_WSU> jon_cs401: you never answered me question
20:04:10 <Joe_G> @nzahid my major is Computer sciene
20:04:12 <mindo> Dhimitraq: what languages do you speak?
20:04:16 <blabbe> There are only 2 reasons to use GCC 1)You are on linux and 2)You want to use valgrind :P
20:04:17 <jon_cs401> JamesC_WSU: my dreams and fears are not apppropriate for a cs blog
20:04:25 <davexunit> blabbe: i guess that's unclear. i specified vs only on windows
20:04:27 <JamesC_WSU> jon_cs401: this is a blog of your life
20:04:37 <nzahid> Joe_G ok, i'll add that to your page.
20:04:37 <ErkanYilmaz> blabbe 3. you are a gcc team member
20:04:50 <mindo> JamesC_WSU: will it eventually become a movie?
20:04:51 <blabbe> ErkanYilmaz: I am what now?
20:05:04 <ErkanYilmaz> blabbe I extend your list from 2 to 3 points
20:05:19 <danspc> kwurst http://teachingopensource.org/index.php/User:ClacroiLnguyen11 did tou find someone
20:05:19 <davexunit> wat
20:05:22 <JamesC_WSU> mindo: only if you can dream it
20:05:24 <blabbe> ErkanYilmaz: Well I guess I should say "Only 2 reasons a sane person"
20:05:26 <mattamizer> redsoxxx1999: HEY!! HEYYY!!! are you still paying attention?
20:05:33 <ErkanYilmaz> blabbe :-)
20:05:34 <blabbe> If you are on the GCC team you are disqaulified because you're not sane :P
20:05:40 <danspc> lnguyen did you fid someone
20:05:42 <jon_cs401> JamesC_WSU: give my blog link a title so its not just a number plz
20:05:49 <mattamizer> blabbe: +1
20:05:59 <jon_cs401> JamesC_WSU: take out the gd math minor
20:06:00 <JamesC_WSU> jon_cs401: BLOG IS BOLDED
20:06:09 <mkenny2> i must be behind that FOSS writeup was due 11 days before the semester started...
20:06:11 <Joe_G> @nzahid what is your major? what would you like me to add to your page?
20:06:18 <long> @danspc: yes, i'm current in trevaaa page
20:06:21 <blabbe> mkenny2: You get an F
20:06:25 <JamesC_WSU> jon_cs401: done.
20:06:25 <blabbe> Just go home now.
20:06:29 <mattamizer> haha
20:06:30 <mattamizer> owned
20:06:31 <jon_cs401> JamesC_WSU: no you need to put a title in the link, look at how i did yours
20:06:35 <davexunit> doom doom doom go home now
20:06:35 * mkenny2 sighs
20:06:36 <mindo> are we allowed to just make stuff up?
20:06:38 <JamesC_WSU> jon_cs401: I know
20:06:40 <davexunit> no
20:06:42 <davexunit> you fool
20:06:43 <mattamizer> I'm gonna sing the doom song
20:06:47 <JamesC_WSU> jon_cs401: people will read blog, and see a link
20:06:50 <nzahid> Joe_G major Comp Sci, blog: nzahid.wordpress.com, senior at wsu
20:06:52 <jon_cs401> JamesC_WSU: bless you
20:06:53 <mattamizer> doom doom doom doom doom doom doom doom doom doom doom doom doom
20:06:54 <redsoxxx1999> oh sorry matt, no i wasnt. lol
20:06:57 <mattamizer> doom doom doom doom
20:06:58 * mikeiudi waves at mkenny2
20:07:02 <mattamizer> doom doom doom doom doom doom
20:07:05 <davexunit> mattamizer: spamming
20:07:07 <blabbe> davexunit: Think we have enough written down now?
20:07:07 <JamesC_WSU> ./ban mattamizer
20:07:08 <davexunit> :P
20:07:12 <mattamizer> <3 you all
20:07:13 <jon_cs401> JamesC_WSU: how did you make the Major/Minor part of my page look all different with a doted line?
20:07:13 <davexunit> blabbe: yeah probably
20:07:16 <Dhimitraq> mindo human: 3 Eng, Greek, and Albanian -- programming: C/C++, Java, javascript(ajax), bash, rub/php(only a couple of things on these though)...how about you?
20:07:22 <mattamizer> redsoxxx1999: so what do you want on your blog?
20:07:26 <JamesC_WSU> jon_cs401: put a bunch of spaces
20:07:30 <Dhimitraq> ruby*
20:07:34 * mikeiudi mattamizer has left the channel
20:07:40 <jon_cs401> JamesC_WSU: I dont believe you
20:07:45 <davexunit> mikeiudi: nuh uh
20:07:50 <JamesC_WSU> jon_cs401: for languages I know: Visual Basic, C, C++, Phyton, and java
20:07:51 <ErkanYilmaz> does someone need help in the syntax/formatting of his/her wiki page? or any other help?
20:07:52 <blabbe> Oh by the way THIS IS FOR EVERYONE: Help me convince kwurst to let us work on Irrlicht for our open source project. You will get to learn some things about making 3D games :)
20:07:53 <mikeiudi> davexunit: haha
20:08:00 <redsoxxx1999> ummm... i dont know. Put the patriots are gonna win the superbowl!
20:08:03 <davexunit> ErkanYilmaz: I am all set, but thanks
20:08:07 <nzahid> Joe_G do you want me to add anything else to your page?
20:08:09 <ErkanYilmaz> davexunit OK
20:08:09 <mattamizer> kwurst: hey, we should work on Irrlicht
20:08:11 <CoadyL> danspc: looks fine to me, anything you want me to add on yours?
20:08:21 <mattamizer> redsoxxx1999: okie doke
20:08:30 <davexunit> blabbe: Irrlicht is cool but not practical!
20:08:33 <JamesC_WSU> mattamizer link for the lazy?
20:08:38 <kwurst> mkenny2: Did I mess up the due date?
20:08:41 <blabbe> ALSO FOR EVERYONE: if we work on irrlicht, we will get to learn specifically about how to make things actually happen in 3D on the screen
20:08:49 <blabbe> davexunit: Irrlicht is no less practical than ogre :P
20:08:52 <JamesC_WSU> blabbe link for the lazy.
20:08:53 <mkenny2> kwurst: i think so it says 6 January 2012
20:08:54 <Dhimitraq> blabbe: agreed- irrlicht looks like a cool project.
20:08:57 <blabbe> JamesC_WSU: sec
20:08:59 <Joe_G> @nzahid you can also put senior
20:09:00 <davexunit> blabbe: I would love to just work on a music player for linux but that is also not practical
20:09:06 <nzahid> Joe_G ok
20:09:15 <davexunit> blabbe: I mean any 3D rendering library
20:09:15 <mkenny2> kwurst: i just assumed it was 6 Feb?
20:09:18 <kwurst> mkenny2: Ahhh, got the month wrong. I'll fix it.
20:09:19 <blabbe> davexunit: audio on linux period is not practical :P
20:09:20 <Joe_G> @nzahid anything else you would like me to add?
20:09:24 <JamesC_WSU> jon_cs401: what is your biggest achievement in CS thus far?
20:09:27 <blabbe> EVERYONE: This is irrlicht http://irrlicht.sourceforge.net/
20:09:30 <davexunit> no
20:09:42 <jon_cs401> JamesC_WSU: none to speak of, i hope this class will produce one
20:09:45 <nzahid> Joe_G that is all, thanks.
20:10:00 <JamesC_WSU> jon_cs401: you make this blog so easy
20:10:05 <blabbe> davexunit: If we worked on irrlicht we would actually be making a benchmark suite to help them improve the performance of irrlicht
20:10:09 <kwurst> long: Did you get someone to work with you/
20:10:13 <blabbe> Which would be quite practical :)
20:10:26 <mattamizer> blabbe: that looks like a HUGE project!
20:10:28 <blabbe> It would only require learning to use the Irrlicht API, which is quite simple
20:10:35 * mikeiudi likes using IRC better than pidgin
20:10:37 <blabbe> mattamizer: Hold on a sec I will show you something
20:10:42 <long> @kwurst: yes
20:10:43 <mattamizer> blabbe: ok
20:10:48 <davexunit> mikeiudi: IRC and pidgin are different things
20:10:50 <JamesC_WSU> jon_cs401: http://teachingopensource.org/index.php/User:Jhasenzahl happy?
20:10:52 * mikeiudi props to davexunit for irssi
20:10:57 <davexunit> ohhh irssi
20:10:59 <davexunit> yeah
20:11:03 <blabbe> mattamizer: http://irrlicht.sourceforge.net/docu/ scroll down to "A Short Sample"
20:11:03 <long> @kwurst: i added some comments on trevaaa page
20:11:05 <jon_cs401> JamesC_WSU: Yeah its dece
20:11:11 <kwurst> long: you don't need to use the "@", but it seems to work with it anyway...
20:11:13 <JamesC_WSU> jon_cs401: Low blow.
20:11:14 <mattamizer> blabbe: TO THE INTERNET
20:11:22 <mikeiudi> davexunit: yeah man feelin like a boss using it
20:11:23 * Dhimitraq shamefully using a webchat
20:11:37 <blabbe> mattamizer: That short sample is how you start up the engine, load a model, and then draw the model and text to the screen every frame
20:11:37 <long> kwurst: i guess it's a habit..:)
20:11:37 <davexunit> ohloh has MediaWiki as one of the most active projects
20:11:47 <blabbe> It's like 30 lines including whitespace and comments :P
20:11:51 <blabbe> Super easy to use
20:11:57 <davexunit> also, GNOME might be cool
20:11:59 <kwurst> davexunit: Yeah, but is it mostly in PHP?
20:12:05 <jon_cs401> JamesC_WSU: Yeah I think you should add some colors
20:12:09 <davexunit> yes it is a php webapp :(
20:12:09 <blabbe> Woah GNOME?
20:12:13 <JamesC_WSU> smh
20:12:20 <jon_cs401> JamesC_WSU: my favorite color is blue
20:12:20 <blabbe> Let's not do gnome lol
20:12:22 <long> so there's a limit to how many lines we can view?
20:12:23 <mattamizer> blabbe: that doesn't look bad at all
20:12:25 <kwurst> davexunit: You know what jeffm would say about it then...
20:12:27 <mikeiudi> davexunit: you ever mess with conky scripts by any chance?
20:12:29 <blabbe> mattamizer: Yeah it is really easy to use
20:12:34 <mattamizer> agreed, please no GNOME
20:12:36 <davexunit> kwurst: yes i would haha
20:12:39 <mattamizer> blabbe: seems it
20:12:40 <JamesC_WSU> jon_cs401: can't have any color in wikis
20:12:40 <davexunit> mikeiudi: yes
20:12:47 <mattamizer> blabbe: I'm on board
20:12:50 <jon_cs401> JamesC_WSU: :O
20:12:52 <trevaaa> this looks pretty cool: http://en.wikipedia.org/wiki/Armadillo_(C%2B%2B_library)
20:12:55 <ErkanYilmaz> JamesC_WSU jon_cs401 colors are possible
20:12:57 <kwurst> long: well, since it still works, you don't have to change...
20:13:00 <davexunit> kwurst: PHP is ugly and old, but she's tried and true and MediaWiki is a wonderful project
20:13:01 <mikeiudi> davexunit: I got fed up with it, couldn't get a weather script to work haha
20:13:09 <JamesC_WSU> ErkanYilmaz: I just didn't want to do t
20:13:11 <mattamizer> I think Edubuntu would be neat too, since it currently needs a lot of help IMHO
20:13:11 <JamesC_WSU> it
20:13:23 <ErkanYilmaz> JamesC_WSU OK
20:13:28 <jon_cs401> ErkanYilmaz: thank you
20:13:29 <davexunit> Edubuntu would be difficult i think
20:13:37 <jon_cs401> JamesC_WSU: give me my colors or im telling
20:13:42 <blabbe> TO EVERYONE: http://pastebin.com/wvasbNY This is a sample (taken from the irrlicht docs) of how to start the engine and drwa a model and text to the screen
20:13:42 <Joe_G> @nzahid thanks check out your page and let me know if you want me to change anything else
20:13:46 <mattamizer> whyfor? we're all students and they could use the feedback
20:13:47 <Dhimitraq> mindo go ahead and read your wiki, and see if you want anything added
20:13:50 <blabbe> That is why we should work with irrlicht!~~
20:13:52 <kwurst> mattamizer: Needs a lot of help is good, but would we need a lot of help to help them?
20:13:55 <JamesC_WSU> jon_cs401: I don't know how
20:14:04 <davexunit> mattamizer: what kwurst said
20:14:10 <mattamizer> kwurst: good question, I'll have to do more research
20:14:26 <ErkanYilmaz> jon_cs401 like a html command: e.g. <font color="red">my text</font>
20:14:26 <jon_cs401> anyone know how to display an image? it is accessible with a URL
20:14:31 <davexunit> well guys, GENTOO is the most active project on ohloh :P
20:14:35 <mattamizer> blabbe: unknown paste ID
20:14:42 <blabbe> Oh sorry one second
20:14:48 <jon_cs401> ErkanYilmaz: thanks
20:14:54 <Dhimitraq> mindo so what do you think the power level of your wiki page is? ^^
20:14:54 <blabbe> http://pastebin.com/wvasbNYY THIS is a sample of irrlichyt
20:14:57 <blabbe> irrlicht*
20:14:59 <nzahid> Joe_G it looks good, thanks. check out your page too and let me know if it's ok.
20:15:03 <JamesC_WSU> jon_cs401: no color
20:15:03 <mindo> Dhimitraq: 7
20:15:10 <davexunit> kwurst: what languages should i try to stick to? Java, C?
20:15:12 <kwurst> #action Everyone should send me their teachingopensource.org username
20:15:13 <jon_cs401> JamesC_WSU: okay i tried
20:15:14 <mindo> Dhimitraq: lol jk its good
20:15:14 <davexunit> as far as a project
20:15:18 <blabbe> PLEASE not Java
20:15:21 <blabbe> PLEASE
20:15:24 <Joe_G> @nzahid Its perfect! thanks
20:15:28 <davexunit> kwurst: in a PM or...?
20:15:33 <mikeiudi> mkenny2: I think whatever davexunit suggests we should vote for the same project...however I hope he isn't looking at super difficult projects...
20:15:34 <blabbe> I've served my sentence but commited no crime :[
20:15:43 <mattamizer> blabbe: is that the same code you just had me look at?
20:15:44 <danspc> kwurst danspc
20:15:44 <kwurst> davexunit: C and Java have the advantages the everyone in the class should know them...
20:15:47 <blabbe> mattamizer: Yes
20:15:51 <ErkanYilmaz> jon_cs401 "anyone know how to display an image? it is accessible with a URL" <- depends on plugins of that wiki being installed or not, normally people upload meida to the wiki
20:16:16 <ErkanYilmaz> meida <- media
20:16:21 <trevaaa> It shoudn't matter what language it's in (unless it's Scheme or something). People should be willing to learn a new language at this point
20:16:23 <davexunit> kwurst: yeah that's my logic there as well... but there aren't a lot of java projects that are any good
20:16:30 <davexunit> but C projects... there are tons
20:16:32 <CoadyL> trevaaa: agreed
20:16:37 <kwurst> danspc: I think I'll put up an assignment on bboard (or something) don't have to write them all down...
20:16:45 <JamesC_WSU> trevaaa we should just write in binary
20:16:45 <blabbe> Well, of the ones kwurst mentioned, Firefox is C++ and JavaScript
20:16:54 <kwurst> davexunit: see my answer to danspc
20:16:58 <mattamizer> firefox wwould be fun
20:16:58 <jon_cs401> ErkanYilmaz: ok thanks
20:16:59 <trevaaa> JamesC: or Assembly
20:17:00 <mikeiudi> kwurst: I agree about using something with C or java...
20:17:14 <sflynn1976> C or C++
20:17:14 <blabbe> Both of which are pretty decent languages. Everyone probably already knows C++ I think and JavaScript is pretty easy to get started with
20:17:15 <JamesC_WSU> trevaaa: can't even link right
20:17:15 <mattamizer> I'm fired up on this irrlicht idea though
20:17:25 <blabbe> Yeah everyone join mattamizer and I
20:17:27 <davexunit> I would vote for a C program then. would C++ be acceptable?
20:17:31 <mattamizer> I don't know C++, but I'm sure i can pick it up quick
20:17:31 <blabbe> Let's all pull for Irrlicht :P
20:17:44 <blabbe> Who WOULDNT want to work on a 3D rendering engine? :D
20:17:45 <davexunit> Since OOP is obviously something everyone here knows
20:17:56 <mattamizer> we're down with OOP?
20:17:56 <davexunit> blabbe: i don't think anyone is taking your bait haha
20:17:57 * mikeiudi is surprised mattamizer knows how to program?
20:17:59 <trevaaa> C++ would be awesome
20:18:08 <mattamizer> mikeiudi: hur hur hur
20:18:11 <kwurst> #action Groups should try to decide on a group name
20:18:23 <mattamizer> AWESOMEALOT OCELOTS
20:18:27 <trevaaa> the BAMFs
20:18:28 <JamesC_WSU> jon_cs401: glad you put my motto there
20:18:30 <blabbe> Who else is in group 4?
20:18:34 <davexunit> TEAM NOTGOODATMUCH
20:18:37 <kwurst> mattamizer: I think you mentioned that before....
20:18:38 <JamesC_WSU> jon_cs401: add my gamertag, and steamID so we can pwn noobs
20:18:41 * mikeiudi likes daves
20:18:44 <mattamizer> davexunit: llz
20:18:48 <mattamizer> davexunit: lulz*
20:18:48 * mkenny2 gives a thumbs up.
20:19:06 <blabbe> TEAM FOUR IS TEAM EDWARD
20:19:06 <mattamizer> JamesC_WSU: I need your Steam ID brah
20:19:08 * blabbe runs away
20:19:08 <mkenny2> i like to pwn nubs in halo.
20:19:10 <kwurst> #action Groups can make team pages on the WSU CS Wiki. I'll go get the link...
20:19:18 <JamesC_WSU> mattamizer: musclegaze
20:19:18 <mattamizer> blabbe: -9001 internets
20:19:19 <JamesC_WSU> sup
20:19:21 <JamesC_WSU> brah
20:19:22 <jon_cs401> JamesC_WSU: whats your steam ID
20:19:24 <davexunit> can we wordfilter pwn and nub?
20:19:35 <jon_cs401> JamesC_WSU: check it your brotorcycle is now clickable
20:19:36 <JamesC_WSU> musclegaze
20:19:40 <davexunit> they need to die with 1999
20:19:43 <blabbe> davexunit: Why nub? You don't want to get pwned?
20:19:44 * mikeiudi winces at thought of twilight movies
20:19:50 <davexunit> ;__;
20:20:03 <JamesC_WSU> best picture to date
20:20:18 <kwurst> #info I made a CS 401 Spring 2012 page on the WSU CS wiki: http://cs.worcester.edu/wiki/index.php?n=Main.CS401Spring2012?action=edit
20:20:20 <mattamizer> clearly better than that Titanic waste of time
20:20:23 <mattamizer> shee what I did there?
20:20:42 * mikeiudi laughs at matt not with him
20:20:44 <davexunit> http://beefymiracle.org/
20:20:55 <mattamizer> kwurst: do you want us to put our usernames there?
20:20:56 * blabbe doesn't click davexunit's link
20:21:02 <mkenny2> lol
20:21:03 <JamesC_WSU> mattamizer: what is your id?
20:21:09 <kwurst> davexunit: Isn't that a fedora build?
20:21:10 <mattamizer> JamesC_WSU: mattamizer
20:21:13 <CoadyL> not sure if i should click that or not...
20:21:17 <mindo> ^
20:21:21 <JamesC_WSU> mattamizer: how am I going to remember that?
20:21:22 <davexunit> kwurst: Yes. it's the name for Fedora 17
20:21:26 <davexunit> just found it funny
20:21:32 <blabbe> fedora? Why do you like terrible things?!?! :P
20:21:37 <jon_cs401> JamesC_WSU: added your steam ID, anything else?
20:21:45 <jon_cs401> JamesC_WSU: my steamID corb01772
20:21:51 <davexunit> blabbe: I don't use fedora, but i don't hate it
20:21:52 <kwurst> mattamizer: Yes, creating a page for your group, and putting links to your TOS pages sounds like a good idea
20:21:53 <JamesC_WSU> jon_cs401: ew
20:21:53 <mattamizer> JamesC_WSU: I know, so hard to remember all my different user names
20:22:03 <mattamizer> kwurst: m'kay
20:22:20 <davexunit> so i'm in group 3, right mikeiudi ?
20:22:23 <mikeiudi> davexunit: are you for reals on our team name? I am for it.
20:22:23 <davexunit> i'll make a page
20:22:25 <CoadyL> so... awesomealot ocelots it is?
20:22:27 <teamspirit> steam makes my money disappear...T.T
20:22:31 <blabbe> Who else here is in group 4?
20:22:33 <mikeiudi> davexunit: roger that
20:22:45 <blabbe> Who wants to create a page for groupr 4 (not me :D )
20:22:49 <blabbe> -r
20:22:59 <kwurst> #action Each group should create a group page on the WSU CS Wiki
20:23:05 <mattamizer> who is in group 1 with Coady and I?
20:23:08 <mikeiudi> davexunit: I will edit it once you add some stuff?
20:23:17 <CoadyL> group 1.... assemble
20:23:21 <teamspirit> mattamizer: what is our group name?
20:23:25 <trevaaa> @Group 5: what's up?
20:23:43 * mikeiudi wishes the team name was Channel 5 News team..thanks coady lol
20:23:50 <jon_cs401> JamesC_WSU: your wiki is a masterpiece and is finished
20:23:50 <JamesC_WSU> who is in my group
20:23:58 <kwurst> #info You probably want to come up with your group name first
20:24:02 <JamesC_WSU> jon_cs401: link
20:24:04 <sflynn1976> wracking my brain for a good but appropriate name for 5
20:24:07 <ndoe049> trevaaa: You pick it out
20:24:12 <jon_cs401> http://teachingopensource.org/index.php/User:JamesCelona
20:24:13 <blabbe> group 4 will be the kids who are too cool to have a name
20:24:14 <CoadyL> now i want to be in group 5 >.<
20:24:16 <danspc> Group 3 do we have a name
20:24:18 <kwurst> #info Doesn't have to be done today...
20:24:20 <blabbe> We will just be
20:24:23 <blabbe> "Group 4"
20:24:28 <trevaaa> ndoe049: I'll try to think of something
20:24:31 <teamspirit> kwurst do we emal you our teaching os user name?
20:24:46 <teamspirit> group 1 ftw
20:24:46 <long> I might have missed it, but does group 2 have a name yet?
20:24:52 <kwurst> teamspirit: How about you put it on your group page
20:24:54 <jon_cs401> Group 3 here
20:24:55 <mikeiudi> kwurst: Do we create the team page under the CS Project Section?
20:24:57 <mattamizer> teamspirit: Awesomealot Oscelots was tossed out there
20:25:03 <ndoe049> trevaaa: your first idea was pretty awesome
20:25:04 <JamesC_WSU> jon_cs401: your blog is done as well, pleas sent monie quikhttp://teachingopensource.org/index.php/User:Jhasenzahl
20:25:07 <mattamizer> any other ideas for a group 1 team name?
20:25:13 <kwurst> mikeiudi: Go to http://cs.worcester.edu/wiki/index.php?n=Main.CS401Spring2012?action=edit
20:25:41 <CoadyL> mattamizer: i dont think i can top that one at the moment
20:25:50 <JamesC_WSU> James Celona
20:25:51 <davexunit> yeah i am still trying to figure out how to add a new page
20:25:52 <JamesC_WSU> Long Nguyen
20:25:53 <JamesC_WSU> Armindo Andrade
20:25:55 <JamesC_WSU> Marcos Knight
20:25:57 <JamesC_WSU> Who are you?
20:25:59 <trevaaa> ndoe049: glad you liked it :)
20:26:03 <jon_cs401> JamesC_WSU: he likes to enjoys playing poker. jon drives himself a honda civic
20:26:06 <jon_cs401> JamesC_WSU: lmao
20:26:07 <mindo> <-- im Armindo Andrade
20:26:09 <mikeiudi> thats the main page do we add a new internal link to a page under CS projects?
20:26:12 <long> I'm me....
20:26:23 <JamesC_WSU> long we're in a group
20:26:24 <davexunit> unsigned long
20:26:27 <JamesC_WSU> LOL
20:26:30 <long> lol
20:26:33 <teamspirit> mattamizer: did you create the wiki yet?
20:26:40 <mattamizer> teamspirit: no
20:26:45 <mattamizer> teamspirit: am I supposed to be?
20:26:47 <teamspirit> GROUP 1 anyone created the wiki yet?
20:26:51 <kwurst> mikeiudi: Someone needs to start the CS 401 page at that link. Then you can create new group pages linked from there.
20:27:03 <JamesC_WSU> jon_cs401: send me your link
20:27:08 <teamspirit> mattamizer: was asking if anyone did so didn't make double
20:27:15 <jon_cs401> JamesC_WSU: http://teachingopensource.org/index.php/User:JamesCelona ??
20:27:20 <JamesC_WSU> jon_cs401: no yours
20:27:33 <jon_cs401> JamesC_WSU: just replace yourname with Jhasenzahl
20:27:37 <mattamizer> teamspirit: nope, if you could make the page I would be eternally grateful
20:27:45 <mikeiudi> davexunit: sir, where will our page be located? under the Other links under the Sections?
20:27:55 <JamesC_WSU> jon_cs401: yeah but your lastname isn't something easily remembered
20:27:59 <sflynn1976> create a new wiki page [[page name]]
20:28:02 <kwurst> #info Warning: If everyone tries to edit the wiki page at once, we'll get conflicts. They can be fixed, but I wanted to warn you...
20:28:06 <mattamizer> teamspirit: and we shall be the Awesomealot Oscelots and be THE GREATEST TEAM IN ALL THE LAND
20:28:06 * teamspirit trying to find where to seel
20:28:21 <jon_cs401> JamesC_WSU: http://teachingopensource.org/index.php/User:Jhasenzahl
20:28:23 * mikeiudi laughts at team Awesomealot Oscelots
20:28:33 <kwurst> #info Unfortunately the wiki software I installed doesn't handle simultaneous edits well.
20:28:34 <mattamizer> mikeiudi: I will kill you ded
20:28:41 <mattamizer> mikeiudi: :D
20:28:41 <JamesC_WSU> jon_cs401: too late now
20:28:47 * mikeiudi starts packing his bag...
20:28:52 <teamspirit> mattamizer: do we get knighted as well
20:28:55 <blabbe> kwurst: Is your bot tracking hash tags?
20:28:55 <davexunit> mikeiudi: okay now for a name...
20:28:57 <CoadyL> mikeiudi: you best watch yourself
20:29:02 <kwurst> #info But it was easy to install.
20:29:06 <JamesC_WSU> mikeiudi hold it right there, pla.
20:29:08 <JamesC_WSU> pal
20:29:21 * mikeiudi just got threated by matt's whole team
20:29:28 * mikeiudi threatened**
20:29:40 <kwurst> blabbe: Yes, we're using meetbot, which will produce minutes later, with lists of actions (to-dos)
20:29:41 <davexunit> mikeiudi: team __________ we need name
20:29:49 <blabbe> Ahh ok
20:29:54 <jon_cs401> davexunit: group 3?
20:29:58 <mattamizer> davexunit: Team Rocket, you won't
20:29:58 <davexunit> yes
20:29:59 <JamesC_WSU> group Number 2: whats the deal?
20:30:02 <davexunit> i will
20:30:04 <mikeiudi> davexunit: Team Rocket Seconded!
20:30:06 <davexunit> that's our name
20:30:08 <davexunit> perfect
20:30:10 <mattamizer> win!
20:30:11 <davexunit> thanks mattamizer
20:30:15 <blabbe> OH DARN
20:30:23 <blabbe> Why didn't I think of Team Rocket :(
20:30:26 <long> group 2: we need a name?
20:30:28 <mikeiudi> wait it was matt's idea? we should start over
20:30:28 <jon_cs401> Team Rocket?
20:30:31 <mattamizer> rofl
20:30:32 <kwurst> There was a Team Rocket last time I taught this course...
20:30:44 <mattamizer> Prepare for trouble...
20:30:50 <davexunit> and make it double
20:30:52 <mindo> Group 2 name........................
20:30:53 <kwurst> Want to guess who was in that group?
20:31:02 <davexunit> jesse and james
20:31:03 * mikeiudi wants to be meowth in the group of team rocket
20:31:17 <davexunit> meeeeeowth that's right!
20:31:17 <long> group 2: since they all like Team Rocket, let us be Team Magma
20:31:25 * teamspirit scared no groups have appeared yet.
20:31:25 <kwurst> matt is having a heart attack
20:31:26 * mikeiudi also wants a shot at jesse
20:31:29 <davexunit> LOOKS LIKE TEAM ROCKET'S BLASTING OFF AGAAAAAAAAAIIIIIIIIIIN
20:31:34 <mattamizer> love it
20:31:36 <mattamizer> lol
20:31:37 <blabbe> *ding*
20:31:42 <mattamizer> leveled up?
20:31:44 <blabbe> *sparkle*
20:31:50 * mikeiudi is trying to remember where he left his game boy and pokemon red
20:31:52 <davexunit> haha as they disappear into the horizon
20:31:55 <trevaaa> each team could be a member of the elite 4
20:31:59 <JamesC_WSU> so team group 2
20:32:02 <JamesC_WSU> whats the dilly?
20:32:06 <blabbe> mikeiudi: Mine are right next to my bed. I bring mine here to school some day s:P
20:32:09 <davexunit> mikeiudi: at the convenience store when you were 12
20:32:11 <JamesC_WSU> aside from long I dunno any of you
20:32:16 <mikeiudi> blabbe: sounds good
20:32:28 <long> @JamesC: I don't care man, just pick a name....
20:32:30 <davexunit> okay so everyone, pokemon themed names
20:32:33 <mindo> JamesC_WSU: What if everyone in Group 2 stands up?
20:32:34 * mikeiudi remembers he emulated his gameboy onto his droid phone...
20:32:37 <davexunit> team aqua, team magma
20:32:39 <kwurst> So, guesses as to who was in the last Team Rocket?
20:32:43 * JamesC_WSU team group 2 stand
20:32:43 <davexunit> team... somethingorother
20:32:44 <blabbe> davexunit: Nuh-uh
20:32:46 <mattamizer> John
20:32:47 * JamesC_WSU team group 2 stand
20:32:48 <mkenny2> mikeiudi: maybe its at the toys'r us pokemon league
20:32:48 <mattamizer> Rocko
20:32:55 <kwurst> mattamizer: nope
20:32:59 <blabbe> If you aclnowledge the existence of pokemon after G/S/C you LOSE
20:32:59 <long> can't we just raise hand =.=
20:33:01 <blabbe> Good DAY SIR
20:33:02 <mindo> JamesC_WSU: no one stood up first
20:33:03 <mattamizer> team 1, shall we be team aqua?
20:33:05 <mikeiudi> WTS Holigraphic Charizard?
20:33:11 <JamesC_WSU> mindo: maybe I'm all by myself
20:33:16 <davexunit> blabbe: haha yeahhhhh but i still play the new ones
20:33:28 <davexunit> my friend refuse to recognize after 151
20:33:30 <mattamizer> ok, team 1 is team aqua now
20:33:31 <JamesC_WSU> S> Charizard cards
20:33:32 <blabbe> davexunit: You LOSE you get NOTHING good DAY SIR
20:33:33 <mattamizer> we rebranded
20:33:33 <davexunit> friends*
20:33:42 <mattamizer> I SAID GOOD DAY!
20:33:43 <JamesC_WSU> T> Charizard cards  for runescape EQ
20:33:48 <davexunit> blabbe: don't quote gene wilder in my chat room!
20:33:54 <mattamizer> oh god, EQ
20:34:04 <mattamizer> so many hours lost to the abyss
20:34:07 <kwurst> Now, I have to see if I can remember...
20:34:31 <mikeiudi> ah runescape...how many days I will never get back I wonder...
20:34:41 <sflynn1976> team5 = 'A Fifth'
20:34:48 <teamspirit> GROUP 1 http://cs.worcester.edu/wiki/index.php?n=Main.AwesomealotOscelots
20:35:04 <mattamizer> teamspirit: THANKS! :D
20:35:06 <blabbe> HEY WHO IS FROM GROUP 4 I iknow me and EdCS401 is. WHO ELSE
20:35:07 <trevaaa> 3/5
20:35:21 <trevaaa> as in compromise
20:35:27 <blabbe> Team 4 = "Group 4"
20:35:43 <mkenny2> solid name
20:35:46 <JamesC_WSU> TeamTwoTimesTooMany
20:35:48 <CoadyL> +1 for originality
20:35:55 <mattamizer> ^
20:36:00 <teamspirit> GROUP 1 go add in your user names for teaching open source please.
20:36:04 <sflynn1976> what's wrong with an alcohol reference?
20:36:07 <mikeiudi> davexunit: want a rename?
20:36:07 <kwurst> So, have we driven off all the non-CS 401 people?
20:36:14 <mattamizer> TO THE INTERNET
20:36:15 <davexunit> hahahahah
20:36:18 <ianweller> kwurst: i'm sitting here laughing
20:36:23 <davexunit> yeah we flooded this room...
20:36:26 <Joe_G> blabbe I am in group 1
20:36:35 <Joe_G> blabbe i meant group 4
20:36:39 <kwurst> ianweller: I'm glad you're amused.
20:36:39 <blabbe> Oh heh
20:36:43 <ianweller> kwurst: it's a great distraction for whatever class i'm supposedly sitting in right now
20:36:51 <davexunit> lol
20:36:53 <mikeiudi> group two is installing aim and trying to find the opensource channel
20:36:55 * ianweller . o O ( where am i )
20:36:56 <trevaaa> group 5: sqrt(25)?
20:37:02 <Joe_G> blabbe what is our group name? lol
20:37:12 <blabbe> Joe_G: Our group name is "Group 4"
20:37:31 <blabbe> We are too noncomformist to make a name
20:37:36 <danspc> Group 3 Name?
20:37:45 <davexunit> team dr pepper?
20:37:46 <kwurst> mattamizer: And the wiki markup for PMWiki differs slightly from MediaWiki (Wikipedia)
20:37:53 <sflynn1976> A fifth of 25?
20:37:55 <jon_cs401> car ramrod
20:38:06 <blabbe> Actually I will let the rest of you guys in group 4 decide, we have two choices
20:38:07 <long> Groups 2, please raise hand...I only knows 2 James...
20:38:08 <JamesC_WSU> TeamTwoTyrannicalTeenTitains roll call
20:38:09 <davexunit> i think team rocket is the best we're gonna do\
20:38:11 <blabbe> We can be "Group 4" OR
20:38:13 <davexunit> ooh ooh unlessssss
20:38:18 <davexunit> blue baracudas
20:38:21 * mikeiudi Team Rocket link has a question mark next to it?
20:38:21 <davexunit> silver snakes
20:38:21 <ndoe049> trevaaa: I vote for that
20:38:26 <blabbe> We can be "Fellowship of the Ring" (In that case I am Gandalf of course)
20:38:27 <mkenny2> legends!
20:38:30 <davexunit> red jaguars
20:38:34 <davexunit> purple parrots
20:38:35 <mkenny2> Green Monkeys
20:38:41 <davexunit> that one was lame
20:38:42 <davexunit> leave
20:38:43 <kwurst> mattamizer: Click on the "Basic Editing" link at the bottom of the left menu...
20:38:46 <JamesC_WSU> SILVER SNAKES
20:38:46 <CoadyL> legends of the hidden temple reference? lovin it
20:38:52 <mkenny2> lol
20:38:57 <davexunit> okay mcdonalds product placement
20:39:00 <kwurst> mikeiudi: That means that the page is not created yet.
20:39:00 <mikeiudi> davexunit: Anoynmous for a team name?
20:39:01 <blabbe> 90s nick for the win :P
20:39:04 <Joe_G> blabbe i think "fellowship of the Ring" is a little extreme, dont you think?
20:39:07 <jon_cs401> davexunit: i vote for anything not pokemon related
20:39:08 <teamspirit> mattamizer: [[ http://teachingopensource.org/index.php/User:DJorgji | *Dhimitraq Jorgji]]  looks something like that
20:39:10 <davexunit> mikeiudi: god no
20:39:10 <sflynn1976> robot jesus and the purple ponies
20:39:13 <mikeiudi> kwurst: Thank you sir.
20:39:22 <teamspirit> mattamizer: for external links
20:39:30 <davexunit> jon_cs401: team jigglypuff it is
20:39:35 * kwurst salutes mikeiudi
20:39:42 <blabbe> Joe_G: We must destroy the ring!
20:39:43 <mikeiudi> davexunit: Team Name: Hannah Montana?
20:39:50 <davexunit> mikeiudi: no
20:39:51 * mikeiudi crosses fingers
20:39:54 * mikeiudi cries
20:39:56 <jon_cs401> davexunit: i am at your mercy of whether it fits my criteria cuz i have no idea
20:39:58 <JamesC_WSU> long hi
20:39:58 <mkenny2> mikeiudi: Team Edward?
20:39:59 * davexunit crushes hopes and dream
20:40:06 <davexunit> s
20:40:17 <JamesC_WSU> long we are not group 2TwoPeople
20:40:18 <kwurst> mkenny2: No: Star Alliance!
20:40:19 <Joe_G> blabbe what does the other people in the groupp think?
20:40:34 <blabbe> I dunno they won't SAY ANYTHING IN THE CHANNEL
20:40:34 <JamesC_WSU> long we are now group 2TwoPeopleTooShort**
20:40:39 <blabbe> HEY GROUP 4 SPEAK UP
20:40:41 <mattamizer> kwurst: got it
20:40:42 <kwurst> mkenny2: Do you know about the Star Alliance?
20:40:52 <mikeiudi> Team: SnakesOnAPlane?
20:40:55 <davexunit> no
20:40:58 <long> @JamesC: lol...
20:40:58 <mkenny2> kwurst: no i do not
20:40:59 <mikeiudi> best movie ever? lmao
20:41:06 <JamesC_WSU> mikeiudi birds on a bus
20:41:13 <davexunit> Team: Segfault?
20:41:19 <davexunit> meh
20:41:27 <mikeiudi> Team: SamJackson?
20:41:30 <davexunit> NO
20:41:32 <mikeiudi> AH
20:41:35 <kwurst> That is George Takaei's StarWars/StarTrek group opposing Twilight
20:41:36 <mikeiudi> Team: Miley Cyrus?
20:41:43 <JamesC_WSU> aww yeahhh
20:41:51 <mikeiudi> Team: LohanCyrusBieber?
20:41:52 <mattamizer> kwurst: SUCH A THING EXISTS?! TO THE INTERNET!!!
20:41:52 * davexunit removes mikeiudi's naming privileges
20:41:53 <kwurst> Oops, misspelled Takei
20:41:55 <JamesC_WSU> I mean, respectable, my chap.
20:42:01 <mikeiudi> that last one was good?
20:42:03 <mikeiudi> lol
20:42:06 <mkenny2> kwurst: haha i knew there would be something like that out there
20:42:24 <trevaaa> ndoe049: it doesn't accept parantheses
20:42:26 <davexunit> Team: Untitled
20:42:29 <AO_Dhimitraq> team initials FTW^^
20:42:34 <trevaaa> Team: Default
20:42:39 <mikeiudi> Team: Republic?
20:42:42 <mattamizer> kwurst: he's the Broker of Star Peace
20:42:49 <mindo> JamesC_WSU: What name have you decided on?
20:42:54 <mikeiudi> Team: Rebel Alliance?
20:42:57 <davexunit> Team: HelloIsThisThingOn
20:43:01 <mikeiudi> Team: WOOKIE
20:43:04 <trevaaa> You rebel scum
20:43:05 <davexunit> no
20:43:08 <mattamizer> ^
20:43:14 <mikeiudi> Team: LeiaIsMySister?
20:43:18 <davexunit> no star wars
20:43:21 <kwurst> I can only assume that all of the quiet people, not participating in the silliness, are working on researching FOSS projects...
20:43:21 <mattamizer> ^
20:43:26 <davexunit> hahahaha
20:43:28 <mattamizer> or sleeping
20:43:30 <blabbe> Team How Did I Get Here I Am Not Good With Computer
20:43:31 <mattamizer> whichever
20:43:36 * mikeiudi quickly alt tabs to his browser
20:43:37 <Joe_G> blabbe where the heck is everyone else in our group??? How bout "Team Meatballs"? hahaha
20:43:38 <davexunit> blabbe: yes
20:43:44 <mattamizer> Team Disinterested
20:43:49 <Joe_G> blabbe jk
20:43:50 <JamesC_WSU> mindo Some form of alliteration with the letter T
20:43:54 <blabbe> Joe_G: I don't know, EdCS401 NjorogeCS401 Speak up!
20:43:56 <davexunit> Team: Sandwich
20:43:59 <mikeiudi> Team: BetterThanMatts
20:44:03 <mattamizer> ^
20:44:05 <kwurst> JamesC_WSU: Team Team?
20:44:06 <davexunit> possibly
20:44:13 <trevaaa> Team: DoesntWantToLearnANewProgrammingLanguage
20:44:18 <mikeiudi> team meat?
20:44:18 <blabbe> nzahid EdCS401 NjorogeCS401 speak now or you get no say in our name :P
20:44:21 <mattamizer> Team T.E.A.M
20:44:28 <davexunit> Team: ThereIsAnIinThisTeam
20:44:28 <trevaaa> Team America
20:44:31 <mattamizer> then come up with something clever to fit the acronym
20:44:33 <AO_Dhimitraq> who is going to view all the de-motivationals on the internet?
20:44:33 <kwurst> JamesC_WSU: Team Tech Team?
20:44:35 <mattamizer> f*ck yeah
20:44:41 <blabbe> How about Team TONIR
20:44:44 <davexunit> Team: Giant Robot
20:44:49 <nzahid> blabbe lol i am good with 'fellowship of the ring'
20:44:49 <mikeiudi> Team Allyourbasearebelongtous?
20:44:51 <blabbe> It stands for TONIR: Our Name Is Recursive
20:44:52 <JamesC_WSU> team al gore
20:44:54 <davexunit> no
20:45:10 <blabbe> Joe_G: nzahid votes for fellowship
20:45:13 <davexunit> Team: MEAT
20:45:14 <kwurst> blabbe: Nice.
20:45:16 <AO_Dhimitraq> or lolcats for that matter
20:45:18 <trevaaa> Team Obama
20:45:21 <davexunit> no
20:45:21 <mikeiudi> team Clinton2012?
20:45:23 <davexunit> no
20:45:24 <mattamizer> they're made out of meat
20:45:32 <mikeiudi> ahhh wait Palin2012!!
20:45:34 <mattamizer> awesome short that everyone shoudl watch
20:45:35 <blabbe> EdCS401 NjorogeCS401 last chance to speak up or we are going with Fellowship of the Ring
20:45:46 <mattamizer> blabbe: but, there's no ring
20:45:50 <davexunit> there is no in team, but there is an i in meat pie
20:45:50 <blabbe> DONT CARE
20:45:56 <blabbe> I WILL BRING ONE IN IF I HAVE TO
20:45:58 <davexunit> no i**
20:45:59 <NjorogeCS401> blabbe: I'm here
20:45:59 <Joe_G> blabbe how bout team jacob? hahahaha
20:46:01 <JamesC_WSU> team long hair don't care
20:46:04 <mattamizer> blabbe: isn't there only one?
20:46:08 <long> @kwurst: we're the Cereal Killers
20:46:12 <blabbe> mattamizer: Minor details
20:46:17 <mattamizer> lol
20:46:18 <mikeiudi> Team DaveDoesMostOfTheWork
20:46:20 <JamesC_WSU> long that was the name of the guy in Hackers
20:46:22 <mattamizer> ^
20:46:24 <JamesC_WSU> now we're copy cats
20:46:33 <long> @James: lol...really now....
20:46:37 <mattamizer> JamesC_WSU: wasn't it blaze or some junk
20:46:38 <blabbe> NjorogeCS401: Yu have a problem with Fellowship of the Ring as our team name?
20:46:41 <JamesC_WSU> no
20:46:42 <NjorogeCS401> blabbe: What name did you suggest again...?
20:46:44 <jochy> i prefer zero cool
20:46:49 <kwurst> long: I have a comic somewhere called Cereal Baby Keller
20:46:51 <blabbe> "Fellowship of the Ring"
20:46:58 <JamesC_WSU> mattamizer: It was crash, burn, nikon something
20:47:00 <davexunit> okay, we're team rocket. i'm tired of thinking up names
20:47:06 <jon_cs401> noo
20:47:06 <CoadyL> team over 9000?
20:47:08 <mindo> did any of you guys hack the gibson?
20:47:09 <mikeiudi> NO'0
20:47:11 <davexunit> no
20:47:15 <kwurst> davexunit: You could do some real work...
20:47:18 <NjorogeCS401> blabbe: Sounds good to me...
20:47:20 <mattamizer> JamesC_WSU: Crash Override
20:47:24 <davexunit> kwurst: yeah...
20:47:28 <blabbe> kwurst: Team 4 is Fellowship of the Ring
20:47:29 <long> but seriously...only 2 ppl in group 2 here today or what?
20:47:30 <JamesC_WSU> mindo have to find a back door, let me grab my classes and go surf the server
20:47:33 <mikeiudi> Team Internets.
20:47:34 <JamesC_WSU> glasses*
20:47:38 <Joe_G> blabbe i have no idea where you came up with that group name but it sounds like we are from a star wars movie!!!
20:47:40 <jon_cs401> Team Individuality
20:47:42 <davexunit> just name a mundane object
20:47:45 <blabbe> Joe_G: wat
20:47:46 <davexunit> we'll be that
20:47:53 <blabbe> You have never read or watched Lord of the Rings?
20:47:57 <mikeiudi> davexunit: last one.... A-Team!
20:48:00 <mindo> you have my axe!
20:48:00 <davexunit> no
20:48:01 <trevaaa> Team 5: its all set
20:48:06 <Joe_G> blabbe nope never
20:48:08 <mikeiudi> davexunit: I give up lol
20:48:10 <mkenny2> Team Stapler
20:48:18 <blabbe> Joe_G: Ok, that is your homework assignment
20:48:19 <JamesC_WSU> team staple remover
20:48:21 <blabbe> Watch lord of the rings
20:48:23 <kwurst> long: You have 4 out of 5 members of your group here.
20:48:34 <jon_cs401> Team Rusted Toaster
20:48:38 <JamesC_WSU> kwurst where are these illusive creatures?
20:48:51 <davexunit> or how about Team Humans
20:48:52 <long> @kwurst:oh, ok...but I only know 1 guy
20:48:52 <mattamizer> JamesC_WSU: They hide in basements
20:49:00 <Joe_G> blabbe #nothankyou
20:49:02 <mattamizer> WAIT!!
20:49:02 <mkenny2> Team Pizza Rolls
20:49:03 <long> and i was gonna spam until i get my question answered..
20:49:05 <JamesC_WSU> mattamizer: damn
20:49:12 <mattamizer> what are the names of the little dudes in Mononoke?
20:49:13 <blabbe> Joe_G: Ok, well, too bad, we are Fellowship of the Ring :P
20:49:13 <mikeiudi> davexunit: you have my vote for whatever you want bro
20:49:18 <davexunit> can we just be the blue baracudas?
20:49:19 <JamesC_WSU> long that's why we should be working on bots
20:49:23 <JamesC_WSU> or at least twitter bots
20:49:28 <mattamizer> Silver Monkeys were better IMO
20:49:29 <mkenny2> davexunit: yes
20:49:42 <davexunit> okay. done. i'mma go look at foss stuff
20:49:42 <kwurst> james: Your team is you, long, mindo, marcos, and (missing) James
20:49:55 <AO_Dhimitraq> http://cs.worcester.edu/wiki/index.php?n=Main.CS401Spring2012
20:49:57 <JamesC_WSU> mindo this WHOLE TIME?! how could you not tell me
20:49:59 <JamesC_WSU> I trusted ylu
20:50:01 <JamesC_WSU> you*'
20:50:13 <mattamizer> spurned by the internet
20:50:14 <mindo> JamesC_WSU: i said i was?!!!?!?!?!?!
20:50:16 <mattamizer> I've seen this before
20:50:20 * JamesC_WSU searches for marcos
20:50:26 <kwurst> Marcos - what name are you using?
20:50:28 <mindo> JamesC_WSU: i am sitting right in front of you
20:50:28 <davexunit> Team 3: Add your names to the team page on the wiki
20:50:31 <long> marcos, where are u?
20:50:40 <JamesC_WSU> mindo: make a noise
20:50:46 * trevaaa can't find teammates
20:50:48 <mattamizer> rofl
20:50:50 <JamesC_WSU> mindo: like a cat
20:50:51 <mattamizer> perfect
20:50:51 <mindo> JamesC_WSU: good noise?
20:50:52 <rindolf> Hi all.
20:50:56 <mindo> JamesC_WSU:
20:50:57 <davexunit> aloha
20:50:58 <JamesC_WSU> mindo: dece
20:51:00 <long> i didn't catch that...do it again...mindo...
20:51:01 <Joe_G> blabbe lets allow the group to decide
20:51:06 <mindo> JamesC_WSU: you make a noise, an elephant noise
20:51:13 <JamesC_WSU> mindo: I don't know how
20:51:14 <mindo> JamesC_WSU: security reasons
20:51:19 * mattamizer is giddy with anticipation
20:51:19 <blabbe> Joe_G: We did. 3 voted for Fellowship, one hasn't voted
20:51:29 <blabbe> 3 v 1 (1 abstaining) means that Fellowship wins L
20:51:30 <blabbe> :P
20:51:37 <davexunit> that's a dumb name
20:51:43 <kwurst> JamesC_WSU: Knightcs401
20:51:44 <davexunit> be team awesomename
20:51:47 <blabbe> YOU are a dumb name
20:51:53 <kwurst> long: Knightcs401
20:51:58 <JamesC_WSU> Here I am
20:52:02 <Joe_G> i agree with davexunit
20:52:03 <Joe_G> lol
20:52:07 <JamesC_WSU> kwurst thank you
20:52:16 <mattamizer> Team <INSERT NAME>
20:52:18 <kwurst> Knightcs401: are you still on?
20:52:24 <long> @kwurst:that's my group name?
20:52:29 <long> nvm
20:52:42 <kwurst> long: No, that's Marcos' IRC nick
20:53:02 * JamesC_WSU Knightcs401 I have cookies
20:53:05 <davexunit> okay now onto some actual work finally...
20:53:10 <JamesC_WSU> no
20:53:11 <trevaaa> Team Knights Who Say "NEE"
20:53:12 <blabbe> Joe_G: Fellowship of the Ring IS an awesome name. If you would WATCH the movie or read the books you would KNOW that
20:53:23 <mattamizer> davexunit: you won't, no actual work gets done on the internet
20:53:24 <mindo> If your in Group 2 and you know it, CLAP YOU HANDS!
20:53:35 <mattamizer> davexunit: but if you WERE to do work, GIMP looks neat
20:53:58 <blabbe> mattamizer: have you actually used gimp?
20:53:59 <kwurst> trevaaa: It's "Ni", I believe
20:54:03 <blabbe> It's quitepainful :P
20:54:07 <Joe_G> blabbe i seen part of the movie n i got bored to death
20:54:09 <JamesC_WSU> trevaaa ran on
20:54:16 <mattamizer> kwurst: No, it's "Icky Ikcy Pekang Zoop Boing"
20:54:18 <trevaaa> kwurst: I was torn
20:54:29 <davexunit> blabbe: yeah all the time. i think it's great
20:54:32 * mattamizer NI
20:54:41 * kwurst It
20:54:48 <blabbe> davexunit: You also think programming in vim is great
20:54:52 <davexunit> it is
20:54:54 <JamesC_WSU> hello group two
20:54:59 <davexunit> efficiency man
20:55:03 <jon_cs401> hello
20:55:07 <kwurst> Too bad James is missing all of this.
20:55:14 <Knightcs401> marcos is here james
20:55:17 <kwurst> Well, he can read the logs...
20:55:22 <trevaaa> That's what he gets for skipping
20:55:24 <JamesC_WSU> kwurst his facebook messenger must have at least 100 messages
20:55:28 <mattamizer> blabbe: I have
20:55:33 <mattamizer> blabbe: I'm not good at it, but I've used it
20:55:50 <blabbe> It crashes too much for anyone to use more than 5 minutes at a time :D
20:55:54 <mikeiudi> davexunit: I updated our page lmao check it out
20:55:58 <davexunit> ...
20:56:17 <mattamizer> blabbe: nooo
20:56:21 <jon_cs401> its not that funny
20:56:23 <davexunit> i see nothing
20:56:27 <jon_cs401> i mean its kinda funny
20:56:46 <JamesC_WSU> Hi Hater.
20:57:12 * mikeiudi *sighs* we were updating at the same time it got erased
20:57:13 <kwurst> #info I like the links to the TOS pages on the team wiki pages.
20:57:18 <jon_cs401> we should have been the Red Jaguars
20:58:18 <mindo> Does group 2 have a name?
20:58:32 <kwurst> mikeiudi: You shouldn't have lost stuff.
20:58:41 <trevaaa> Group 5: you can go edit the page and add your blog links to our wiki
20:58:41 * mchua reads up
20:58:43 <mchua> someone pinged?
20:58:50 <kwurst> mikeiudi: Oh, wait, maybe I remember that happening before.
20:58:51 <JamesC_WSU> mindo I thought things
20:58:52 <JamesC_WSU> your turn
20:59:11 <CoadyL> group 1: im assuming we are sticking with awesomealot ocelots?
20:59:18 <kwurst> mchua: Welcome. Lots of silliness to read. May not find much useful...
20:59:31 <mchua> wow, this is awesome! life in the channel!
20:59:36 * mchua whoops in joy
20:59:40 <mattamizer> yup
20:59:43 <JamesC_WSU> Life is kind of a funny word
20:59:44 <mchua> welcome to all kwurst's students :D
20:59:52 <kwurst> mchua: Now some of the students can try to out-type you - HA!
20:59:53 <mchua> y'all going to be hanging out here for the semester?
20:59:53 * mikeiudi all BARACUDAS add your names to the site page
20:59:53 <JamesC_WSU> I wouldn't describe our conversations as life
20:59:58 <mattamizer> mchua: howdy :)
21:00:02 <mchua> kwurst: sorry about the silence earlier, I was in German
21:00:06 <mchua> (...reading class)
21:00:23 <blabbe> I hate when I accidentally exist in a different language
21:00:30 <mchua> oh, you folks will totally out-type me. I'm simultaneously translating passages on Bertolt Brechts ("Augsburg is, among other things, the birthplace and hometown of...")
21:00:33 <blabbe> Sometimes I am in Chinese and I can't understand myself :(
21:00:44 <mchua> ...and getting ready to do QA on Eutester, https://github.com/eucalyptus/eutester/, with a guy named Vic.
21:00:47 <kwurst> mcha: That should have said "Entshuldingen"
21:00:50 <mchua> so, multithreading. :D
21:00:54 <JamesC_WSU> mchua I understood some of those words
21:01:01 <mattamizer> EUtester you say..
21:01:18 <jon_cs401> group 3 multi editing
21:01:20 <davexunit> wakari masen
21:01:24 <mchua> kwurst: Entschuldigen Sie mein Zuspaetkommen.
21:01:37 <mchua> mattamizer: yep yep... ever heard of eucalpytus?
21:01:52 <mchua> http://www.eucalyptus.com/
21:01:54 <kwurst> mchua: I can understand that, but I can't write that well...
21:01:57 <mattamizer> mchua: nope, but we need a FOSS project
21:02:05 <mchua> kwurst: I looked it up on dict.cc. My grammar isn't that good yet.
21:02:09 <mchua> mattamizer: it's FOSS.
21:02:10 <mchua> https://github.com/eucalyptus/eutester/
21:02:14 <rindolf> Are you people the Teaching Open Source students ?
21:02:21 <kwurst> mchua: Ah, nice.
21:02:26 <trevaaa> what do you mean "you people"?
21:02:32 <rindolf> mattamizer: are you looking for a FOSS project?
21:02:40 <rindolf> trevaaa: well, those talking here.
21:02:45 <mchua> mattamizer: eucalyptus is infrastructure as a service, so I'm helping Vic (one of the engineers there) with eutester, which is (hopefully) going to be a way to automatically test a eucalyptus instance.
21:02:59 <trevaaa> rindolf: just kidding around :)
21:03:00 <rindolf> Usually this channel is inactive.
21:03:04 <mattamizer> mchua: that sounds wicked interesting
21:03:04 <rindolf> trevaaa: ah.
21:03:05 <mchua> rindolf: hey there. :) I think we may be the only non-Worcester folks here...
21:03:08 <mattamizer> rindolf: yes, I am
21:03:15 <rindolf> mchua: hi.
21:03:25 <JamesC_WSU> rindolf we're in an Open Source class, testing our IRC capabilities
21:03:29 <mattamizer> rindolf: we need some FOSS projects to get in on for our Open Source class
21:03:34 <kwurst> rindolf: And it may be inactive again after this. I don't know how many of my student will hang out here.
21:03:38 <rindolf> mattamizer: then I can interest you in http://www.shlomifish.org/open-source/ .
21:03:52 <rindolf> kwurst: sure.
21:03:56 <davexunit> i can attempt to add this to the channels that i lurk
21:03:59 <kwurst> rindolf: Good idea. I forgot about that site
21:04:03 <mchua> rindolf: are any folks other than you contributing to those projects?
21:04:17 <mattamizer> rindolf: that's quite the list
21:04:19 <rindolf> kwurst: which one? Mine.
21:04:28 <rindolf> mchua: to some, yes.
21:04:29 <kwurst> #info http://www.shlomifish.org/open-source/ .
21:04:30 <mchua> mattamizer: if y'all would fill us in a bit more about the sorts of projects you're looking for, we can try to help.
21:04:42 <rindolf> mchua: I adopted a few.
21:05:04 <mattamizer> mchua: Really it's any FOSS project that needs some assistance. Personally I'd love to get involved with writing some code for one, but that's not a necessity
21:05:12 <kwurst> mchua: ianweller was here, lurking and laughing at the silliness, but he may be gone now.
21:05:26 <blabbe> Heh rindolf based on your page I am guessing you haven't looked at IE9 at all :P
21:06:05 <mchua> Nearly all the FOSS projects in the world need some sort of assistance, so it's also a question of what you're interested in doing...
21:06:25 <mchua> I'm spending a fair bit of time around Eucalyptus lately and would be happy to take folks along with me if they're interested in poking into cloud computing and QA thereof.
21:06:34 <rindolf> blabbe: I have only used MSIE 8.
21:06:35 <kwurst> mchua: They are supposed to be looking for projects over the next week.
21:06:41 <trevaaa> mchua: i would be interested in working on something math related. not sure how the rest of the class feels about that though...
21:06:45 <mattamizer> mchua: that sounds interesting for sure
21:06:46 <ianweller> kwurst: still lurking :)
21:06:47 <mchua> A friend of mine, Sumana, is involved in Mediawiki development, and always needs extra hands there (then again, it's PHP.)
21:06:49 <rindolf> blabbe: maybe I can use MSIE 9 on my Windows 7 partition.
21:06:55 <rindolf> Haven't checked.
21:06:58 <mchua> trevaaa: Math, as in math education, or math... like MATLAB type software?
21:07:11 <kwurst> trevaaa: Then research Sage for next week's discussion
21:07:13 <mchua> trevaaa: because there's a guy here, Jason Aubrey, who works on http://webwork.maa.org/
21:07:32 <trevaaa> mchua: something like MATLAB software would be really cool
21:07:47 <rindolf> mattamizer: many projects have bug trackers that you can post patches on.
21:07:58 <mchua> trevaaa: Ah, ok -- then, like kwurst said, sage is a good place to look; there's also scipy and octave
21:08:09 <blabbecs401> SOrry I got disconnected :/
21:08:10 <mattamizer> rindolf: true, I've never gotten up the courage to try to write a patch though
21:08:11 <mchua> trevaaa: actually, if you're interested in things beyond simply "writing new code"
21:08:16 <rindolf> mattamizer: OK.
21:08:31 <kwurst> mchua: That's Sage, but my concern is that it's had only 150 contributors - total, ever, and we might overwhelm them with 25 students.
21:08:41 <mchua> kwurst: oh, are they all going to be doing the same thing?
21:08:46 <mattamizer> kwurst: and our awesome, don't forget that bit
21:08:47 <mchua> er, working on the same project?
21:08:49 <mikeiudi> davexunit: check out the team photo
21:08:53 <blabbecs401> rindolf: You make some good points about web browsers, but "MSIE is not standards compliant while other browsers are" <== No browsers are standards compliant, there hasn't been a properly standards compliant browser since like Firefox 2.2 :P
21:09:09 <blabbecs401> At least not of the major ones
21:09:10 <kwurst> mchua: Yes, I think putting them all in one project will work best.
21:09:17 <trevaaa> mchua: I would definitely be interested in something like that, as long as it has room for the class to contribute
21:09:25 <rindolf> blabbecs401: well, I'm too tired to argue about it right now.
21:09:25 <mchua> trevaaa: I'd point you towards http://greenteapress.com/matlab/index.html which is an open content textbook that uses matlab -- I know the professor, and he *really* wants someone to "translate" the book into an open source software
21:09:32 <mchua> trevaaa: so, for instance, write the Octave version of that book
21:09:55 <kwurst> mchua: They can share info about the project, structure, build process, etc, but each of the 5 teams can choose a different bug or feature.
21:09:56 <mchua> trevaaa: (Octave being one of the open source alternatives to MATLAB -- not nearly as full-featured, but that's a first-year engineering text, so...)
21:10:01 <mchua> kwurst: roger roger.
21:10:05 <davexunit> mikeiudi: i actually like it. good job.
21:10:14 <mattamizer> O_o
21:10:21 <mattamizer> dave likes something?!
21:10:22 <mikeiudi> davexunit: mkenny2's find.
21:10:23 <mchua> trevaaa: so that would involve picking a chapter or two of the book and trying the exercises out in Octave -- figuring out how to install and use octave for the same things
21:10:25 <mattamizer> ALERT THE INTERNT
21:10:26 <trevaaa> mchua: it doesn't sound too difficult though if it's only a first year textbook
21:10:31 <JamesC_WSU> =)
21:10:38 <mikeiudi> mattamaizer: check out our team photo
21:10:39 <mchua> trevaaa: ...I'd look at some of the mid-chapter exercises before saying that. :)
21:10:47 <JamesC_WSU> :)
21:10:49 <mattamizer> trevaaa: told
21:10:52 <mchua> trevaaa: sdziallas_afk took the class last year and it... was hard.
21:10:53 <kwurst> mchua: The plus, for us, for Sage, is that our Math department is using it.
21:10:53 <trevaaa> mchua: is it similar to MATLAB at all?
21:11:01 <mchua> kwurst: oooo, then sage would be great too.
21:11:10 <blabbecs401> Sage uses python, though, I really don't like python :(
21:11:12 <mchua> trevaaa: Octave? Yeah, it's matrix math, like Matlab.
21:11:21 <mchua> blabbecs401: why not?
21:11:27 <davexunit> <3 python
21:11:36 <mattamizer> best team photo EVER
21:11:36 * JamesC_WSU agrees with dave
21:11:44 <blabbecs401> Well, I am not a fan of the syntax, but a bigger problem I have with it is the way the standard library is laid out
21:11:46 <JamesC_WSU> mattamizer link for the lazy?
21:11:51 * mikeiudi just took that photo
21:11:54 <mattamizer> one moment
21:12:02 <davexunit> i am trying to browse through github and look at C projects
21:12:04 <kwurst> blabbecs401: You should talk to Dr. Mahadev. She's not liking Python because she doesn't like the object system.
21:12:18 <mattamizer> [[ http://teachingopensource.org/index.php/User:DJorgji | *Dhimitraq Jorgji]]
21:12:21 <mattamizer> not that
21:12:23 <davexunit> the object system is great though :(
21:12:24 <mattamizer> hold on
21:12:31 <kwurst> davexunit: Good job - doing real work!
21:12:39 <davexunit> copy just the url next time mattamizer haha
21:12:45 <blabbecs401> kwurst: I don't know who that is, this is my first semester at this school
21:12:46 <JamesC_WSU> lol yeah
21:12:46 <mattamizer> http://a4.ec-images.myspacecdn.com/images02/23/686c1aff95fd4027b3d2afacf6ed2a03/l.jpg
21:12:52 <JamesC_WSU> felt like I was in grade school
21:13:05 <davexunit> kwurst: no luck so far as things that i think would be good/reasonable to do
21:13:08 <dhimitri> matt: O
21:13:20 <blabbecs401> AFAIK though python's OOP model is actually closer to what OOP originally meant than most languages
21:13:24 <mattamizer> it's the team photo for the Blue Barracudas
21:13:26 <mattamizer> LULZ
21:13:38 <kwurst> I'm not clicking on any more photo links while on the projector...
21:13:42 <davexunit> hahahaha
21:13:44 <mattamizer> rofl
21:13:45 <blabbecs401> I haven't looked close enough at python's object model to know for sure though
21:13:46 <mattamizer> wise
21:13:48 <davexunit> that one was okay though
21:13:54 <mattamizer> it's SFW
21:13:56 <mattamizer> and HILARIOUS
21:13:57 <JamesC_WSU> kinda
21:13:58 <davexunit> but THIS one...
21:13:58 <jon_cs401> yeah
21:14:01 * mikeiudi is relieved the professor's link did not work.
21:14:11 <kwurst> That one wasn't so bad, but I don't want to hit a NSFW
21:14:20 <davexunit> well if someone did that...
21:14:23 <davexunit> they'd be a jerk
21:14:26 <mattamizer> ^
21:14:35 <davexunit> and we would personally beat them up in the parking lot
21:14:36 <blabbecs401> They would be a not particularly nice individual
21:14:42 <mattamizer> mchua: are you in this channel often?
21:14:43 * trevaaa likes this comment
21:14:52 <mchua> mattamizer: I'm almost always here.
21:14:54 <kwurst> You guys should talk to mchua more...
21:14:56 <davexunit> mattamizer: worst pickup line ever
21:15:00 <trevaaa> mattamizer: nice pick up line
21:15:08 <blabbecs401> hahaha
21:15:09 <JamesC_WSU> you come here often?
21:15:17 <kwurst> About FOSS projects...
21:15:20 <davexunit> do you /join here often?
21:15:23 <mattamizer> mchua: groovy, I'll be around later and would like to hear more about some of the FOSS projects you know about and/or work on
21:15:31 <mattamizer> also, I hate you guys
21:15:33 <trevaaa> hey baby whats your FOSS?
21:15:35 <mchua> mattamizer: I connect to IRC through a friend's server -- I've got it running in a screen session there so I can always pop in and see the conversation logs.
21:15:38 <davexunit> anywho!!!!!!
21:15:48 <davexunit> inkscape?  vector image editor? eh? eh?
21:15:51 <kwurst> OK, time to be polite and serious...
21:15:52 <mchua> davexunit: so I don't /join here often, but
21:15:57 <mattamizer> I think that'd be neat Dave
21:16:02 <mchua> as JamesC_WSU said, I *am* here often.
21:16:09 <mchua> Don
21:16:12 <blabbecs401> inkscape is cool I wouldn't mind woking on inkscape
21:16:16 <davexunit> nice to meet you btw mchua
21:16:16 <mattamizer> indeed
21:16:21 <mattamizer> ^
21:16:27 <mikeiudi> ^
21:16:30 <trevaaa> ^
21:16:30 <JamesC_WSU> ^
21:16:33 <ianweller> v
21:16:35 <mattamizer> ?
21:16:36 <blabbecs401> c-c-c-combo breaker
21:16:43 <mattamizer> WIN!
21:16:45 <davexunit> what language is inkscape written in... one sec googling
21:16:49 <trevaaa> #winning
21:16:57 <mchua> davexunit: C++, with Python plugins, iirc.
21:16:58 <mattamizer> *tear*
21:16:58 <blabbecs401> davexunit: probably C++
21:17:06 <kwurst> trevaaa: I don't think meetbot knows that hash tag
21:17:21 <mikeiudi> kwurst: on a scale of ten, how likely is it we will be programming in C or Java?
21:17:28 <mattamizer> I think like half the class would need to learn C++ on the fly
21:17:29 <mchua> davexunit: The Inkscape developers are extremely friendly -- Jon Cruz is particularly good at getting newcomers started, but he's also perpetually hosed.
21:17:43 <davexunit> mchua: good to know thanks
21:17:44 <kwurst> We're almost out of class time, so you should all ask any questions you have, rather than fool around.
21:17:44 <mchua> mikeiudi: 10, if you want to restrict project searching to those that use C and/or Java.
21:18:03 <mchua> mikeiudi: There are a ton of projects written in any language (yes, even Haskell) you can thinmk of.
21:18:03 <blabbecs401> Hey guys let's all work on a project written in Piet
21:18:06 <mchua> er, think.
21:18:07 <trevaaa> I think that picking up C++ on the fly would probably still be easier than trying to get everyones C skills up to these standards
21:18:10 <kwurst> mikeiudi: That's really up to the class.
21:18:16 <mchua> Try looking at ohloh -- have you done that yet, kwurst?
21:18:18 <blabbecs401> http://www.dangermouse.net/esoteric/piet.html :D
21:18:24 <mkenny2> trevaaa: agreed
21:18:26 <mattamizer> mchua: he told us to check it out
21:18:32 <mchua> might be worth throwing ohloh on the projector, it's got useful sort/search features for projects you're looking at.
21:18:36 <mchua> Ok.
21:18:43 <mchua> So, most important thing in choosing a FOSS project to contribute to:
21:18:50 <mchua> It's not the codebase, it's not the community size, it's not the language it's written in.
21:18:55 <mchua> It's mentors.
21:18:58 <mattamizer> ?
21:19:08 <mattamizer> so the people leading the project?
21:19:11 <mchua> Can you find someone who *already* has deep knowledge of the code and community, and make a bargain with them to take the time to show you around?
21:19:13 * JamesC_WSU claps
21:19:22 <kwurst> JamesC_WSU: why?
21:19:22 <davexunit> that would be very helpful
21:19:23 <blabbecs401> That's why we should use Irrlicht
21:19:28 <JamesC_WSU> I was impressed
21:19:31 <mchua> mattamizer: Doesn't have to be a project leader, but needs to be someone who knows their way around it, and has made the sort of contributions you want to learn to make.
21:19:32 <blabbecs401> I've spent years elbow deep in irrlicht :P
21:19:39 <mattamizer> mchua: roger
21:19:48 <mattamizer> blabbecs401: we need neck deep
21:19:53 <mattamizer> blabbecs401: sorrah
21:19:55 <davexunit> mchua: kwurst has been looking for someone that could help us like that
21:19:58 <mchua> mattamizer: and they need to know the other people, not just "be able to code"
21:20:05 <blabbecs401> mattamizer: I was holding my hands above my head
21:20:08 <blabbecs401> So it was more like ear deep
21:20:13 <blabbecs401> Oh yeah
21:20:15 <mattamizer> mchua: right, so you can get to know the project better
21:20:18 <mchua> davexunit: and kwurst is absolutely right. so have you found that sort of person?
21:20:21 <mchua> mattamizer: exactly.
21:20:28 <davexunit> mchua: i don't think so
21:20:33 <mattamizer> mchua: seems like we have a LOT of research to do
21:20:42 <kwurst> mchua: Nope, need to do some contacting...
21:20:49 <mchua> kwurst: I'd be happy to get folks started with eucalyptus since that's where I'm poking around, but don't know if there's interest in that -- I'm hanging out with Python stuff, mostly.
21:20:50 <blabbecs401> I actually have been in contact with the Irrlicht devs already
21:20:53 <mattamizer> kwurst: so are you going to do that legwork?
21:21:01 <mchua> kwurst: but gregdek's at euca as well, so that's a plus.
21:21:03 <mchua> potentially.
21:21:04 <blabbecs401> And they told me what they would like us to do if we heped them out
21:21:09 <davexunit> kwurst: just pick something and we'll work on it haha
21:21:15 <kwurst> mchua: I was hoping to get some preferences from the class before I started with contacts.
21:21:16 <mchua> blabbecs401: excellent, and does it sound feasible to you?
21:21:17 <mattamizer> ^
21:21:20 <sflynn1976> i would think that finding a program that you would use in daily life would ease the transition
21:21:22 <mchua> kwurst: ah, yeah, good call. :)
21:21:30 <mchua> kwurst: you are a brave man, sir. :) by the way. have I ever told you that?
21:21:32 <kwurst> mchua: Ooh gregdek. That would be nice.
21:21:36 <blabbecs401> mchua: Yeah, but kwurst said he doesn't want to do it because he's not familiar with rendering :(
21:21:50 <blabbecs401> But he sad if I can convince the rest of the class we might do it anyway :P
21:21:55 <mattamizer> ^
21:21:56 <blabbecs401> So that is what I am trying to do
21:21:58 <blabbecs401> said*
21:22:00 <davexunit> i want a more practical app
21:22:04 <trevaaa> me too
21:22:06 <mattamizer> ^
21:22:07 <davexunit> something that people will use
21:22:07 <mchua> blabbecs401: so, do you folks have a blog planet or something where you'll be taking notes?
21:22:08 <blabbecs401> What makes it not practical?
21:22:13 <mindo> blabbecs401: have you tried monetary bribes yet?
21:22:14 <davexunit> yes
21:22:16 <mchua> in a format more polished and permanent than this IRC channel?
21:22:27 <blabbecs401> mchua: We have blogs subscribed to TOS planet
21:22:29 <davexunit> mchua: we have a cs blog and we'll be on teaching open source
21:22:41 <mchua> blabbecs401, davexunit -- excellent, thanks.
21:22:43 <kwurst> mchua: They should all be posting to the TOS planet.
21:22:48 <mchua> I also blog on the TOS planet, so I'll see you folks there. :)
21:22:56 <mattamizer> killer
21:22:56 <davexunit> :)\
21:23:05 <mattamizer> ok, time to head home for dinner I think
21:23:09 <blabbecs401> davexunit: What makes irrlicht not practical?
21:23:10 <mattamizer> peace in the middle east
21:23:21 <JamesC_WSU> mattamizer what's for dinner?
21:23:25 <JamesC_WSU> too late
21:23:28 <davexunit> blabbecs401: i think it would be best to contribute to something that people use
21:23:32 <mikeiudi> until we meet again ladies and gents.
21:23:32 <davexunit> people who aren't programmers
21:23:34 <kwurst> mchua: And they are all blogging to: http://cs.worcester.edu/blog/
21:23:37 <trevaaa> that's why I like the math ideas
21:23:43 <mchua> kwurst: this, btw, is *excellent* -- I'm used to people being super-shy the first time on irc.
21:23:45 <davexunit> sage would be good
21:23:46 <trevaaa> people actually need stuff like that
21:23:47 <mchua> kwurst: how did you do that?
21:23:47 <blabbecs401> davexunit: That has nothing to do with practicality.
21:23:52 <blabbecs401> Sage would be terrible :/
21:23:56 <mchua> kwurst: ooo, yes!
21:24:00 <mchua> (re blog)
21:24:01 <kwurst> mchua: Shy? Not my students...
21:24:11 <mchua> kwurst: see, I wish we had 200 more like them.
21:24:12 <ndoe049> \leave
21:24:14 <davexunit> we are a BIT unruly...
21:24:14 <kwurst> mchua: Harder to get them to work...
21:24:17 <mchua> kwurst: okay, maybe not in the same channel at the same time, but...
21:24:36 <mchua> kwurst: oh, I'm sure we can find something for them to do. :D
21:24:43 <mindo> ¯\_(ツ)_/¯ See you guys
21:24:53 <mchua> aaaaand the exodus.
21:24:56 <davexunit> hahaha
21:24:58 <JamesC_WSU> mchua thanks for the info
21:24:59 <davexunit> i am still here
21:25:05 <JamesC_WSU> I, too, am.
21:25:06 <davexunit> mchua: thanks for the bit of guidance
21:25:11 <dhimitri> bye bye
21:25:13 <kwurst> When should I stop the meeting? Now?
21:25:15 <mchua> kwurst: ping me sometime if there's a way I can help.
21:25:16 <davexunit> kwurst: take the reigns and make a decision!
21:25:32 <kwurst> #endmeeting