#ansible-meeting: Testing Working Group

Meeting started by gundalow at 17:00:17 UTC (full logs).

Meeting summary

  1. Core updates (gundalow, 17:01:30)
    1. Ansible 2.3 RC1 has been released https://groups.google.com/forum/#!topic/ansible-devel/V2ESSQqLnS0 Pleeeeeeeeeeease test it and report bugs (gundalow, 17:01:53)
    2. Ansible 2.3 contians lots of changes to the *network* modules, so if you use any of those pleeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeese test those a well (gundalow, 17:02:30)
    3. Devel is now 2.4, which no longer support Python 2.4 (the requirement is py 2.6+ & 3.5+). (gundalow, 17:03:26)
    4. Be mindfull of the above when you need to backport tests or functional changes to stable-2.3. As always PRs should be used when making changes to branches to allow CI to run (gundalow, 17:04:27)

  2. Ubuntu 12.04 EOL (gundalow, 17:05:49)
    1. Ubuntu 12.04 goes EOL (End Of Live) in April, when should we remove it from our CI pipeline (gundalow, 17:06:28)
    2. Dylan personally says we are OK to no longer test Ubuntu 12.04 on devel, though he is going to check with "the business" (gundalow, 17:19:02)
    3. AGREED: will park decission making process till Dylan has reported back (gundalow, 17:20:33)

  3. Python 2.4 (gundalow, 17:21:40)
    1. Docs on Ansible 2.4 support http://docs.ansible.com/ansible/dev_guide/developing_modules_python3.html#minimum-version-of-python-3-x-and-python-2-x (gundalow, 17:30:16)
    2. Docs on Python 2.4 support http://docs.ansible.com/ansible/dev_guide/developing_modules_python3.html#minimum-version-of-python-3-x-and-python-2-x (gundalow, 17:30:46)

  4. CI Shell out using run_command #18181 (gundalow, 17:56:36)
    1. https://github.com/ansible/ansible/issues/18181 (gundalow, 17:56:42)
    2. AGREED: check to go into validate-modules (code-smell is going to get an overhaul soon) (gundalow, 17:59:56)

  5. Open Floor (mattclay, 18:05:14)
  6. Cloud Integration Tests (mattclay, 18:05:46)
    1. https://github.com/ansible/community/issues/114#issuecomment-286357055 (mattclay, 18:06:02)
    2. https://forums.aws.amazon.com/thread.jspa?messageID=733153 appears to be related to why the test_ec2_asg test with the load balancer times out. But I haven't figured out the solution yet. (shertel, 18:15:00)

  7. structured way to reuse tests for both normal mode and check-mode testing (gundalow, 18:26:58)
    1. I'd [Dag] like to discuss a structured way to reuse tests for both normal mode and check-mode testing, and also discuss the use of YAML anchors and references for doing idempotency testing. Since I would like to redo all the Windows integration tests (some are simply missing) I would like to get approval on the preferred mechanism. (gundalow, 18:27:15)
    2. See this example : https://github.com/ansible/ansible/pull/22611/files#diff-9bdd58936ad3aaccf0f2daa7c4a385e1R1 (gundalow, 18:27:23)
    3. https://github.com/ansible/ansible/blob/devel/test/integration/README.md#network-tests (gundalow, 18:30:19)

  8. Open Floor (mattclay, 18:50:03)


Meeting ended at 18:56:33 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. gundalow (94)
  2. dag (79)
  3. mattclay (60)
  4. abadger1999 (42)
  5. bcoca (42)
  6. mikedlr (37)
  7. shaps (16)
  8. shertel (11)
  9. thaumos (9)
  10. alikins (7)
  11. nitzmahone (5)
  12. zodbot (4)
  13. allanice001_ (3)
  14. jtanner (1)


Generated by MeetBot 0.1.4.