#ansible-meeting: Testing Working Group

Meeting started by mattclay at 17:02:34 UTC (full logs).

Meeting summary

    1. :) (gundalow, 17:05:13)
    2. We have a new "import" sanity test in ansible-test and CI now. It will detect imports of python modules not in the standard library in either modules or module_utils which are not protected by a try/except block. (mattclay, 17:06:02)
    3. We will be extending this test to cover plugins as well. (mattclay, 17:06:29)
    4. We will be dropping testing of Fedora 24 and 25 with python 2 on Shippable and adding Fedora 25 and 26 with python 3. (mattclay, 17:07:00)

  1. Replacing pep8 with pycodestyle (https://github.com/ansible/ansible/pull/25947) (mattclay, 17:09:06)
    1. ACTION: mattclay to merge PR once CI passes (mattclay, 17:21:15)

  2. Community Wiki (https://github.com/ansible/community/issues/114#issuecomment-310875236) (mattclay, 17:22:11)
    1. Testing Wiki exists at https://github.com/ansible/community/wiki/Testing (gundalow, 17:25:51)
    2. Existing files which don't pass the import sanity test: https://github.com/ansible/ansible/blob/devel/test/sanity/import/skip.txt (mattclay, 17:30:41)

  3. Open Floor (mattclay, 17:34:36)
    1. https://codecov.io/gh/ansible/ansible/src/devel/lib/ansible/modules/system/ping.py (mattclay, 17:35:07)
    2. https://github.com/ansible/community/wiki/Testing%3A-progress-tracker/_edit#fixing-broken-imports added (gundalow, 17:39:16)


Meeting ended at 17:58:53 UTC (full logs).

Action items

  1. mattclay to merge PR once CI passes


Action items, by person

  1. mattclay
    1. mattclay to merge PR once CI passes


People present (lines said)

  1. mattclay (69)
  2. gundalow (24)
  3. Pilou (20)
  4. zodbot (6)
  5. jtanner (6)
  6. abadger1999 (5)
  7. spredzy (5)


Generated by MeetBot 0.1.4.