#ansible-meeting: Testing Working Group

Meeting started by gundalow at 17:00:06 UTC (full logs).

Meeting summary

    1. Agenda https://github.com/ansible/community/labels/testing (gundalow, 17:00:33)
    2. https://github.com/ansible/ansible/projects/14 <= started this for myself, wonder if it makes sense for WG (bcoca, 17:02:32)

  1. GitHub project for tests (gundalow, 17:02:58)
    1. bcoca created https://github.com/ansible/ansible/projects/14 (gundalow, 17:03:07)
    2. We also have https://github.com/ansible/community/wiki/Testing%3A-progress-tracker (gundalow, 17:04:26)
    3. AGREED: Lets test out using https://github.com/ansible/ansible/projects/14 (gundalow, 17:11:18)

  2. CI for docs for lookups and ither plugins that now support "docs" (gundalow, 17:11:44)
    1. The validation of the DOCUMENTATION block is done in validate-module in test/sanity/validate-modules/schema.py (gundalow, 17:12:28)
    2. running ansible-doc is done in test/runner/lib/sanity/ansible_doc.py (gundalow, 17:13:13)
    3. https://gist.github.com/bcoca/432421a045153648edba8fd82455254c (bcoca, 17:41:29)
    4. https://github.com/ansible/ansible/pull/32757 (bcoca, 17:47:47)

  3. Distributed CI code coverage (gundalow, 17:49:05)
    1. Coverage is live for DCI Network runs: https://codecov.io/gh/ansible/ansible/tree/4443da2d79afc0daea6790d3aa81ade83a5455e7/lib/ansible/modules/network (gundalow, 17:49:25)


Meeting ended at 18:11:58 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. gundalow (72)
  2. bcoca (55)
  3. mattclay (27)
  4. sivel (9)
  5. zodbot (5)
  6. Pilou (1)


Generated by MeetBot 0.1.4.