12:00:54 <kshlm> #startmeeting Weekly community meeting - 29/Jun/2016
12:00:55 <zodbot> Meeting started Wed Jun 29 12:00:54 2016 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:55 <zodbot> The meeting name has been set to 'weekly_community_meeting_-_29/jun/2016'
12:01:02 <kshlm> #topic Rollcall
12:01:07 <kshlm> Hey everyone!
12:01:27 * rjoseph o/
12:01:48 * ndevos .o>
12:01:52 * skoduri is here
12:02:23 * kkeithley is here
12:02:38 <kkeithley> ndevos looks very official
12:02:39 * atinm is here
12:02:45 * karthik___ is here
12:02:46 * msvbhat is here
12:03:10 * msvbhat is lurking though
12:03:56 <kshlm> Welcome everyone!
12:04:01 <kshlm> Let's start
12:04:06 * poornimag is here
12:04:17 <kshlm> The meeting agenda is at https://public.pad.fsfe.org/p/gluster-community-meetings
12:04:28 <kshlm> #topic Next week's meeting host
12:04:32 <kshlm> Any volunteers?
12:05:03 <kkeithley> I'll do it
12:05:08 <kkeithley> If I'm not on a jury
12:05:28 <kshlm> Thanks kkeithley
12:05:38 <kshlm> #info kkeithley is next weeks meeting host
12:05:46 <kshlm> #topic GlusterFS 4.0
12:06:00 <kshlm> Time for some updates on 4.0
12:06:15 <kshlm> atinm, ^ this is your cue.
12:07:02 <atinm> GD2 - work on txn framework continues by kshlm, kshlm has also sent another patch on the config management
12:07:17 <atinm> we have few clean up patches contributed by ppai
12:07:47 <atinm> DHT2 & NSR - I don't have updates since the stakeholders are busy in RH summit I believe
12:07:58 <atinm> asengupt, do you have anything to update on NSR?
12:08:28 <ndevos> atinm: can you start to think about adding tests for GD2? we can run them nightly (or on github PRs) in the CentOS CI
12:08:33 * kshlm wants to clarify that config management is not purpleidea's config mgmt, it's about getting a proper config file support for GD2.
12:08:34 <rjoseph> JBR?
12:08:35 <asengupt> We are currently working on rollback
12:08:39 <asengupt> for jbr
12:08:58 <asengupt> i have sent a patch but there are gonna be some more iterations
12:09:11 <ndevos> rjoseph: Journal Based Replication, previously know as NSR
12:09:14 <asengupt> Jeff is also working iteratively on
12:09:25 <asengupt> the fdl and reconciliation patches
12:09:30 <asengupt> which are also out
12:09:34 <atinm> I should have named it JBR only, my bad!
12:09:50 <asengupt> That's as much update we have from our end
12:10:18 <ndevos> ah, right, I already was surprised to see "JBR?" from rjoseph :D
12:10:28 <atinm> ndevos, we are still working on the framework implementation, once that matures and we have some commands implemented we will certainly get to that stage
12:10:50 <kshlm> ndevos, We are currently running tests on wercker.com for GD2 on each PR.
12:10:56 <kshlm> #link https://app.wercker.com/#applications/560a6c0971f137d02f0ad371
12:11:01 <ndevos> atinm: oh, maybe we can at least some unit-tests already?
12:11:15 <ndevos> +run
12:11:17 <atinm> ndevos, that's already part of the codebase what kshlm pointed out
12:11:34 <atinm> ndevos, we do run the unit tests through wercker
12:11:38 <ndevos> atinm: thats good, where do they get run?
12:11:50 <kshlm> ndevos, the link I posted.
12:12:01 <ndevos> ah, I see
12:12:13 <ndevos> so we're now using 3 CI's?
12:12:27 <kshlm> We don't have enough unit tests yet.
12:13:01 <kshlm> ndevos, I'd set it up before we had centos-ci.
12:13:14 <ndevos> I'd say that even one unit test is sufficient, well, even building could be a test
12:13:25 <kshlm> I'm willing to change it.
12:13:46 <kshlm> I'll see if I can get a centos-ci job up for it.
12:13:49 <ndevos> kshlm: cool, I'd like to see it changed, and am happy to help with that
12:14:39 <ndevos> kshlm: just copy https://github.com/gluster/glusterfs-patch-acceptance-tests/blob/master/centos-ci/heketi-functional/run-test.sh , modify to your needs and pass it to me
12:14:47 <kshlm> #action kshlm to setup GD2 CI on centos-ci
12:15:01 <kshlm> ndevos, I will. Thanks.
12:15:19 <kshlm> Back to being the meeting host.
12:15:26 <ndevos> asengupt: same counts for JBR/FDL, got any tests we should start to run night/scheduled?
12:15:29 <kshlm> Anything more to add for 4.0?
12:15:50 <atinm> nothing from my side
12:16:03 <asengupt> ndevos, we have some basic tests that are already present in the test repo
12:16:07 <asengupt> apart from that
12:16:20 <asengupt> we don't have more specific ones right now
12:16:33 <asengupt> some are due to framework constraints
12:16:49 <asengupt> and some coz we haven;t fixed those specifics
12:16:52 <ndevos> asengupt: ok, just think about adding them when there is something that can be run
12:17:01 <kshlm> asengupt, Are you talking about the current test framework, ie include.rc/cluster.rc?
12:17:16 * post-factum is joining late
12:17:29 <asengupt> the existing test cases are in tests/basic/jbr
12:17:33 * ndevos thinks testing is a part of development, and includes extending test frameworks if needed
12:17:35 <kshlm> You could start trying out distaf for your tests.
12:17:47 <kshlm> ndevos, I agree.
12:18:00 <asengupt> yes the existing framework lacks certain ways of testing some quircky cases
12:18:02 <ndevos> ... and any "testing" I mention, is ALWAYS "automated testing"
12:18:03 <asengupt> as in locking
12:19:32 <kshlm> Locking is not clear enough. I'd like to hear more about this.
12:19:51 <kshlm> Probably on the mailing list in a separtae discussion after this meeting.
12:19:51 <ndevos> asengupt: I suggest to check with Apeksha or others that work on distaf, they should be able to guide you and help with extending the framework
12:20:23 <asengupt> yup i will discuss with apeksha
12:20:31 <kshlm> Okay.
12:20:32 <msvbhat> asengupt: ndevos: What feature extention needed for distaf?
12:20:34 <asengupt> kshlm will take this offline
12:20:46 <kshlm> That's it for 4.0 then.
12:20:47 <ndevos> discussion on gluster-devel is of course most appreciated, everyone need to learn about distaf too :)
12:20:59 <kshlm> msvbhat, please take it up out of this meeting.
12:21:08 <ndevos> msvbhat: I guess you'll see it in the email asengupt sends to the list :)
12:21:09 <msvbhat> sure thing, Thanks
12:21:20 * kshlm is glad msvbhat is hanging around
12:21:29 <kshlm> #topic GlusterFS-3.9
12:21:30 <msvbhat> Okay, Thanks :)
12:21:35 <atinm> msvbhat++
12:21:36 <glusterbot> atinm: msvbhat's karma is now 1
12:21:42 <kshlm> 3.9 cycle has begun.
12:21:57 <kshlm> prantihk, aravindavk and dblack are managing the release.
12:22:19 <kshlm> aravindavk sent out an announcement on the devel list regarding 3.9
12:22:31 <kshlm> #link https://www.gluster.org/pipermail/gluster-devel/2016-June/049923.html
12:22:57 <ndevos> initial roadmap is on https://www.gluster.org/community/roadmap/3.9/
12:23:09 <kshlm> Everyone working on features/fixes for 3.9 please go through the mail.
12:23:57 <kshlm> We should be following the new release-process for 3.9.
12:24:24 <ndevos> make your feature bugs block "glusterfs-3.9.0", so taht it automagically gets added to the tracker https://bugzilla.redhat.com/showdependencytree.cgi?id=glusterfs-3.9.0
12:24:46 <kshlm> ndevos and I have been preparing the process document at https://public.pad.fsfe.org/p/glusterfs-release-process-201606
12:25:04 <kshlm> Everyone is welcome to help evolve the document and the process.
12:25:09 <kshlm> It is still a WIP.
12:26:21 <kshlm> That's all about 3.9 for now.
12:26:27 <kshlm> #topic GlusterFS-3.8
12:27:08 <kshlm> 3.8.1 is still on track for 10th July
12:27:29 <kshlm> ndevos, I don't think this hasn't changed
12:27:40 <ndevos> correct, that is still the plan
12:28:06 <ndevos> wait, well, close, I'll be travelling from the 10th on, so maybe we'll release it on the 9th or so
12:28:16 <ndevos> bugs that need fixing in 3.8.1 should add "glusterfs-3.8.1" in the "blocks" field
12:28:31 <ndevos> once done, the bug should have been added to https://bugzilla.redhat.com/showdependencytree.cgi?id=glusterfs-3.8.1
12:29:01 <kshlm> Yup.
12:29:25 <ndevos> the release process that kshlm just mentioned above, contains the criteria for patches that can be accepted
12:30:18 <ndevos> #info component maintainers may merge changes, as long as they stick to the patch acceptance criteria mentioned in the release process
12:30:49 <kshlm> This info needs to be added to the process doc.
12:31:36 <ndevos> the merging part? yes, probably, and only up until a week of the planned release date
12:32:11 <kshlm> I've just added it.
12:32:16 <ndevos> ok, thanks!
12:33:00 <kshlm> So we're done with 3.8 for now?
12:33:13 <ndevos> from my POV, yes
12:33:56 <kshlm> Thanks.
12:34:02 <kshlm> #topic GlusterFS-3.7
12:34:27 <kshlm> 3.7.12 was tagged, last Friday
12:34:52 <kshlm> It was later than I'd promised, because I was a bit under the weather.
12:35:05 <kshlm> The announcement was made yesterday on the mailing lists.
12:35:20 <kshlm> #link https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
12:35:34 <kshlm> 3.7.12 release window is now opened.
12:35:45 <kkeithley> 3.7.13?
12:35:47 <ndevos> "merge window"?
12:35:55 <kshlm> yes
12:35:57 <kshlm> and yes.
12:36:19 <kshlm> hagarth should be the release manager, but I'll be helping as well.
12:36:29 <kkeithley> go easy on your wrists
12:36:47 <kshlm> kkeithley, It's fine now. Thanks for remembering,
12:37:11 <ndevos> 3.7.13 will be released tomorro?
12:37:13 <ndevos> +w
12:37:42 <kshlm> I'm targetting a mid July release.
12:37:44 <ndevos> I see that 8 patches have been merged already, seems sufficient for an update
12:38:03 <kkeithley> let's try to stick to the schedule please
12:38:21 <ndevos> yes, I would also like to see us getting back to the regular schedule
12:38:34 <kshlm> I've forgotten what the schedule was.
12:38:58 <ndevos> 3.8 around the 1oth, 3.6 around the 20th and 3.7 around the 30th
12:38:59 <kkeithley> 3.7.x on the 30th, 3.8.x on the 10th, 3.6.x on the 20th IIRC
12:39:11 <kshlm> Yup.
12:39:34 <kshlm> We're nearly a month past schedule for 3.7.12.
12:39:35 <ndevos> #link https://www.gluster.org/community/release-schedule/
12:39:41 <ndevos> hmm, needs updating for 3.8
12:40:03 <kshlm> Should we still do a 3.7.13 right away?
12:41:12 <ndevos> yes, I think so
12:41:34 <kkeithley> no, not IMO, but whatever.   The packagers might revolt
12:41:53 <ndevos> 3.7.12 got a major libgfapi bug, that should be fixed with the update
12:42:10 * ndevos isnt sure the patch is merged yet?
12:42:15 <kshlm> That could be a reason to do it.
12:42:33 <post-factum> +1 for .13 tomorrow :)
12:42:43 <kshlm> But the packages 3.7.12 packages have that fix.
12:42:47 <kkeithley> the packages are patched to fix that, so from a packaging perspective there is no urgent need for 3.7.13
12:43:22 <ndevos> some people build packages from the tarball... that doesnt have the fix
12:43:35 <ndevos> like Arch downgraded back to 3.7.11
12:43:36 <kshlm> If that one change gets merged, I'm ready to do .13.
12:44:07 <kshlm> But it will take a while to get back all maintainers to rerun sanity checks.
12:44:11 <ndevos> someone just needs to click [submit] on http://review.gluster.org/14822 :)
12:44:12 <kkeithley> since I'm out on jury duty tomorrow, (and maybe Friday too) and Monday is a holiday in the US, I can assure you there won't be any packages built until late next week at the earliest
12:44:51 <kshlm> kkeithley, You really are on jury duty.
12:44:54 <ndevos> kkeithley: thats fine, the packages you built have the patch added already
12:45:28 <kkeithley> I defintely have to go tomorrow.  I may or may not be empanelled. Won't know 'til tomorrow
12:45:34 <kshlm> I'll do it. I'll get the maintainers rounded up again.
12:45:48 <ndevos> I'm still not sure how strictly maintainers need to ack a stable release... they would be doing that 3x a month
12:46:30 <kshlm> Shouldn't take too long for .13
12:46:42 <kshlm> Very little changes have gone in since .12.
12:47:09 * ndevos shrugs
12:47:21 <kshlm> Asking for acks 3 times a month seems okay, if they don't have to run a bunch of tests everytime.
12:47:48 <kshlm> But that is still being done manually for now.
12:48:02 <kshlm> We need to make it automated ASAP.
12:48:09 <ndevos> I hope maintainers get bored of running tests manually, and start automating them ;-)
12:48:53 <kshlm> #agreed 3.7.13 to be released on schedule for 30th
12:49:31 <kshlm> I'm keeping my fingers crossed that I can tag it tomorrow.
12:50:01 <kshlm> #topic GlusterFS-3.6
12:50:18 <kshlm> I had to get a discussion started on EOLing 3.6, which I haven't yet.
12:50:39 <kshlm> Other than that, not a lot more to discuss regarding 3.6
12:51:05 <kshlm> Anyone have anything to add?
12:51:57 <kshlm> #topic NFS-Ganesha
12:51:58 <ndevos> 3.6 goes EOL when 3.9 gets releases? in September
12:52:16 <kshlm> ndevos, that's the plan.
12:52:53 <kshlm> I was supposed to announce that 3.6 will only get security updates till then.
12:53:11 <ndevos> ah, ok
12:53:26 <ndevos> skoduri, jiffin, kkeithley: nfs-ganesha update?
12:54:01 <skoduri> nothing new..md-cache bug fixes and extended APIs (multi-fd) support going on for FSAL_GLUSTER and FSAL_CEPH
12:54:09 <kkeithley> nfs-ganesha has one last FSAL to update to EX. Then it should wind down quickly to GA 2.4
12:54:53 <post-factum> nice
12:54:57 <kkeithley> FSAL_RGW too
12:55:00 <kshlm> Thanks skoduri and kkeithley
12:55:59 <kshlm> If there's nothing more to add, we'll move onto Samba.
12:56:16 <kshlm> I don't see any samba folk active though.
12:56:41 <skoduri> rjoseph?
12:56:57 <rjoseph> Samba side nothing much, only thing we are planning to improve test cases in libgfapi
12:57:36 <kshlm> That's good to know.
12:57:40 <rjoseph> we are one of the main users of libgfapi, this will help us find out issues early
12:58:10 <kshlm> What sorts of tests are you planning?
12:58:20 <rjoseph> currently no  libgfapi tests run on our regressions
12:58:38 <rjoseph> so poornima sent a patch to enable the few tests we have there
12:58:57 <rjoseph> So thats the first step
12:59:03 <kshlm> Ah, so these are not integration tests with Samba.
12:59:37 <rjoseph> Not directly
12:59:52 <ndevos> rjoseph: ah, poornima solved the compiling/linking difficulties with libgfapi?
13:00:09 <rjoseph> ndevos: I guess not
13:00:19 <ndevos> oh :-/
13:00:42 <ndevos> rjoseph: also, maybe we can run the upstream samba tests on a Gluster environment? I'm planning to do so for QEMU too http://thread.gmane.org/gmane.comp.emulators.qemu/422907
13:01:56 <rjoseph> ndevos, That would be great but before that we need libgfapi tests. After that we will take that too
13:01:58 <kshlm> We are over time right now.
13:02:42 <kshlm> rjoseph, Please keep us all updated on the progress.
13:02:53 <rjoseph> sure
13:02:56 <kshlm> Thanks.
13:02:58 <ndevos> rjoseph: I dont think there is a "before that we need", any tests we can run help
13:03:33 <kshlm> We are over time so I'll quickly proceed to Last weeks AIs.
13:03:54 <kshlm> ndevos, You and rjoseph can talk this over in gluster-dev
13:04:01 <kshlm> #topic Last weeks AIs.
13:04:42 <kshlm> Apart from Jiffin announcing 3.8 on the mailing lists, none of the others have been completed.
13:05:00 <rjoseph> ndevos: sure, but given the resources you might like to prioritise... Anyway we can take this offline
13:05:44 <kshlm> I'll try to get the longest standing AI (create bot acccounts on github,etc.) done with nigelb. He'll be bangalore for a few days.
13:06:22 <kkeithley> Oh, he's not in BLR? Where is he, Chennai? Or Pune?
13:06:35 <ndevos> Delhi, I though?
13:06:46 <kshlm> He was in Delhi, now in Mumbai.
13:06:47 <kkeithley> ah, okay
13:06:52 <kkeithley> he gets around.
13:06:56 <ndevos> ah, lol
13:07:35 <kshlm> Me and rastar will also be helping him understand our current CI setup better.
13:08:17 <kshlm> We should have some news to share on what our Jenkins will shape up to be soon.
13:08:38 <kshlm> That's all we've got for todays meeting.
13:09:02 <kshlm> Here are the standard weekly announcements,
13:09:08 <kshlm> If you're attending any event/conference please add the event and yourselves to Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
13:09:08 <kshlm> Put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
13:09:08 <kshlm> Use the following etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
13:09:36 * kshlm is wondering if we should still have the backports announcment
13:09:48 <kshlm> Thanks for attending the meeting everyone.
13:09:53 <kshlm> See you all next week.
13:09:54 <ndevos> thanks kshlm!
13:10:02 <kshlm> #endmeeting