12:00:29 <rafi1> #startmeeting Weekly community meeting 01/June/2016
12:00:29 <zodbot> Meeting started Wed Jun  1 12:00:29 2016 UTC.  The chair is rafi1. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:29 <zodbot> The meeting name has been set to 'weekly_community_meeting_01/june/2016'
12:00:41 <rafi1> Hil All
12:00:51 <rafi1> TIme for this week community meeting
12:00:58 <rafi1> #topic Rollcall
12:01:17 <rafi1> Please raise your hand and mark your attendance
12:01:26 * jiffin is here
12:01:39 <jiffin> \o/
12:02:27 * karthik___ is here
12:02:34 * partner here
12:02:40 * anoopcs is here
12:02:56 * overclk is around...
12:03:53 <rafi1> cool, I think we have enough participation to proceed
12:04:18 <rafi1> and I have sent reminder to all our irc channels
12:04:35 <rafi1> #topic Next weeks meeting host
12:05:08 <rafi1> Who are gonna volunteer next week community meeting
12:05:10 <rafi1> ?
12:05:58 <rafi1> hchiramm: would you be able to volunteer next week community meeting
12:06:48 <rafi1> For time being, I'm proposing hchiramm
12:07:11 <rafi1> if anyone interested, Please feel free to take the spot
12:07:22 * kkeithley is here
12:07:30 <rafi1> #topic GlusterFS 4.0
12:08:16 <rafi1> jdarcy, shyam, atinm ; Do you have anything to update for GlusterFS 4.0 ?
12:09:46 * rjoseph is late for the meeting
12:10:38 <rafi1> I think all GlusterFS4.0 maintainers are not around here, so moving into next topic
12:11:35 <rafi1> atinm just updated me that no progress was made to the project from last week
12:11:47 <rafi1> #topic GlusterFS 3.8
12:12:10 <jiffin> rafi1: ndevos provided update in gluster-dev
12:12:20 * jiffin pasting from it there
12:12:34 <jiffin> ndevos: 3.8 GA is still planned for later this week, unless absolute blockers get filed
12:12:47 <jiffin> ndevos: we still need updates to the release notes from feature owners on https://public.pad.fsfe.org/p/glusterfs-3.8-release-notes
12:12:59 <rafi1> jiffin: do we have any absolute blockers ?
12:13:08 <jiffin> ndevos: also please remind everyone that backports need reviews too http://review.gluster.org/#/q/status:open+project:glusterfs+branch:release-3.8
12:13:34 <jiffin> rafi1: there are pending patches for 3.8 features
12:13:48 <rafi1> #help needed to review the backport patches
12:13:55 <rafi1> #link http://review.gluster.org/#/q/status:open+project:glusterfs+branch:release-3.8
12:14:01 <jiffin> which is still under review
12:14:22 <rafi1> please give your time to review the patches
12:14:31 <jiffin> feature owners are confident that , it will be done before GA
12:14:33 * post-factum is late
12:14:54 <rafi1> we still need updates to the release notes from feature owners on https://public.pad.fsfe.org/p/glusterfs-3.8-release-notes
12:15:01 <post-factum> was that bug with rolling update to 3.8 fixed?
12:16:11 <rafi1> #info requesting to feature owners to give their release notes here in https://public.pad.fsfe.org/p/glusterfs-3.8-release-notes
12:16:43 <rafi1> post-factum: jiffin is helping in 3.8 release cycle,
12:16:53 <rafi1> post-factum: he should be able to give an answer
12:17:18 <jiffin> post-factum: I am not aware of that context
12:17:32 <jiffin> post-factum: do u have the bug id?
12:17:35 <post-factum> heh, that was considered to be a blocker
12:17:42 <post-factum> let me check
12:18:44 <post-factum> mm nope, hagarth should know for sure
12:18:51 <post-factum> as he is the one who encountered it
12:18:54 <rafi1> post-factum: the dependency tree can be found here in https://bugzilla.redhat.com/showdependencytree.cgi?id=glusterfs-3.8.0&hide_resolved=1
12:19:03 <rafi1> #link https://bugzilla.redhat.com/showdependencytree.cgi?id=glusterfs-3.8.0&hide_resolved=1
12:19:12 <post-factum> i'm not sure the bugreport was created
12:19:51 <post-factum> oh. found the discussion
12:19:53 <jiffin> post-factum: oh
12:20:01 <post-factum> #link https://meetbot.fedoraproject.org/gluster-meeting/2016-05-18/weekly_community_meeting_18may2016.2016-05-18-12.06.log.html
12:20:17 <post-factum> starting from 12:41:46
12:20:28 <post-factum> or even 12:43:33
12:21:17 <jiffin> post-factum: AFAIR itisravi was working on that
12:21:57 <rafi1> post-factum: jiffin : Please make sure that it will land into the 3.8
12:22:02 <post-factum> unfortunately, he is not here :(
12:22:44 <rafi1> jiffin: can you poke itiravi and update post-factum about the bus status
12:22:52 <rafi1> *bug
12:23:11 <jiffin> post-factum: http://review.gluster.org/#/c/14414/
12:23:18 <jiffin> its merged I guess
12:23:52 <post-factum> ok then
12:23:57 <post-factum> thanks jiffin
12:24:07 <rafi1> #link https://bugzilla.redhat.com/show_bug.cgi?id=1337130
12:24:08 <glusterbot> Bug 1337130: unspecified, unspecified, ---, ravishankar, ON_QA , Revert "glusterd/afr: store afr pending xattrs as a volume option" patch on 3.8 branch
12:24:21 <rafi1> post-factum: are you referring into the same bug ?
12:25:03 <rafi1> post-factum: if that is the case, you can see the bug as fixed in 3.8
12:25:04 <post-factum> rafi1: it looks like the one that hagarth described 2 weeks ago
12:25:15 <jiffin> post-factum: we can discuss it offline
12:25:17 <rafi1> post-factum: coool
12:25:21 <jiffin> rafi1: please proceed
12:25:46 <rafi1> Does any body have anything to update pn 3.8 ?
12:25:54 <rafi1> cool
12:26:00 <rafi1> moving into the next topic
12:26:13 <rafi1> #topic GlusterFS 3.7
12:26:33 <post-factum> 3.7.12 :(
12:26:50 <rafi1> I think we have to pick a release manager for 3.7.12
12:28:28 <rafi1> we can discuss about choosing a release manager in next meeting, when hagarth is around
12:28:40 <jiffin> copying from hagarth's mail
12:29:07 <jiffin> 1. Treat June 1st as the cut-off for patch acceptance in release-3.7.
12:29:07 <jiffin> 2. I will tag 3.7.12rc1 on June 2nd.
12:29:07 <jiffin> 3. All maintainers to ack content and stability of components by June 9th.
12:29:07 <jiffin> 4. Release 3.7.12 around June 9th after we have all acks in place.
12:29:20 <jiffin> it was a proposal send send by him
12:29:26 <rafi1> cool
12:29:33 <rafi1> thanks for the update jiffin
12:30:11 <rafi1> #info tentative date for 3.7.12 is on June 9th
12:30:25 <rafi1> #topic GlusterFS 3.6
12:30:38 <anoopcs> #link http://www.gluster.org/pipermail/gluster-devel/2016-May/049677.html
12:31:02 <olia> hi, is there any update on the smoke test failures for 3.6?
12:31:43 <anoopcs> olia, Do you have any link to failed test result?
12:32:06 <rafi1> olia: rastar is looking into 3.6 builds failures on BSD
12:32:12 <olia> yes http://review.gluster.org/#/c/14418/ and http://review.gluster.org/#/c/14403/
12:33:07 <rafi1> olia: this an action item on rastar
12:34:06 <rafi1> olia: he is still debugging it, he will update one he done the rca
12:34:14 <rafi1> *once
12:34:34 <olia> ok! thank you very much!
12:35:34 <rafi1> olia: please send a mail to gluster-devel ccing rtalur@redhat.com if you want to update anything on this problem
12:35:51 <rafi1> olia: make sense :) ?
12:36:08 <olia> yes sure thank you :)
12:37:42 <rafi1> #info targeted release for next 3.6 version ie 3.6.10 will be around 26 of this month
12:37:51 <rafi1> Moving into the next topic
12:38:04 <rafi1> #topic GlusterFS 3.5
12:38:17 <rafi1> Since ndevos is absent
12:38:43 <rafi1> if no body has nothing to update , I will proceed to next topic
12:39:03 <rafi1> cool
12:39:21 <rafi1> discussion on protocol integration with gluster
12:39:32 <rafi1> #topic NFS Ganesha
12:40:03 <rafi1> kkeithley: jiffin ndevos : any thing to update for mentioned topic ?
12:40:10 <kkeithley> not much to report.   nfs-ganesha-2.4.0-dev19 was built for Fedora24 and Fedora25/rawhide
12:40:34 <kkeithley> 2.4.0 GA will be soonish, no specific date set though
12:40:58 <rafi1> kkeithley: okey, thanks for the update
12:41:11 <rafi1> #Topic Samba
12:41:35 <kkeithley> the gating factor is conversio of all the FSALs to "ex" the new extended FSAL api
12:41:40 <kkeithley> conversion
12:42:18 <rafi1> kkeithley: is it already done ?
12:42:21 <post-factum> kkeithley: what is the advantage oh new api?
12:42:24 <post-factum> *of
12:43:00 <kkeithley> IIRC it's allows for better use of the mdcache
12:43:11 <jiffin> post-factum: + it provides more consistent file handles
12:44:21 <jiffin> and it is under review
12:45:01 <rafi1> okey
12:45:07 <rafi1> moving into the next topic
12:45:16 <rafi1> #topic samba
12:45:27 <rafi1> rjoseph: anoopcs : obnox please come forward and take the MIC
12:46:29 <rafi1> here, you can update samba+gluster integration related progress
12:47:42 <anoopcs> Minor updates to Samba 4.4, 4.3 and 4.2 are happening this month.
12:47:57 <rafi1> anoopcs: thanks for the update
12:48:48 <rafi1> #topic AI from last week
12:49:17 <rafi1> #topic kshlm/csim/nigelb to set up faux/pseudo user email for gerrit, bugzilla, github
12:49:40 <rafi1> nigelb: do you have anything to update
12:50:10 <nigelb> rafi1: Only that it shouldn't be on my list in the first place.
12:50:36 <rafi1> nigelb: I just asked
12:50:54 <rafi1> nigelb: because kshlm and csim is not around here
12:51:56 <rafi1> nigelb: please ignore if you are not the right person for this AI
12:52:12 <rafi1> carrying this AI into next week
12:52:27 <rafi1> #action kshlm/csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:52:48 <rafi1> #topic aravinda/amye to check on some blog posts being distorted on blog.gluster.org, josferna's post in particular
12:53:24 <rafi1> aravindavk: amye : any update ?
12:54:31 <rafi1> Moving this AI to next week
12:54:47 <rafi1> #action aravindavk/amye to check on some blog posts being distorted on blog.gluster.org, josferna's post in particular
12:55:19 <rafi1> #topic hagarth to announce release strategy after getting inputs from amye
12:55:31 <rafi1> I think this action item is already done
12:55:44 <rafi1> #link http://www.gluster.org/pipermail/gluster-devel/2016-May/049677.html
12:56:49 <rafi1> #topic kshlm to check with reported of 3.6 leaks on backport need
12:57:31 <rafi1> since kshlm is not here, carry forward this item into next week
12:57:40 <rafi1> #action kshlm to check with reported of 3.6 leaks on backport need
12:57:51 <rafi1> #topic rastar to look at 3.6 builds failures on BSD
12:58:11 <rafi1> rastart updated me that this AI is still inprogress,
12:58:25 <rafi1> #action  rastar to look at 3.6 builds failures on BSD
12:58:36 <rafi1> we are done with last week AI
12:58:48 <rafi1> #topic Open floor
12:59:24 <rafi1> everyone, please throw your innovative suggestions
13:00:29 <rafi1> cool
13:00:54 <rafi1> If nobody has nothing to update , I will end the meeting
13:01:04 <rafi1> #endmeeting