20:00:05 <jborean93> #startmeeting Windows Working Group
20:00:05 <zodbot> Meeting started Tue Aug 1 20:00:05 2017 UTC. The chair is jborean93. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:05 <zodbot> The meeting name has been set to 'windows_working_group'
20:00:20 <jborean93> Howdy all
20:01:32 <nitzmahone> yo
20:01:38 <jborean93> #chair nitzmahone
20:01:38 <zodbot> Current chairs: jborean93 nitzmahone
20:02:09 <jhawkesworth_> heya
20:02:19 <jborean93> #chair jhawkesworth_
20:02:19 <zodbot> Current chairs: jborean93 jhawkesworth_ nitzmahone
20:03:11 <jborean93> #topic https://github.com/ansible/community/issues/195#issuecomment-314705308 new modules
20:03:25 <jborean93> anything anyone wants to add regarding the new modules for 2.4
20:03:37 <jborean93> there is a pretty substantial list which is great to see
20:04:10 <nitzmahone> Yep- should have everything that's ready merged for 2.4, but probably won't be much movement there until after core freeze (at least by me)
20:04:18 <jborean93> I've looked at the win_xml very briefly and ok with it. I don't have really anything substantial to test it with but feel like we should just merge and se where it takes up
20:04:25 <nitzmahone> WFM
20:04:25 <jborean93> cc karstensrage
20:04:49 <jhawkesworth_> win_toast basically needs to run async. seems weird though so not really sure what I'm going to do with that
20:04:53 <nitzmahone> community + preview, so bases/asses more or less covered ;)
20:05:33 <nitzmahone> jhawkesworth_: yeah, seems like it needs a shared host process or something to keep the notifications alive... Maybe just nuke the PR for now?
20:05:38 <jhawkesworth_> would be nice to see how win_xml gets on with tests from xml module
20:05:56 <jborean93> are there currently tests for the xml module?
20:06:29 <jhawkesworth_> If I recall there are loads of tests for xml module - lots of xml files about beer IIRC
20:06:38 <nitzmahone> win_xml has some basic smoke tests
20:06:51 <jhawkesworth_> (to be clear I mean the python xml module has lots of tests)
20:07:03 <jborean93> yep, I've seen only a few for win_xml in the PR
20:07:13 <jborean93> Will see if we can use the same tests for win_xml
20:07:33 <jborean93> #action jborean93 to follow up karstensrage regarding win_xml tests
20:07:44 <jhawkesworth_> cool thanks
20:07:50 <jborean93> anything else for new modules
20:08:11 <nitzmahone> nawp
20:08:13 <jborean93> I've got a few but they aren't critical and an wait until people have more time to test
20:08:14 <jhawkesworth_> not from me
20:08:21 <jborean93> #topic https://github.com/ansible/community/issues/195#issuecomment-318914470 WSL support
20:08:31 <jborean93> I know dag isn't online but he added it as a topic
20:08:47 <jhawkesworth_> yeah I don't think much changes really.
20:08:55 <jborean93> I personally don't think we should support it as MS don't support it for non development purposes
20:09:02 <jhawkesworth_> I'm still not going to set forks to 10000 and run my datacenter off it
20:09:21 <jhawkesworth_> yup, its still a tool for developers
20:09:22 <jborean93> I'm also under the assumption Server 2016 doesn't even run it yet, just the preview
20:09:25 <nitzmahone> I'm not going to say it's *impossible* to test in CI, but it's probably not worth the trouble. Any issues we have there are likely to be scalability issues, which we won't be hitting during CI anyway
20:09:32 <nitzmahone> Nope, no servers will run it
20:09:55 <jhawkesworth_> if its not going on servers its not suitable for production workloads. ergo its still a dev tool
20:10:00 <jborean93> + . the only issue I've come across is windows line endings when trying to source ansible pulled down using windows git
20:10:05 <nitzmahone> I did some basic testing with like 20 forks over ssh with no problems at all (even on my junky old Core 2 Duo from 2007)
20:10:31 <jborean93> cool sounds like we have a consensus
20:10:38 <jhawkesworth_> I have used like 30 forks but don't have much inventory in test datacenters
20:10:42 <nitzmahone> I think there might be some git flags we could use to force things to *nix line endings, but my gitfu is weak in that area (never used it on Windows much)
20:10:54 <jborean93> there si for Windows and I ended up doing that
20:11:06 <jborean93> just wans't fun when the inventory just stopped working for no reason
20:11:11 <nitzmahone> heh
20:11:14 <jborean93> plus vault fails with \r\n
20:11:14 <jhawkesworth_> I never used git for windows either
20:11:24 <nitzmahone> arguably we'll need to figure that out anyway, esp if we ever end up doing native Windows controller
20:11:34 * jborean93 fumes with Windows line endings
20:11:37 <jhawkesworth_> I think I saw a PR re \r\n and vault earlier
20:11:46 <jhawkesworth_> alkins I think
20:11:49 <nitzmahone> I'm debating putting it on the 2.5 roadmap as an exploratory/experimental item
20:12:05 <nitzmahone> Yeah,I was just reviewing that PR today
20:12:29 <nitzmahone> At least they're not the bastard old Mac \r
20:12:40 <jhawkesworth_> native win controller would be awesome - help me with adoption by devs if nothing else
20:12:45 <nitzmahone> Exactly
20:13:08 <jborean93> #topic https://github.com/ansible/community/issues/195#issuecomment-319161331 member/membership
20:13:20 <nitzmahone> It'd depend on us bulletproofing threaded workers, and I honestly don't know how well it'd perform at scale on Windows without PyPy
20:13:38 <jborean93> plus there is the Kerberos ticket management issue
20:14:02 <nitzmahone> Yeah, though I have a couple ideas there
20:14:20 <nitzmahone> WRT renaming win_group_member- anyone else have an opinion?
20:14:26 <jborean93> for your member/membership I'm pretty ambivalent
20:14:36 <jborean93> if we already have a standard would be good to just align with it
20:14:40 <jborean93> both make sense to me
20:14:42 <jhawkesworth_> I like consistent names
20:15:04 <jhawkesworth_> I also don't mind typing whole words so happy with member -> membership
20:15:16 <jborean93> those 4 extra chars though :)
20:15:24 <jborean93> might get RSI
20:15:26 <jhawkesworth_> :-)
20:15:29 <nitzmahone> :P
20:15:41 <jborean93> cool, happy to make that change nitzmahone?
20:15:57 <jhawkesworth_> good names are worth the typing
20:16:00 <nitzmahone> OK- it's definitely an OCD thing, but I like having the module name map to the resource it's managing
20:16:26 <nitzmahone> jborean93: were you volunteering, or asking me if I'm happy to make it (yes)
20:16:31 <jborean93> #action nitzmahone to rename win_group_member to win_group_membership
20:16:35 <jborean93> done :)
20:16:38 <jborean93> #topic open floor
20:16:38 <nitzmahone> +1
20:16:45 <jborean93> Anything else to talk about
20:16:56 <nitzmahone> nothing from me oday
20:16:59 <nitzmahone> *today
20:17:15 <jhawkesworth_> I will be a bit offline till middle of the month (family holiday)
20:17:23 <nitzmahone> Nice- have fun!
20:17:29 <jborean93> only thing to add is I'm making changes to win_copy so hopefully people haven't been working on it
20:17:36 <nitzmahone> Going anywhere cool?
20:17:37 <jborean93> cool hope it is enjoyable for you
20:18:07 <jhawkesworth_> thanks. Northern France. Hopefully slightly warmer than soggy UK!
20:18:46 <jborean93> might get to see the sun in summer at least
20:18:56 <nitzmahone> Sweet...
20:18:59 <jhawkesworth_> saw your note about win_copy so wil leave that alone for now
20:19:20 <nitzmahone> Perfect timing, my lunch just arrived... See ya'll later!
20:19:40 <jborean93> cool, fast meeting is a good meeting
20:19:46 <jhawkesworth_> I'll let you get on. Have a good one
20:20:02 <jborean93> #endmeeting