17:13:24 <stickster> #startmeeting
17:13:24 <zodbot> Meeting started Wed Nov  5 17:13:24 2014 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:13:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:13:42 <stickster> #meetingname workstation
17:13:42 <zodbot> The meeting name has been set to 'workstation'
17:13:55 <stickster> #meetingtopic Workstation WG followup: Apps changes in F21
17:14:18 <stickster> #topic More added apps
17:14:23 <stickster> #link https://lists.fedoraproject.org/pipermail/desktop/2014-October/010893.html
17:14:33 <stickster> Next up is Logs :-)
17:15:28 <stickster> #chair mclasen kalev jwb ryanlerch andreasn
17:15:28 <zodbot> Current chairs: andreasn jwb kalev mclasen ryanlerch stickster
17:15:29 <mclasen> I hate to say, but it is probably not useful enough in its current state to warrant inclusion by default
17:16:26 <stickster> It's quite sluggish
17:16:46 <andreasn> so I upgraded from f20 to f21, so just wanted to confirm that logview is still in
17:17:08 <kalev> yes, upgrades don't delete apps you have installed
17:17:23 <andreasn> yes, but on a fresh f21, is it there?
17:17:47 <stickster> mclasen: It seems like there's an opportunity to have more tie-in with e.g. journalctl ability to show logs per unit, etc.
17:17:58 <stickster> but... neither here nor there, sorry for weeds.  /me backs off :-D
17:18:21 <stickster> andreasn: Yes, I did a fresh install of F21 (although it was just before Alpha) and have Logs
17:18:22 <mclasen> sure, it needs more feature work to be really useful
17:18:33 <kalev> since we didn't ship a log viewer for F20, it wouldn't be a regression if we didn't ship one for F21 either
17:18:42 <stickster> kalev: You answered my next question, thx :-)
17:18:47 <andreasn> right, so that's two apps with the same icon and almost the same name
17:19:18 <stickster> I guess the story for now is still really 'journalctl' and/or dmesg or other tty-based scrounging
17:19:24 <aday> doesn't seem like logs ever got its own icon
17:19:51 <stickster> aday: Is it using the icon for another app?
17:20:05 * stickster only has Logs on here when he types 'log' at the Overview search
17:20:33 <stickster> Oh I see, logview above. Sorry, missed that.
17:20:37 <andreasn> it's using the same icon as logview, but that's if you don't have both installed at the same time. It's a all right icon
17:20:55 <stickster> So question is, drop or retain?
17:21:13 <kalev> aday: what's your opinion?
17:21:14 <andreasn> but gnome-logs itself feels quite unready. Very unresponsive UI and odd margins and paddings
17:21:36 <aday> kalev, i agree with andreasn
17:21:57 <aday> but i do think we should be explicit about our reasoning here
17:22:14 <aday> so the relevant developers know what is wanted
17:23:23 <stickster> So far reasons include: unresponsive UI, UI tweaks needed, missing filter capabilities ?
17:23:28 <mclasen> https://wiki.gnome.org/Apps/Logs/Roadmap
17:24:08 <aday> be more useful
17:24:12 <aday> ? :)
17:24:59 <aday> i'm not sure what that means though... more efficient visual presentation? easier browsing?
17:25:13 <andreasn> I'm happy to file bugs about the visuals
17:25:23 <mclasen> ryanlerch, fmuellner: one thing I've been meaning to point out wrt to the logo extension: we may want to make it avoid the bottom panel in classic mode
17:25:45 <fmuellner> mclasen: oh, that's a good point!
17:25:46 <stickster> andreasn: Thanks
17:25:58 <aday> andreasn, i think i filed some already. i'll find the numbers
17:26:19 <andreasn> aday: thanks
17:26:36 <stickster> aday: I think the gap between being able to 'journalctl -u cupsd' and what Logs can do is fairly stark
17:26:56 <stickster> Although I would not advocate the word "cupsd" appearing anywhere in Logs of course :-)
17:27:04 <aday> andreasn, this was the main one - https://bugzilla.gnome.org/show_bug.cgi?id=727895
17:27:21 <otaylor> I think the basic bar for gnome-logs is that it should be something that we'd imagine peopel wanting to use rather than 'journalctl' in a terminal - and currently, it isn't - I think mostly in terms of density, responsiveness, and general ability to scan and search
17:27:30 <stickster> otaylor: Well said.
17:27:51 <kalev> also, we shouldn't think here as _dropping apps_, it's more like _not adding them_ since they are all new additions compared to F20
17:28:01 <stickster> kalev: Right.
17:28:01 <andreasn> right
17:28:11 <stickster> So are we generally agreed, don't add Logs?
17:28:19 <kalev> seems so
17:28:38 <stickster> #agreed Don't add Logs
17:28:51 <stickster> #action andreasn File add'l bugs on visuals as necessary
17:28:55 <stickster> Maps?
17:29:08 <stickster> #chair otaylor
17:29:08 <zodbot> Current chairs: andreasn jwb kalev mclasen otaylor ryanlerch stickster
17:29:31 <andreasn> so, as I mentioned in the meeting, the app is not quite there yet. It's functional, but rough
17:29:36 <kalev> I'd be for not adding Maps either, it's still a bit rough
17:29:52 <kalev> and I'm not sure it's something that needs to be in a core install, can easily be installed later if it's needed
17:30:11 <mclasen> maps is close to useful than logs
17:30:17 <drago01> for me its the same as with the dictionary ... I personally would use firefox for my "mapping needs"
17:30:25 <mclasen> still not a google maps killer, needless to say...
17:30:35 <andreasn> both Windows, OSX and Android comes with a Map app by default, so there is some baseline fuctionality for a OS there
17:31:10 <kalev> do Windows and OS X include it in their desktop installations too?
17:31:21 <kalev> or is it just for phones?
17:31:35 <andreasn> at least OSX since Mavericks, not super sure about Win8 actually
17:31:35 <aday> maps will be more compelling when it has more desktop integration - a search provider, integration with contacts, maybe with sharing when we have it
17:31:43 <andreasn> aday: agreed
17:31:54 <aday> maps is useful as way to display geographical information from other places
17:32:00 <kalev> and printing, so one could take a map with them when they are actually out looking for a place
17:32:26 <aday> yeah
17:32:28 <drago01> kalev: that would have been useful like 10 years ago
17:32:55 <kalev> OK, send to phone functionality instead of printing, then?
17:33:03 <mclasen> I still find it useful, when travelling abroad with unsure connectivity
17:33:11 <drago01> yeah that wouöd make more sense
17:33:43 * stickster not sure what to do with it other than locate something
17:33:46 <aday> there's also printing as in screenshotting
17:33:51 <andreasn> we're working on a number of those things upstream
17:33:58 <aday> basically into sharing territory
17:34:15 <otaylor> I think the main advantage of having maps at all is to promote the OSM ecosystem - but without working geolocation, etc, it's not a good advertisement
17:34:28 <stickster> *nod, seems like sharing is the breakthrough bit
17:35:14 <aday> i like the idea of being able to search for a location and get results from clocks, weather and maps
17:35:36 <fmuellner> aday: indeed
17:35:47 <mclasen> does maps have a search provider yet ?
17:35:50 <stickster> aday: +1 but does that work?
17:35:53 <stickster> mclasen: *jinx
17:36:01 <stickster> it doesn't here afaict.
17:36:02 <aday> not yet, as far as i know
17:36:11 <stickster> So in interest of time:
17:36:18 <stickster> #propose Don't add Maps to default at this time.
17:36:31 <stickster> oops.
17:36:53 <kalev> +1
17:37:02 <stickster> +/-1 -- where +1 == "don't add to default", and -1 == "no, let's add it to default"
17:37:18 <mclasen> +1
17:37:34 <otaylor> +1
17:38:49 <stickster> #agreed don't add Maps to default
17:38:57 <stickster> Sound Recorder
17:39:19 <stickster> Do we have anything to record voice memos or sounds other than SR?
17:39:30 <stickster> (in default)
17:39:42 <mclasen> its the only thing that does recording, afaik
17:39:49 <aday> i think the more pertinent question is whether sound recording is something you'd expect out of the box
17:39:50 <kalev> not sure it's ready though
17:40:39 <drago01> why would it not be "ready" ?
17:40:44 <kalev> "recording" is a pretty distinct keyword, should be easily discoverable through application search even if it's not installed by default
17:40:49 <drago01> it seems to just work (tm)
17:41:17 <stickster> aday: It's hard to say, but as a productivity tool, voice memos are pretty well established in a lot of form factors, laptops are maybe the biggest but seem to be reasonable too
17:41:52 <kalev> drago01: clicking the play button doesn't do anything here, for example
17:41:54 <otaylor> THere's one bug where if you hit play on an unselected row in the list it doesn't play, but otherwise, it seems to mostly be fairly functional and nicely simple
17:42:07 <kalev> drago01: then I had to use command line search to find out where it actually put the file that it recorded
17:42:23 <andreasn> it's not located under Utilities currently it seems
17:42:23 <mclasen> It doesn't seem to end up in ~/Recordings ?
17:42:25 <otaylor> But I'm still not convinced that it's really core default functionality that people expect to be in an OS
17:42:32 <kalev> mclasen: it did
17:42:37 <stickster> kalev: Works fine here
17:42:50 <drago01> stickster: he probably didn't select a row
17:43:01 <drago01> (see what otaylor said)
17:43:04 <mclasen> ah, now it worked
17:43:11 <kalev> ahh, indeed, looks like the play button only works after selecting the row, right
17:43:30 <stickster> kalev: Ah, now it's wonky here too after looking at info :-)
17:43:53 <stickster> So polish may be an issue :-)
17:43:57 <mclasen> sounds like a bug (no pun, but maybe time to move on...)
17:43:59 <stickster> otaylor: fair enough
17:44:03 <stickster> mclasen: yup
17:44:12 <aday> stickster, it makes sense as a standard feature in a notes app. not sure standalone
17:44:31 <stickster> aday: Would be interesting to tie into bijiben maybe.
17:44:51 <stickster> proposal:  Don't add Sound Recorder at this time. +/-1?
17:45:06 <kalev> +1
17:45:08 <aday> stickster, yeah, although i doubt we'd be able to do online sync for voice recordings
17:45:26 <drago01> well every other os has one by default right? (windows, osx, ios, andorid, ..)
17:46:32 <aday> drago01: are you sure? i don't see one on my phone here
17:47:34 <drago01> oh indeed
17:47:39 <drago01> not on android
17:47:50 * stickster waits for weigh-in so we can move on :-)
17:47:52 <mclasen> I see something called voice recorder on mine
17:48:07 <stickster> mclasen: me too
17:48:15 <otaylor> web search seems to indicate windows yes, android no, os x no (but there's a record sound feature in the QuickTime player)
17:48:40 <otaylor> the android phone I have (4.4) only seems to have a 3rd party thing I installed
17:48:44 <drago01> mclasen: stock android or some vendor skin? not here on nexus 4
17:49:01 <mclasen> some vendor
17:49:06 <drago01> ok
17:49:09 * stickster has VZW GS5
17:49:17 <stickster> My N7 is upstairs
17:49:53 <stickster> Anyway, we're getting away from the point... in other cases it seems like "not core, well discoverable" was good enough not to add.
17:49:57 <stickster> e.g. brasero
17:50:26 <drago01> yeah fair enough
17:50:35 <stickster> SR comes up near or at top of list for 'record', 'sound', 'voice' searches in Software
17:51:53 <mclasen> odd that 'subtitle editor' and  epiphany come in higher for 'voice', I'll say
17:52:02 <stickster> Can we finish this and move on?
17:52:12 <mclasen> +1 for leaving it out
17:52:38 <otaylor> +1 to leave it out as well
17:53:07 <stickster> #agreed Don't add Sound Recorder in default
17:53:18 <stickster> Weather!
17:54:20 <otaylor> Seems useful to me to include
17:54:42 <andreasn> very well executed app
17:54:42 <stickster> otaylor: To me too. Although here (maybe a bug?) I can't seem to do anything with auto-location
17:54:46 <stickster> It looks beautiful
17:55:14 <kalev> auto-location was turned off by default globally for the final GNOME 3.14 release
17:55:17 <stickster> gotcha
17:55:20 <kalev> unsure why though
17:55:38 <kalev> I'd keep this one too
17:55:56 <kalev> let's move on, looks like we have rough consensus
17:56:04 <kalev> 5 minutes to FESCo meeting :)
17:56:12 <stickster> #agreed keep Weather by default
17:56:16 <stickster> simple-scan?
17:56:41 <kalev> not sure again that this is something that should be in the core functionality -- scanners are pretty rare
17:57:07 * stickster has an old one, which proves kalev's point
17:57:13 <aday> kalev, agree
17:57:13 <drago01> well lots of printers have built in scanners
17:57:25 <stickster> There are more AIO units these days, true
17:57:34 <andreasn> multi-function-printers are quite common I would say
17:57:51 <mclasen> can you get simple-scan to work with those ?
17:57:55 <aday> still not sure they're commen enough
17:57:56 <drago01> yes
17:58:04 * mclasen admits that he never figure it out for the printer/scanner at home
17:58:15 <drago01> here its simply start it
17:58:18 <drago01> press scan button
17:58:22 <drago01> simple enough ;)
17:58:23 <andreasn> always worked out of the box for me
17:58:31 <mclasen> drago01: nomen est omen
17:58:42 <andreasn> but might depend on the model. This is an HP
17:59:13 <stickster> FWIW: Every printer that just came up in my survey of Epson, HP, Canon home/home-office sites was an AIO unit with a scanner.
17:59:25 <stickster> i.e. at the vendor site, that's all they advertise
17:59:33 <stickster> maybe almost all they sell.
17:59:57 <stickster> I haven't shopped for a printer recently but that's pretty telling
18:00:09 <sgallagh> I've tried numerous times to get the scanner working on my AIO and have never succeeded
18:00:10 <drago01> yeah people rarely buy standalone printers (or even scanners)
18:00:24 <sgallagh> (I resigned myself to using its scan-to-email function instead)
18:00:30 <stickster> I would say this is closer to core functionality
18:00:50 <stickster> Also, a FESCo meeting is coming up, and I need to leave.
18:01:02 <stickster> aday: What say you?
18:01:04 <sgallagh> (I am referring to a network AIO, though. Not locally-attached)
18:01:16 <stickster> sgallagh: You are a geek! Stop talking! :-D
18:01:48 <mclasen> stickster: if it was core, I would kinda expect scanners to figure in the control-center somehow
18:01:56 <stickster> sgallagh: And I say that with only love and admiration :-)
18:02:01 <aday> stickster, i don't have a strong opinion, but it feels a bit more towards the specialised end of the spectrum
18:02:03 <sgallagh> stickster: I'm... not sure how to take that
18:02:20 <stickster> sgallagh: With a grain of salt, as with everything that emergeth from my piehole
18:02:36 <drago01> mclasen: why? what would you want to configure there?
18:02:46 <drago01> other than network scanners most are "plug and play"
18:02:47 <sgallagh> drago01: That's where printers are configured...
18:02:52 <stickster> I would feel like it was just "press and play" which is basically what happens in simple-scan
18:03:09 <sgallagh> drago01: How about scanning DPI, color vs. b/w...
18:03:29 <drago01> sgallagh: that's an app setting
18:04:06 <drago01> sgallagh: that depends on what you want to scan... having to set it "globally" each time makes no sense
18:04:08 <sgallagh> drago01: You could say the same about default printer DPI, but we set that in gnome-settings
18:05:18 <stickster> #chair aday
18:05:18 <zodbot> Current chairs: aday andreasn jwb kalev mclasen otaylor ryanlerch stickster
18:05:21 <mclasen> drago01: dunno, defaults for resolution, color/bw/grayscale, feeder or not,...
18:05:42 <stickster> aday: mclasen: otaylor: andreasn: I'm leaving you in charge. Please remember to #endmeeting when discussion is done, I have to leave as was foretold
18:05:53 <stickster> :-)
18:06:08 <stickster> also kalev ^ even though he's in FESCo
18:07:08 <mclasen> should we keep going for the last app ?
18:07:21 <mclasen> looks like only transmission-gtk is left ?
18:07:48 <otaylor> Did we make a decision abouto simple-scan?
18:07:59 <mclasen> oh, maybe not
18:08:36 <kalev> sorry, I have to herd cats in the fesco meeting, have to chair it today
18:08:46 <otaylor> I think it's pretty good for the role (though haven't actually used it) - but for installed-by-default - I think the basic question is whether it woudl reduce confusion and make things easier for the 20% or so of people who are going to try and  scan from their all-in-one or plug in a usb scanner
18:09:20 <mclasen> simple-scan clearly needs some touch support
18:09:33 <mclasen> everything with a rotate button should
18:10:06 <mclasen> kalev: herd them hard!
18:10:17 <hadess> mclasen, simple-scan needs to be an intent, just like taking a photo from a camera
18:10:18 <andreasn> it seems to come up pretty far down in gnome-software
18:10:25 <drago01> can someone on a f21 system check what a search for "scan" yields?
18:10:26 <mclasen> hadess: that too
18:10:35 <mclasen> andreasn: first hit for 'scan' here
18:10:48 <otaylor> does gnome-software up installed software in the search?
18:10:48 <aday> when i compare simple scan with somethnig like clocks or weather, it is clearly much more specific
18:11:11 <aday> knowing the time, taking a memo, or looking up a contact are generic. scanning a document isn't
18:11:13 <andreasn> I have it installed here too, but maybe old data
18:11:41 <otaylor> (after I remove it via yum it still shows up as installed in gnome-software...)
18:12:30 <mclasen> still comes in first here, after removing it
18:13:12 <mclasen> anyway, to wrap this up: suggestion: keep simple-scan off the default in f21
18:13:44 <otaylor> +1 people shouldn't expect that everything they might want to do has a preinstalled application - let's keep down clutter in the app list
18:14:18 <andreasn> true
18:15:05 <sgallagh> related: can we get the hplip-gui package listed in GNOME Software?
18:15:47 <drago01> just add an appdata file in the package?
18:15:51 <mclasen> does it contain an app ?
18:16:36 <sgallagh> mclasen: /usr/share/applications/HP-hplip.desktop
18:16:43 <ryanlerch> sgallagh, it is currently not sowing up because it doenst have a logo
18:16:51 <ryanlerch> s/logo/icon
18:17:12 <sgallagh> ryanlerch: An icon exists in the Overview once it's installed
18:17:13 <ryanlerch> *showing
18:17:55 <ryanlerch> sgallagh, this is the error: Failed to find icon: specified icon '/usr/share/hplip/data/images/128x128/hp_logo.png' does not exist
18:18:02 <mclasen> any further votes on simple-scan ?
18:18:27 <sgallagh> mclasen: I'm not WG, but I'm fine with removing it, since it's easily-discoverable
18:19:22 <sgallagh> ryanlerch: /usr/share/hplip/data/images/128x128/hp_logo.png exists on my system (as well as many other sizes)
18:19:53 <ryanlerch> sgallagh, hughsie is the man to talk to -- he should know what is going on...
18:20:00 <mclasen> #agreed leave simple-scan out of the default
18:20:19 <mclasen> I guess we've run out of steam here now, so I'll leave transmission for next time
18:20:30 <mclasen> #endmeeting