14:01:15 <mcatanzaro> #startmeeting Workstation WG
14:01:15 <zodbot> Meeting started Wed Sep  2 14:01:15 2015 UTC.  The chair is mcatanzaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:27 <mcatanzaro> #meetingname workstation
14:01:27 <zodbot> The meeting name has been set to 'workstation'
14:01:32 <mcatanzaro> #topic Roll call!
14:01:34 * mclasen_ is here
14:01:55 * otaylor is here
14:02:03 <juhp_> hi
14:02:25 <mcatanzaro> kalev rdieter
14:02:34 <rdieter> hola
14:02:36 <kalev> hello
14:03:23 <mcatanzaro> So Paul sent regrets. We're missing Ryan (haven't heard from him) and Christian (who said he'd be here; guess he's busy?).
14:06:16 <mcatanzaro> OK, well let's try to plow through some of these agenda items, them.
14:06:24 <mclasen> cschaller says he has trouble connecting to freenode
14:06:28 <mcatanzaro> #chair mclasen rdieter kalev juhp_ otaylor
14:06:28 <zodbot> Current chairs: juhp_ kalev mcatanzaro mclasen otaylor rdieter
14:06:36 <mcatanzaro> :(
14:07:13 <mcatanzaro> Well we have quorum, so let's proceed....
14:07:55 <mcatanzaro> #topic i686 install media
14:08:11 <mcatanzaro> FESCo has decided that i686 will no longer be produced as a "primary/blocking deliverable" for F24.
14:08:44 <mcatanzaro> We had expressed a preference to continue producing this media if and only if the kernel team would continue maintaining the kernel, but that's not going to happen.
14:09:08 <mcatanzaro> So... this is mostly an informational point, I suppose, unless anyone has any objections?
14:09:26 <mclasen> seems so
14:09:37 <rdieter> no objection, probably for the best in the long run
14:09:45 <mcatanzaro> It might not have any practical significance; FESCo didn't say, for example, that we can't still put an i686 download in the sidebar on the download page.
14:10:12 <mcatanzaro> But we can't block the release on i686 bugs anymore.
14:10:17 <mcatanzaro> (Seems reasonable to me.)
14:10:23 <juhp_> yes
14:11:06 <mcatanzaro> OK, moving on
14:11:17 <mcatanzaro> #topic Is the text on the workstation product on getfedora.org OK?
14:11:33 <mcatanzaro> https://getfedora.org/
14:11:57 <mcatanzaro> #info "Fedora Workstation is a polished, easy to use operating system for laptop and desktop computers, with a complete set of tools and helpers for developers and makers of all kinds."
14:12:05 <mcatanzaro> Seems fine to me
14:12:07 <mcatanzaro> https://getfedora.org/en/workstation/
14:12:16 <mcatanzaro> #info "This is the Linux workstation you've been waiting for."
14:12:20 <mcatanzaro> Seems fine to me
14:12:51 <mcatanzaro> #info "Fedora Workstation is a reliable, user-friendly, and powerful operating system for your laptop or desktop computer. It supports a wide range of developers, from hobbyists and students to professionals in corporate environments."
14:12:51 <mclasen> to me too
14:13:06 <kalev> to me too
14:13:12 <mcatanzaro> That is the only point I am somewhat concerned about; my worry is that once you read that, if you're not a developer, you might think "oh it's for developers, not me."
14:13:25 <otaylor> mcatanzaro: But that's not the text on getfedora.org
14:13:27 <mcatanzaro> The rest of the page looks good to me. Thoughts from the rest of you?
14:13:52 <mcatanzaro> otaylor: Well, it's getfedora.org/en/workstation/ :p  You think they meant only the text on the homepage?
14:14:12 <rdieter> developers and makers of all kinds... is a good fit imo
14:14:25 <rdieter> personally, I think the phrase "and helpers" doesn't add anything, and could be dropped, but otherwise is fine
14:14:41 <juhp_> rdieter: +1
14:14:48 <mcatanzaro> Yeah, "and helpers" is redundant... a minor tweak.
14:14:57 <otaylor> mcatanzaro: Well, probably meant both ... it's a bit confusing that there are two different short blurbs
14:15:47 <mcatanzaro> otaylor: Good point; maybe we could merge the blurbs together, and use the same one on both pages. Probably something to leave to the design folks.
14:15:57 <otaylor> But anyways, it all looks pretty fine to me
14:16:01 <kalev> I think the text flows better with "and helpers" :)
14:16:09 <kalev> but not a native speaker here and will defer to all of you!
14:16:10 <otaylor> kalev: What is a helper?
14:16:32 <kalev> I don't know, but I think it's deliberately ambiguous
14:16:51 <kalev> can we use another word there?
14:16:53 <otaylor> kalev: if it's a about flow, it might as well be "tools and thingamajigs"
14:17:02 <kalev> sure :)
14:17:03 <mcatanzaro> The word "helper" doesn't really translate perfectly to American English, I think. It's basically the same as "tool" right?
14:17:09 <mclasen> without it, the workstation text may end up a line shorter than the others
14:17:42 <mcatanzaro> "Fedora Workstation is a reliable, user-friendly, and powerful operating system for your laptop or desktop computer, with a complete set of tools for developers and makers of all kinds."
14:17:58 <mcatanzaro> (merging some words from the Workstation-specific page in, to make it longer)
14:19:41 <mcatanzaro> Well this is a minor point. Seems we all think the text is mostly fine. So moving on....
14:19:52 <mcatanzaro> #topic SecureBoot enabled causes Win 8 UEFI to not start from grub
14:19:54 * juhp_ sees the Japanese translation by default :)
14:20:17 <mclasen> you also want to avoid making it look too similar to the other two texts right next to it, which might argue for leaving out the 'powerful' which is used for the server already
14:20:38 <mcatanzaro> +1 mclasen
14:20:43 <mcatanzaro> juhp_: Nice to know we have good translation coverage
14:20:54 <juhp_> :)
14:21:01 <mcatanzaro> https://bugzilla.redhat.com/show_bug.cgi?id=1170245
14:21:43 <mcatanzaro> The TL;DR of this bug is that it makes dual boot with modern Windows not work. RejectedBlocker, but a patch is available, but not applied yet since it requires creation of a new shim to be signed....
14:22:06 <pjones> yeah, we need to get the patch upstream for this, and it wasn't on my TODO for shim last release - can somebody file an issue here: https://github.com/rhinstaller/shim/issues ?
14:22:14 <otaylor> mcatanzaro: what
14:22:24 <otaylor> 's the action that the WG needs to take here?
14:22:32 <mcatanzaro> pjones: Awesome; I was going to propose making a formal request to you to review the issue, didn't realize you were here.
14:23:00 <mcatanzaro> otaylor: I was going to propose simply stating that dual-boot is a high-priority for us, please look at the bug. :)
14:24:12 <mcatanzaro> #action I will ask Chris Murphy to follow up on https://github.com/rhinstaller/shim/issues
14:24:23 <mcatanzaro> #undo
14:24:23 <zodbot> Removing item from minutes: ACTION by mcatanzaro at 14:24:12 : I will ask Chris Murphy to follow up on https://github.com/rhinstaller/shim/issues
14:24:39 <mcatanzaro> #action mcatanzaro to ask Chris Murphy to follow up on https://github.com/rhinstaller/shim/issues regarding https://bugzilla.redhat.com/show_bug.cgi?id=1170245
14:24:54 <mcatanzaro> #topic Default applications
14:25:23 <mcatanzaro> I'm proposing to remove Shotwell and Transmission from the default install. stickster already voted in advance: +0 remove shotwell, +1 remove transmission.
14:25:27 <mcatanzaro> Comments?
14:26:15 <kalev> one guideline that I've always kept in mind for myself is that we should try and have handlers for commonly used file types
14:26:25 <otaylor> -1 to remove shotwell, I don't see removing it without replacement +1 to remove transmission - it doesn't seem like something that needs to be preinstalled
14:26:33 <mclasen> I generally agree with reducing the set of pre-installed applications
14:26:33 <kalev> such a documents people might receive or images or ... torrent files
14:26:35 <mcatanzaro> kalev: eog is the default image viewer; Shotwell is quite a bit more than that.
14:26:50 <juhp_> mclasen, yes
14:26:55 <kalev> also, Shotwell used to be very actively maintained years ago, but not that much anymore
14:26:57 <mclasen> but maybe we should focus on removing the useless ones first :-)
14:27:00 <mcatanzaro> Also relevant: about a year ago, we agreed to aggressively pare down the set of default applications. But, not sure we are all still on board with that plan. :)
14:27:14 <mcatanzaro> Shotwell has had only translation commits since April, I think
14:27:30 <mclasen> shotwell is in maintenance mode upstream
14:27:47 <mcatanzaro> mclasen: I think it has dropped out of maintenance mode, I'm afraid. Same for Geary. :(
14:27:54 <mclasen> not actively developed, at least
14:28:25 <otaylor> I guess the question about shotwell is are we creating an "attractive nuisance" with it - are people going to see it, and do a bunch of work importing their photos into it, that will later turn out to be lost work?
14:28:32 <mcatanzaro> rishi: If we were to get rid of Shotwell, would you still want to wait longer before we add GNOME Photos?
14:29:14 <mcatanzaro> The easy solution for us is to replace it with Photos. But if it's not ready, it's not ready.
14:29:30 <mclasen> otaylor: thats a concern, and we should keep migration in mind for when we do a switch
14:29:54 <mcatanzaro> Also relevant: if we want to keep it, we really need to fix the "probably doesn't verify TLS certificates for facebook/youtube/etc." issue; since there is no upstream, that will be on us to fix....
14:30:29 <mcatanzaro> (I still haven't verified this bug for sure, but I'm pretty confident it's a problem.)
14:31:57 <otaylor> rishi: Have you researched migration at all ... what it would mean for a user to go from shotwell to Photos?
14:33:07 * mclasen not sure rishi is paying attention here
14:33:29 <otaylor> If we pull Shotwell out as unmanaged, what is our recommendation for photo management (what we would feature in Software)? digikam? If we think there's a way forward from our current Shotwell recommendation, I'd rather not bounce around here
14:33:32 <mcatanzaro> otaylor: I think rishi is afk. The user's photos are all going to show up in Photos immediately, since tracker indexes ~/Pictures. But I think any changes made in Shotwell (e.g. red eye removal) or organization done will probably be lost, since Shotwell does not modify the original files.
14:34:08 <mcatanzaro> Anyway, there is more I want to get to today, so let's defer Shotwell to the next meeting: we can get some answers from rishi in the meantime.
14:34:24 <mcatanzaro> Let's vote on transmission. I'm +1 to remove, stickster is +1, otaylor is +1.
14:35:19 <mcatanzaro> mclasen kalev juhp: ^
14:35:31 <kalev> I think it might be good to have something installed that acts as a file handler for torrent files
14:35:58 * mclasen got rishi's attention
14:36:19 <mclasen> rishi: here now ?
14:36:32 <sgallagh> kalev: I think an ideal situation would be for GNOME Software to grow the capability to help locate file-handlers
14:36:42 <juhp_> sgallagh, yes
14:37:01 <sgallagh> i.e. Click on a torrent file, get taken to a Software page listing torrent tools
14:37:03 <mclasen> kalev: don't we support installing mime handlers via gnome-software now ?
14:37:21 * juhp_ was wondering that too
14:37:58 <kalev> mclasen: yes, Software supports it, but I am not sure how well it's hooked up all the way from firefox to nautilus to gnome-software
14:38:05 * kalev has to test it.
14:38:08 * rishi scrolls up
14:38:14 <mclasen> hi rishi
14:40:01 <mclasen> rishi: the topic of replacing shotwell by photos came up
14:40:06 <mcatanzaro> kalev: firefox is pretty bad at opening files...
14:40:14 <rishi> otaylor: mcatanzaro: One thing that would need addressing is importing the tags from shotwell, but no, I haven't investigated that.
14:40:27 <rishi> I wouldn't replace shotwell until we figured out sharing and editing.
14:40:29 <otaylor> rishi: Will Photos have a similar tags concept?
14:40:43 <rishi> otaylor: It has albums, which is sort of like tags.
14:40:45 <mclasen> rishi: wasn't editing in the works already ? is that 3.20 material ?
14:40:49 <mcatanzaro> Firefox opens an actual GtkFileChooser to /usr/bin and has the user pick the program to view the file in
14:40:58 <rishi> mclasen: Yeah 3.20. Couldn't finish it in time for 3.18.
14:41:29 <rishi> Sharing is a bigger question. We could either do a one-off thing because it is quite important for photos, or we could wait to do it properly with portals, etc..
14:42:12 <otaylor> rishi: I guess we could imagine writing an importer that could show you your tags and events in Shotwell and let you figure out which ones you wanted to import as albums
14:42:42 <otaylor> rishi: Would need some user research to figure out how people actually use Shotwell
14:43:26 <rishi> otaylor: Yes. Although similar importers exist for f-spot to shotwell.
14:43:52 <rishi> We could probably do something similar. I have never tried those.
14:44:23 <otaylor> rishi: What about edits? does it seem feasible to import the non-destructive edits from Shotwell?
14:45:22 <mclasen> mcatanzaro: would be easy for them to use a app chooser, with the gtk3 port
14:45:30 <rishi> otaylor: Theoretically, yes.
14:45:47 <rishi> I haven't looked at how all the operations in shotwell map to gegl ones.
14:46:03 <rishi> I have only looked closely at a few of them.
14:46:08 <rishi> But, yes, it should be.
14:46:18 * otaylor wonders how we could do a useful survey of what photo tools fedora users are *actively using* and have an invested interest in. Do people just throw all their photos onto Facebook?
14:46:23 <mcatanzaro> mclasen: Would that bring automatic integration with GNOME Software?
14:46:38 <mclasen> yes
14:47:06 <otaylor> Anyways, for the purposes of this meeting, my suggestion is that we stay the course with what we are doing currently until we have a plan for moving forward
14:47:33 <rishi> otaylor: Grab stuff from camera/phone/USB, do a few tweaks, and push to Facebook would be a big use-case. I know that the designers want to optimize for this one.
14:47:36 <rishi> otaylor: yeah
14:47:38 <mcatanzaro> #chair cschalle
14:47:38 <zodbot> Current chairs: cschalle juhp_ kalev mcatanzaro mclasen otaylor rdieter
14:47:49 <mclasen> it sounds like we have a rough idea what tasks go on a shotwell -> photos migration plan
14:48:03 <cschalle> sorry for being late, when connecting over a mobile network freenode was giving me hell about needing a SASL account to be allowed to log in
14:48:23 <kalev> pffff, how come you don't have a SASL account!
14:48:43 <kalev> :)
14:48:50 <mcatanzaro> rishi: How much work would this all be? Is it realistic to expect it to be ready for F24?
14:49:48 <mcatanzaro> Is Shotwell->Photos migration something you can convince mclasen/cschalle to let you do at work? :D
14:50:20 <rishi> mcatanzaro: There are a few big things - a) import from removable storage b) editing c) sharing d) get stuff from shotwell
14:50:41 <rishi> (a) and (b) are in progress.
14:51:15 <rishi> F24 might be a bit aggressive, I think.
14:51:23 <mcatanzaro> OK.
14:52:33 <mcatanzaro> Let's defer on removing Shotwell for now, then. But we need to fix the immediate security problem, or disable Shotwell's sharing features.
14:53:32 * mcatanzaro notes lack of volunteers, grudgingly admits he is the best person for that....
14:53:57 <mclasen> is there a bug for 'immediate security problem' ?
14:54:00 * mclasen wasn't aware of it
14:54:14 <mcatanzaro> mclasen: Not really
14:55:05 <mcatanzaro> Just https://bugzilla.gnome.org/show_bug.cgi?id=751709#c4
14:55:31 <mcatanzaro> #action mcatanzaro to investigate probable Shotwell security issue
14:55:43 <mcatanzaro> So, Transmission
14:56:00 <mcatanzaro> We have three votes to remove. kalev thinks it's useful to have to handle torrent files.
14:57:24 <mcatanzaro> TBH, I think most users will never see a torrent file; they're kind of a niche usecase. And it is featured in Software with a huge banner. So I will keep my vote to remove. Any formal votes from kalev cschalle juhp?
14:58:49 <cschalle> I wouldn't mind dropping it, I mean it is somewhat niche and can easily be found in Software
14:59:10 <mclasen> I'm +1 on removing transmission
14:59:26 * mcatanzaro forgot to ask mclasen :(
14:59:40 <mclasen> testing mime-handler support in gnome-software is a good idea
15:00:19 <juhp_> I am guess I don't have strong objections - I seldom use it
15:00:32 <mcatanzaro> OK, we're +4 formal votes to remove (mcatanzaro, stickster, otaylor, mclasen), with tepid support from cschalle and opposition from kalev, so proposal passes.
15:00:35 <juhp_> s/am//
15:00:40 <mcatanzaro> And we're out of time, so that's all.
15:00:49 <mcatanzaro> Thanks everyone!
15:00:56 <mcatanzaro> #action mcatanzaro to remove transmission
15:00:58 <mcatanzaro> #endmeeting