15:00:10 <stickster> #startmeeting Workstation WG
15:00:10 <zodbot> Meeting started Wed Nov 11 15:00:10 2015 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:13 <stickster> #meetingname workstation
15:00:13 <zodbot> The meeting name has been set to 'workstation'
15:00:16 <stickster> #topic Roll call
15:00:19 <stickster> .hello pfrields
15:00:19 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
15:00:28 * mclasen__ present
15:00:32 <otaylor> Here!
15:00:51 <stickster> hi guys
15:00:58 <kalev-phone> hello!
15:01:19 * stickster holds door open a couple minutes still. mcatanzaro emailed me to say he can't be here today
15:01:41 <cschalle_> hello stickster !!!!!!!!!
15:01:47 <stickster> that was rather enthusiastic
15:02:10 <cschalle_> I been up since 4am drinking tons of caffeine, feeling very enthusiastic at this point :)
15:02:13 * linuxmodder|LISA passively watching
15:02:15 <stickster> yikes
15:02:20 <stickster> We have quorum, let's go
15:02:28 <stickster> #chair mclasen__ kalev-phone cschalle_ otaylor
15:02:28 <zodbot> Current chairs: cschalle_ kalev-phone mclasen__ otaylor stickster
15:02:37 <stickster> #topic Brief coverage of F23 release
15:02:59 <rdieter> halo
15:03:05 <stickster> hi rdieter!
15:03:07 <stickster> #chair rdieter
15:03:07 <zodbot> Current chairs: cschalle_ kalev-phone mclasen__ otaylor rdieter stickster
15:03:10 <stickster> #info Overall reaction to the release has been positive, nice work everyone.
15:03:37 <mclasen__> cschalle_ was holding up the linux action show review as a very positive example
15:04:08 <kalev-phone> we got gnome 3.18.1 in there ss a FE which fixed many papercuts and made it nicer
15:04:23 <cschalle_> yeah, one thing they pointed out though that I kinda agree with is that the ad banners we show in anaconda looks outdated and ugly
15:04:28 * stickster listened to LAS last night, it was very positive -- a lot of time spent on Server/Cockpit, but there was quite a bit of positive feedback on Workstation related features like Software
15:04:51 <stickster> #link http://www.jupiterbroadcasting.com/90206/fedora-from-the-cockpit-las-390/
15:04:55 <cschalle_> so maybe we should look at either refreshing them or dropping them for F24
15:05:06 <kalev-phone> someone had an idea to generate anaconda banners frpm appdata
15:05:27 <stickster> There was also a bit on sticking close to upstream, vs. how some other distros do things -- did you guys catch that?
15:05:27 <kalev-phone> should be not too hard
15:06:17 <cschalle_> stickster, no, please remind me what that was about
15:06:26 <stickster> cschalle_: On the other hand I saw some social media complimenting a couple of the banners' FOSSy messages
15:07:08 <cschalle_> stickster, yeah, I am not saying we need to drop banners, but the current ones do look like something that was added in 2001 and never updated or made to match the general look and feel of anaconda
15:07:14 <stickster> cschalle_: They were talking about *buntu dropping their software center because apparently it's too hard to maintain and they may be having a hard time making it support their version of containers
15:07:26 <cschalle_> stickster, ah yeah, remember that
15:07:52 <stickster> cschalle_: We should be able to fix that -- I like the idea of apps, but also in general I bet the design team could take up some redesign here to more closely match current look/feel
15:08:54 <stickster> #action stickster Consult design team about an F24 task to revamp anaconda banner designs
15:09:23 <stickster> Anything else F23-relevant before we move on?
15:09:48 <cschalle_> stickster, yeah, just that we need to handle things better in the future around X updates and NVidia driver
15:10:18 <cschalle_> stickster, at a minimum we should mention in the release notes that people will need to wait until next NVidia driver is out before updating if they require the binary driver
15:10:44 <cschalle_> but I will speak with the graphics team about if there are even better ways of handling this
15:10:45 <rdieter> release_notes++
15:11:24 <rdieter> fedora certainly won't/can't wait on nvidia
15:11:40 <rdieter> (historically at least)
15:11:42 <stickster> cschalle_: That's a good point -- we may need to figure out where to put a notice like that
15:12:03 <cschalle_> rdieter, yeah, I am not saying we should 'wait', but maybe shipping pre-release X.org is a bit going to far the other way :)
15:12:33 <stickster> #action cschalle_ consult with graphics guys for input on our best approach to document how long, if at all, NVidia users may need to delay F24 upgrade
15:13:13 <stickster> OK, we need to move on for time
15:13:14 <otaylor> Could *conceivably* be put into the new upgrade tool, thought that's a lot of special casing
15:13:26 <stickster> That seems fragile at best
15:14:17 * stickster puts this in the same league as e.g. Pro Tools users on Mac OS X. You don't blindly upgrade the OS without a sign your stuff will work. It would make sense for us to make some call on that and let users know
15:14:23 <otaylor> stickster: Honestly "it's in the release notes" is also fragile.. but anyways, I'm not seriously proposing it
15:14:27 <stickster> yeah
15:15:09 <stickster> Let's come back to this after Christian talks more to graphics folks, I can put on next agenda
15:15:22 <stickster> #action stickster return to graphics issue for next agenda
15:15:36 <mclasen__> we have a plan for calling out incompatible apps before the upgrade
15:15:36 <stickster> #topic Work relevant to installer
15:16:05 <mclasen__> we could possibly do the same for incompatible drivers ?
15:16:31 <stickster> So mcatanzaro had mentioned some relevant work like pre-installer language selection
15:17:53 <stickster> It wasn't clear who is talking to anaconda folks about that -- e.g. making sure data shows up in a way they can use in the installer, or avoid showing things to the user twice
15:18:31 <cschalle_> we should also revisit our settings for creating user passwords, it is a bit annoying that the password requirements change depending on where you create the user account (and in do think that anaconda might be a bit overly strict here being my personal irritation)
15:19:08 <kalev-phone> one idea here was to run gnome-initial-setup on live media beforw gdm
15:19:41 <kalev-phone> basically just allowing setting language and keyb layout
15:20:23 <kalev-phone> and then as a last step, offer logging in to the live session or launching installer
15:20:44 <kalev-phone> replacing the in session welcome window we have now
15:20:45 <stickster> does anyone know whether anaconda picks up TZ from the Live session when you run the install-to-disk helper?
15:21:55 <stickster> ok, I guess not :-)
15:22:06 <kalev-phone> maybe, but it also does iĆ¼ geolocation
15:22:13 <kalev-phone> ip
15:22:28 <cschalle_> kalev-phone, on the flip side there, another thing the LAS guys mentioned as an annoyance was having to boot into the live session to install, adding a GIS thing there would make that even more so
15:23:08 <mclasen__> we wanted to avoid double-asking for things like timezone by having anaconda record the fact that it was explicitly set up, somewhere
15:23:20 <mclasen__> but I don't think we got anything for that from the anaconda side
15:23:33 <kalev-phone> oh, but the gis thing could launch anaconda directly, without needing a live session
15:23:38 <stickster> cschalle_: But the thing is if it doesn't appear to be a Live session yet, i.e. seamless with installer, maybe you avoid it seeming like you're doing two separate things
15:23:43 <stickster> kalev-phone: right
15:24:43 <stickster> mclasen__: Yeah, that was one point in adding this to agenda -- to see who's discussing with anaconda team *how* data can be provided for them to pick up for an installation
15:24:56 <mclasen__> its the other way around
15:25:02 <stickster> mclasen__: Are we waiting for them to tell us spec for that?
15:25:08 <mclasen__> anaconda needs to provide it to us so g-i-s can skip the page
15:25:21 * satellit live does not setup wireless in anaconda...
15:25:21 <cschalle_> I can follow up with dcantrell on this
15:25:35 <mclasen__> I pinged him about it a few weeks ago
15:25:48 <stickster> mclasen__: In kalev-phone's idea, isn't it the other way around? Like, if we boot Live image and run some g-i-s type process, wouldn't we then feed that to Anaconda?
15:26:01 <stickster> it sounds like sort of a two way street to em
15:28:32 <mclasen__> if anaconda runs on a live system, it can just use whatever language, timezone, etc is active in that session ?
15:29:07 <stickster> yes -- are we certain that gets picked up, though, in the case that kalev-phone is suggesting, pre-gdm/pre-session?
15:29:11 <mclasen__> I don't really see what we need to 'provide' this way around
15:29:22 <stickster> I confess ignorance here, looking to be educated ;-)
15:29:34 <mclasen__> and I don't really want to spend tons of resources on engineering a live-cd-only configuration system
15:29:46 <mclasen__> I did look into adding language selection to that little welcome screen once
15:30:04 <mclasen__> but I couldn't quite figure out how to make a gjs app reload its translations, and gave up
15:30:18 <mclasen__> thats about the only preconfiguration that I think makes sense here
15:30:32 <stickster> that was what mcatanzaro was talking about too
15:30:36 <mclasen__> because we can't change it easily inside the running session
15:30:54 <stickster> I think
15:31:36 <stickster> OK, it doesn't seem clear that everyone wants to do a specific thing here, so might need a bit more discussion on-list rather than dragging this whole meeting down for it :-)
15:32:34 <stickster> plus would be good to have dcantrell in on discussion from anaconda side
15:32:39 <mclasen__> I'll see if mcatanzaro wants to give the language selection a try
15:33:33 <stickster> #action mclasen__ will talk to mcatanzaro about language selection idea, and once we're agreed on what to do there, consult with anaconda team
15:33:57 <stickster> #topic Desktop info on Developer Portal
15:33:59 * mclasen__ not convinced the anaconda team is involved in this part
15:34:02 <mclasen__> but ok
15:34:14 <stickster> yeah, perhaps not, if so that consult is pretty short
15:34:37 <stickster> "sure, whatever floats your boat"? :-)
15:35:04 <stickster> This topic went around the list for a bit and I don't think we resolved what info would be worth getting on the developer portal
15:36:28 <stickster> I agree the GNOME developer docs are an excellent resource and we don't want to whole-hog duplicate a bunch of that. But having a page that ties together a Fedora process for getting the tools, suggesting a workflow, and doing a graphical app in one or two langs would probably be useful.
15:37:25 <stickster> As a novice dev, I had a hard time pulling that out of the GNOME docs, and tbh, it's not really GNOME upstream responsibility to figure out how your distro tools fit together, or teach you e.g. pygobject
15:37:57 <otaylor> stickster: wait what, why isn't it GNOME's responsibility to teach you pygobject?
15:38:14 <stickster> It seems like all the docs reference the regular C libs
15:38:52 <otaylor> stickster: that's a long-standing problem (some baby steps have been taken, never really gotten anywhere) but it doesn't seem any more Fedora-specific to be teaching pygobject
15:39:19 <stickster> And I'm not suggesting the Developer Portal duplicate all that for Python... rather that a couple hints on doing a hello-world-ish GUI implementation in Python, C, etc. from tool installation onward could be helpful
15:40:35 * stickster seeking other ideas.
15:40:51 <stickster> The tough part is trying to make something like that age gracefully (or age-proof)
15:42:18 <stickster> It's possible we could do this as a short process that links to GNOME docs for specific steps... like a roadmap of learning
15:43:53 <otaylor> stickster: maybe "article" form is better - "Here's how I got started developing my GNOME app under Fedora on August 23, 2015" ?
15:43:54 <stickster> OK, perhaps people aren't interested in this topic en masse :-) ... I'll try to propose something concrete on list
15:44:26 <otaylor> stickster: Have a link to the developer.gnome.org and a couple of articles that are Fedora specific?
15:44:33 <mclasen__> I must say, clicking through the developer portal for a bit, I'm unsure about the eventual goal here
15:44:46 <mclasen__> so far, it seems like a website that lists sudo dnf commands to run ?
15:45:02 <otaylor> I think creating a maintenance task of trying to make a "better" developer.gnome.org is not going to see sustained work
15:45:20 <stickster> No, that doesn't seem workable (or well bounded)
15:45:37 <stickster> The article idea could work, though. This might be something good for the Magazine, come to think of it
15:45:53 <stickster> Some articles there have quite a long shelf life from what we've seen in stats
15:46:11 <mclasen__> one idea I floated to cschaller here in the room: maybe we could invite the developer portal developers (!)
15:46:31 <mclasen__> to discuss what their goals for the portal are, going forward, and how it could fit in the workstation
15:46:55 <stickster> Yeah, and see what they have in mind in this space
15:47:37 <stickster> #action stickster invite Developer Portal devs to list/meeting to ask about goals and roadmap, and how it fits with Workstation/native app devel
15:47:55 <stickster> Anything else on this before we move on?
15:48:35 <stickster> #topic Application pruning for F24
15:49:23 <stickster> OK, this was an add-on topic... specifically kalev and mcatanzaro asked about Empathy, DevAssistant, and Shotwell
15:50:21 <stickster> #info Empathy
15:50:32 <kalev-phone> empathy in particular has been on life support upstream for past few years
15:51:12 <stickster> *nod... and afaik the major thing that's kept it in, is there hasn't been any other roadmap for chat or how it integrates in gnome-shell
15:51:15 <cschalle_> yeah, Collabora are not investing in telepathy and friends anymore, and nobody else has so far stepped up
15:52:14 <cschalle_> now that the chat functionality is gone from GS, maybe there is no reason to keep it around?
15:52:42 <mclasen__> the chat functionality is not gone enough yet
15:52:47 <mclasen__> still entangled
15:53:46 <kalev-phone> can I make it removable in gnome-software at least? right now it cannot even be uninstalled
15:54:00 <stickster> mclasen__: So right now, that functionality includes things like being able to reply in a message notification, online status, other?
15:54:35 <mclasen__> not sure about online status, but reply, yes
15:55:05 * stickster wondering, is this an example where people are just moving to using web apps like Slack/FB/G+/Gchat/other
15:55:14 <rdieter> stickster: partly, yes
15:56:03 <otaylor> I don't know what chat protocol even works well with Empathy any more...
15:56:04 <mclasen__> its an example of interoperability getting lost in the webs walled gardens...
15:56:14 <stickster> otaylor: no idea, XMPP/Jabber?
15:56:54 <mclasen__> look in the goa panel, there's a long list of obscure protocols
15:56:55 <otaylor> stickster: so as long as you don't want to talk to anybody you know....
15:57:04 <cschalle_> it should still be a decent XMPP client, I guess if there are problems is if Google have moved gtalk so far away from it that it doesn't work anymore for speaking with gtalk users
15:57:11 <mclasen__> gadu-gadu, zephyr, yahoo japan,...
15:57:20 <stickster> kalev-phone: Is that just a change in "mandatory/optional" for the group?
15:57:30 <kalev-phone> right, exactly, google shutting down xmpp ad msn gone
15:58:09 <stickster> what about SIP?
15:58:36 <kalev-phone> stickster: no, gnome software has an harscoded list of "system" apps that cant be uninstalled from g-s
15:58:42 <cschalle_> stickster, it never did voice/video well. rishi and I tried to fix it about two years ago and it sorta worked for 1 release, and then when it broke again we gave up
15:59:01 <stickster> cschalle_: ah
15:59:29 <stickster> Well, we are running out of time, do people feel like we are ready to actually *do* anything here yet? Or do we need to move this to list?
16:00:02 <mclasen__> making empathy removable is something we can do
16:00:19 <kalev-phone> great :)
16:00:24 <mclasen__> I'll investigate untangling gnome-shell and telepathy upstream, and report back
16:00:47 <stickster> #action mclasen__ to look at untangling gnome-shell and telepathy upstream and report back
16:00:53 <stickster> OK. We can look at the others next time
16:01:09 <kalev-phone> maybe we should have a hard look on gnome-softwares unremovablr apps together
16:01:10 <stickster> In DevAssistant case we'd like dev portal guys' input
16:01:20 <stickster> Thanks for coming everyone, time to go!
16:01:25 <kalev-phone> and see if wr can drop some more
16:01:26 * mclasen__ just wanted to mention that Wayland is the default in rawhide now, before we run out
16:01:37 <stickster> #info Wayland is now default in Rawhide!
16:01:44 <mclasen__> please report your favorite pet bugs and issues
16:01:53 <stickster> Thanks mclasen__
16:01:55 <mclasen__> the feature page has a list of known bigger items
16:02:18 * stickster closes up shop to get out of the way
16:02:20 <stickster> #endmeeting