15:00:06 <stickster> #startmeeting Workstation WG
15:00:06 <zodbot> Meeting started Wed Sep 28 15:00:06 2016 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:06 <zodbot> The meeting name has been set to 'workstation_wg'
15:00:08 <stickster> #meetingname workstation
15:00:08 <zodbot> The meeting name has been set to 'workstation'
15:00:10 <stickster> #topic Roll call
15:00:11 <stickster> .hello pfrields
15:00:13 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
15:00:53 <mclasen> .hello mclasen
15:00:54 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
15:00:55 <rdieter> .hello rdieter
15:00:57 <zodbot> rdieter: rdieter 'Rex Dieter' <rdieter@math.unl.edu>
15:01:13 <kalev> .hello kalev
15:01:14 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
15:01:15 <otaylor> .hello otaylor
15:01:18 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
15:02:13 <stickster> #chair mclasen rdieter kalev otaylor mcatanzaro
15:02:13 <zodbot> Current chairs: kalev mcatanzaro mclasen otaylor rdieter stickster
15:02:59 <mcatanzaro> .hello catanzaro
15:02:59 <zodbot> mcatanzaro: catanzaro 'None' <mcatanzaro@gnome.org>
15:03:08 <stickster> I'm going to push jkurik's to the top of the agenda given the importance
15:03:18 <stickster> #toipc OStree image as deliverable
15:03:21 <stickster> argh
15:03:25 <stickster> #topic OStree image as deliverable
15:03:30 <stickster> #link https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/message/NWBSGXEIICDTRCBL6DZ3ZMJHUX3D6VKA/
15:04:49 <mclasen> we did the work, but not the paperwork ?
15:04:53 <stickster> So apparently this Change was never put before FESCo -- perhaps because no one moved the page to the appropriate "ready-for-wrangler" category
15:05:51 <mclasen> I probably failed there
15:06:01 <stickster> per https://fedoraproject.org/wiki/Changes/Policy
15:06:19 <stickster> So the thing is, what we're putting out for F25 is experimental and AFAIK we aren't trying to drive a lot of publicity around it yet
15:07:00 <stickster> If we want to have it included in talking points, release notes & announcement, etc., though -- we're going to need to go hat in hand to FESCo to see if that's OK
15:07:31 <kalev> I think the most important thing here is to get something integrated so we can iterate from there and make it better
15:07:34 <mclasen> I think we're fine with not beig in talking points
15:07:38 <kalev> not sure if publicity is important at this point
15:08:06 <kalev> so to me it sounds fine to not have it as an official change
15:08:18 <sgallagh> I'd suggest that publicity at this point should be on the devel@ list rather than the public lists.
15:08:18 <kalev> as long as releng doesn't then say that we can't have it at all :)
15:09:02 <stickster> that shouldn't be the case... if no change were allowed without a Change (so to speak) most of Fedora would just stand still
15:09:40 <stickster> sgallagh: see, that sounds about right to me anyway -- the audience for the experimental ostree workstation is definitely not the at-large public
15:09:43 <sgallagh> stickster: Right, most things are relatively minor updates and don't need a Change
15:10:12 <stickster> too many things are probably not working on it -- and mainly this enables us to have a central place to get and test the deliverable
15:10:35 <sgallagh> Changes are mainly there to indicate what things should be marketed or (in the case of System-Wide Changes) to ensure people get warning of Big Things Happening before it breaks tham
15:10:37 <sgallagh> *them
15:10:40 <stickster> yup
15:10:58 <mclasen> so, do we need to make any decision here ?
15:11:07 <stickster> #proposed Don't include ostree workstation in any publicity stuff, and submit Change for F26 with the expectation that during this cycle, iteration will make it more suitable for public consumption
15:11:21 <mclasen> +1
15:11:21 <kalev> +1
15:11:49 <mcatanzaro> +1
15:12:01 <rdieter> +1
15:12:13 <stickster> I'm +1 on my own proposal :-)
15:12:32 <stickster> otaylor?
15:12:55 <otaylor> sorry, got distracted, reading backlog, one second
15:13:22 <otaylor> sounds right to me - +1
15:13:28 <stickster> #agreed Don't include ostree workstation in any publicity stuff, and submit Change for F26 with the expectation that during this cycle, iteration will make it more suitable for public consumption (+1: 6, 0: 0, -1: 0)
15:14:27 <mclasen> I guess I'll repurpose that change page for f26 then
15:14:39 <stickster> #action mclasen consult with jkurik, edit Change page, and put into appropriate ready-for-wrangler and F26 categories
15:14:55 <stickster> #action stickster make sure ostree workstation doesn't appear in publicity materials
15:15:02 <stickster> Anything else on this one?
15:16:26 <stickster> #topic GNOME 3.22 pending issues
15:17:53 <stickster> OK, so I put this on the docket because there were some issues people were seeing with Shell and/or other components that were crashy in F25 pre-release
15:18:24 <mcatanzaro> So Gustavo Noronha just knocked out the most serious GTK+ and WebKit issues this week at the Web Engines Hackfest; they're too late for F25 beta but will filter in soon after
15:18:55 <stickster> mcatanzaro: These are affecting those evo and epiphany breakage bugs?
15:19:02 <mclasen> stickster: do we have a list of bugs ? I didn't see any shell bugs on the blocker list
15:19:05 <mcatanzaro> stickster: Yeah, that was one of them
15:19:13 <mclasen> and I believe some that adamw threw around have been fixed upstream
15:19:16 <stickster> https://bugzilla.redhat.com/show_bug.cgi?id=1378985
15:19:18 <kalev> could use some karma for https://bodhi.fedoraproject.org/updates/gtk3-3.22.0-2.fc25 to fix content placement in totem and gnome-maps
15:19:19 <stickster> https://bugzilla.redhat.com/show_bug.cgi?id=1378987
15:19:53 <mcatanzaro> That one is fixed stickster
15:19:56 <kalev> the issue mcatanzaro mentioned shouldn't affect beta because we have webkitgtk4 .92 package there; I took the .0 update out of the megaupdate to avoid these issues for beta
15:19:59 <mcatanzaro> https://bugzilla.redhat.com/show_bug.cgi?id=1379440 and https://bugzilla.redhat.com/show_bug.cgi?id=1366897 are my wishlist
15:20:09 <mcatanzaro> Actually all the GNOME blockers look likely to be solved
15:20:39 <mcatanzaro> Ah, that's right kalev, good call!
15:20:47 * stickster searches in vain for the shell issue(s) that prompted him to mention it in agenda email... I need to make sure to include those explicitly in the future
15:21:58 <stickster> I don't think either of those were the ones I was thinking of, but I'm sure none of the bugs I found were marked blockers
15:23:13 <mcatanzaro> Overall things are looking pretty good
15:23:19 <stickster> So the only thing I can really ask here is whether anyone's aware of serious issues in Beta that (1) are unlikely to be fixed by freeze exception in time for Beta; and (2) should go onto the Common Bugs page in the meantime
15:23:51 <stickster> The logout/login thing is certainly one, if that's not expected fixed for Beta
15:24:32 <mclasen> ray pushed a fix for that
15:24:39 <stickster> halfline++
15:24:39 <zodbot> stickster: Karma for rstrode changed to 2 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:24:43 <stickster> COOKIE PARTY!
15:25:01 <stickster> that's sad that ray has so few cookies, he deserves many more
15:25:05 <rdieter> halfline++
15:25:05 <zodbot> rdieter: Karma for rstrode changed to 3 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:25:48 <stickster> http://67.media.tumblr.com/tumblr_lhwsvuLJ6t1qzig84o1_400.gif
15:26:32 <stickster> #info Let's try to keep an eye on any serious issues that need noted in the Common Bugs page for Beta
15:26:57 <stickster> Anything else on this topic?
15:27:47 <stickster> #topic Talking points completion
15:27:49 <stickster> #link https://fedoraproject.org/wiki/Fedora_25_talking_points#Fedora_Workstation
15:28:20 <stickster> So I already removed ostree Workstation from this section... but I'm wondering if there's other stuff we could be noting ehrre
15:28:23 <stickster> *here
15:29:34 <mclasen> could throw in a link to the gnome 3.22 release notes if you want more material
15:29:42 <stickster> mclasen: That's a good call, +1
15:30:09 <stickster> mclasen: I'll grab the most relevant highlights out as well just to emphasize
15:32:27 <stickster> done
15:32:47 <stickster> mcatanzaro: kalev: rdieter: otaylor: anything else that we might have missed in the TPs?
15:33:55 <stickster> Well, this may be a short meeting then. That's not a crime. ;-)
15:33:59 * kalev can't think of anything to add at the moment.
15:34:24 <stickster> #topic All other business (open floor)
15:35:59 <stickster> shhhh... be vewwy quiet... we'we hunting wabbits
15:36:28 <stickster> well, I guess we can call this one early then :-)
15:36:30 <mcatanzaro> TPs look good to me
15:36:38 <stickster> thanks mcatanzaro, kalev
15:36:39 <mcatanzaro> Cheers
15:36:41 <kalev> wabbits!
15:37:08 <stickster> and thanks to everyone for coming :-)  I think you guys've earned a short meeting... F25 is looking pretty sweet, I've been running it daily
15:37:16 <stickster> See you next time!
15:37:19 <stickster> #endmeeting