14:00:43 <stickster> #startmeeting Workstation WG
14:00:43 <zodbot> Meeting started Mon Dec  5 14:00:43 2016 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:43 <zodbot> The meeting name has been set to 'workstation_wg'
14:00:49 <stickster> #meetingname workstation
14:00:49 <zodbot> The meeting name has been set to 'workstation'
14:00:52 <stickster> #topic Roll call
14:01:01 <kalev> hello
14:01:03 <stickster> .hello pfrields
14:01:04 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
14:01:28 <stickster> Hm, the meeting room is apparently topic locked, not that it matters for minutes
14:02:09 <stickster> jwboyer: if you get a chance, maybe you can fix that ^ ... chanserv says you're a founder
14:03:12 <mcatanzaro> .hello catanzaro
14:03:13 <zodbot> mcatanzaro: catanzaro 'None' <mcatanzaro@gnome.org>
14:03:25 <kalev> maybe it's easier if we just move to #fedora-meeting-1 instead of fighting with topic changes here?
14:03:26 * pravins listening
14:03:55 <stickster> kalev: don't worry, I'm not going to fight it, but let's not move again and cause more confusion
14:04:14 <stickster> if we can't fix I'll set up a different location for next time(s)
14:04:22 * kalev nods.
14:04:45 <stickster> #chair mcatanzaro kalev mclasen cschalle juhp rdieter_work
14:04:45 <zodbot> Current chairs: cschalle juhp kalev mcatanzaro mclasen rdieter_work stickster
14:05:14 <stickster> Anyone seen other folks?  I expect juhp to be here since we shifted time mainly to accommodate him ;-)
14:06:30 <mclasen> its snowing here, so owen might be in traffic...
14:06:52 <stickster> mclasen: yay, winter weather!
14:07:54 <stickster> we don't have quorum, but I think our first item was going to be on the Change for coredumpctl, right mcatanzaro ?
14:08:23 <stickster> we could go ahead with that and hope other folks show up afterward; if not, short meeting.
14:08:57 <stickster> #topic F26 Change for coredumpctl
14:09:15 <stickster> #info (TOPIC: F26 Change for coredumpctl)
14:09:31 <mcatanzaro> #link https://fedoraproject.org/wiki/Changes/coredumpctl
14:09:56 <mcatanzaro> So I have a change page prepared but not yet submitted
14:10:38 <mcatanzaro> I mailed one of the ABRT developers (Jakub Filak) to ask for feedback but got no response, maybe he's on vacation or just unhappy about the change. So I think we can proceed.
14:10:54 <mcatanzaro> The SELinux bug is still a blocker. Last meeting we decided to escalate that to FESCo.
14:11:30 <mcatanzaro> I forget whose action item that was. Mine was to write the change page. :)
14:11:47 <mcatanzaro> That's all I wanted to say about this!
14:12:07 <stickster> mclasen: do you know any of the other ABRT developers? I think we should at least get some sign they're aware of this change
14:12:19 <mclasen> I tihnk I saw jfilak recently left
14:12:25 <mclasen> left red hat, I mean
14:12:29 <mcatanzaro> Ow
14:12:51 <mcatanzaro> So he was the only ABRT developer who was really visible, bad timing. :(
14:12:52 <mclasen> so things might be a bit up in the air on the abrt side currently
14:13:03 <stickster> oof
14:13:20 <stickster> I see a mhabrnal on their commit log quite frequently
14:14:37 <stickster> #action stickster Find out if there are any folks full time on ABRT atm
14:15:26 <stickster> mcatanzaro: ISTR the idea was to try and get someone from ABRT + someone from selinux together with us to discuss the bug + change page
14:15:27 <rdieter> hola
14:15:31 <stickster> before we go the fesco route
14:16:01 <kalev> I agree, would be good to discuss with someone from the ABRT side before going behind their bcaks
14:16:39 <stickster> If no one will talk with us or we can't get an agreement going, then FESCo is an escalation step
14:17:28 * kalev nods.
14:17:29 <stickster> mcatanzaro: You might be able to reach the right people by raising visibility of the Change page on devel@
14:18:24 <mclasen> mcatanzaro: so, abrt will pick up coredumps from the journal ?
14:18:34 <stickster> It'll get announced there by jkurik, which happens (I think?) after the page is in the "ready for wrangler" status, which is done by adding a [[Category:...]] link
14:18:57 <juhp_> sorry I am late - forgot about the day change
14:19:21 <mclasen> yay, juhp_
14:20:16 <mcatanzaro> mclasen: Yes
14:20:34 <mclasen> then this seems uncontroversial to me
14:20:57 <mcatanzaro> stickster: I guess we might as well just go ahead and do that and see if anyone responds? I guess it will be controversial actually, to no longer have core dumps created in cwd.
14:21:03 <stickster> o/ rdieter juhp_
14:22:14 <stickster> mcatanzaro: Go ahead and change the category on the page -- that would be the next step AFAICT. It looks basically complete to me
14:22:32 <stickster> #action mcatanzaro move page to "ready for wrangler" status
14:22:56 <stickster> I'll still try to find us someone in ABRT to talk with us along with SELinux dev from the relevant bug
14:22:56 <mcatanzaro> stickster: Done, wheels are now in motion....
14:23:04 <mcatanzaro> stickster: Sounds good, thanks.
14:23:20 <stickster> Do we have cschalle here yet?
14:23:35 <cschalle> I have been here the whole time :(
14:23:58 <stickster> Awesome, in that case...
14:24:05 <stickster> #topic Branding proposal
14:24:12 <stickster> #info (TOPIC: Branding proposal)
14:25:03 <cschalle> ok, should I just kick off?
14:25:20 <stickster> cschalle: sure -- sorry, was navigating to the mail thread but I'm slow on this new keyboard still
14:25:49 <cschalle> So I wrote a first draft to the mailing list with a proposed wording for a mission statement around branding. Didn't get a lot of feedback so far.
14:27:02 <cschalle> I am sure the wording can be better, for instance based on hadess feedback I have been pondering if the word distinguishable would be better than the word distinct for instance, as I guess the word distinct might convey a bigger departure than what I think we envisioned
14:27:35 <stickster> "distinct" connotes "different"
14:28:07 <cschalle> but at this point I guess I would like to hear from the other working group members what they think about the general mission statement, as once we have something we agree on I think we should also get the council to sign off on it before starting to look at implementation
14:28:23 <kalev> I think it looks good, but not a native English speaker here
14:28:33 <rdieter> silly question, got any links for the draft, or can post what the proposed mission statement is?
14:28:36 <stickster> I guess this is a bit language-lawyerly, but then again, if we don't want to be bogged down in that part of the discussion, makes sense to say "distinguishable"... meaning "you can tell"
14:28:53 <stickster> rdieter: I'm trying to find the link in email web ui, bear with me :-)
14:29:13 <cschalle> rdieter, its on the workstation mailing list
14:29:23 <cschalle> title Branding Mission Statement
14:29:35 <stickster> #link https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/message/JDTS6HNMQA2VTTQ7C7BAF5ZQC25JL75V/
14:29:36 <cschalle> (assuming you are subscribed to the list ;)
14:30:35 <mclasen> obvious first question: distinct from what ?
14:30:46 <stickster> I'm good with s/distinct/distinguishable/ -- I think it still establishes the goal that e.g. mattdm wants
14:30:48 <mclasen> distinct from the fedora server ?
14:30:56 <mclasen> thats fine with me
14:30:56 <cschalle> stickster, yeah, I think in my mind both distinct and distinguishable both mean 'identifiable', but distinct maybe comes across as 'completely different' ?
14:31:13 <cschalle> mclasen, distinct from the rest of the world
14:31:33 <stickster> cschalle: maybe not "completely," but yeah, "different" is sort of understood when you say "distinct" because it's like saying "distinct from some other thing."
14:31:40 <mclasen> that, I'm not so sure about... we want to be the same as the rest of the world, in most respects
14:32:09 <cschalle> mclasen, to some degree yes, which is why we are having a discussion now about distinct vs distinguishable :)
14:32:22 <stickster> I think "distinguishable" is better, since it specifically means the viewer can tell what they're seeing (they can distinguish it), without presuming that it has to be *substantially* differnt
14:32:44 <stickster> But "distinguishable" doesn't automatically mean "identical" either, so let's not assume that ;-)
14:33:07 <sgallagh> I don't think the intent is for Workstation to be different from Server (that's kind of implied with Server having only Cockpit as its official GUI)
14:33:19 <juhp_> so is this more about theming or is there more planned to it than that?
14:33:28 <mcatanzaro> I don't know what to think of this proposal TBH. I agree that Fedora needs to be distinguishable; right now if you change the desktop wallpaper you've no way to tell the difference between it and Debian or any other GNOME distro.
14:33:34 <sgallagh> It pretty much means recognizable as Fedora
14:33:36 <mclasen> I agree with the mission to make the fedora workstation a coherent product ('more than sum of parts')
14:33:40 <mcatanzaro> But I hope we don't start making huge downstream UI changes.
14:33:41 <stickster> it's a fine line I guess... because as others pointed out, we don't necessarily want to change anything radical about the GNOME interface, which has been user tested to some degree I guess
14:33:45 <mclasen> I'm not sure branding has a significant role in that
14:34:09 <cschalle> juhp_, well that is the follow-up, to discuss how to implement the mission statement, doubt we go down the path of trying to do a separate theme though, most likely going to be something a lot more subtle
14:34:18 <stickster> cschalle: +1
14:34:22 <juhp_> okay
14:34:25 <stickster> also mcatanzaro +=
14:34:27 <stickster> +1
14:34:48 <juhp_> sounds reasonable to me
14:35:19 <stickster> I think one issue is that when we've had this discussion, invariably five people jump into the discussion with strawmen that don't necessarily work from a design perspective
14:35:29 <kalev> I don't think the plan here is to make huge downstream ui changes, maybe just put a fedora logo and name here and there. right cschalle?
14:35:50 <stickster> I would really like to see designers bring their expertise to bear here, and not presume what the result is off the bat
14:36:18 <sgallagh> kalev: I don't think that's necessarily what's going to happen either. I think cschalle's proposal rightly leaves the implementation to the designers.
14:36:27 <stickster> kalev: heh, that kind of example is what I was hoping to avoid as a rat-hole :-D
14:36:35 <mclasen> kalev: worst kind of branding
14:37:00 <cschalle> kalev, well I don't want to preclude the implementation discussion to much, but yeah my approach is that I eventually want to come up with something that is clear, yet unintrusive. And I do want us to review the current branding things we got as part of this, so it is not just about adding here, but about where and how
14:37:43 * kalev nods.
14:38:34 <stickster> cschalle: So do we have any designer(s) lined up to work on this within a reasonable time frame, i.e. before we get to Alpha freeze (end of Feb)?
14:38:35 <kalev> my hope is that whatever we do in Fedora would also work in RHEL, so that we could share code and bugs and everything
14:38:58 <mclasen> I think it is going to require some serious effort to get there, in particular if it has to be distinct
14:39:02 <stickster> kalev: That's not a bad point
14:39:12 <cschalle> stickster, I don't have anyone formally assigned at this point, but hopefully between you and mclasen you should be able to rustle up people
14:39:15 <stickster> mclasen: "distinguishable" ;-)
14:39:16 <mclasen> but I agree that listing our current 'branding' efforts is a good starting point
14:39:18 * mcatanzaro has to leave early today, bye
14:39:26 * mcatanzaro pleased that designers will be consulted
14:39:32 <stickster> mcatanzaro: thanks for being here!
14:40:12 <mclasen> I can volunteer to start a wiki page for that, do we have a canonical place for it ?
14:40:23 * mclasen hasn't been in the fedora wiki in some time...
14:40:57 <stickster> mclasen: I honestly don't know. If not, I guess one thing we should consider is how this fits in  with other edition branding, e.g. Cockpit/Server
14:41:01 <cschalle> anyway, my suggested path forward is that I will put the statement onto the wiki and also check with mattdm if the council wants to review it before we move forward. I will replace distinct with distinguishable
14:41:26 <cschalle> ah, ok, so mclasen beat me to the wiki page creation :) I am fine with that
14:41:41 <stickster> might not be as much about matching, more about being complementary... again, design question
14:42:08 <stickster> #action mclasen start wiki page about the larger branding effort
14:42:18 <juhp_> so is it Fedora Branding or Workstation Branding btw?
14:42:28 <sgallagh> juhp_: "Yes"
14:42:28 <stickster> #action mclasen stickster powwow about designers to rope into effort
14:42:29 <mclasen> I will do a page that lists what branding we currently have in place
14:42:37 <juhp_> sgallagh, lol
14:42:38 <cschalle> Fedora Workstation, sgallagh doesn't like it when we try to dictate him and the server team ;)
14:42:42 <mclasen> I'm somewhat on the fence about larger efforts
14:42:47 <sgallagh> cschalle: Not so, actually.
14:43:04 <sgallagh> /me clarifies
14:43:15 <stickster> sgallagh: juhp_: I think whatever happens in Workstation should at least be *complementary* to e.g. something like Cockpit in the Server edition
14:43:29 <sgallagh> I think that the direct need right now is for "Fedora Workstation" to be recognizable as compared to e.g. Debian GNOME
14:43:44 <juhp_> Desktop branding? :)
14:44:02 <sgallagh> As a long-term goal, I think Fedora as a whole should probably establish some additional branding guidelines that Workstation and Server/Cockpit would try to adhere to.
14:44:23 <juhp_> sounds reasonable yeah
14:44:53 <sgallagh> juhp_: I'm trying to indicate that this isn't a "Fedora" XOR "Workstation" topic, but a "Fedora Workstation" topic.
14:45:19 <kalev> does Cockpit have any kind of Fedora branding as prior art we could use?
14:45:20 <juhp_> ok - I am just trying to clarify the intent
14:45:58 <sgallagh> kalev: Cockpit has fairly simple (but effective) branding
14:46:09 <juhp_> sgallagh, by Workstation I meant Fedora Workstation...
14:46:34 <sgallagh> The login page for it has a logo available and all of the logged-in pages identify that the system is "Fedora Workstation", "Fedora Server", "Red Hat Enterprise Linux", etc.
14:46:34 <mclasen> sgallagh: but is it distinct ?
14:46:38 <andreasn> Cockpit is never called "Cockpit" in Fedora Server
14:46:43 <andreasn> it is "Fedora Server"
14:46:59 <stickster> nice!
14:47:20 <sgallagh> mclasen: I'm afraid of getting into a debate about the meaning of that word.
14:47:29 <mclasen> sorry, just kidding
14:47:30 <sgallagh> It's never ambiguous what OS it's running on
14:48:04 <sgallagh> (Also, if you run Cockpit on Fedora Workstation, it clearly identifies the system as being "Fedora Workstation Edition")
14:48:25 <andreasn> because that is what it is :)
14:49:17 <mclasen> thats nice
14:49:30 <sgallagh> Now, the approach that Cockpit has taken is unlikely to be a good fit for Workstation
14:49:36 <sgallagh> But it *is* recognizable
14:50:04 <stickster> So mclasen, it seems like the WG should participate on, or at least stay tuned to, your wiki page so we have an idea what the objectives for the designers are
14:50:20 <mclasen> https://fedoraproject.org/wiki/Workstation/Branding
14:50:35 <juhp_> great that is what I would have used too :)
14:50:36 <mclasen> more to come
14:50:38 * stickster takes a moment to note... he has to close this meeting at :55 (in 5 minutes) to chair another meeting elsewhere
14:51:39 <stickster> Sounds like no one's opposed to rolling forward with this... and I guess we can go to open floor for a few minutes?
14:51:49 <stickster> #topic All other business - open floor
14:52:00 <stickster> #info (TOPIC: All other business - open floor)
14:52:53 <mclasen> do we need to act on the flatpak runtime discussion ? I have to admit that I didn't fully follow the mailing list discussion on it
14:53:05 <stickster> Oof, I need to catch up on that thread myself mclasen
14:53:12 <mclasen> ok, next time them
14:53:15 <mclasen> then
14:53:22 <stickster> OH! Meeting schedule
14:54:12 <stickster> So... the next meeting is scheduled for Monday Dec 19... but I will be on PTO.  I'll hit list to find a chair.  The meeting after that is Monday Jan 2 which is an observed holiday for most of us
14:54:36 <stickster> I would like to not skip two meetings, thus the above.  Any opposed or can't make it to either one?
14:55:51 <stickster> OK then...
14:55:53 <stickster> #action stickster hit mailing list to explain meeting schedule going forward, establish a chair for Dec 19 meeting
14:55:57 <kalev> I can't make it to Jan 2 probably
14:56:32 <stickster> kalev: yeah, I doubt many folks will... I would think we should cancel that one, but the 19th we should do... esp. with the flatpak questions potentially in the air
14:56:41 * kalev concurs.
14:56:46 * stickster might be persuaded to get up in time for that meeting and chair it in his PJs, not sure yet
14:56:54 <juhp_> +1
14:57:10 <stickster> OK, closing up here then, I have to roll to my other meeting!
14:57:17 <stickster> Thank you for attending, everyone!
14:57:20 <stickster> #endmeeting