13:01:38 <kalev> #startmeeting Workstation WG
13:01:38 <zodbot> Meeting started Mon Sep 10 13:01:38 2018 UTC.
13:01:38 <zodbot> This meeting is logged and archived in a public location.
13:01:38 <zodbot> The chair is kalev. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:38 <zodbot> The meeting name has been set to 'workstation_wg'
13:01:51 <kalev> #meetingname  workstation
13:01:51 <zodbot> The meeting name has been set to 'workstation'
13:01:55 <kalev> #topic Roll call
13:02:00 <kalev> morning! who's around today?
13:02:03 <stickster> .hello pfrields
13:02:04 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
13:03:02 <juhp> .hello petersen
13:03:03 <zodbot> juhp: petersen 'Jens Petersen' <petersen@redhat.com>
13:03:16 <stickster> kalev: ryanlerch is out sick and sent regrets
13:03:22 <kalev> #chari stickster juhp otaylor ryanlerch
13:03:24 <kalev> ahh k
13:03:27 <kalev> #chair stickster juhp otaylor ryanlerch
13:03:27 <zodbot> Current chairs: juhp kalev otaylor ryanlerch stickster
13:03:39 <kalev> I think mclasen might still be travelling
13:04:00 <stickster> Ah, I see -- cschaller as well?
13:04:12 <kalev> not sure
13:04:20 <stickster> *nod
13:05:13 <otaylor> .hello otaylor
13:05:14 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
13:05:58 <stickster> Seems we're short one body for quorum, fwiw. But if there are things we can discuss or move forward, I'm fine to keep going here :-)
13:06:42 <kalev> #chair cschalle
13:06:42 <zodbot> Current chairs: cschalle juhp kalev otaylor ryanlerch stickster
13:06:48 <kalev> now we should have quorum!
13:07:06 <kalev> soooo, let's get started
13:07:20 <kalev> we have quite an agenda in https://pagure.io/fedora-workstation/issues?status=Open&tags=meeting
13:07:38 <kalev> I'd like to put an item to the top of the agenda and start with that
13:07:47 <kalev> #topic GNOME 3.30.0 megaupdate
13:08:11 <kalev> I've been out like half of the summer, but back since last week and have been wrangling the 3.30 updates
13:08:33 * stickster saw builds rolling in
13:08:56 <kalev> we were much behind there and as it stands right now, what's going to be in F29 beta is a mix of 3.28 and early 3.29 development snapshots + some final 3.30 packages
13:09:18 <juhp> oh
13:09:19 <kalev> there was a bit of discussion on the list about that, some of that spilled over to -devel and -test lists as well
13:09:52 <kalev> #info 3.30.0 megaupdate prepared and in updates-testing now
13:10:11 <kalev> https://bodhi.fedoraproject.org/updates/FEDORA-2018-85d637c544
13:10:35 <kalev> I'd like some help here, first with testing if anyone has time to give it a spin
13:10:52 <kalev> and second I'd like some opinions if we should try to push it to be included in F29 beta or not
13:11:56 <stickster> Man, it would be a shame to not get a better package set into F29 Beta... the mixture sounds like it'll be rather doomy
13:12:01 <otaylor> kalev: I think including it makes more sense than landing a big pile of updates after beta
13:12:34 <stickster> the upshot is anyone on the beta is going to get a big pile of those updates, yeah. so I'm not sure what good it does to delay that
13:12:41 <kalev> I'm leaning that way as well
13:13:23 <kalev> sgallagh and others had concerns that it might destibilize beta and delay it if something goes wrong
13:13:44 <kalev> mattdm seemed to like the idea of including it in beta
13:14:04 <stickster> it's a fair worry, but OTOH it seems like these packages should be in *better* shape than 3.29.x
13:14:23 * kalev nods.
13:14:48 <otaylor> kalev: Obviously it would be better if we could test out composes with the big pile of updates before landing them and seeing if anyhting breaks - but without that capability, I think going ahead makes more sense than the alternative
13:15:02 * kalev nods.
13:15:11 <kalev> okay, I'll try to push for it then
13:15:30 <kalev> if anyone has time to hang out at the blocker review meeting in the evening and argue for it, that would be wonderful :)
13:15:31 <juhp> Cool
13:15:53 <otaylor> kalev: Do you know the time of that?
13:16:00 * mattdm shows up :)
13:16:00 <kalev> proposal: #agreed Workstation WG would like to see the GNOME 3.30.0 megaupdate land in F29 beta
13:16:10 <kalev> can we vote for ^^ please? so I have some WG backing to show
13:16:16 <stickster> +1
13:16:18 <kalev> +1
13:16:26 <cschalle> +1
13:16:30 <sgallagh> kalev: My concern is that it's a huge number of rebases well-past when we froze. It's effectively a restart of the Freeze
13:16:33 <juhp> +1 assuming no significant regressions
13:16:39 <mattdm> It seems odd to have one of our Editions not have its fundametnal software close to the version intended to release
13:16:48 <otaylor> +1
13:16:53 <sgallagh> And it's a bigger jump (at least in version numbers) than we usually see at this stage, because some things are going straight from 3.28
13:17:00 <mattdm> Ideally, we'd be able to release a workstation beta separately from Server
13:17:06 <mattdm> but eh, here we ware
13:17:08 <mattdm> are
13:17:18 <stickster> I think it would be a good idea for WG members to participate in the testing of a candidate, if it's agreed that there'll be a compose with 3.30 included.
13:17:31 <mattdm> What I want, though, is to make sure that the primary effort is supported by the edition WG
13:17:31 <sgallagh> Also, we *have* already seen a regression in pygobject3, which is somewhat alarming
13:17:37 <stickster> Not assume that QA (or someone) will just do it
13:17:49 <mattdm> yeah. what stickster is saying :)
13:17:49 <kalev> sgallagh: that's already fixed before any builds reached testing
13:17:57 <juhp> stickster: right
13:18:05 <otaylor> sgallagh: it's clear that it's non-ideal, but I don't think anyone would propose that we don't go to 3.30 during the F29 cycle and stick with 3.28 ... so it's a question of how best to manage that
13:18:20 <sgallagh> kalev: Sure, and I appreciate the rapid response, but it *does* indicate that such things can and may happen
13:18:43 <mattdm> I support sgallagh's concern particularly because sgallagh tends to do hours of extra work including late nights and weekends making sure releases go out
13:18:45 <sgallagh> otaylor: I guess I don't understand why 3.29.92 isn't the right choice
13:19:01 <kalev> sgallagh: of course, but that is the exact reason why I want it in beta -- to get as much testing as possible, so that final can be less painful
13:19:19 <stickster> mattdm: indeed.
13:19:22 <otaylor> sgallagh: For beta or GA? But also, it's sound like we don't have 3.29.92 - we have "mixed set of development snapshots"
13:19:24 <kalev> sgallagh: and I'm confident we have the resources to hunt down regressions in a reasonable time if anything comes up
13:19:56 <sgallagh> otaylor: Could we meet in the middle with the expectation that GNOME will target 3.31.92 for Beta next time around and not do this same late-delivery dance?
13:20:19 <otaylor> kalev: no getting married again in the next 6 months! ;-)
13:20:23 <kalev> ok! :)
13:20:31 <stickster> sgallagh: Do we have release schedules for F30 and GNOME 3.32 already?
13:20:42 <sgallagh> Or at least have Workstation contact FESCo and request an exemption in advance, rather than force the issue mid-Freeze?
13:20:50 <sgallagh> stickster: I think so, yes
13:21:03 <stickster> sgallagh: ^ yes, that *for sure* (advance notice/comms)
13:21:07 <otaylor> sgallagh: I think that's a reasonable expectation to have - and clearly we should have manage to shift the work around and get it done anyways
13:21:10 <sgallagh> (Oh, congratulations on your wedding, kalev!)
13:21:16 <kalev> I think it's difficult to not have a schedule clash, given that GNOME releases every 4 weeks (and 2 weeks during RC time) and Fedora freezes are 3 weeks
13:21:18 <cschalle> sgallagh, yeah, sorry about that I think kalev being gone and general summer vacations cause a bit of a breakdown this time
13:21:22 <stickster> kalev: I didn't even realize that was why you were gone! Congratulations
13:21:23 <kalev> sgallagh: thanks! :)
13:21:31 <mattdm> sgallagh: f30 release schedule yes
13:21:31 <kalev> stickster: thanks!
13:21:52 <mattdm> #link https://fedoraproject.org/wiki/Releases/30/Schedule
13:21:53 <kalev> here's GNOME 3.32 schedule: https://wiki.gnome.org/ThreePointThirtyone
13:21:59 <mattdm> #link https://wiki.gnome.org/ThreePointThirtyone
13:22:04 <mattdm> thanks kalev
13:22:10 <kalev> #chair mattdm
13:22:10 <zodbot> Current chairs: cschalle juhp kalev mattdm otaylor ryanlerch stickster
13:22:10 <sgallagh> OK, I think I'm on-board with this exception this time, if only because of the non-3.29 bits in the mix.
13:22:23 <mattdm> #link https://fedoraproject.org/wiki/Releases/30/Schedule
13:22:26 <mattdm> #link https://wiki.gnome.org/ThreePointThirtyone
13:22:51 <sgallagh> But like I said, it would be really beneficial to the Project as a whole if we had advance coordination about disconnects like this.
13:23:14 <sgallagh> FESCo might have decided (for example) to skip entering Freeze and just assert that we were moving to the Rain Date for Beta
13:23:15 <kalev> yes, indeed
13:23:34 <sgallagh> Given everyone else a little extra unfrozen time too
13:23:46 <kalev> anyway! looks like we have an agreement here and +5 votes as well
13:23:50 <sgallagh> Or not, but the option would have been therre
13:24:00 <sgallagh> OK, I've said my piece. Thanks for listening :)
13:24:01 <kalev> #agreed Workstation WG would like to see the GNOME 3.30.0 megaupdate land in F29 beta (+1:5, 0:0, -1:0)
13:24:07 <stickster> Ha, yup -- 3.32 on 2019-03-11 and F30 beta freeze 2019-03-06 :-D
13:24:11 <kalev> thanks sgallagh and mattdm!
13:24:27 <mattdm> Experience has shown that moving the Fedora schedule back past these dates leads to other problems
13:24:49 <stickster> sgallagh: also, I think it would be fair for you to put WG on the hook to assist with extra work here
13:25:09 <mattdm> stickster: GNOME 3.31.92 rc release  is set for same day as F30 freeze
13:25:37 <sgallagh> mattdm: Let's move that discussion to a theoretical FESCo ticekt
13:25:41 <mattdm> What I'd like to see is a F30 change for GNOME 3.32 with a freeze exception scheduled in
13:26:04 <stickster> seems sensible to me
13:26:07 <mattdm> okay, but I want that fesco ticket to be started by a Change submission :)
13:26:22 <sgallagh> ack
13:26:36 <kalev> ack, I can do the 3.32 Change
13:26:51 <kalev> #action Kalev to ask for a 3.30.0 megaupdate freeze exception
13:27:06 <kalev> #action Kalev to file a 3.32 Change for Fedora 30
13:27:19 <kalev> otaylor: you asked earlier when is the blocker review meeting, I think it's at 16:00 UTC in #fedora-blocker-review, but I couldn't find an official mail
13:27:42 <sgallagh> otaylor: noon EDT
13:27:48 <otaylor> sgallagh: Thanks
13:28:03 <kalev> ok, let's move on
13:28:27 <kalev> #topic Review F29 deliverables
13:28:30 <kalev> https://pagure.io/fedora-workstation/issue/72
13:29:22 <kalev> I think we can just +1 it and move on, don't think anything has changed wrt deliverables
13:29:55 <otaylor> +1
13:30:28 <juhp> +1
13:30:33 <kalev> proposal: #agreed Workstation WG acknowledges the deliverables. No requirements have changed compared to F28.
13:30:36 <kalev> +1
13:31:29 <kalev> there was some talk in another ticket about dropping the install tree, which I think would get rid of the netinstall, but that's for F30 I think
13:32:17 <cschalle> +1
13:32:41 <stickster> +1
13:33:09 <stickster> kalev: I just realized I hadn't seen dusty's comment on filing an RFE on that install tree issue -- done now, https://github.com/rhinstaller/anaconda/issues/1600
13:33:17 <kalev> thanks stickster
13:33:22 <kalev> #agreed Workstation WG acknowledges the deliverables. No requirements have changed compared to F28.
13:33:40 <kalev> (+1 from me too)
13:33:49 <kalev> #topic Should we include NetworkMaanger-ppp by default?
13:33:52 <kalev> https://pagure.io/fedora-workstation/issue/70
13:34:16 <otaylor> I
13:34:18 <kalev> I have no clue here if it's something that we should do or not
13:34:25 <otaylor> I'd want to see feedback from the NM maintainers
13:35:02 <kalev> makes sense
13:35:04 <kalev> #info kalev to add NM maintainers to ticket, revisit in two weeks
13:35:09 <stickster> I don't see any big requires list for this. Pulls in ppp of course, and that doesn't seem to have any big stacks behind it.
13:35:57 <stickster> +1 kalev
13:35:57 * kalev nods.
13:36:04 <kalev> #topic Decide whether to include gnome-shell-chrome
13:36:04 <cschalle> +1
13:36:07 <kalev> https://pagure.io/fedora-workstation/issue/66
13:37:03 <kalev> so this is what's replacing the npapi (firefox) plugin that the gnome shell extensions web site was using for installing extensions
13:37:17 <stickster> If it's needed for Firefox and Chrome, this seems like a no-brainer to me
13:37:17 <otaylor> Making extensions.gnome.org work out of the box without a need to layer something on silverblue sounds right to me
13:37:26 <otaylor> do we need to remove the old npapi plugin?
13:37:56 <kalev> hm, not sure. right now it's still installed by gnome-shell
13:38:00 <kalev> /usr/lib64/mozilla/plugins/libgnome-shell-browser-plugin.so
13:38:03 <juhp> (I think ppp for mobile modem doggles)
13:38:42 <juhp> I think we should add it too
13:38:48 <otaylor> kalev: well, probably we don't *need* to remove it - we could just wait for upstream to elimintate it
13:38:53 * kalev nods.
13:39:15 <kalev> yeah, I think we would have heard complaints if we _had_ to remove it to make gnome-shell-chrome work
13:39:39 <stickster> *nod
13:39:51 <kalev> +1 from me for including it
13:39:58 <stickster> +1 here, obviously
13:40:01 <juhp> +1
13:40:02 <otaylor> +1
13:41:20 <kalev> cschalle: ?
13:42:05 <cschalle> +1
13:42:08 <kalev> #agreed Workstation WG agrees to include gnome-shell-chrome (+1:5, 0:0, -1:0)
13:42:40 <kalev> ok, I think that's all from the meeting list. we have a few more tickets tagged with the meeting tags, but looks like some of them got discussed last week when I was gone
13:43:12 <kalev> and the dropping of evolution ticket I'd rather not discuss without mclasen, and I forgot to invite aday and Milan
13:43:32 <kalev> so, that's all from me
13:43:35 <kalev> #topic Open Floor
13:43:55 <otaylor> I'd like to promote my Flatpak creation call-for-participation
13:44:10 <otaylor> https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/GMJWTQBZW37A64IJMTQOUT7VQYW7UQKO/#ZD7JW7C7QGKS5R7G3LGI4EV2VG3CMM5D
13:44:32 <kalev> #info otaylor has flatpak building working in koji
13:44:47 <kalev> awesome work, Owen!
13:45:17 <cschalle> as a sidenote here, we need to come up with a plan for Fedora Flatpaks ie. repository inclusion etc, but lets do that next time
13:45:18 <otaylor> In summary, while there are some loose ends to tie up, we're ready for people to dive in and start creating Flatpaks from Fedora RPMs (and would appreciate people doing that to find holes in the tools and documentation)
13:45:42 <mattdm> otaylor++
13:45:42 <zodbot> mattdm: Karma for otaylor changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:46:12 <otaylor> There is also a page of 300+ applications that should be easy to create Flatpaks of - https://fedoraproject.org/wiki/Flatpak:Easy
13:46:31 <stickster> otaylor++++
13:46:37 <stickster> otaylor++
13:46:40 <zodbot> stickster: Karma for otaylor changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:46:45 <stickster> zoddie you scamp
13:46:48 <stickster> cookie party!
13:46:54 <kalev> otaylor++
13:46:55 <zodbot> kalev: Karma for otaylor changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:47:41 * otaylor wants Flatpaks more than cookies!
13:48:15 <stickster> otaylor: Sorry if I'm missing something obvious -- what does the colored number represent in that page?
13:48:39 <stickster> is that like "relative difficulty"?
13:48:50 <otaylor> stickster: the colored number represents the the number of dependencies that are needed to be rebuilt
13:48:53 <stickster> Oh never mind -- I get it, it's deps
13:48:55 <stickster> *jinx
13:49:22 <otaylor> stickster: it's one measure of difficulty (or at least, time you have to sit waiting for builds)
13:49:25 <stickster> :-)
13:50:04 <kalev> #info next meeting is on Monday Sep 24, chair is ryanlerch
13:50:16 <kalev> thanks for coming everybody!
13:50:20 <kalev> #endmeeting