13:02:01 <juhp> #startmeeting Workstation WG Meeting
13:02:01 <zodbot> Meeting started Mon Oct  8 13:02:01 2018 UTC.
13:02:01 <zodbot> This meeting is logged and archived in a public location.
13:02:01 <zodbot> The chair is juhp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:02:01 <zodbot> The meeting name has been set to 'workstation_wg_meeting'
13:02:33 * juhp was looking at a ticket...
13:02:35 <juhp> #meetingname workstation
13:02:35 <zodbot> The meeting name has been set to 'workstation'
13:03:04 <juhp> #topic roll call
13:03:17 <otaylor> .here otaylor
13:03:38 <aday> o/
13:04:50 <mclasen> .hello mclasen
13:04:51 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
13:05:02 <juhp> #chair otaylor mclasen
13:05:02 <zodbot> Current chairs: juhp mclasen otaylor
13:05:23 <juhp> Is the member list on https://fedoraproject.org/wiki/Workstation up to date?
13:06:10 <mclasen> looks up-to-date to me
13:06:17 * mclasen goes to ping some people
13:06:20 <kalev> hello
13:06:29 <mclasen> hey, kalev
13:06:40 <juhp> #chair kalev
13:06:40 <zodbot> Current chairs: juhp kalev mclasen otaylor
13:07:08 <juhp> mclasen: thanks
13:07:50 <juhp> We have 7 tickets tagged meeting https://pagure.io/fedora-workstation/issues?status=Open&tags=meeting
13:08:52 <mclasen> don't see anybody else around
13:09:18 <juhp> I see - so we don't have quorum
13:09:40 <juhp> stickster: around?
13:10:35 <juhp> well should look at some tickets anyway..?
13:10:45 <mclasen> I'm in favor of it
13:11:16 <juhp> It is a shame mcantazaro not here
13:11:29 <juhp> #topic Fix placement of Welcome to Fedora application in live boot
13:11:38 <juhp> https://pagure.io/fedora-workstation/issue/79
13:11:48 <juhp> I didn't actually understand this one...
13:12:12 <kalev> I recall hearing that Ubuntu is shipping a gnome-shell patch to make all new application windows centered
13:12:46 <juhp> aha
13:12:53 <aday> juhp, it's the window position of the "do you want to try or install fedora?" thing
13:13:19 <juhp> Maybe my vm screen is too small ;) :-)
13:13:29 <juhp> okay
13:13:36 <mclasen> maybe unrelated, but I noticed in a vm recently that gnome-initial-setup is not maximized on my small vm screen
13:14:14 <otaylor> hmm, not sure how to fix that other than shell patch or extension, or figuring out what the generic explanation is for why that window should be centered
13:14:16 <kalev> https://gitlab.gnome.org/GNOME/mutter/issues/246 is asking for this upstream
13:14:31 <juhp> But trying now the welcome dialog is centered for me
13:14:55 <aday> i'd be interested to know how off center the window is
13:15:13 <juhp> nod
13:15:19 <mclasen> seems like a ticket that would benefit from a screenshot
13:15:23 <juhp> A screenshot would be nice or a bug report
13:15:26 <juhp> nod
13:15:37 <juhp> We can request one at least
13:16:43 <mclasen> good idea
13:16:45 <juhp> kalev: do you think we should apply such a patch to fedora?
13:16:50 <juhp> done
13:18:05 <kalev> juhp: no, I don't think so, we should just get it changed upstream if it makes sense to change it
13:18:21 <otaylor> I don't think we should globally change the window positioning behavior to fix this one issue, or jump to change the window positioning behavior globally without properly going through design
13:18:30 <juhp> Fedora they start at 100x100??
13:18:41 <juhp> okay
13:18:52 <aday> yes, it seems like i should take a look
13:19:04 <otaylor> juhp: windows cascade from the upper left - try right-click "New Window" a bunch of times for gnome-terminal
13:19:09 <aday> i've been meaning to look at window positioning for some time, but it's a big task
13:19:19 <juhp> otaylor: ah right
13:19:26 <juhp> indeed
13:19:45 <juhp> okay, anything more on this before we move on?
13:20:29 <aday> otaylor, if you know any of the history behind the current behaviour, that'd be useful to have
13:21:53 <mclasen> move on...
13:21:54 <juhp> #topic What's new in F29 Workstation article for Fedora Magazine <https://pagure.io/fedora-workstation/issue/78>
13:23:18 <juhp> Not sure which ticket bcotton really meant
13:23:26 <otaylor> aday: I added a quick comment to the issue, I think that captures the essence, I can try to remember more or do metacity archeology if that would be useful.
13:23:46 <otaylor> juhp: That one
13:24:10 <otaylor> juhp: https://pagure.io/fedora-workstation/issue/22 - "A couple things that need improvement:
13:24:14 <otaylor> No one put together a "What's New in F26 Workstation" article for the Magazine"
13:25:42 <juhp> I see
13:26:06 <aday> thanks otaylor
13:26:17 <juhp> Any takers?
13:26:53 * mclasen won't commit to writing an article before end of october - going to be travelling
13:26:59 <juhp> https://fedoramagazine.org/whats-new-fedora-28-workstation/
13:27:09 <juhp> https://fedoramagazine.org/whats-new-fedora-27-workstation/
13:27:20 <juhp> https://fedoramagazine.org/whats-new-fedora-26-workstation/
13:28:57 <mclasen> I would volunteer cschaller, given that he's not here
13:29:07 <mclasen> but he's travelling next week as well
13:29:12 <juhp> hehe :)
13:29:25 <juhp> Well we can take it to the mailing-list I suppose
13:30:26 <juhp> Okay let's move on
13:31:22 <mclasen> yeah
13:31:24 <juhp> #topic Workstation minimum system requirements on getfedora.org <https://pagure.io/fedora-workstation/issue/76>
13:31:36 <mclasen> I can commit to collecting some bullet points it the ticket
13:32:12 <juhp> So we discussed this last week and basically agreed to updating but not sure if we need to action the change?
13:32:41 <juhp> Though no record left in the ticket, but I did leave a couple of comments
13:32:50 <juhp> mclasen: that would be very helpful surely
13:32:53 <juhp> thanks
13:33:57 <juhp> One of my comments was that it would actually be good to review the page it seems to me - probably hasn't been refreshed in a while
13:34:09 <mclasen> Your suggestion in the ticket sounds good to me
13:34:19 <juhp> the whole page https://getfedora.org/en/workstation/download/
13:34:19 <otaylor> juhp: I like your proposed wording.
13:34:23 <juhp> mclasen: ok
13:34:26 <juhp> thanks
13:35:01 <otaylor> But what's that next sentence?
13:35:10 <otaylor> To do this, run the live version of Fedora Workstation from your USB flash drive on the computer you'd like to install to, run the Fedora Media Writer application, and follow the on-screen prompts to complete installation.
13:35:17 <otaylor> Does that make sense to anyone else?
13:35:29 <juhp> Nope
13:35:34 <mclasen> its not the media writer
13:35:38 <mclasen> its the installer
13:35:44 <juhp> That is what I mean - I think the whole page needs some love
13:36:20 <juhp> Or at least more than just those numbers
13:37:05 <otaylor> The whole thing is screwy
13:37:19 <otaylor> "To run Fedora Workstation, you will need:
13:37:23 <otaylor> Fedora Media Writer (download above)" - but the download offered above is the iso when you are running on linux
13:37:38 <juhp> We could expand the ticket to cover revising the whole text
13:37:47 <juhp> or have a new ticket if that is clearer
13:38:14 <juhp> otaylor: hmm yeah
13:38:19 <otaylor> The rest seems more like bug reports on the page - do we know where this page is maintained and by who?
13:38:20 <aday> or redesign the entire process
13:38:23 * aday hides
13:38:24 <mclasen> we'll need a websited ticket anywy
13:38:32 <juhp> I guess most people just click on download ;o)
13:38:42 <aday> (i'm serious though)
13:38:44 <otaylor> I probably have never read past the download link on that page
13:38:51 <juhp> aday: that would be welcome too
13:39:09 <juhp> otaylor: yeah lol ;-)
13:39:22 <otaylor> aday: it would be worth seeing what the experience is like from different platforms, seeing if it needs a redesign, but I don't think that should block fixing obvious bugs in the website text
13:39:31 <juhp> indeed
13:40:07 <juhp> https://getfedora.org/en/server/ seems nice and simple
13:40:48 <otaylor> juhp: https://getfedora.org/en/server/download/ is the equivalent page
13:40:53 <juhp> nvm that was the page above
13:40:55 <juhp> yeah
13:41:17 <aday> otaylor, sure sure
13:41:33 <otaylor> It feels like the workstation page was updated when we started having fedora-media-writer avialable for all platforms, but maybe a bit sloppily
13:42:31 <mclasen> we do have the media writer on flathub
13:42:41 <mclasen> so one could use it on linux as well
13:43:05 <otaylor> So, someone should take an action to file a issue or issues on https://pagure.io/fedora-websites/ to make the page make sense. I guess I can do that.
13:43:53 <juhp> otaylor: great thanks!
13:44:46 <juhp> #action otaylor will file a issue on https://pagure.io/fedora-websites/ to make the page make sense
13:44:51 <juhp> thanks, a lot
13:46:03 <juhp> #topic Repository for new docs site sources https://pagure.io/fedora-workstation/issue/69
13:48:13 <juhp> hmm
13:48:35 <juhp> Anyone have anything to add here to the discussion?
13:48:38 <otaylor> I'm slightly in favor of a separate docs repository rather than making pagure.io/fedora-workstation have the docs, what do other people think?
13:49:11 <otaylor> A lot of docs are under https://pagure.io/projects/fedora-docs/*
13:49:22 * mclasen wonders if this will duplicate or supersede existing content on the wiki
13:49:36 <otaylor> there's fedora-docs/silverblue and fedora-docs/flatpak there
13:50:02 <juhp> https://docs.fedoraproject.org/en-US/fesco/Third_Party_Repository_Policy/
13:50:12 <juhp> aha
13:50:35 <juhp> otaylor: yeah seems to make sense
13:50:35 <otaylor> mclasen: I believe supersede - the idea is to move to having a pull-request based workflow for documentation, instead of free-for-all-wiki
13:50:50 <sgallagh> Oh, related: https://src.fedoraproject.org/rpms/fedora-release/pull-request/32
13:51:14 <sgallagh> If there's a new WS-specific docs site, please let me know so I can update it for this new os-release tag.
13:51:14 <mclasen> so somebody on the docs team gets to decided on workstation poilicies ?!
13:51:14 <juhp> aha
13:51:42 <juhp> Well we could file PRs I guess, hm
13:51:45 <otaylor> mclasen: repository ownership is different from organization
13:51:47 * mclasen feels that this is process for process' sake, to some extent
13:52:00 <mclasen> but thats how we roll, I guess
13:52:16 <otaylor> mclasen: 'fedora-docs/workstation' can be owned by the workstation group
13:52:26 <juhp> ah right
13:53:53 <mclasen> sgallagh: i don't think a policy documents website is going to be a great fit for that
13:54:04 <otaylor> The idea of the new docs.fedoraproject.org is that docs can be pulled from anywhere and don't need to be in fedora-docs repositories, so if people prefer, we can definitely make it fedora-workstation/docs or just put them in fedora-workstation/
13:54:20 <sgallagh> mclasen: Sorry, I missed that it was developer-focused docs rather than user-focused.
13:54:22 <sgallagh> Carry on
13:54:30 <mclasen> but then, nothing is... I think you should just drop the idea of a docs link in os-release, tbh
13:55:47 <juhp> Does this affect F29 or it is just general thing?
13:56:16 <juhp> Maybe we can discuss more next time or in email
13:56:37 <juhp> I will update the ticket with a comment anyway
13:57:46 <juhp> We are running short of time
13:58:01 <otaylor> I think we maybe should discuss next time, figure out what the larger context of what docs we want for Fedora Workstation
13:58:24 <juhp> remaining topics included: Evolution, zram, default partitioning
13:58:35 <juhp> otaylor: sure sounds good
13:58:55 <juhp> #topic Open Floor
13:59:14 <juhp> anyone have anything else to discuss quickly or mention before we close?
13:59:27 <mclasen> I guess today is the day before hard freeze for f29 ?
13:59:37 <juhp> Ah yes I think so
13:59:40 <mclasen> if we need to get anything in last minute...today is the dy
13:59:43 <mclasen> day
14:00:00 <juhp> Final Freeze is tomorrow
14:00:04 <juhp> yes
14:00:26 <juhp> Okay I think we are out of time...
14:00:26 * mclasen will look for a gnome-software release with more flatpak fixes
14:00:32 <juhp> aha
14:00:52 <juhp> Thanks everyone for the meeting
14:01:00 <juhp> #endmeeting