13:09:27 <mclasen> #startmeeting Workstation WG
13:09:27 <zodbot> Meeting started Mon Apr  8 13:09:27 2019 UTC.
13:09:27 <zodbot> This meeting is logged and archived in a public location.
13:09:27 <zodbot> The chair is mclasen. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:09:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:09:27 <zodbot> The meeting name has been set to 'workstation_wg'
13:09:29 <cschalle> yeah, sorry, I am juggling 3 things atm
13:09:36 <mclasen> #meetingname workstation
13:09:36 <zodbot> The meeting name has been set to 'workstation'
13:09:50 <mclasen> #topic Roll call
13:09:55 <mclasen> .hello mclasen
13:09:56 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
13:10:02 <juhp> .hello petersen
13:10:03 <zodbot> juhp: petersen 'Jens Petersen' <petersen@redhat.com>
13:10:32 <otaylor> .hello otaylor
13:10:33 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
13:10:34 <otaylor> (sorry to be late!)
13:10:36 <kalev> .hello kalev
13:10:37 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
13:11:24 <mclasen> thats 4
13:11:26 <mclasen> one more ?
13:12:19 <cschalle> .hello cschalle
13:12:20 <zodbot> cschalle: Sorry, but you don't exist
13:14:10 <mcatanzaro> .hello catanzaro
13:14:11 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanzaro@gnome.org>
13:14:30 <ryanlerch> .hello ryanlerch
13:14:31 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
13:15:22 <mclasen> do we have items for the agenda ?
13:15:40 <juhp> I added one
13:15:49 <juhp> that came up in irc apparently
13:15:52 <otaylor> mclasen: Can you do a report on the Silverblue test day?
13:16:13 <mclasen> I can point to the results page, thats about it
13:16:18 <mclasen> but yes
13:16:35 <mclasen> juhp: where did you add it ?
13:16:49 <juhp> To the meeting tag
13:17:21 <juhp> https://pagure.io/fedora-workstation/issue/54
13:18:15 <juhp> #fedora-workstation:<cmurf> Any chance of https://pagure.io/fedora-workstation/issue/54 being tagged for tomorrow's meeting? The most immediately relevant point of that is the last comment, about just giving root a +10G bump for Fedora 30.
13:18:49 <mclasen> ok, lets start with that
13:19:01 <mclasen> #topic "Default disk partitioning layout for workstation"
13:19:19 <juhp> Is it still possible for f30?
13:19:47 <kalev> should be possible to change this week. next week starts the final freeze
13:19:50 <mclasen> juhp: I think that depends entirely on who you ask
13:20:08 <juhp> okay
13:20:36 <otaylor> I'm pretty sure we can get 50G => 60G for F30, going to no-home-by-default harder
13:21:23 <kalev> I have no clue where the defaults are set though. Somewhere in Anaconda, I guess?
13:21:53 <juhp> anaconda team should know :)
13:22:30 <kalev> looks like it's, pyanaconda/storage/partitioning.py in anaconda
13:23:11 <juhp> Should we open an rfe in bz then?
13:23:11 <mclasen> do the numbers make sense ?
13:23:20 <kalev> https://github.com/rhinstaller/anaconda/blob/f30-devel/pyanaconda/storage/partitioning.py#L48
13:23:20 <juhp> or a PR?
13:23:38 <mclasen> if 50G was arbitrary, why go to 60, and not 100 ?
13:23:49 * mcatanzaro not convinced +10 GB is useful
13:24:33 <mcatanzaro> If we stick with separate / then we simply need more than that
13:24:56 <mcatanzaro> We seemed pretty determined to get rid of separate / last time we discussed this (of course can't do that a week before final freeze)
13:25:41 <juhp> Yeah we really should
13:25:46 <juhp> for f31?
13:26:15 <otaylor> mcatanzaro: what do you think the minimal increase is that is useful?
13:26:37 <kalev> mclasen: I think the 50 GB limit is there so that / wouldn't end up taking up all of the space, and instead leave more space to /home
13:26:51 <juhp> Specially with small discs (cough ssd) no /home is necessary I think
13:27:07 <otaylor> (I think everybody agrees on the single /, except for people who want to put homedirs in loopback mounted encrypted files...)
13:27:18 <mcatanzaro> otaylor: I don't know
13:28:12 <juhp> Also virt-manager vs gnome-boxes
13:28:22 <mcatanzaro> So set aside F30... for F31, we can we do single / right? I know we'e waiting to do the LUKS change at the same time?
13:28:45 <mclasen> what is "the luks change" again ?
13:29:36 <mcatanzaro> LUKS enabled by default
13:30:18 <juhp> We have a ticket, no?
13:30:32 <kalev> can we ignore F31 for now and just concentrate on the F30 issue to get the fix out?
13:30:44 <mclasen> ok, so where do we stand on the f30 change - do we just vote on 50 -> 60 and see if we can get that implemented ?
13:30:51 <juhp> https://pagure.io/fedora-workstation/issue/82
13:30:55 <mclasen> or is there an alternative proposal ?
13:31:01 <kalev> I'll note that we have fedora flatpaks enabled by default in F30 so that / requirements are going to be larger than in just rpm-based system
13:31:21 <kalev> let's just vote on the 50 -> 60 change
13:31:54 <otaylor> kalev: should that be 50 -> 70 ?
13:32:04 <kalev> I don't known :)
13:32:06 <kalev> I don't know :)
13:32:11 <mclasen> aha! the alternative proposal
13:32:19 <juhp> how big are the runtimes for reference?
13:32:24 <mclasen> or 50 -> 75 ?
13:32:41 <mclasen> numerology...
13:33:02 <kalev> org.fedoraproject.Platform/x86_64/f29 is 1 GB
13:33:11 <juhp> thanks
13:33:44 <juhp> 15GB?  (or lower bids allowed? ;o)
13:33:51 <juhp> s/or/are/
13:34:34 <juhp> Hmm well maybe 70GB is good enough?
13:35:11 <mclasen> lets vote on 70GB first, and proceed to lower numbers if necessary
13:35:18 <mclasen> +1 on 70GB from me
13:35:19 <otaylor> +1 for 70GB
13:35:23 <kalev> +1
13:35:27 <juhp> +1
13:35:43 <ryanlerch> +1
13:36:22 <mclasen> any more votes ? this seems accepted
13:37:06 <kalev> otaylor: by the way, not sure if you saw: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7d91eea013 enables the fedora flatpak repos by default
13:37:17 <otaylor> kalev: very cool
13:37:35 <kalev> sadly this missed the silverblue test day
13:37:37 <mclasen> ok. any volunteer to file an anaconda bug / ticket / pr / whatever ?
13:37:54 <kalev> I can go do that now if you update the workstation ticket to say it's accepted
13:38:13 * kalev has anaconda git repo checked out.
13:38:56 <mclasen> thanks
13:39:14 <mclasen> #action kalev will file an anaconda ticket
13:39:23 <mclasen> I updated the workstation ticket
13:39:34 <mclasen> #topic Silverblue test day
13:40:05 <mclasen> to summarize, a Fedora testday on Silverblue happened on Friday
13:40:11 <mclasen> the results are here: http://testdays.fedorainfracloud.org/events/63
13:40:37 <mclasen> I started looking over it this morning, there doesn't seem to be any huge issue that jumps out at me
13:41:00 <mclasen> one recurring topic is issues with firefox and flatpak repo files getting downloaded as text files
13:42:24 <mclasen> anybody else have impressions from the test day ?
13:43:36 <mclasen> looks like some people tried to use pkcon for tests
13:44:01 <kalev> filed to 70 GB pr: https://github.com/rhinstaller/anaconda/pull/1939
13:44:09 <juhp> kalev: thanks!
13:44:42 <kalev> mclasen: gnome-software regressed just before the test day and the rpm-ostree backend stopped working due to rpm-ostree changing the libdnf version it bundles
13:44:53 <mclasen> too bad
13:45:16 <otaylor> Seems like there is some issue with adding repos from the command line vs. gnome-software picking them up?
13:45:27 <kalev> yep, I should look into that
13:45:51 <otaylor> Sems like people hit the firefox problem, tried to work around it, and still didn't see stuff
13:49:58 <mclasen> installing chrome seems to have worked for most people
13:51:18 <kalev> ohh nice
13:51:37 * mclasen is moving some items along in the silverblue kanban board according to the test results
13:52:11 <kalev> sadly the gnome-software backend was non-functional during the test day, otherwise it should be just the matter of double clicking on the rpm to install chrome
13:52:33 <mclasen> yeah, unfortunate
13:52:43 <mclasen> so this affected gnome-software, but not rpm-ostree itself ?
13:53:16 <kalev> yeah
13:53:51 <kalev> had to rebuild gnome-software against the same version of bundled libdnf that rpm-ostree switched to
13:54:54 * mclasen quietly rolls eyes
13:55:07 <mclasen> we have 5 minutes left - any other topics to raise ?
13:56:11 <juhp> kalev: they can't share?
13:56:46 <kalev> juhp: they can and they do, but rpm-ostree bumped the soname and that broke gnome-software
13:57:11 <kalev> I mean, bumped the bundled libdnf soname :)
13:57:54 * kalev is not very happy of how this is set up right now.
13:58:02 <juhp> okay right
13:58:54 <otaylor> OK, I need to head off. I sent out mail(s) about doing another attempt at finding a new meeting time. Please add your info there, and we'll see if something shows up or we need to find someone to fill in for stickster
13:59:55 <mclasen> #endmeeting