18:24:54 <aday> #startmeeting Workstation WG (2020-03-10)
18:24:54 <zodbot> Meeting started Thu Mar 12 18:24:54 2020 UTC.
18:24:54 <zodbot> This meeting is logged and archived in a public location.
18:24:54 <zodbot> The chair is aday. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:24:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:24:54 <zodbot> The meeting name has been set to 'workstation_wg_(2020-03-10)'
18:24:55 <aday> #meetingname workstation
18:24:55 <aday> #chair aday cmurf
18:24:55 <zodbot> The meeting name has been set to 'workstation'
18:24:55 <zodbot> Current chairs: aday cmurf
18:24:55 <aday> #topic Rollcall
18:24:55 <aday> #info present: cmurf, neal, aday, feborges, langdon, mclasen, petersen, mcatanzaro, kalev
18:24:55 <aday> #info regrets: tpopela
18:24:57 <aday> #info missing: otaylor
18:24:59 <aday> 
18:25:01 <aday> #topic Approve minutes from 3 March
18:25:03 <aday> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2020-03-10/workstation.2020-03-10-10.50.html
18:25:08 <aday> #agreed No objections - approved
18:25:10 <aday> #topic Announcements
18:25:12 <aday> #info Volunteers would be welcome for https://pagure.io/fedora-workstation/issue/135 (F32 issue)
18:25:14 <aday> #info F32 beta is scheduled for 17 March. There are blockers so it's 50/50 whether it will go out on time (blocker list: https://qa.fedoraproject.org/blockerbugs/milestone/32/beta/buglist ).
18:25:17 <aday> Status reports:
18:25:19 <aday> #topic enabling earlyoom by default
18:25:21 <aday> #info https://pagure.io/fedora-workstation/issue/119#comment-631241
18:25:23 <aday> #info Michael has asked whether we should re-evaluate our decision to enable earlyoom in F32
18:25:25 <aday> #info Benjamin Berg has made progress on using cgroups to protect core desktop processes. We might not need any out of memory killer. In testing the system lags but doesn't hang.
18:25:28 <aday> earlyoom was intended as a temporary measure. It might not be needed for F33 so introducing it just for F32 doesn't seem worthwhile.
18:25:31 <aday> Jens: thinks this is a valid concern
18:25:33 <aday> Kalev, Landgon: defer to others
18:25:37 <aday> Matthias: in favour of keeping earlyoom in F32
18:25:39 <aday> Neal: generally in favour of earlyoom. Doesn't trust cgroups. Doesn't think they're fine-grained enough. earlyoom is more generic than cgroups.
18:25:42 <aday> Allan: could there be upgrade issues with people going from F32 > F33? Neal doesn't think this should be an issue. Expects the real solution to be oomd, but that's a way off - F35 at least. Swapping from earlyoom to oomd is straightforward. cgroups changes and earlyoom can be complementary rather than conflicting.
18:25:46 <aday> Michael: doesn't think that earlyoom will be needed - just cgroups. We've had some negative technical comments on devel about earlyoom and we decided to go ahead with it anyway, in order to ensure desktop responsiveness, but if we don't need it we can avoid those criticisms. This is a rapidly evolving area of work.
18:25:50 <aday> Neal: cgroups just protects key gnome compontents. It doesn't preserve the rest of the session - other apps that aren't getting the memory they need. Michael: that's correct.
18:25:53 <aday> Chris: the cgroups work seems very promising. The earlyoom developers have responded to the feedback from devel, and those fixes will be introduced as a F32 zero day update.
18:25:56 <aday> Michael: asks if earlyoom devs have addressed the issue that earlyoom ignores and defeats systemd memory protection configuration. It ought to learn to parse systemd unit files to avoid breaking expected systemd functionality.
18:26:00 <aday> #agreed No consensus on backing earlyoom out, so we'll leave it in for F32.
18:26:02 <aday> #topic Automatically install the OpenH264 codecs
18:26:06 <aday> #info https://pagure.io/fedora-workstation/issue/84 & https://pagure.io/releng/issue/9246
18:26:08 <aday> #info Changes merged. Needs testing.
18:26:10 <aday> #info Neal: releng seems confident that these changes will be fine
18:26:12 <aday> #topic Should we include thermald by default?
18:26:14 <aday> #info https://pagure.io/fedora-workstation/issue/71
18:26:16 <aday> #agreed Defer until Benjamin Berg can join us
18:26:18 <aday> Topics:
18:26:20 <aday> #topic Reconsider updates policy
18:26:22 <aday> #info https://pagure.io/fedora-workstation/issue/107
18:26:24 <aday> Goal for this item is to review the issue and prepare for 17 Mar meeting with Matthew Miller
18:26:26 <aday> Michael: currently we install updates once a week and security updates daily - leads to too many updates. Proposal is to switch to two weekly updates, and only apply urgent updates daily (rather than security updates).
18:26:30 <aday> Michael: we could assess how frequently urgent updates get pushed on the server side. We could look into how Fedora developers classify urgent versus non-urgent. Ideally we'd reintroduce Bohdi's batching functionality. However, for now, we can start with the easy changes in Software.
18:26:36 <aday> Kalev: agrees with the proposal.
18:26:38 <aday> Neal: would like us to look at high priority rather than urgent. Thinks that getting batching back in Bohdi is unlikely. Michael: we can run some queries on Bohdi to see what the different priorities might include.
18:26:41 <aday> #agreed We'll move forward with the proposal in the ticket, and discuss further with Matthew Miller.
18:26:44 <aday> #action Chris will reach out to Matthew
18:26:46 <aday> #topic Review installation-related issues
18:26:48 <aday> #info Our list of installation-related issues is https://pagure.io/fedora-workstation/issues?status=Open&tags=installation&close_status=
18:26:51 <aday> Chris: let's prioritize the issues and form a delegation to meet with Anaconda.
18:26:53 <aday> #info Allan has organised the installer issues into categories based on what stage they are at (see the appendix below).
18:26:56 <aday> Allan suggests focusing on issue A, since it fixes a lot of issues at once and the path forward is relatively clear.
18:26:59 <aday> #action Allan to provide designs for a reorganised installer session.
18:27:01 <aday> Langdon raises some concerns about the proposal in A. Allan agrees to provide mockups for comment.
18:27:06 <aday> Michael: the WG can take a light touch approach to UI/UX issues in the Anaconda. We should defer to the Anaconda team.
18:27:09 <aday> Chris: we could run the list past the Anaconda team and get their input regarding what they have the resources to work on.
18:27:12 <aday> #action Michael, Allan and Neal volunteer to meet with the Anaconda team
18:27:14 <aday> #topic Appendix: installation-related issues
18:27:16 <aday> #info 1. Issues with solutions
18:27:18 <aday> #info A. Desktop session integration - also discussed in #124
18:27:20 <aday> - Proposed behaviour: ask try/install outside the desktop session, have installation happen in locked-down shell session, prompt to reboot when installation is done
18:27:23 <aday> - This would make installation more robust and provide a clearer UX
18:27:25 <aday> - It would eliminate the need to address #79 (fedora welcome window position)
18:27:27 <aday> - It would also fix #85 (offline automated installation is not possible)
18:27:29 <aday> #info B. Change from hub and spoke to a linear workflow - #124
18:27:31 <aday> - The hub model doesn't have much value for workstation, since there's only three spokes. Preference to have a simple linear model
18:27:36 <aday> - gnome-initial-setup assumes that each spoke has been configured, but we don't have any guarantee that they have been
18:27:39 <aday> #info 2. Issues which need engineering design
18:27:41 <aday> #info C. Disk partitioning changes
18:27:43 <aday> - Swap size and configuration - Anaconda team seem happy to proceed with our recommendation, when we have one
18:27:46 <aday> - System data encryption - #136. Unclear if we have a preference here.
18:27:48 <aday> - User data encryption - #82. Unclear if we have a preference here.
18:27:50 <aday> #info 3. Issues which need UX design recommendations
18:27:52 <aday> #info D. Installation progress page
18:27:54 <aday> - The page doesn't look good, but it's not entirely clear what the solution is?
18:27:56 <aday> #info E. Simplify installation destination page - #132
18:27:58 <aday> - Do we want to hide advanced partitioning? Reduce overlap between the models, improve terminology.
18:28:01 <aday> - Unclear what the preferred design is here; seems like the Anaconda team are open to suggestions
18:28:06 <aday> #endmeeting