05:02:04 <cmurf> #startmeeting Workstation WG (2020-05-05)
05:02:04 <zodbot> Meeting started Wed May  6 05:02:04 2020 UTC.
05:02:04 <zodbot> This meeting is logged and archived in a public location.
05:02:04 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:02:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:02:04 <zodbot> The meeting name has been set to 'workstation_wg_(2020-05-05)'
05:02:07 <cmurf> #meetingname workstation
05:02:07 <zodbot> The meeting name has been set to 'workstation'
05:02:09 <cmurf> #chair cmurf
05:02:09 <zodbot> Current chairs: cmurf
05:02:26 <cmurf> #topic Rollcall
05:02:29 <cmurf> #info present: cmurf, aday, mcatanzaro, langdon, neal, tpopela, mclasen, kalev, jens, feborges, james
05:02:31 <cmurf> #info regrets:
05:02:33 <cmurf> #info missing: owen
05:02:35 <cmurf> #topic Approve 28 Apr minutes
05:02:37 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2020-04-30/workstation.2020-04-30-22.35.html
05:02:39 <cmurf> #agreed No objections - approved
05:02:41 <cmurf> #topic Announcements
05:02:43 <cmurf> #info No announcements
05:02:45 <cmurf> #topic Follow-ups
05:02:47 <cmurf> #info issue#140
05:02:49 <cmurf> #link https://pagure.io/fedora-workstation/issue/140
05:02:51 <cmurf> Chris: live image is oversize - the max size is whatever the WG says it is - releng and qa don't really care. Chris floated the idea of having a test day and they're good with that idea.
05:02:53 <cmurf> Adam Williamson has a script that checks the size against the maximum limit we set, and files a bug. The Rawhide compose report contains a summary of changes between nightly composes. e.g.
05:02:55 <cmurf> https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/OULJLKESLBXM6GMOFSO52QM2YY7EC2W4/
05:02:57 <cmurf> #info image size can be whatever WG wants; QA and releng are agreeable to the 'image review test day' idea; needs owner
05:02:59 <cmurf> #topic Approve filtered view of flathub as third-party repo?
05:03:01 <cmurf> #link https://pagure.io/fedora-workstation/issue/108
05:03:03 <cmurf> Allan's intro - what's the general approach here?
05:03:05 <cmurf> Neal: doesn't think we'll be able to enable all of Flathub. Has Flathub split free/non-free/tainted? Would be OK with a button to enable free+untainted.
05:03:07 <cmurf> Matthias: there's no plan to split the repos in Flathub; but there is filtering - whitelists things that are good rather than blacklisting things that are bad (because blacklists are liable to fail). Installing Flathub in full will replace the filtered version.
05:03:09 <cmurf> Kalev: the filtered view makes sense for us - avoids the duplicates issue with Flathub apps replacing Fedora apps.
05:03:11 <cmurf> Can we have a button to enable the unfiltered view? Michael: the problem with that is if it enabled patent-encumbered software - that is something we cannot add. We don't need a free/non-free split. We need a tainted/untainted split.
05:03:13 <cmurf> The whitelist belongs to fedora and lives as part of fedora-workstation-repositories. Neal would be interested in using this in KDE too.
05:03:15 <cmurf> Kalev: would like to enable many more apps - maybe start with one chunk and then add more. eg. Skype, Steam, Spotify, Atom, VS Code,  Matthias: if we expand the list we'll need a process for it.
05:03:17 <cmurf> #topic Guidelines for preinstalled and non-removable apps
05:03:19 <cmurf> #link https://pagure.io/fedora-workstation/issue/125#comment-644039
05:03:21 <cmurf> Allan: Developed guidelines for preinstalled and non-removal apps, posted in the issue
05:03:23 <cmurf> Working group discusses and debates the benefits and downsides of preventing apps from being removed
05:03:25 <cmurf> Working group discusses whether we want to continue providing a large amount of default applications, a small bare-bones install, or a blend between the two
05:03:27 <cmurf> #info No conclusions here yet
05:03:29 <cmurf> #topic F32 retrospective, and appoint chair for F33 cycle
05:03:31 <cmurf> #link https://pagure.io/fedora-workstation/issue/141
05:03:33 <cmurf> #info Deferred to next meeting.
05:03:44 <cmurf> #endmeeting