01:35:58 <cmurf> #startmeeting Workstation WG (2020-05-12)
01:35:58 <zodbot> Meeting started Wed May 13 01:35:58 2020 UTC.
01:35:58 <zodbot> This meeting is logged and archived in a public location.
01:35:58 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:35:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
01:35:58 <zodbot> The meeting name has been set to 'workstation_wg_(2020-05-12)'
01:36:00 <cmurf> #meetingname workstation
01:36:00 <zodbot> The meeting name has been set to 'workstation'
01:36:02 <cmurf> #chair cmurf
01:36:02 <zodbot> Current chairs: cmurf
01:36:23 <cmurf> #topic Rollcall
01:36:25 <cmurf> #info present: cmurf, aday, tpopela, neal, mcatanzaro, jens, mclasen, langdon, owen, ernestas, feborges, james
01:36:27 <cmurf> #info regrets:
01:36:29 <cmurf> #info missing: kalev
01:36:31 <cmurf> #topic Approve 5 May minutes
01:36:33 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2020-05-06/workstation.2020-05-06-05.02.log.html
01:36:35 <cmurf> #agreed Approved - no objections
01:36:37 <cmurf> #topic Announcements
01:36:39 <cmurf> FESCo has approved systemd-resolved
01:36:41 <cmurf> If people want to suggest an agenda item, they should set the meeting-request tag in Pagure
01:36:43 <cmurf> #topic F32 retrospective, and appoint chairs for F33 cycle
01:36:45 <cmurf> #link https://pagure.io/fedora-workstation/issue/141
01:36:47 <cmurf> Motion is to continue as we are now - cmurf as chair and aday as co-chair.
01:36:49 <cmurf> No objections.
01:36:51 <cmurf> #agreed cmurf and aday to chair/co-chair for F33
01:36:53 <cmurf> #topic Give ABRT some love
01:36:55 <cmurf> #link https://pagure.io/fedora-workstation/issue/130
01:36:57 <cmurf> Ernestas from the ABRT team has joined us
01:37:00 <cmurf> Summary: there are 2 bug reporting modes -
01:37:01 <cmurf> 1. Automatic background crash reports that go to faf.org with truncated backtraces - these are working well
01:37:03 <cmurf> 2. Semi-automated manual crash reports. These are suffering from a number of issues. Michael has a longstanding concern about the quality of the tool. It's nice when it works - the quality of the reports is good.
01:37:05 <cmurf> Ernestas mentions one issue that is being worked on.
01:37:07 <cmurf> Michael describes ABRT issue #331 which results in every issue being private rather than public. Ernestas wonders about whether the blacklist feature is worth having.
01:37:09 <cmurf> - Langdon likes the blacklist. Suggests that it stays but that it's presented a bit differently?
01:37:11 <cmurf> Ernestas - there are bugs everywhere. ABRT status is mostly maintenance.
01:37:13 <cmurf> #info Some of the issues in the list aren't easy to fix. There are plans to rearchitect ABRT.
01:37:15 <cmurf> Ernestas - isn't sure how much the data gets used.
01:37:17 <cmurf> Matthias - looks at it every few months.
01:37:19 <cmurf> Neal - do people know that we have this functionality?
01:37:21 <cmurf> Owen - defined workflows for triage and working through stacktraces would help. Right now we have the FAF, but it's not a great place to have contributors. This isn't necessarily a project for the ABRT, but it seems to be the missing piece. - turning the data into actionable work items.
01:37:23 <cmurf> Allan - interested in using retrace stats to monitor stability/reliability over time.
01:37:25 <cmurf> Michael - can we automatically make bugzilla reports when a trace gets reported over a 100 times?
01:37:27 <cmurf> Allan - could we automatically generate regular email reports?
01:37:29 <cmurf> Tomas - how many people working ABRT? Ernestas - 3.5, but it's a fairly junior team.
01:37:31 <cmurf> #info Asked Ernestas to keep WG informed of progress
01:37:33 <cmurf> #topic Automatically adding new packages when upgrading
01:37:35 <cmurf> #link https://pagure.io/fedora-workstation/issue/138
01:37:37 <cmurf> #info Related issues #60, #66, #88
01:37:39 <cmurf> We used the supplement to bring in earlyoom for F32. However, this was supposed to be a short-term fix.
01:37:41 <cmurf> Michael: there are some other things that are being installed by default, but not being pulled in on upgrade. Game mode is one example.
01:37:43 <cmurf> Neal: if we are going to do this for other packages, supplements won't scale. We'll need a recommends in a centralised release package. We might need to write a policy for it.
01:37:45 <cmurf> #action Neal to followup with Daniel Mach to see if there are any developments on the DNF side
01:37:47 <cmurf> #action Michael to add a recommends for something or other
01:37:49 <cmurf> #topic Default disk partitioning layout for Workstation
01:37:51 <cmurf> #link https://pagure.io/fedora-workstation/issue/54
01:37:53 <cmurf> Chris: there's been some discussion in #54, on the subject of btrfs. Should we consider btrfs by default? We've previously decided to use one big ext4 volume.
01:37:55 <cmurf> Red Hat's storage team has previously rejected btrfs. Neil: they will consider it if Fedora start using it. That's how ext4 got into Fedora/RHEL.
01:37:57 <cmurf> Matthias: using btrfs would need community support in Fedora in order to get it off the ground. Neil thinks that there are developers who might work on it, including people from Facebook.
01:38:00 <cmurf> Michael: Fedora is already diverged from RHEL in terms of its filesystem.
01:38:01 <cmurf> The Red Hat concern is staffing to support btrfs.
01:38:03 <cmurf> Owen: we do need staffed support for our default filesystem - the Fedora community alone likely isn't going to be enough. btrfs isn't in the same place it was when the question was first asked though. There's also the question of integrating it into the desktop, including features that users might want to interact with. The storage team might prefer that we do this around stratis instead,
01:38:05 <cmurf> but that's a more complicated beast and could make it more difficult. Doing btrfs as a guerilla project isn't going to work. The default filesystem is an important part of the operating system and is something we need to ensure keeps working. We could ask the question: what would it take to support this?
01:38:07 <cmurf> Chris: it can take a lot of effort to ask the question, so is it worth doing that? Can the WG get to the point of wanting to pursue that?
01:38:09 <cmurf> Matthias: we need to answer the "why"? What are the benefits of btrfs? And if there are benefits, are those things that require integration (and therefore work - in which case, who is going to do that?)
01:38:11 <cmurf> Chris: should stratis be on the table? Matthias: the answer to that question is the same.
01:38:13 <cmurf> #info Brief discussion whether to consider Btrfs by default among other options. Ran out of time. No decision.
01:38:36 <cmurf> #endmeeting