13:30:42 <cmurf> #startmeeting Workstation WG (2020-06-02)
13:30:42 <zodbot> Meeting started Tue Jun  2 13:30:42 2020 UTC.
13:30:42 <zodbot> This meeting is logged and archived in a public location.
13:30:42 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:30:42 <zodbot> The meeting name has been set to 'workstation_wg_(2020-06-02)'
13:30:44 <cmurf> #meetingname workstation
13:30:44 <zodbot> The meeting name has been set to 'workstation'
13:30:46 <cmurf> #chair cmurf
13:30:46 <zodbot> Current chairs: cmurf
13:30:48 <cmurf> #topic Rollcall
13:30:50 <King_InuYasha> .hello ngompa
13:30:50 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
13:30:59 <King_InuYasha> let's see if my connectivity holds up...
13:31:36 <King_InuYasha> (I don't tend to have reliable IRC connectivity)
13:33:06 <cmurf> well this could be short :D
13:35:12 <cmurf> is it the meeting location or is it the agenda or is it IRC connectivity?
13:35:23 <petersen> Hello
13:35:26 <mclasen> err
13:35:29 <tpopela> Didn't know it's on IRC :D we were on Bluejeans :D
13:35:32 <mclasen> we were all on bluejeans
13:35:43 <cmurf> haha
13:35:43 <mclasen> aday is on pto today
13:35:53 <mcatanzaro> .hello catanzaro
13:35:54 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanza@redhat.com>
13:36:00 <mclasen> .hello mclasen
13:36:01 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
13:36:02 <petersen> Despite reading your agenda mail 10min ago I still ended up in BJ lol
13:36:06 <cmurf> ok nice
13:36:09 <tpopela> .hello tpopela
13:36:10 <zodbot> tpopela: tpopela 'None' <tpopela@redhat.com>
13:36:13 <petersen> .hello2
13:36:14 <zodbot> petersen: petersen 'Jens Petersen' <petersen@redhat.com>
13:36:34 <mcatanzaro> We have langdon coming too, half of didn't read the meeting agenda and wound up in BlueJeans
13:36:52 <mcatanzaro> aday sends his regrets today, but I guess that's OK if we have meetbot to take minutes ;)
13:36:58 <cmurf> old new habits die hard
13:37:05 <petersen> yeah haha
13:37:15 <cmurf> we'll see what happens next week, do we all end up here?
13:37:28 <petersen> hopefully not ;-P
13:37:30 <cmurf> i haven't seen kalev in a while, is he OK?
13:37:46 <mclasen> I haven't seen him today
13:38:10 <tpopela> cmurf: mclasen he replied to some email where I'm CC'ed few minutes ago..
13:38:11 <mclasen> I exchanged emails with him last week. he was responding
13:38:35 <cmurf> #topic Approve 26 May minutes
13:38:37 <cmurf> #link https://meetbot.fedoraproject.org/teams/workstation/workstation.2020-05-26-23.53.log.html
13:38:48 <cmurf> objections?
13:39:11 <cmurf> #agreed No objections - approved
13:39:18 <cmurf> #topic Announcements
13:39:19 <otaylor> .hello otaylor
13:39:22 <otaylor> (sorry to be late - rebooted to try and fix sound, then realized it was irc today)
13:39:22 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
13:39:50 <cmurf> I don't think I have anything qualifying as an announcment, got a couple things for followup that will be brief.
13:41:20 <cmurf> oh there's maybe an idea for updating the bootloader on Silverblue and CoreOS, https://github.com/coreos/fedora-coreos-tracker/issues/510
13:41:25 <langdon> .hello2
13:41:26 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
13:41:29 <langdon> sorry.. my bouncer fell over and didn't want to come back
13:41:47 <cmurf> bootupd
13:42:15 <cmurf> ok no other announcements
13:42:18 <feborges> .hello2
13:42:19 <zodbot> feborges: feborges 'Felipe Borges' <feborges@redhat.com>
13:42:27 <cmurf> #topic Followups
13:42:29 <cmurf> #info Supporting hibernation in Workstation ed., draft 2
13:42:31 <cmurf> #link https://pagure.io/fedora-workstation/blob/master/f/hibernationstatus.md
13:42:33 <cmurf> quick followup
13:42:43 <cmurf> Done and published. Got a bump already over the weekend to clarify the nature of the hibernation as loophole around Secure Boot risk.
13:42:57 <cmurf> Yesterday found a new hibernation bug, and I've taken it directly upstream.
13:43:12 <cmurf> I guess I like pain?
13:43:46 <petersen> hehe
13:43:46 <cmurf> Discussion on devel@ is going pretty smoothly, and light.
13:44:01 <cmurf> That's all I've got at the moment. Any questions on that?
13:44:33 <tpopela> cmurf: nothing from my side. Good work!
13:45:20 <cmurf> I can totally see why users pull their hair out on it. Not their fault!
13:45:25 <cmurf> #info enable swap-on-ZRAM by default
13:45:27 <cmurf> #link https://pagure.io/fedora-workstation/issue/127
13:45:35 <cmurf> let's see...
13:45:43 <cmurf> change proposal preview is being circulated to various affected groups: anaconda, editions: cloud server iot coreos
13:45:55 <cmurf> some tweaks are needed and then i'll set it to ready for wrangler status. No sadness from cloud or server folks about hibernation.
13:46:26 <cmurf> that's all i've got on that
13:46:38 <cmurf> any other followups/status reports needing attention?
13:47:21 <cmurf> alrighty
13:47:22 <otaylor> I can give a quick status on assembling a whitelist for flathub
13:47:29 <cmurf> oh yeah go ahead
13:47:50 <otaylor> I started working from the flathub statistics about what is downloaded most frequently
13:48:24 <otaylor> Looking in particular at *from scratch* downloads, not deltas, as a proxy for "fresh install" - since otherwise, you see the apps that people update most frequently at the top of the stats
13:49:03 <langdon> sorry..  i need more coffee... what is the context for the whitelist for flathub?
13:49:12 <langdon> my memory is failing me
13:49:16 <otaylor> In quick summary, what people download most are "extra-data wrappers around proprietary apps"
13:49:23 <mcatanzaro> #topic Whitelist for flathub
13:50:00 <otaylor> langdon: we want to add flathub, but not *all of flathub*
13:50:09 <cmurf> #chair mcatanzaro
13:50:09 <zodbot> Current chairs: cmurf mcatanzaro
13:50:34 <cmurf> #topic Whitelist for flathub
13:50:35 <otaylor> Not all of flathub because a) potential patent issues b) fedora legal wants the ability to remove individual apps if concerns arise
13:51:06 <langdon> oh .. this guy? https://pagure.io/fedora-workstation/issue/108
13:51:27 <petersen> yes
13:51:35 <langdon> gotcha.. thanks
13:51:46 <cmurf> #link https://pagure.io/fedora-workstation/issue/108
13:52:21 <otaylor> Of the top 50 apps, 15 are proprietary - mostly wrappers (1 with redistribution permission), 10 are things we already have fedora flatpaks for, 6 have patent issues
13:52:39 <cmurf> interesting
13:52:40 * petersen ponders voice-to-chat :)
13:52:52 <otaylor> 14 are in fedora, but Flatpaks
13:53:05 <langdon> is the list somewhere?
13:53:09 <otaylor> and 7 are unpackaged OSS software
13:53:40 <petersen> So only 7?
13:53:43 <langdon> any consistency to the "frameworks"? ie.. are they all electron apps? (all == the 7)
13:54:19 <otaylor> https://fishsoup.net/misc/flathub-popular-may-downloads.txt
13:54:29 <otaylor> that's my notes
13:54:49 <feborges> yay, Boxes is in the list :)
13:55:14 <otaylor> langdon: "planner" is not - it's a Elementary app in vala, others are, I think
13:56:01 <otaylor> (I tend to doubt playonlinux is packageable leaving aside the electron part)
13:56:15 <otaylor> Well, pycharm clearly isn't electron either
13:56:37 <langdon> postman ranking so highly seems weird
13:56:47 <tpopela> Telegram is a Qt app..
13:57:03 <King_InuYasha> planner is packaged in Fedora
13:57:06 <King_InuYasha> as elementary-planner
13:57:27 <sub_pop> Having a first-rate VSCode experience would be _amazing_. The Flatpak is frustrating to work with.
13:57:28 <kwizart> telegram relies on ffmpeg (unless one want a disabled version)
13:57:32 <otaylor> I think one main question I have is "In Fedora, No Flatpak" - most of these aren't wouldn't be hard to make Fedora Flatpaks of
13:57:45 <petersen> Do those ".........................." dots mean something?
13:57:57 <langdon> ms packages code as an rpm.. with a repo..
13:58:16 <otaylor> petersen: the ..... dots indicate the cut-off lines if we wanted to whitelist 20 apps
13:58:24 <petersen> Ah I see
13:58:45 <mclasen> otaylor: if you say "main question"... what is the question ?
13:58:53 <langdon> sub_pop: i generally think flatpak needs to solve the "add on" issue.. how do you make extensions work that really on natively installed things.. e.g. python ext using pylint (although i think that example is solved)
13:59:35 <tpopela> otaylor: it will depend on whether they are as RPMs in Fedora.. Otherwise you would have to find maintainers, ..
13:59:38 <otaylor> mclasen: Do we want to whitelist these from flathub, or do we want to encourage/wait-for them to be Flatpak'ed in Fedora - of course that's dependent on a different question
14:00:09 <otaylor> Do we want to whitelist apps that have Fedora Flatpaks, or concentrate on things that are additions
14:00:25 <tpopela> otaylor: I would prefer the additions..
14:00:43 <otaylor> tpopela: " it will depend on whether they are as RPMs in Fedora" - don't quite follow
14:01:41 <cmurf> re: in Fedora, no Flatpak not being hard to make Flatpaks; how hard? what's needed?
14:03:00 <otaylor> cmurf: how hard it depends on the app - it's somewhere between 10 minutes and weeks and weeks (weeks and weeks being libreoffice mostly :-)
14:03:11 <cmurf> oh man
14:03:14 <cmurf> that's a spread
14:04:14 <otaylor> cmurf: https://docs.fedoraproject.org/en-US/flatpak/tutorial/ is the documentation, https://fedoraproject.org/wiki/Flatpak:Easy categorizes some apps, though it's way out of date at this point
14:04:20 <cmurf> i'm not sure how to go about answering the question
14:04:33 <tpopela> otaylor: I mean all the dependencies and so on.. You really can't make a Fedora Flatpak from anything that's not available as an RPM in Fedora no?
14:04:39 <mclasen> otaylor: I think my vote would be to focus the whitelist on additions, and not wait for extra packaging effort
14:04:40 <King_InuYasha> you cannot
14:04:52 <King_InuYasha> tpopela: ^
14:04:58 <otaylor> tpopela: yes, My question was about things that *are* availbale as rpms in fedora
14:05:03 <otaylor> mypaint, say
14:05:54 <langdon> this might be off topic.. but are there any "converters" from say appimages or snaps to flatpaks? like build srcs->build srcs
14:07:16 <tpopela> otaylor: ah, ok.. at that point I would prefer to try to flatpak them in Fedora.. Sorry I didn't understood it..
14:08:07 <mclasen> langdon: there are a few apps on flathub that have been converted from snaps, I believe. I haven't looked in detail if that could be described as "a converter"
14:08:49 <langdon> mclasen: you mean by hand? yeah.. i was looking for something that would get you 90% of the way there..
14:09:16 <mclasen> I saw the link go by in #flatpak, but that was a month ago...
14:10:53 <mclasen> regarding telegram, why would ffmpeg affect it ? other than sharing videos
14:10:55 <cmurf> i think i'm also +1 to focusing on the whitelist and wouldn't wait for them being flatpak'd in Fedora
14:11:13 <tpopela> mclasen: let me ask jgrulich, that's maintaining it..
14:11:30 <cmurf> but i'm not sure if there's a way to encourage them being flatpak'd or if there's a distinct advantange to them being flatpak'd in Fedora rather than just whitelisted from flathub
14:12:23 <mclasen> for some people "its all fedora" is considered an advantage
14:12:30 <langdon> mclasen: +1
14:12:33 <cmurf> for sure
14:12:40 <otaylor> cmurf: well, "if there's a distinct advantange to them being flatpak'd in Fedora rather than just whitelisted from flathub" can be a can of worms to open
14:12:40 * mclasen not in that camp
14:13:03 <feborges> we have some interns in the brno office working on converting rpms to flatpaks, so we could point them to work on these specific conversions
14:13:13 <cmurf> i wasn't looking for a can of worms :D but what I meant by distinct is, one that makes it worth waiting for it to happen
14:13:31 <otaylor> cmurf: some people might trust Fedora packaged stuff more, Fedora packaged stuff *with considerable handwaving* is more likely to reliably get security updates
14:13:47 <langdon> i don't think it is worth waiting for.. but i do think we should be encouraging as many as possible to be coming from fedora
14:14:04 <langdon> is the fedora flatpak repo available to other distros?
14:14:09 <cmurf> ok something sorta missing in flatpaks before you have them, is, recency
14:14:23 <otaylor> langdon: note that once we whitelist something, we can't unwhitelist it, since people would then get stuck on whatever we had when we removed the whitelist
14:14:27 <mclasen> langdon: you can install it anywhere, yes
14:14:38 <langdon> mclasen: not flathub.. to be clear
14:14:48 <otaylor> langdon: yes (does require flatpak-1.6)
14:14:48 <cmurf> i see that information fairly clearly with an RPM, using dnf info X, but i don't offhand get any indication how up to date a flatpak is kept unless it's installed already
14:14:51 <cmurf> and not by date
14:15:18 <langdon> otaylor: i think the "stuck on" is fine.. people reinstall all the time..
14:15:20 <mclasen> otaylor: but that (removing things from the whitelist) is exactly the capability that legal asks from us, no ?
14:15:40 <otaylor> mclasen: well, if there was a legal fire, "stuck on" would be OK, at least for now
14:16:02 <mclasen> so this is just to get fedora onto dry land... users can sink or swm
14:16:07 <mclasen> swim
14:16:16 <mclasen> works for me
14:16:17 <otaylor> mclasen: I do think the whitelist really should have an equivalent to the flatpak eol functionality
14:16:30 <cmurf> i agree
14:16:30 <langdon> and... wouldn;t it operate like rpms.. who ever had latest would be the version you get on update? so if we took it off the whitelist.. the fedora rev would take over on next update
14:16:41 <otaylor> mclasen: But I don't think that would be appropriate if the app just got flatpak'ed in fedora
14:17:09 <otaylor> langdon: flatpaks don't make any assumption that there is a world-spanning set of comparable version numbers :-)
14:17:48 <langdon> oh... is "xyz" from flathub not the same as "xyz" from fedora? intrinsically?
14:17:48 <otaylor> langdon: an app is not-up-to-date, if the current version in the repo is different than what you have installed (unless you've "pinned" what you have installed)
14:18:16 <langdon> yeah.. thats what i was afraid of..
14:18:43 <cmurf> yeah they can be completely different
14:18:45 <otaylor> langdon: "Version" in Flatpak terms is just a free-form text field
14:19:55 <otaylor> OK, I think we've devolved into random discussion :-)
14:20:05 <King_InuYasha> no surprise there
14:20:09 <langdon> whitelist++ :)
14:20:12 <King_InuYasha> easy to do on IRC :)
14:20:33 <langdon> i did say i was potentially going off topic.. :)
14:20:36 <cmurf> otaylor: could you update #108 with some of this info?
14:20:57 <otaylor> My next step is to turn my notes and questions into  more formal form, and send the notes to the desktop list, and put the questions on the ticket
14:21:19 <otaylor> cmurf: yes, will do
14:21:31 <cmurf> #action otaylor to update #108 ticket and send notes to desktop@
14:21:52 <cmurf> ok so keeping to our preferred 50 minute aimpoint...
14:21:56 <cmurf> #topic Open Floor
14:22:23 <cmurf> on item i forgot, i am working on more speakers for this cycle
14:22:33 <cmurf> if anyone has suggestions let me know
14:22:35 <petersen> great
14:23:13 <mclasen> cmurf: coreos folks ? various topics come to mind
14:24:05 <cmurf> sure - throw out 1 or 2 topics?
14:24:42 <mclasen> installer (ignition vs anaconda), toolbox
14:25:08 <cmurf> ok good
14:25:36 <cmurf> add suggestions to #145 or let me know on IRC by pm if you prefer
14:25:39 <King_InuYasha> fb btrfs folks to talk about their experiences?
14:26:02 <King_InuYasha> since people seem to be weird about btrfs in the WG, maybe that would help allay their fears
14:26:23 <cmurf> ok
14:26:27 <cmurf> anything else?
14:26:50 <mclasen> weird ?
14:26:53 * mclasen lets that slide
14:27:16 <cmurf> thanks for showing up everyone
14:27:30 <cmurf> next week back to the blue :D
14:27:35 <cmurf> #info adjourned
14:27:37 <cmurf> #endmeeting