23:32:51 <cmurf> #startmeeting Workstation WG (2020-06-09)
23:32:51 <zodbot> Meeting started Tue Jun  9 23:32:51 2020 UTC.
23:32:51 <zodbot> This meeting is logged and archived in a public location.
23:32:51 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:32:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:32:51 <zodbot> The meeting name has been set to 'workstation_wg_(2020-06-09)'
23:32:53 <cmurf> #meetingname workstation
23:32:53 <zodbot> The meeting name has been set to 'workstation'
23:32:55 <cmurf> #chair cmurf
23:32:55 <zodbot> Current chairs: cmurf
23:33:11 <cmurf> #topic Rollcall
23:33:13 <cmurf> #info present: cmurf, neal, aday, kalev, tpopela, mcatanzaro, mclasen, langdon, jens, feborges, james, igor
23:33:15 <cmurf> #info regrets:
23:33:17 <cmurf> #info missing: owen (showed up later)
23:33:19 <cmurf> #topic Announcements
23:33:21 <cmurf> Chris: swap on zram test day will be on 15th June. There's been discussion about it on devel. Chris is inclined to make it F33-only rather than applying the change on upgrade.
23:33:23 <cmurf> Chris: Facebook folks will be joining us next week to talk btrfs
23:33:25 <cmurf> #topic Followups
23:33:27 <cmurf> Allan has submitted the policy change to council for the Flathub whitelist (ADD LINK HERE)
23:33:29 <cmurf> #topic automatically adding new packages when upgrading
23:33:31 <cmurf> #link https://pagure.io/fedora-workstation/issue/138
23:33:33 <cmurf> Michael: for earlyoom we used a reverse weak dependency - had it depend on fedora-release-workstation. The dep is specified in earlyoom. We agreed that that's hard to maintain because the dependencies would be scattered around. To solve this we could just flip the dependency around, and have fedora-release-workstation have a weak dependency on earlyoom etc.
23:33:35 <cmurf> Michael has looked at the history for what we used to have in the comps group, and has come up with a long list: https://src.fedoraproject.org/fork/catanzaro/rpms/fedora-release/c/a0df346ba7851111363adccdedeab4cc5d3edb24?branch=master
23:33:37 <cmurf> Michael: this clearly isn't maintainable, so we need something else.
23:33:39 <cmurf> owen joins.
23:33:41 <cmurf> Michael: there are 4 other issues - things that we agreed should be installed on upgrade and currently aren't (#60, #66, #88, #142).
23:33:43 <cmurf> Neal: we either need to use metapackages or have the DNF team fix comps groups. Should be fixed in Fedora as a distro and not through the fedora-release-workstation. Note switching to metapackages are not translatable.
23:33:45 <cmurf> Matthias: the decision is really up to the DNF team.
23:33:47 <cmurf> What's a metapackage? It's just a package which doesn't contain any files.
23:33:49 <cmurf> Neal: some issues around pungi and metapackages? (This is the infra for composing releases.)
23:33:51 <cmurf> Kalev: DNF will attempt to install a recommend dependency on every upgrade. If we switch to metapackages, this means recommended packages are effectively not removable: they'll be installed again on every upgrade. (Example: removing Firefox, gedit.) So switching to metapackages will also require dnf changes.
23:33:53 <cmurf> Kalev, Matthias: agrees that metapackages are cleaner than compsgroups. Everything is a package.
23:33:55 <cmurf> Igor: would prefer metapackages. The alternative would be to make system-upgrade upgrade comps using 'dnf group update'. Neal: that latter option would be easy. James: this sounds easy and correct.
23:33:57 <cmurf> #agreed: pursue 'dnf group update' option rather than metapackages, for starters
23:33:59 <cmurf> #action: Neal will open an RFE against DNF
23:34:01 <cmurf> #topic Guidelines for preinstalled and non-removable apps
23:34:03 <cmurf> #link https://pagure.io/fedora-workstation/issue/125
23:34:05 <cmurf> #agreed deferred until Allan has done some work
23:34:07 <cmurf> #topic Fedora 33 planning session
23:34:09 <cmurf> #link https://pagure.io/fedora-workstation/issue/145#comment-655102
23:34:11 <cmurf> Is Fedora too conservative? Matthias: technology choice should be led by UX.
23:34:13 <cmurf> Allan: what's the WG's strategy for making apps available to users? Is it just the 3rd party repos? How do then advertise apps to users, either through the UI or on the website?
23:34:15 <cmurf> Neal: the goal should be to minimize the number of cases where a user needs to manually install an unmentionable 3rd party repo. 90% of cases should be fulfilled by what we make available out of the box.
23:34:17 <cmurf> #topic Planning for next week's meeting
23:34:19 <cmurf> Facebook will be joining us to talk btrfs.
23:34:21 <cmurf> One question will be timeframe: would the target be F33 or F34?
23:34:23 <cmurf> Chris would like someone else to moderate.
23:34:25 <cmurf> Owen: we should resolve the question of whether we are open to btrfs in principle before having a conversation about the practicalities of implementing it as a change. It would therefore be interesting to hear from Facebook as to why they think that btrfs would be good for Fedora.
23:34:27 <cmurf> WG discusses btrfs.
23:34:29 <cmurf> Allan: it would be good for the WG to have a more thorough/organised understanding of the issues prior to meeting with Facebook. Can we have that conversation over the mailing list prior to next week?
23:34:31 <cmurf> Chris: we could delay the meeting with Facebook, but the change proposal deadline is approaching fast. Will try to circulate some notes over the next week.
23:34:33 <cmurf> Owen: questions for Facebook - what features do the use, what do they value, what do you think is relevant for desktops? Why would they like to see Fedora progress in this area?
23:34:38 <cmurf> #endmeeting