05:13:38 <cmurf> #startmeeting Workstation WG (2020-08-04)
05:13:38 <zodbot> Meeting started Wed Aug  5 05:13:38 2020 UTC.
05:13:38 <zodbot> This meeting is logged and archived in a public location.
05:13:38 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:13:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:13:38 <zodbot> The meeting name has been set to 'workstation_wg_(2020-08-04)'
05:13:40 <cmurf> #meetingname workstation
05:13:40 <zodbot> The meeting name has been set to 'workstation'
05:13:42 <cmurf> #chair cmurf
05:13:42 <zodbot> Current chairs: cmurf
05:14:06 <cmurf> #topic Rollcall
05:14:08 <cmurf> #info present wg members: cmurf, tpopela, aday, mclasen, Neal, jens, langdon
05:14:10 <cmurf> #info regrets wg members:
05:14:12 <cmurf> #info present guests: salimma, feborges, dcavalca
05:14:14 <cmurf> #topic Approve 28 July minutes
05:14:16 <cmurf> #link https://meetbot.fedoraproject.org/teams/workstation/workstation.2020-07-29-01.51.log.html
05:14:18 <cmurf> #agreed No objections - approved
05:14:20 <cmurf> #topic Announcements
05:14:22 <cmurf> #info New login/logout release blocking criteria has been proposed
05:14:24 <cmurf> #info GNOME 3.38 UI freeze is on Saturday
05:14:26 <cmurf> #info Nest starts on Friday
05:14:28 <cmurf> #link https://flocktofedora.org/
05:14:30 <cmurf> #topic Follow-ups & status reports
05:14:32 <cmurf> 3rd party repos - FESCo members have proposed a considerable re-write, which could well require that we have to go back to Council. We're likely looking at a more protracted processed that we'd hoped for
05:14:34 <cmurf> BTRFS testing. Will likely have a meeting with legal soon.
05:14:36 <cmurf> #topic NVIDIA driver and UEFI secure boot
05:14:38 <cmurf> https://pagure.io/fedora-workstation/issue/155
05:14:40 <cmurf> Peter's busy with the grub cve situation. Do we have everyone we need to discuss? We also need Christian and Kalev.
05:14:42 <cmurf> #agreed Deferred until we have the right people available
05:14:44 <cmurf> #topic Review Fedora 33 issues
05:14:46 <cmurf> #link https://pagure.io/fedora-workstation/issues?status=Open&milestone=Fedora+33&close_status=
05:14:48 <cmurf> Code completion deadline is 25 August - that's beta freeze.
05:14:50 <cmurf> Issue 71 - we've approved that - can close it.
05:14:52 <cmurf> Issue 105 - we need Kalev and he's away. it won't get done - move to F34.
05:14:54 <cmurf> Issue 108 - filtered view of Flathub - blocked on policy wrangling - move to F34.
05:14:56 <cmurf> Issue 134 - monospace is too small - some progress upstream, maybe some more before F33. Allan is working on it.
05:14:58 <cmurf> Issue 153 - BTRFS by default. Ongoing questions:
05:15:00 <cmurf> - cmurf needs to write magazine articles
05:15:02 <cmurf> - Compression could be too much to chew for F33
05:15:04 <cmurf> - Discard mount option for ssds?
05:15:06 <cmurf> Issue 167 - remove archive manager. Waiting on associated changes in nautilus. Not urgent.
05:15:08 <cmurf> Issue 169 - remove weather. Would be good to remove but oh no the shell integration. Likely needs to be pushed to Fedora 34.
05:15:10 <cmurf> #topic Open floor
05:15:12 <cmurf> #topic BTRFS recovery experience
05:15:14 <cmurf> Owen looked at this; 3 possible failure states. The 2nd doesn't happen - it doesn't do readonly - just mount or no mount. No mount is "suboptimal" - "here's a cli, figure it out". Right now we don't know how common that is. We could try and push for a better error message for f33, but it's not an easy area to address. We know that there's a UX issue there; however at this point we don't
05:15:16 <cmurf> know exactly what UX we want. We could try and improve our docs - the draft docs are too technical. Documenting the failure modes would be a good step. We're just hoping that people don't hit these states very often.
05:15:18 <cmurf> - Neal: the framework for recovery modes has landed.
05:15:20 <cmurf> - Davide: recovery stuff is slated for 5.9. is hoping to take another pass at the docs. booting with readonly is likely out of scope for f33, but we could possibly take the worst rough edges off the current experience.
05:15:22 <cmurf> - Owen: lots of stuff isn't going to work readonly; we need to decide what the step by step experience will be - what happens once in readonly? etc etc.
05:15:24 <cmurf> - Neal: we could work around overlay fs in ram for readonly.
05:15:26 <cmurf> #action Owen to write up his investigation results in more detail.
05:15:49 <cmurf> #endmeeting