08:02:08 <cmurf> #startmeeting Workstation WG (2021-03-02)
08:02:08 <zodbot> Meeting started Wed Mar  3 08:02:08 2021 UTC.
08:02:08 <zodbot> This meeting is logged and archived in a public location.
08:02:08 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
08:02:08 <zodbot> The meeting name has been set to 'workstation_wg_(2021-03-02)'
08:02:11 <cmurf> #meetingname workstation
08:02:11 <zodbot> The meeting name has been set to 'workstation'
08:02:13 <cmurf> #chair mcatanzaro
08:02:13 <zodbot> Current chairs: cmurf mcatanzaro
08:02:29 <cmurf> #topic Rollcall
08:02:32 <cmurf> #info present: Allan, Chris, Jens, Kalev, Langdon, Michael, Neal, Tomas, Owen
08:02:34 <cmurf> #info regrets: mclasen
08:02:36 <cmurf> #info present guests:
08:02:38 <cmurf> #topic Approval of Feb 16 minutes
08:02:40 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2021-02-17/workstation.2021-02-17-06.21.log.html
08:02:42 <cmurf> #agreed no objections
08:02:44 <cmurf> #topic Announcements, follow-ups, status reports
08:02:46 <cmurf> #topic Updated activities overview design for GNOME 40 / F34
08:02:48 <cmurf> #link https://pagure.io/fedora-workstation/issue/210
08:02:50 <cmurf> #info The GNOME Shell what we have in Fedora 34 right now is very close to what's going to be in Fedora 34 Final.
08:02:52 <cmurf> #info Allan writing an article about GNOME 40 for Fedora Magazine, hoping to be done this week
08:02:54 <cmurf> #topic Automatically install the OpenH264 codecs
08:02:56 <cmurf> #link https://pagure.io/fedora-workstation/issue/84
08:02:58 <cmurf> #info Postponed to next week
08:03:00 <cmurf> #topic gnome-software should allow configuring which software source takes precedence when installing software
08:03:02 <cmurf> #link https://pagure.io/fedora-workstation/issue/187
08:03:04 <cmurf> Milan who filed the ticket and was unhappy about the status quo is now gnome-software maintainer.
08:03:06 <cmurf> #info Allan would like to have some goals and scope set.
08:03:08 <cmurf> Michael is saying that it would be good to have a way to configure the preferred source.
08:03:10 <cmurf> Chris is asking if there is a way for Workstation WG to configure the default on case-by-case basis (e.g. if Evolution wants to default to rpm then they'd be able to).
08:03:12 <cmurf> Neal would like a way to configure the default as well.
08:03:14 <cmurf> Chris asks: If we add UI for this in gnome-software, what is the UI for this in gnome-shell? How do we handle duplicates (flatpak and rpm installed at the same time) in shell overview?
08:03:16 <cmurf> Owen says that the should not appear as duplicates in gnome-shell provided that the flatpak and rpm build both use the same desktop file name.
08:03:18 <cmurf> Langdon would actually prefer to always have separate entries in gnome-shell, even if the desktop names match.
08:03:20 <cmurf> Owen thinks that having a way to set default priorities would make sense.
08:03:22 <cmurf> Allan doesn't want to have a setting if the only motivation is that flatpaks are occasionally broken. Should just fix them.
08:03:24 <cmurf> Owen says that flatpaks are generally working well. If someone has issues with them, we should track down the issues.
08:03:26 <cmurf> Owen says that there is no good way to decide how to prioritize repositories when the user adds additional repos. We just can't know if the user would prefer e.g. flathub over fedora flatpaks, or vice versa. People would expect to have an ability to change the priority order.
08:03:28 <cmurf> #info Owen: Somebody should write down use cases. Then we can decide what is important and how to solve them and which ones to prioritize.
08:03:30 <cmurf> #action Michael and Langdon to do some housekeeping to split up the ticket.
08:03:32 <cmurf> #topic Open Floor
08:03:42 <cmurf> #endmeeting