03:18:16 <cmurf> #startmeeting Workstation WG (2021-08-17)
03:18:16 <zodbot> Meeting started Wed Aug 18 03:18:16 2021 UTC.
03:18:16 <zodbot> This meeting is logged and archived in a public location.
03:18:16 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:18:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
03:18:16 <zodbot> The meeting name has been set to 'workstation_wg_(2021-08-17)'
03:18:17 <cmurf> #meetingname workstation
03:18:17 <zodbot> The meeting name has been set to 'workstation'
03:18:19 <cmurf> #chair: Neal
03:18:19 <zodbot> Current chairs: : Neal cmurf
03:18:34 <cmurf> #topic Rollcall
03:18:36 <cmurf> #info present:  Allan, Kalev, Chris, Michael, mclasen, Neal, Langdon, Owen
03:18:38 <cmurf> #info regrets: Jens, Tomas, Zac,
03:18:40 <cmurf> #info present guests:Luna Jernberg(bittin)
03:18:42 <cmurf> #topic Approval of August 10 minutes
03:18:44 <cmurf> https://meetbot.fedoraproject.org/teams/workstation/workstation.2021-08-12-03.09.html
03:18:46 <cmurf> #agreed  minutes are approved
03:18:48 <cmurf> #topic Announcements, Status Reports
03:18:50 <cmurf> #info Fedora podcast episode on GNOME
03:18:52 <cmurf> #link https://fedoraproject.fireside.fm/18
03:18:54 <cmurf> #topic GNOME 41 Beta
03:18:56 <cmurf> #info It will land within a week, includes GNOME Software redesign
03:18:58 <cmurf> - Upstream beta release will be approximately within the next week (tarballs done, need to get them all build together)
03:19:00 <cmurf> - Fedora 35/rawhide is being updated on a rolling fashion to the latest releases
03:19:02 <cmurf> - interesting changes include GNOME Software redesign, third-party opt-in in GNOME Initial Setup, Power Profiles improvements (automatically switch to power saving when we're on low battery) [much rambling conversation about power saving feature]
03:19:04 <cmurf> - Issues we need to watch/track in the Software changes:
03:19:06 <cmurf> - NVIDIA driver installation path (clicking through navigation) gone - can still search
03:19:08 <cmurf> - Issue upstream to add something back, but might easily miss release - not clear who would implement
03:19:10 <cmurf> - If we don't add back, will need to coordinate with anybody has the old process documented (Lenovo)
03:19:12 <cmurf> - Suggested that we might want a more general "hardware helper" tool - though there aren't a lot of examples of things that need manual intervention for driver installation - NVIDIA + maybe Broadcom Wireless firmware.
03:19:14 <cmurf> - Repositories dialog redesign needs testing (and interaction with fedora-third-party changes)
03:19:16 <cmurf> #action aday to file a ticket about improving hardware driver experience
03:19:18 <cmurf> #topic open floor
03:19:20 <cmurf> Neal thinks that we should have a "status notifier" functionality by default in Fedora - there are apps he uses where he feels they are unsuable without a status icon.
03:19:22 <cmurf> - There are long-standing issues with both the design of the status icon (very inconsistent patterns) and the existing protocols, but apps are continuing and perhaps increasingly using status icons (probably because
03:19:24 <cmurf> Ubuntu ships a GNOME Shell extension)
03:19:26 <cmurf> - https://wiki.gnome.org/Initiatives/StatusIconMigration/ is an upstream page that tries to track usage of the
03:19:28 <cmurf> status icons and alternatives
03:19:30 <cmurf> - There are various different extensions - different forks. (https://extensions.gnome.org/extension/615/appindicator-support/ is what Ubuntu uses)
03:19:32 <cmurf> - https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/1014#note_568908 summarizes problems with the appindicator protocol.
03:19:34 <cmurf> - Discussion of the UI on different platforms - most platforms have some sort of icons. Most have issues with icons proliferating annoyingly and taking up most space. Langdon, Neal want to manage their icons.
03:19:36 <cmurf> #agreed meeting adjourned
03:21:49 <cmurf> #endmeeting