02:53:52 <brainycmurf> #startmeeting Workstation WG (2021-12-21)
02:53:52 <zodbot> Meeting started Wed Dec 22 02:53:52 2021 UTC.
02:53:52 <zodbot> This meeting is logged and archived in a public location.
02:53:52 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
02:53:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
02:53:52 <zodbot> The meeting name has been set to 'workstation_wg_(2021-12-21)'
02:53:52 <brainycmurf> #meetingname workstation
02:53:52 <brainycmurf> #chair Allan
02:53:52 <zodbot> The meeting name has been set to 'workstation'
02:53:52 <zodbot> Current chairs: Allan brainycmurf
02:54:03 <brainycmurf> #info Present members: Allan, Michael, Neal, Tomas, Chris, Kalev
02:54:03 <brainycmurf> #info Present guests: Felipe
02:54:03 <brainycmurf> #info Regrets:
02:54:03 <brainycmurf> #info Missing: Langdon, Mattias, Owen, Jens
02:54:03 <brainycmurf> #info Secretary: Allan
02:54:04 <brainycmurf> #topic Add gnome-software and NetworkManager (or NetworkManager-wiifi) to protected packages for workstation?
02:54:07 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/260
02:54:09 <brainycmurf> Initial reaction - it's surprising that NetworkManager can be removed.
02:54:13 <brainycmurf> Some voices in favour of making it possible to remove NetworkManager, in case people want to tweak their systems (say if they are only using ethernet). But how does someone recover if they remove it by accident, and they only have network access via wifi?
02:54:17 <brainycmurf> If we were to make NetworkManager non-removable, how would we do it? Hard dependency on gnome-control-center? Recommends on gnome-control-center? Protected package?
02:54:20 <brainycmurf> Chris: protected packages can be unprotected if people really want to get rid of something.
02:54:22 <brainycmurf> Seems to be a consensus to protect NetworkManager using the protects mechanism, so that people can unprotect and remove it if they want.
02:54:25 <brainycmurf> #action Michael to do this
02:54:27 <brainycmurf> #topic gnome-terminal -> gnome-console
02:54:29 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/261
02:54:31 <brainycmurf> gnome-terminal has been a pain downstream - there's a bunch of patches that we maintain.
02:54:33 <brainycmurf> Does Console obsolete the patches we have against gnome-terminal? Examples of background transparency and notifications for long-running operations. Would be good to check this in detail.
02:54:36 <brainycmurf> Question: would we drop the gnome-terminal patches if we switched the default terminal?
02:54:38 <brainycmurf> How to handle the migration for existing users? Will need to fix file type associations in Glib so that Console opens .sh files, etc - https://gitlab.gnome.org/GNOME/glib/-/issues/338
02:54:43 <brainycmurf> We probably don't want to migrate existing users to the new app - just make it the default on new installs.
02:54:46 <brainycmurf> #topic Offline updates: install updates after the user shutdown the computer, instead of in the next boot
02:54:49 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/258
02:54:51 <brainycmurf> Proposal is to install updates, then turn off, rather than restart, then install, then restart. This would avoid 2 reboot cycles and 2 LUKS password prompts for encrypted systems.
02:54:54 <brainycmurf> Installing updates would still be optional when powering off/restarting.
02:54:56 <brainycmurf> Michael: could be done with `systemctl isolate`. Some concerns here that it might not be as safe. Seems to be a consensus that the proposed behaviour would be an improvement.
02:54:59 <brainycmurf> Would need to be implemented in GNOME Software / GNOME Shell.
02:55:01 <brainycmurf> Might require a change proposal if we were to change this.
02:55:03 <brainycmurf> #action Michael to file a ticket against gnome-software
02:55:05 <brainycmurf> #topic Update the Workstation PRD
02:55:07 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/262
02:55:09 <brainycmurf> Deferred
02:55:13 <brainycmurf> #topic PyCharm's official third-party repo doesn't have any appstream metadata, can't be found in gnome-software
02:55:16 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/254
02:55:18 <brainycmurf> Deferred
02:55:20 <brainycmurf> #topic Announcements, status updates
02:55:22 <brainycmurf> #info Tomas has been working on the updated PRD - see https://pagure.io/fedora-workstation/issue/262
02:55:25 <brainycmurf> #info Allan has had some positive interaction with Canonical about the appindicator extension.
02:55:27 <brainycmurf> #info The minutes from last week have been posted online.
02:55:29 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2021-12-15/workstation.2021-12-15-16.05.log.html
02:56:00 <brainycmurf> #endmeeting