04:51:21 <brainycmurf> #startmeeting Workstation WG (2022-03-01)
04:51:21 <zodbot> Meeting started Wed Mar  2 04:51:21 2022 UTC.
04:51:21 <zodbot> This meeting is logged and archived in a public location.
04:51:21 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
04:51:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
04:51:21 <zodbot> The meeting name has been set to 'workstation_wg_(2022-03-01)'
04:51:21 <brainycmurf> #meetingname workstation
04:51:21 <brainycmurf> #chair Allan
04:51:21 <zodbot> The meeting name has been set to 'workstation'
04:51:21 <zodbot> Current chairs: Allan brainycmurf
04:51:41 <brainycmurf> #info Present members: Allan, Michael, Tomas, Owen, Chris, Jens, Sally
04:51:41 <brainycmurf> #info Present guests:
04:51:41 <brainycmurf> #info Regrets: Matthias
04:51:41 <brainycmurf> #info Missing:
04:51:41 <brainycmurf> #info Secretary: Owen
04:51:42 <brainycmurf> #topic NVIDIA driver and UEFI secure boot
04:51:44 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/155
04:51:46 <brainycmurf> * Michael has an action to find someone at Red Hat to bring to the discussion (in respect to kernel keyring specifics) - has reached out to various people, no response yet.
04:51:49 <brainycmurf> #topic Add VS Code to the 3rd party repos
04:51:53 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/283
04:51:55 <brainycmurf> * Everybody thought it was a reasonable step - similar to Google Chrome
04:51:57 <brainycmurf> * Doesn't work on Silverblue, but separate issue (maybe we need a slightly different Flathub filter for silverblue so we can include the VS Code Flatpak there, but not for Workstation)
04:52:00 <brainycmurf> * Neal asked about Edge
04:52:02 <brainycmurf> #action Tomas to get this done
04:52:04 <brainycmurf> #topic Rescue boot entry not updated on OS upgrades
04:52:06 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/259
04:52:08 <brainycmurf> What's the story here?
04:52:10 <brainycmurf> * "As intended" but maybe not ideal?
04:52:12 <brainycmurf> * Some questions: Do you want to do it every time a kernel upgrades? Only to a known kernel? Before a system upgrade? Should it be a initramfs generated on Fedora Infrastructure for greater reliability (a known good environment)? Do we have problems with the rescue image being broken when you go to use it? Is the current prompt the best solution for these rescue situations?
04:52:17 <brainycmurf> #action Chris to start a thread on devel
04:52:19 <brainycmurf> #topic New Anaconda UI
04:52:23 <brainycmurf> #link https://communityblog.fedoraproject.org/anaconda-is-getting-a-new-suit/
04:52:25 <brainycmurf> Feedback on existing pain points - https://hackmd.io/@aday/BkG74VLl9
04:52:27 <brainycmurf> * Some feedback on pain points document discussed - want to make it constructive.
04:52:29 <brainycmurf> * Discussion about to what extent we want a divergent experience from the Enterprise Linux experience - do we need something that is fundamentally simpler?
04:52:32 <brainycmurf> * Neal suggests that if we want a divergent experience, then we should try to glue the Elementary installer onto the Anaconda backend.
04:52:35 <brainycmurf> * Discussion of what the installer should be asking for Workstation (ideally)
04:52:37 <brainycmurf> * timezone
04:52:39 <brainycmurf> * hostname (long digression)
04:52:41 <brainycmurf> * **partitioning** - what is the scope - should you be able to resize Windows partitions? Setup complicated partioning schemes, etc?
04:52:44 <brainycmurf> * Windows partitions: its hard (encryption). (Chris - this should be left to the native OS - use a Windows tool to resize Windows partitions.) But this is something that really hits people at install fests (Neal) and is a big competitive point (Owen). Neal points to the elementary design docs. (https://github.com/elementary/installer/wiki ; https://docs.google.com/document/d/1Sw07eNjORV1rBEGhlWJmD39BgNBVNbJEJhLzrc_6T
04:52:49 <brainycmurf> 0w/edit)
04:52:53 <brainycmurf> * Allan suggested scoping partitioning to selecting disposition of existing partitions (mount, resize, etc.)
04:52:56 <brainycmurf> * Michael: will users who complain about our complicated disk portioning screen be satisfied if we radically simplify and limit it?
04:52:59 <brainycmurf> #topic Announcements, status updates
04:53:01 <brainycmurf> Deferred to the chat.
04:53:03 <brainycmurf> #info The minutes from last week have been posted online.
04:53:05 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-02-24/workstation.2022-02-24-00.14.log.html
04:53:32 <brainycmurf> #endmeeting