22:54:05 <brainycmurf> #startmeeting Workstation WG (2022-04-05)
22:54:05 <zodbot> Meeting started Tue Apr  5 22:54:05 2022 UTC.
22:54:05 <zodbot> This meeting is logged and archived in a public location.
22:54:05 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
22:54:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
22:54:05 <zodbot> The meeting name has been set to 'workstation_wg_(2022-04-05)'
22:54:06 <brainycmurf> #meetingname workstation
22:54:06 <brainycmurf> #chair Allan
22:54:06 <zodbot> The meeting name has been set to 'workstation'
22:54:06 <zodbot> Current chairs: Allan brainycmurf
22:54:28 <brainycmurf> #info Present members:Allan, Matthias, Chris, Jens, Neal, Tomas, Michael, Owen
22:54:28 <brainycmurf> #info Guests:Luna Jernberg(bittin)
22:54:28 <brainycmurf> #info Regrets:
22:54:28 <brainycmurf> #info Missing:
22:54:28 <brainycmurf> #info Secretary: Matthias
22:54:29 <brainycmurf> #topic Fedora 36: Workstation blockers and priorities
22:54:31 <brainycmurf> #link https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/thread/3QXHARU4KHE3BVHN7TB6P5V2IDUUYZ5O/
22:54:34 <brainycmurf> What happened with Michael's F36 printing issues?
22:54:36 <brainycmurf> #info Michael note: printing changes deferred to F37 due to issues
22:54:38 <brainycmurf> There is an upstream fix in 43, the release team members present will look at getting it into 42.1.
22:54:41 <brainycmurf> #action Allan to propose a GNOME freeze exception for the printer issue
22:54:43 <brainycmurf> There is a filechooser / portal issue that is fixed upstream, will get it into a GTK release for 42.1.
22:54:46 <brainycmurf> The remaining bug is 2063156, no fix for that one yet.
22:54:48 <brainycmurf> #action Matthias will talk to Jonas to narrowdown whether this is actually a mutter bug.
22:54:50 <brainycmurf> Bad bug pointed out by Neal: Basic vesa mode doesn't work in Xorg
22:54:52 <brainycmurf> #info basic vesa mode doesn't work in Xorg
22:54:56 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2067151
22:54:58 <brainycmurf> #action Matthias will look for somebody from the graphics team, like ajax to look at this.
22:55:00 <brainycmurf> #info virtio crash in qemu, fix is in a bodhi and needs karma.
22:55:02 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2070066
22:55:04 <brainycmurf> Question from Michael: when screen locks in F36, it often goes to the greeter instead of the
22:55:06 <brainycmurf> screen shield. Is that intentional? Will take it upstream
22:55:08 <brainycmurf> #topic Give ABRT some ❤
22:55:10 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/130
22:55:12 <brainycmurf> No action since we last talked about it. Michael recommends removing abrt from the workstation.
22:55:14 <brainycmurf> Neal says that it still mostly works for him, and cautions that we will get roasted for removing it.
22:55:17 <brainycmurf> Allan asks what the problems actually are. Michael mentions false positives for bugs getting
22:55:19 <brainycmurf> marked as sensitive / private. Retrace server almost always fails. Abrts self-reporting of problems
22:55:22 <brainycmurf> does not work. Offers to restart gnome-shell. There is confusion between userspace and kernel
22:55:26 <brainycmurf> crashes.
22:55:28 <brainycmurf> Neal points out that the retrace server runs on a dedicated machine and frequently runs
22:55:30 <brainycmurf> out of memory. Also that there is a rewrite underway to use debuginfod for local tracing.
22:55:32 <brainycmurf> Owen points out that we had a meeting with the abrt team a while ago (over a year ago now)
22:55:34 <brainycmurf> Neal says that many tools are going to break when the bugzilla api transition happens.
22:55:36 <brainycmurf> Like anaconda's bug reporting.
22:55:38 <brainycmurf> Allan suggests to put this ticket on the agenda again for F37
22:55:40 <brainycmurf> #action Jens to talk to the ABRT Team
22:55:42 <brainycmurf> #topic Red Hat Bugzilla: GNOME packages are in bad shape
22:55:44 <brainycmurf> #lisk https://pagure.io/fedora-workstation/issue/131
22:55:46 <brainycmurf> Tomas outlines his plan to create a mailing list for bugs, and fix up outdated package
22:55:48 <brainycmurf> ownerships. He also points out the Fedora packager dashboard as a good tool for
22:55:50 <brainycmurf> tracking bugs.
22:55:52 <brainycmurf> Tomas hopes to have progress in the next 2 months.
22:55:56 <brainycmurf> Neal opposes autoclosing bugs for sending them upstream.
22:55:58 <brainycmurf> #info remaining topics deferred
22:56:00 <brainycmurf> #topic Announcements, Status Updates
22:56:02 <brainycmurf> Allan has a meeting with Mairin about backgrounds.
22:56:04 <brainycmurf> #info Linux Application Summit 2022
22:56:06 <brainycmurf> #link https://linuxappsummit.org/
22:56:08 <brainycmurf> In Italy and Online 29th April - 1th May
22:56:10 <brainycmurf> Fedora is sponsoring LAS, Matthias and Tomas will be there in person
22:56:12 <brainycmurf> #info Fedora 36 Release Party Online 13-15th May
22:56:14 <brainycmurf> #link https://communityblog.fedoraproject.org/youre-invited-to-the-fedora-linux-36-release-party/
22:56:16 <brainycmurf> #info GUADEC
22:56:18 <brainycmurf> #link http://guadec.org 20-25th July
22:56:20 <brainycmurf> #info Hatch/Nest 2022 (August 2022)
22:56:22 <brainycmurf> #link https://communityblog.fedoraproject.org/nest-with-fedora-fedora-hatch-announcing-dates-call-for-volunteers/
22:56:27 <brainycmurf> #info Meeting minutes from last week posted
22:56:29 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-03-29/workstation.2022-03-29-19.24.log.html
22:56:32 <brainycmurf> #endmeeting