17:08:38 <brainycmurf> #startmeeting Workstation WG (2022-04-12)
17:08:38 <zodbot> Meeting started Tue Apr 12 17:08:38 2022 UTC.
17:08:38 <zodbot> This meeting is logged and archived in a public location.
17:08:38 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:08:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:08:38 <zodbot> The meeting name has been set to 'workstation_wg_(2022-04-12)'
17:08:38 <brainycmurf> #meetingname workstation
17:08:38 <zodbot> The meeting name has been set to 'workstation'
17:08:38 <brainycmurf> #chair
17:08:38 <zodbot> Current chairs: brainycmurf
17:08:56 <NishantMishra[m]> hello
17:09:07 <brainycmurf> #chair aday
17:09:07 <zodbot> Current chairs: aday brainycmurf
17:09:16 <brainycmurf> #info Present members:Allan Day, Mattias, Tomas, Owen, Chris, Michael
17:09:16 <brainycmurf> #info Guests: Luna Jernberg(bittin), Nishant
17:09:16 <brainycmurf> #info Regrets: Jens (juhp)
17:09:16 <brainycmurf> #info Missing:
17:09:16 <brainycmurf> #info Secretary: Michael
17:09:18 <brainycmurf> - Some discussions about GNOME Extension Manager from
17:09:20 <brainycmurf> Matthew Jakeman: https://flathub.org/apps/details/com.mattjakeman.ExtensionManager
17:09:22 <brainycmurf> #topic Add VS Code to 3rd party repos
17:09:24 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/283
17:09:26 <brainycmurf> This requires adding appstream metadata to the Visual Studio Code repository...
17:09:28 <brainycmurf> ...and this requires updating their repository generation tool, pulp.
17:09:30 <brainycmurf> escalate the pulp issue?
17:09:32 <brainycmurf> tomas: the whole thing is blocked on this
17:09:34 <brainycmurf> #action: Owen to hunt down the Pulp maintainers internally, add a Jira ticket
17:09:36 <brainycmurf> #action: Allan to ask for Richard's advice in ticket
17:09:38 <brainycmurf> #topic GUI-based recovery environment
17:09:40 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/288
17:09:42 <brainycmurf> Chris: suggests brainstorming to develop plan for a bare minimum implementation, plus a more extensive approach
17:09:45 <brainycmurf> Owen: concerned people might panic if user data is not available in rescue environment, could accidentally wipe data without realizing it has not yet been lost
17:09:50 <brainycmurf> WG discusses various options to create snapshots for this rescue environment
17:09:52 <brainycmurf> Owen: still not sure what problems we're trying to solve, this seems directionless. What problems will people use this environment to solve?
17:09:55 <brainycmurf> Neal: Historical CommonBugs give an idea of what can break systems, e.g. bootloader upgrades, scriptlets doing the wrong thing during upgrade, etc.
17:09:58 <brainycmurf> Neal: Recovery environment should have web browser, a few GUI disk management tools like blivet and media writer, and terminal
17:10:01 <brainycmurf> Neal: Sadly we cannot recover to a "last known good" environment because we don't have btrfs snapshotting configured
17:10:04 <brainycmurf> Owen: Might make more sense to have an "easy reinstall, keep my data" path, rather than try to recover existing install
17:10:07 <brainycmurf> Neal: anaconda can do this now easily enough
17:10:09 <brainycmurf> Chris: Users should be guided to take a backup (e.g. copy important files to USB stick) before doing something scary in the recovery environment. Biggest fear here is user-induced data loss when users are trying to recover. This could be a variant of gnome-tour.
17:10:13 <brainycmurf> Allan: Would prefer to avoid creating a special app for this, since it would have to be maintained, and would be rarely used. Displaying a page of documentation in a web browser seems more practical. Owen agrees.
17:10:18 <brainycmurf> Chris: Suggests leading users to Ask Fedora or #fedora channel on Matrix
17:10:20 <brainycmurf> Chris: Close but not quite ready to write a proposal yet, let's have more mailing list discussion first.
17:10:23 <brainycmurf> #action: Chris to post some brainstorming to devel@
17:10:25 <brainycmurf> #topic Give ABRT some ❤
17:10:27 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/130
17:10:29 <brainycmurf> Jens reached out to ABRT team and received an update in the ticket
17:10:31 <brainycmurf> Nishant: seeing lots of crashes on F36 Beta, ABRT seems to be doing a good job of reporting them
17:10:33 <brainycmurf> Michael: it was seriously broken for a long time, good to know things are better now
17:10:35 <brainycmurf> Michael: cautiously optimistic that quality might be improving, especially since debuginfod will allow skipping the retrace server
17:10:38 <brainycmurf> Michael: happy if ABRT bugs get resolved, but does not expect UI issues to be resolved regardless
17:10:40 <brainycmurf> #action Allan to develop updated mockups
17:10:42 <brainycmurf> Allan: GTK 4 porting ought to be on agenda
17:10:44 <brainycmurf> #topic F36 release party
17:10:48 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/299
17:10:50 <brainycmurf> Allan: come to the release party!
17:10:52 <brainycmurf> WG discusses what to talk about at release party
17:10:54 <brainycmurf> #action Allan to present overview of latest GNOME release
17:10:56 <brainycmurf> #action Allan to invite ofourdan to discuss Wayland by default for NVIDIA in gdm change
17:10:58 <brainycmurf> #topic Working group membership
17:11:00 <brainycmurf> Allan: Sally is busy and not able to attend regularly. Want to encourage her to attend as much as possible, but not a good fit for a full member.
17:11:03 <brainycmurf> Neal: would be nice to fill empty spot, but not feeling particular pressure to do so.
17:11:05 <brainycmurf> Nishant: is willing to join
17:11:07 <brainycmurf> Michael: inviting someone who is not already an experienced community member would bring fresh perspectives
17:11:10 <brainycmurf> Allan: having more volunteers is healthy
17:11:12 <brainycmurf> Tomas: wants to see someone who has experience working with students
17:11:14 <brainycmurf> Chris: we almost never vote, so it rarely matters whether someone is a full voting member or not
17:11:18 <brainycmurf> Michael: but if you are a full member, you are *expected* to attend meetings rather than merely *welcome* to do so
17:11:21 <brainycmurf> Michael: suggests anyone who has regularly attended our meetings for a while can become a full member
17:11:24 <brainycmurf> Neal: will add any regular attendee to KDE SIG membership when they eventually ask for it. But Workstation WG has a voting restriction and Council reporting requirement, and should be a little more formal beyond just showing up to meetings. Sustained regular contributions (not necessarily code/packaging) should be expected.
17:11:28 <brainycmurf> Owen: not convinced that expanding WG numbers is beneficial, would rather focus on encouraging people who are not official members to contribute
17:11:31 <brainycmurf> #info Backlog topics deferred:
17:11:33 <brainycmurf> #topic The Workstation Working Group is a bottleneck
17:11:35 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/218
17:11:37 <brainycmurf> #topic Workstation user and contributor community on discussion.fedoraproject.org
17:11:39 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/223
17:11:41 <brainycmurf> #topic Consolidate and advertise Workstation chat channels
17:11:43 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/224
17:11:45 <brainycmurf> #topic Parental Controls app getting poor reviews
17:11:49 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/263
17:11:51 <brainycmurf> #topic Announcements, Status Updates
17:11:53 <brainycmurf> #info The minutes from last week have been posted.
17:11:55 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-04-05/workstation.2022-04-05-22.54.log.html
17:11:59 <brainycmurf> #endmeeting