00:19:55 <brainycmurf> #startmeeting Workstation WG (2022-05-10)
00:19:55 <zodbot> Meeting started Wed May 11 00:19:55 2022 UTC.
00:19:55 <zodbot> This meeting is logged and archived in a public location.
00:19:55 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
00:19:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:19:55 <zodbot> The meeting name has been set to 'workstation_wg_(2022-05-10)'
00:19:56 <brainycmurf> #meetingname workstation
00:19:56 <zodbot> The meeting name has been set to 'workstation'
00:19:56 <brainycmurf> #chair aday
00:19:56 <zodbot> Current chairs: aday brainycmurf
00:20:08 <brainycmurf> #info Present members: Allan, Chris, Michael, Tomas, Matthias, Neal, Owen
00:20:08 <brainycmurf> #info Guests: Luna Jernberg (bittin), Ben Cotton, Jack Sedita, Nishant, Jens (2nd half)
00:20:08 <brainycmurf> #info Regrets: Jens (1st half)
00:20:08 <brainycmurf> #info Missing:
00:20:08 <brainycmurf> #info Secretary: Neal
00:20:08 <brainycmurf> #topic Review the state of i18n and l10n
00:20:10 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/267
00:20:12 <brainycmurf> Deferred until next week.
00:20:14 <brainycmurf> #topic Release blocking status of basic functionality tests for apps
00:20:16 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/304
00:20:18 <brainycmurf> Quick check in on this: does the plan seem right? Anything else we should be doing? Should we do a session on QA?
00:20:21 <brainycmurf> Allan: People seem concerned about the quality with the default GNOME apps we offer. Another concern is that the test criteria isn't concrete enough.
00:20:24 <brainycmurf> Neal: There's also a systemic problem with people not being able to report bugs effectively either unless they're release blockers in RHBZ. This needs to be addressed somehow.
00:20:27 <brainycmurf> Tomas: Improving testing using OpenQA on GNOME OS using some of what Fedora QA has done may help>
00:20:29 <brainycmurf> Neal: I'd like to see Rawhide+GNOME mainline continuously tested somehow, like how KDE SIG is planning with KDE Plasma.
00:20:32 <brainycmurf> Matthias: upstream GNOME OS images for Fedora QA [Neal: GNOME OS doesn't necessarily have Fedora customizations.]
00:20:37 <brainycmurf> Tomas: testing needs to happen earlier - needs up to date GNOME available by beta. Michael: do we not have the RC ready for beta? It's always released, but it might not be "ready" for beta freeze. F36 beta freeze was 22 February - that was 2 weeks after GNOME 42 RC? [check this] So there should be time in the schedule.
00:20:41 <brainycmurf> Allan: Kalev was away, so David King had to take time to take over while Kalev was gone.
00:20:43 <brainycmurf> #action Clarify timings for testing the upcoming GNOME release. Put a reminder in our own schedule so we check that the packages are available when they're supposed to be.
00:20:46 <brainycmurf> Michael: not all GNOME modules release betas - they just do an RC. Something to potentially address upstream.
00:20:49 <brainycmurf> Neal: issue with gobject introspection breaking language bindings towards the end of the cycle. Owen: this should be fixed upstream using CI.
00:20:52 <brainycmurf> Some more discussion about GNOME Music and GNOME Console, we haven't switched to these by default yet because of missing basic features.
00:20:55 <brainycmurf> #topic Appoint a chair for the F37 cycle
00:20:57 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/308
00:20:59 <brainycmurf> Call for volunteers.
00:21:01 <brainycmurf> Backlog issues:
00:21:05 <brainycmurf> #topic grub: Show old kernels under a "advanced options"submenu
00:21:07 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/282
00:21:09 <brainycmurf> Neal: This may not be technically feasible with BLS configuration. It's also probably not worth doing anything here because we have generally only 5-ish lines and the menu isn't even shown by default. And UEFI Secure Boot prevents chain loading. But maybe it's possible to add a menu item for going to the firmware boot menu to chain to other SB-enabled OSes (Linux/Windows)
00:21:14 <brainycmurf> #action Chris will reach out to GRUB upstream to figure out if it's possible to improve SB multiboot. Ticket should be closed as deferred to upstream.
00:21:17 <brainycmurf> #topic Howdy integration
00:21:19 <brainycmurf> https://pagure.io/fedora-workstation/issue/272
00:21:21 <brainycmurf> Deferred
00:21:23 <brainycmurf> #topic In Repository Gnome Shell Extesions Need Some TLC
00:21:25 <brainycmurf> https://pagure.io/fedora-workstation/issue/254
00:21:27 <brainycmurf> Deferred
00:21:29 <brainycmurf> #topic Announcements, Status Updates
00:21:31 <brainycmurf> Fedora 36 is released and there is a Release Party Online this weekend: https://hopin.com/events/fedora-linux-36-release-party/
00:21:36 <brainycmurf> Red Hat Summit 2022 in Boston and Online for the more enterprisy stuff: https://www.redhat.com/en/summit
00:21:39 <brainycmurf> GUADEC in 2 months (20-25th July)
00:21:41 <brainycmurf> DevConf.US in 3 months (mid August)
00:21:43 <brainycmurf> #info The minutes from last week have been posted.
00:21:45 <brainycmurf> #link https://meetbot.fedoraproject.org/teams/workstation/workstation.2022-05-03-17.27.log.html
00:21:47 <brainycmurf> #endmeeting