19:51:43 <brainycmurf> #startmeeting Workstation WG (2022-07-12)
19:51:43 <zodbot> Meeting started Tue Jul 12 19:51:43 2022 UTC.
19:51:43 <zodbot> This meeting is logged and archived in a public location.
19:51:43 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:51:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:51:43 <zodbot> The meeting name has been set to 'workstation_wg_(2022-07-12)'
19:51:43 <brainycmurf> #meetingname workstation
19:51:43 <zodbot> The meeting name has been set to 'workstation'
19:51:43 <brainycmurf> #chair Allan
19:51:43 <zodbot> Current chairs: Allan brainycmurf
19:52:04 <brainycmurf> #info Present members: Michael, Neal, Allan, Kalev, Tomas, Jens, Matthias, Chris
19:52:04 <brainycmurf> #info Guests: Zac, Maira
19:52:04 <brainycmurf> #info Regrets:
19:52:04 <brainycmurf> #info Missing:
19:52:04 <brainycmurf> #info Secretary: Jens
19:52:05 <brainycmurf> #topic Drop Flathub filtering
19:52:07 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/300
19:52:09 <brainycmurf> Please document any objections to the current plan on the ticket.
19:52:11 <brainycmurf> Any news on the vendor preference?
19:52:13 <brainycmurf> Matthias talked to Milan, will update the ticket with his response.
19:52:15 <brainycmurf> Do we have a plan for IDEs?
19:52:19 <brainycmurf> Owen: it may be confusing to treat different apps differently. One option would be to add a warning in Software to the effect of "this package may perform worse as a flatpak".
19:52:22 <brainycmurf> #topic Improve GTK4 font rendering by default for 1080p displays
19:52:24 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/295
19:52:26 <brainycmurf> #link https://gitlab.gnome.org/GNOME/gtk/-/issues/3787
19:52:28 <brainycmurf> Michael/Matthias: gtk4 defaults fonts rendering to subpixel positioning - workaround compatibility setting is available though not enabled yet
19:52:31 <brainycmurf> Matthias: some specific font rendering issues have been fixed recently
19:52:33 <brainycmurf> The issue is primarily seen on non hi-dpi resolution displays.
19:52:35 <brainycmurf> Michael: could we make it conditional on display density?
19:52:37 <brainycmurf> Owen: it would be good to have standard screenshots for reference
19:52:39 <brainycmurf> Matthias: not opposed to turning on the compatibility mode. Thinks that a lot of the issues have been resolved. No upstream plans to address this specific issue further.
19:52:42 <brainycmurf> There are some issues when taking screenshots with the gl renderer. Better to use the Cairo one.
19:52:44 <brainycmurf> Matthia's upcoming GUADEC talk on fonts and GTK: https://events.gnome.org/event/77/contributions/274/
19:52:49 <brainycmurf> #action Michael to update the ticket with comparison screenshots using latest GTK
19:52:51 <brainycmurf> #topic Review stale pending-action tickets
19:52:53 <brainycmurf> #topic Remove photos from the default apps
19:52:55 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/164
19:52:57 <brainycmurf> Michael is assigned. Forgot about it. But photos is broken upstream, so yay.
19:52:59 <brainycmurf> Michael will follow up and report back in a couple of weeks.
19:53:01 <brainycmurf> #topic Add VS Code to the 3rd party repos
19:53:03 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/283
19:53:05 <brainycmurf> Tomas: waiting on https://github.com/rpm-software-management/createrepo_c/issues/75
19:53:07 <brainycmurf> Still chasing
19:53:09 <brainycmurf> #topic Graphical recovery environment
19:53:11 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/288
19:53:13 <brainycmurf> Allan added the requirement to our installer doc
19:53:15 <brainycmurf> Neal started the mailing list discussion, not much of use came back though.
19:53:19 <brainycmurf> Chris: has come up sometimes on users list - perhaps could be categorized: need to evaluate what is possible too
19:53:22 <brainycmurf> Owen: wants to see a list of most 5-10 common tasks for the recovery environment
19:53:24 <brainycmurf> Allan: graphical environment without diagnostic/recovery tooling seems like a good initial target. Someone can at least prepare installation media that way, and we can add extra tools later.
19:53:27 <brainycmurf> Allan: is it worth us pursuing this, given that we don't have someone lined up to implement it? Neal is interested in making it happen but needs to know what use-cases needed.
19:53:30 <brainycmurf> Chris: OEMs are interested in system reset
19:53:32 <brainycmurf> #action Chris to take over research to come up with use cases, technical design options.
19:53:34 <brainycmurf> #topic Enable full-preemption
19:53:36 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/228
19:53:38 <brainycmurf> Chris: this dropped off the radar because there's uncertainty how the setting will perform for server and cloud. The upstream view is that it should be fixed for these cases.
19:53:41 <brainycmurf> Justin is reluctant to enable on server and cloud. Only wants it enabled on desktop.
19:53:43 <brainycmurf> Next step is to do more benchmarks with new kernels.
19:53:45 <brainycmurf> #action Chris to dig into it and see about how we can do testing.
19:53:49 <brainycmurf> Could be an early F38 feature - enable in rawhide early in the cycle.
19:53:51 <brainycmurf> GNOME Terminal > GNOME Console
19:53:53 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/261
19:53:55 <brainycmurf> Owen: no major changes since we last looked at it.
19:53:57 <brainycmurf> It is packaged now - we can check off the packaging task.
19:53:59 <brainycmurf> There was no 42.0 release
19:54:01 <brainycmurf> #link https://src.fedoraproject.org/rpms/gnome-console
19:54:03 <brainycmurf> #action Michael to talk to the maintainer about the lack of stable release
19:54:05 <brainycmurf> #action Allan to continue pushing to get the features we want
19:54:07 <brainycmurf> #topic Automatically install the OpenH264 codecs
19:54:09 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/84
19:54:11 <brainycmurf> Deferred
19:54:13 <brainycmurf> #topic Broadcom wireless
19:54:15 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/116
19:54:19 <brainycmurf> Deferred
19:54:21 <brainycmurf> #topic 2m shutdown timer is too long
19:54:23 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/163
19:54:25 <brainycmurf> Deferred
19:54:27 <brainycmurf> #topic Announcements, Status Updates
19:54:29 <brainycmurf> #info The minutes from last week have been posted.
19:54:31 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-07-05/workstation.2022-07-05-20.43.log.html
19:54:34 <brainycmurf> Neal's doing a Fedora hatch event next week in New York
19:54:36 <brainycmurf> #link https://pagure.io/fedora-hatch-2022-rochester
19:54:38 <brainycmurf> GUADEC is next week. Matthias will be out for 2 weeks.
19:54:40 <brainycmurf> Neal will be out next week too.
19:54:42 <brainycmurf> #endmeeting