01:10:39 <brainycmurf> #startmeeting Workstation WG (2022-09-06)
01:10:39 <zodbot> Meeting started Wed Sep  7 01:10:39 2022 UTC.
01:10:39 <zodbot> This meeting is logged and archived in a public location.
01:10:39 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
01:10:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
01:10:39 <zodbot> The meeting name has been set to 'workstation_wg_(2022-09-06)'
01:10:39 <brainycmurf> #meetingname workstation
01:10:39 <brainycmurf> #chair Allan
01:10:39 <zodbot> The meeting name has been set to 'workstation'
01:10:39 <zodbot> Current chairs: Allan brainycmurf
01:10:52 <brainycmurf> #info Present members: Tom, Kalev, Chris, Matthias, Michael, Neal
01:10:52 <brainycmurf> #info Guests: Maira
01:10:52 <brainycmurf> #info Regrets: Owen, Jens
01:10:52 <brainycmurf> #info Missing:
01:10:52 <brainycmurf> #info Secretary: Chris
01:10:53 <brainycmurf> #topic Progress check on workstation blocker issues
01:10:55 <brainycmurf> #topic https://bugzilla.redhat.com/show_bug.cgi?id=2111025 (gnome-shell)
01:10:57 <brainycmurf> https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/2436 has been merged, so the issues should be fixed upstream
01:11:00 <brainycmurf> #topic https://bugzilla.redhat.com/show_bug.cgi?id=2121110 (gnome-initial-setup)
01:11:02 <brainycmurf> Upstream issue is https://gitlab.gnome.org/GNOME/gnome-initial-setup/-/issues/151
01:11:04 <brainycmurf> #topic https://bugzilla.redhat.com/show_bug.cgi?id=2111003 (gnome-contacts)
01:11:06 <brainycmurf> Fix is merged upstream: https://gitlab.gnome.org/GNOME/gnome-contacts/-/merge_requests/207
01:11:08 <brainycmurf> #topic [abrt] totem: nouveau_pushbuf_data(): totem killed by SIGABRT - https://bugzilla.redhat.com/show_bug.cgi?id=2123274
01:11:13 <brainycmurf> New issue since last week
01:11:15 <brainycmurf> Moved to libdrm as it's a nouveau crash (when running Totem)
01:11:17 <brainycmurf> #topic Unable to set up enterprise account with gnome-initial-setup due to missing buttons - https://bugzilla.redhat.com/show_bug.cgi?id=2123494
01:11:20 <brainycmurf> New issue since last week
01:11:22 <brainycmurf> Upstream issue is https://gitlab.gnome.org/GNOME/gnome-initial-setup/-/issues/152
01:11:24 <brainycmurf> A fix has been proposed upstream
01:11:26 <brainycmurf> Bug 2121110 is the only blocker without a fix. Kalev looked into it - it seems to be a shell issue, not gnome-initial-setup. He's planning on testing again with the RC this week. https://bugzilla.redhat.com/show_bug.cgi?id=2121106 could be related
01:11:30 <brainycmurf> #topic F37 release status
01:11:32 <brainycmurf> #info Kalev is nearly done with the GNOME 43 RC packages. We'll have the important ones for the test day.
01:11:35 <brainycmurf> #topic GNOME 43 RC test day:
01:11:37 <brainycmurf> #link https://pagure.io/fedora-qa/issue/705
01:11:39 <brainycmurf> Test day is going ahead
01:11:43 <brainycmurf> #link https://fedoramagazine.org/contribute-at-the-i18n-release-validation-cryptopolicy-and-gnome-43-final-test-weeks-for-fedora-linux-37/
01:11:46 <brainycmurf> #info Will try to get the wiki updated so it shows #fedora-workstation for the discussion during test day (week).
01:11:49 <brainycmurf> #link https://testdays.fedoraproject.org/events/140
01:11:51 <brainycmurf> Allen: the tests in the wiki are too extensive to expect folks to do them all, so maybe break them down into blocks to ensure we get everything tested
01:11:54 <brainycmurf> Discussion on Classic Mode, User Switching, and other lesser used aspects of Shell. If there weren't test cases, some of these areas may not ever get tested or bugs reported.
01:11:57 <brainycmurf> #action Allan will discuss the wiki page with Sumantro, breaking it down into groups and indicate priorities
01:12:00 <brainycmurf> #topic i18n test day results
01:12:02 <brainycmurf> #link https://fedoraproject.org/wiki/Test_Day:2022-09-06_I18N_Test_Day
01:12:04 <brainycmurf> Jens is out this week - deferred until next week.
01:12:06 <brainycmurf> #topic Release blocking criteria for preinstalled apps
01:12:08 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/304
01:12:12 <brainycmurf> Discussion on-going and not as pressing now, but the final release blocker for Contacts makes it worth discussing. QA's goal is to follow a process.
01:12:15 <brainycmurf> Allen: Apps should pass the tests (fix) or be removed (as preinstalled)
01:12:17 <brainycmurf> Michael: Agreed, not going to block the release on these issues.
01:12:19 <brainycmurf> Cosmetic issues shouldn't block release, the bigger issues that actually make the app non-functional (per its purpose) is the concern. But then raises the question of consistency in determining what is a cosmetic issue versus basic functionality.
01:12:23 <brainycmurf> Do we continue to apply the basic functionality requirement to all pre-installed apps? If yes, if there are blockers then the app needs to be fixed (willingness to block) or removed.
01:12:26 <brainycmurf> Neal: It would be super weird to remove, say, Contacts, because a chunk of basic functionality is the whole OS capability compared to alternatives. Not just the app itself, but the whole environment having functionality. People are Ok with imperfect apps that kindof work.
01:12:30 <brainycmurf> Kalev: Contacts doesn't make much sense on its own, OK with removing it.
01:12:32 <brainycmurf> Michael: Upstream plan is to add Geary but it's not ready yet, though there is an active maintainer, it should be ready for GNOME Core soon.
01:12:35 <brainycmurf> Chris: I think it may just be case by case. Not the guidance QA wants to hear but ...
01:12:37 <brainycmurf> #topic Future of dual booting Windows and Fedora
01:12:39 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/278
01:12:43 <brainycmurf> Brief overview of the issues, upstream will be slow, should investigate a GNOME Shell method of choosing.
01:12:46 <brainycmurf> #action Allan to set up a separate call with interested parties
01:12:48 <brainycmurf> #topic Announcements, Status Updates
01:12:50 <brainycmurf> #info Cannot switch to Boot Options on reboot
01:12:52 <brainycmurf> #link  https://bugzilla.redhat.com/show_bug.cgi?id=2124043
01:12:54 <brainycmurf> #info gnome-info-collect released, Fedora Magazine covered it
01:12:56 <brainycmurf> #link https://fedoramagazine.org/help-improve-gnome-using-gnome-info-collect/
01:12:58 <brainycmurf> #info Neal has a PoC to get H264 properly installed and Anaconda properly uninstalled on first boot.
01:13:01 <brainycmurf> #link https://pagure.io/fedora-autofirstboot
01:13:03 <brainycmurf> #info The minutes from last week have been posted.
01:13:05 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-08-30/workstation.2022-08-30-16.23.log.html
01:14:14 <brainycmurf> #endmeeting