16:18:44 <brainycmurf> #startmeeting Workstation WG (2022-09-27)
16:18:44 <zodbot> Meeting started Tue Sep 27 16:18:44 2022 UTC.
16:18:44 <zodbot> This meeting is logged and archived in a public location.
16:18:44 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:18:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:18:44 <zodbot> The meeting name has been set to 'workstation_wg_(2022-09-27)'
16:18:44 <brainycmurf> #meetingname workstation
16:18:44 <zodbot> The meeting name has been set to 'workstation'
16:18:44 <brainycmurf> #chair Allan
16:18:44 <zodbot> Current chairs: Allan brainycmurf
16:18:57 <brainycmurf> #info Present members: Tomas, Michael, Kalev, Allan, Matthias, Jens, Neal, Chris
16:18:57 <brainycmurf> #info Guests:
16:18:57 <brainycmurf> #info Regrets:
16:18:57 <brainycmurf> #info Missing:
16:18:57 <brainycmurf> #info Secretary: Tomas
16:18:58 <brainycmurf> #topic F37 release status
16:19:00 <brainycmurf> #info Final freeze: 4 October
16:19:02 <brainycmurf> #info Early target release date: 18 October
16:19:04 <brainycmurf> #info Kalev will be on vacation in October: 10 - 24
16:19:06 <brainycmurf> Matthias will ask David to keep an eye on freeze exception
16:19:08 <brainycmurf> Some discussion around recent Silverblue breakages, started by Matthias:
16:19:10 <brainycmurf> - grub-mkconfig broke again. Colin recently merged a change to use bootupd (?), which should improve this going forward
16:19:13 <brainycmurf> #link https://github.com/fedora-silverblue/issue-tracker/issues/120
16:19:15 <brainycmurf> - some problems with fontconfig cache format changes. We will take the discussion about possible fixes upstream:
16:19:18 <brainycmurf> #link https://github.com/fedora-silverblue/issue-tracker/issues/305
16:19:20 <brainycmurf> #link https://gitlab.freedesktop.org/fontconfig/fontconfig/-/issues/330
16:19:24 <brainycmurf> #topic Accepted blockers
16:19:26 <brainycmurf> #info VERIFIED - [abrt] totem: nouveau_pushbuf_data(): totem killed by SIGABRT
16:19:28 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2123274
16:19:30 <brainycmurf> #info mesa multithreading issue. Looks like the upstream fixes have been backported.
16:19:32 <brainycmurf> Done!
16:19:34 <brainycmurf> #info NEW - Windows with bitlocker enabled can't be booted, needs to use bootnext instead of chainloader
16:19:37 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2049849
16:19:39 <brainycmurf> No developments since last week. Adam proposal to drop the release criteria still stands.
16:19:41 <brainycmurf> #info No update from last week
16:19:43 <brainycmurf> #info ASSIGNED - Abrt does not report a segfault which is reported in journalctl.
16:19:45 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2128662
16:19:47 <brainycmurf> Issue from last Wednesday. Unclear how much progress has been made on a fix.
16:19:49 <brainycmurf> #info No update, but some progress
16:19:53 <brainycmurf> #info VERIFIED - gnome-software: Correct property name in GsRemovalDialog .ui file
16:19:55 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2125569
16:19:57 <brainycmurf> #info Done!
16:19:59 <brainycmurf> #info ON_QA - Gnome-Maps crashes when searching for locations.
16:20:01 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2129914
16:20:03 <brainycmurf> Upstream libsoup3 patch backported by Kalev
16:20:05 <brainycmurf> #info In testing
16:20:07 <brainycmurf> #topic Proposed blockers
16:20:09 <brainycmurf> #info NEW - Nautilus thumbnailing doesn't work on hidpi screens
16:20:11 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2127618
16:20:13 <brainycmurf> Matthias has an open GLib MR for this. https://gitlab.gnome.org/GNOME/glib/-/merge_requests/2918 (proper fix) /  but it needs a corresponding nautilus change that nobody has written.
16:20:16 <brainycmurf> https://gitlab.gnome.org/GNOME/nautilus/-/merge_requests/977 (revert of the offending change)
16:20:18 <brainycmurf> Declined as blocker, approved as Freeze Exception. QA to review again next week.
16:20:20 <brainycmurf> #action Matthias to follow-up on this one.
16:20:24 <brainycmurf> #topic Approved Freeze exceptions
16:20:26 <brainycmurf> #info POST - systemd returns an empty string for the chassis type
16:20:28 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2129343
16:20:30 <brainycmurf> This is the missing Device Security panel issue. We're waiting on Richard's downstream systemd PR to be merged and released.
16:20:33 <brainycmurf> [tpopela] - I'm surprised by double standards in https://pagure.io/fedora-qa/blocker-review/issue/919
16:20:36 <brainycmurf> Declined as blocker, approved as Freeze Exception
16:20:38 <brainycmurf> #info Pending MR, Tomas will ping at the end of the week if no action by then
16:20:40 <brainycmurf> #info NEW - GNOME keeps activating airplane mode on startup [when wi-fi and bluetooth are disabled]
16:20:43 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2129533
16:20:45 <brainycmurf> Ongoing discussion in https://gitlab.gnome.org/GNOME/gnome-settings-daemon/-/issues/704
16:20:47 <brainycmurf> Declined as blocker, approved as Freeze Exception
16:20:49 <brainycmurf> No changes in the gnome-settings-daemon code, might be something deeper down.
16:20:51 <brainycmurf> #action Matthias will look for a volunteer to dig
16:20:55 <brainycmurf> Others: https://qa.fedoraproject.org/blockerbugs/milestone/37/final/buglist
16:20:57 <brainycmurf> #topic Give ABRT some lurve
16:20:59 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/130
16:21:01 <brainycmurf> We should ask the ABRT maintainers about the state of the project (as our issues are not being addressed). Based on the answer we should evaluate whether ABRT might be included in Fedora Workstation or not. We could also bring the subject on the fedora-devel to see what the community thinks.
16:21:05 <brainycmurf> #action Tomas to get in touch with project owners to figure out the current resources that are allocated to the project.
16:21:08 <brainycmurf> #topic Consider limiting journal size
16:21:10 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/213
16:21:12 <brainycmurf> Latest action was to create a concrete proposal, but who should do this, and where would the proposal go?
16:21:15 <brainycmurf> We probably should involve systemd people (starting with Zbyszek)
16:21:17 <brainycmurf> #action Chris to evaluate the current state
16:21:19 <brainycmurf> #topic Announcements, Status Updates
16:21:21 <brainycmurf> #info The minutes from last week have been posted.
16:21:25 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2022-09-20/workstation.2022-09-20-22.40.log.html
16:21:28 <brainycmurf> #endmeeting