21:38:26 <brainycmurf> #startmeeting Workstation WG (2023-01-17)
21:38:26 <zodbot> Meeting started Tue Jan 17 21:38:26 2023 UTC.
21:38:26 <zodbot> This meeting is logged and archived in a public location.
21:38:26 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
21:38:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:38:26 <zodbot> The meeting name has been set to 'workstation_wg_(2023-01-17)'
21:38:26 <brainycmurf> #meetingname workstation
21:38:26 <zodbot> The meeting name has been set to 'workstation'
21:38:26 <brainycmurf> #chair Michael
21:38:26 <zodbot> Current chairs: Michael brainycmurf
21:38:38 <brainycmurf> #info Present members:  Michael, Allan, Chris, Jens, Kalev, Tomas, Neal
21:38:39 <brainycmurf> #info Guests:
21:38:39 <brainycmurf> #info Regrets: Matthias, Owen
21:38:39 <brainycmurf> #info Secretary: Kalev
21:38:39 <brainycmurf> #topic totem is broken
21:38:39 <brainycmurf> #link https://bugzilla.redhat.com/show_bug.cgi?id=2155639
21:38:43 <brainycmurf> #info Recent mesa update has broken totem and other gstreamer using apps on AMD GPU.
21:38:45 <brainycmurf> #action: Kalev to talk to airlied to see if we can do a downstream workaround.
21:38:47 <brainycmurf> #action: Michael to talk to Niels to ensure ownership of mesa package is correct.
21:38:49 <brainycmurf> #topic Reconsider use of adwaita-qt
21:38:51 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/351
21:38:53 <brainycmurf> Jan couldn't join the meeting, but he left notes in https://pagure.io/fedora-workstation/issue/351#comment-835818
21:38:56 <brainycmurf> Allan points out that the bigger apps ship their own Qt themes. However most of the apps use the default theme, which is Adwaita-Qt right now.
21:38:59 <brainycmurf> The workstation WG members don't have a lot of experience with Qt.
21:39:01 <brainycmurf> Allan: The mediawriter theming is still a bit off of what we hoped how it would look. The Windows and Mac themes don't look very good either.
21:39:04 <brainycmurf> One reason why we have shipped the Adwaita-Qt theme is to make sure mediawriter has the look of a gtk app. Tomas: Mediawriter is written in Qt instead of gtk because Qt has a much better cross-platform support.
21:39:07 <brainycmurf> Allan: Why do we need a Fedora custom media writer for Mac and Windows?
21:39:09 <brainycmurf> Neal: Lists lots of reasons why the existing media writers are broken so we really need one for Mac and Windows.
21:39:14 <brainycmurf> Other image writers don't write our images correctly (would be good to have details here)
21:39:16 <brainycmurf> Also other image writers don't handle ARM images or running on macOS well
21:39:18 <brainycmurf> Other examples of distro media writers:
21:39:20 <brainycmurf> #link https://software.opensuse.org/package/imagewriter
21:39:22 <brainycmurf> #link http://wiki.rosalab.ru/en/index.php/ROSA_ImageWriter
21:39:24 <brainycmurf> Neal would like to keep a Qt theme that makes apps look like native desktop. A problem is that we don't have a QML port of the adwaita-qt theme, but pure Qt apps get the theme correctly.
21:39:27 <brainycmurf> #action: Neal to write down his thoughts in the ticket.
21:39:29 <brainycmurf> #topic Shorter shutdown timer proposal will be discussed at today's FESCo meeting
21:39:31 <brainycmurf> #link https://pagure.io/fesco/issue/2928
21:39:33 <brainycmurf> The vote count is currently at +1, -2 (out of 9 members).
21:39:35 <brainycmurf> What are the offending services? PackageKit, virtualization (qemu, libvirt), podman
21:39:37 <brainycmurf> FESCo has concerns that this is trying to hide problems in services. Michael to go to the FESCo meeting to discuss this.
21:39:42 <brainycmurf> Is it a concern that core dumps take up a lot of space? A reason why we want to do core dumps when a service fails to shut down is because we don't have a better way of logging failures.
21:39:45 <brainycmurf> Jens: 15 seconds feels fairly short.
21:39:47 <brainycmurf> #action Neal and Michael to go to FESCo meeting
21:39:49 <brainycmurf> #topic Reconsider scope of Fedora Flatpaks
21:39:51 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/352
21:39:53 <brainycmurf> Deferred to next week
21:40:10 <brainycmurf> #endmeeting