19:37:36 <brainycmurf> #startmeeting Workstation WG (2023-02-14)
19:37:36 <zodbot> Meeting started Wed Feb 15 19:37:36 2023 UTC.
19:37:36 <zodbot> This meeting is logged and archived in a public location.
19:37:36 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:37:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:37:36 <zodbot> The meeting name has been set to 'workstation_wg_(2023-02-14)'
19:37:36 <brainycmurf> #meetingname workstation
19:37:36 <brainycmurf> #chair Michael
19:37:36 <zodbot> The meeting name has been set to 'workstation'
19:37:36 <zodbot> Current chairs: Michael brainycmurf
19:37:51 <brainycmurf> #info Present members: Tom, Michael, Kalev, Owen, Chris, Allan, Matthias,
19:37:51 <brainycmurf> #info Guests:
19:37:51 <brainycmurf> #info Regrets: Jens, Neal
19:37:52 <brainycmurf> #info Secretary: Chris
19:37:52 <brainycmurf> #topic Fedora 38 beta blockers
19:37:52 <brainycmurf> #link https://qa.fedoraproject.org/blockerbugs/milestone/38/beta/buglist
19:37:54 <brainycmurf> 0 bugs proposed / 0 bugs approved for the GNOME related components
19:37:56 <brainycmurf> We like the idea of doing a review of the blocker bug list at the start of each meeting for this cycle.
19:37:59 <brainycmurf> #topic Fedora 38 final blockers
19:38:01 <brainycmurf> #link https://qa.fedoraproject.org/blockerbugs/milestone/38/final/buglist
19:38:03 <brainycmurf> 1 bug proposed / 0 bugs approved for the GNOME related components
19:38:05 <brainycmurf> #1: Mnemonics are not visible with gtk-hint-font-metrics (enabled by default in Fedora 37) in GTK4 apps
19:38:10 <brainycmurf> https://bugzilla.redhat.com/show_bug.cgi?id=2145219
19:38:12 <brainycmurf> Matthias doesn't have an idea how to fix that.
19:38:14 <brainycmurf> #topic encryption of user data (excludes system)
19:38:16 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/82
19:38:18 <brainycmurf> #topic encryption of system data (excludes user)
19:38:20 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/136
19:38:22 <brainycmurf> Michael summarizes the two issues. WG approved FDE using LUKS. Internationalization team expressed concern over the early boot environment not having the resources needed to express the desired UI.
19:38:25 <brainycmurf> Allan: Accessibility is also a problem.
19:38:27 <brainycmurf> Michael: Interim approach? This should have been done a long time ago.
19:38:29 <brainycmurf> Owen: Discussion of systemd-homed and fscrypt as possible solutions.
19:38:31 <brainycmurf> Chris: systemd-homed needs a leader who can help with the GNOME integration; fscrypt btrfs code has landed upstream but following review there will be significant changes, so it's not a near term option. Note that systemd-homed can put user home on either a LUKS-based loop mounted file, or fscrypt. So while it's more work initially to support homed, than just flip the existing checkbox in anaconda, we can support new technologies
19:38:36 <brainycmurf> via homed as they become available, while also solving other common problems with the conventional FDE-LUKS approach.
19:38:41 <brainycmurf> Owen: Not clear we have an upstream partner systemd upstream to assist with the GNOME integration and gaps in implementation. Implies a significant change compared to the current FDE-LUKS approach. Are there improvements with that conventional approach needed in order to make it the default? Would we use autologin? Would we want Users panel to change both LUKS and login pasphrases?
19:38:46 <brainycmurf> Allan: Password hints or some kind of recovery
19:38:48 <brainycmurf> Owen: We'd need additional warnings and/or a reset mechanism, to indicate to users the seriousness of losing the user and recovery passphrases.
19:38:51 <brainycmurf> Allan: I don't think it should be enabled by default. Too much confusion, difficult to understand and opaque, plus piling on the various other issues accessibility, internationalization, multiuser UX. Opposite direction of having a good experience for new users.
19:38:55 <brainycmurf> Owen: Our downstream may not accept the homed approach so (current) FDE-LUKS wouldn't go away and (we'd need a way to deconflict).
19:38:58 <brainycmurf> Allan: We could outline on devel@ the issues and see where that goes.
19:39:00 <brainycmurf> Owen: Identified the problems and requirements with the doing nothing, the current LUKS option, and systemd-homed - I would like to see this in document form, that lays out the pros/cons for all the options.
19:39:03 <brainycmurf> Allan: Are there other projects that could be interested in making this work?
19:39:05 <brainycmurf> #info This is still a top goal but Workstation WG alone can't make this happen, it needs broader support.
19:39:10 <brainycmurf> #action Owen will summarize this discussion as an invitation to explore it further.
19:39:12 <brainycmurf> Allan also interested in seeing this issue progress.
19:39:14 <brainycmurf> Out of time to conclude the discussion today.
19:39:16 <brainycmurf> #topic Make the test day results more useful
19:39:18 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/329
19:39:20 <brainycmurf> Deferred
19:39:22 <brainycmurf> #topic Reconsider use of adwaita-qt
19:39:24 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/351
19:39:26 <brainycmurf> Deferred
19:39:28 <brainycmurf> #topic Announcements and status updates
19:39:30 <brainycmurf> none
19:39:32 <brainycmurf> #info Last week's meeting minutes posted
19:39:34 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2023-02-07/workstation.2023-02-07-19.55.log.html
19:39:39 <brainycmurf> #info GNOME 44 UI freeze / beta release happened last Saturday
19:39:49 <brainycmurf> #endmeeting