03:42:07 <brainycmurf> #startmeeting Workstation WG (2023-12-05)
03:42:07 <zodbot> Meeting started Wed Dec  6 03:42:07 2023 UTC.
03:42:07 <zodbot> This meeting is logged and archived in a public location.
03:42:07 <zodbot> The chair is brainycmurf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
03:42:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
03:42:07 <zodbot> The meeting name has been set to 'workstation_wg_(2023-12-05)'
03:42:07 <brainycmurf> #meetingname workstation
03:42:07 <zodbot> The meeting name has been set to 'workstation'
03:42:07 <brainycmurf> #chair Michael
03:42:07 <brainycmurf> #info Present members: Michael, Owen, Kalev, Allan, Chris
03:42:07 <zodbot> Current chairs: Michael brainycmurf
03:42:07 <brainycmurf> #info Guests:
03:42:07 <brainycmurf> #info Regrets: Tomas, Matthias, Jens
03:42:09 <brainycmurf> #info Missing:
03:42:11 <brainycmurf> #info Secretary:Owen
03:42:13 <brainycmurf> #topic Switch from meet.opensuse.org to a different conferencing platform
03:42:15 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/403
03:42:17 <brainycmurf> #info new setup (meet-test.opensuse.org) working well for some people, some people seeing video bugs; extensive discussion of alternatives. Will keep meet-test.opensuse.org for now.
03:42:20 <brainycmurf> #topic Enable full preemption
03:42:22 <brainycmurf> #link https://pagure.io/fedora-workstation/issue/228
03:42:24 <brainycmurf> #info Owen with general agreement suggested that doing this by kernel command line is not great - very hard to upgrades, hard to do just for some variants. Chris sent a mail to llkml some time ago about moving switch from debugfs to sysfs, but didn't get a response.
03:42:28 <brainycmurf> #info Neal would like to see characterization of this on server workloads so that we could enable across variants
03:42:31 <brainycmurf> #info Discussion of whether we *know* this is desktop only, or might make sense for server workloads as well - especially now that serv7ers are often running more complex workloads with cgroups, etc.
03:42:36 <brainycmurf> #info Discussion of how to test - what are the (desktop) workloads that we expect this to make a difference - OBS streaming? Audio? (Fedora Jam apparently sets up preempt=full). Is sysprof useful for testing whether preempt=full improves responsiveness/smoothess of GNOME shell under high load
03:42:40 <brainycmurf> #action Chris and Neal to check in with members of Meta kernel team to see if they have insight about moving the switch out of debugfs - or how to move forward for there.
03:42:43 <brainycmurf> #topic Announcements and status updates
03:42:45 <brainycmurf> #link https://discussion.fedoraproject.org/t/learning-from-the-f40-tuned-replaces-ppd-change-proposal/97786
03:42:48 <brainycmurf> #info discussion of role of working group vs. fesco in change proposal process
03:42:50 <brainycmurf> #info Allan change proposals were conceived as "notification" of things coming from upstream
03:42:52 <brainycmurf> #info Neal - there's a split between notications of upcoming upstream changes, and change proposals for work that is being done downstream - specific to fedora, and the second set of things is getting larger; policy documents lag behind.
03:42:56 <brainycmurf> #info Nobody wanted to copy the releng part where there has to be a ticket filed
03:42:58 <brainycmurf> #info Allan felt there isn't enough time between posting and voting - that voting can get in the way of the discussion.
03:43:01 <brainycmurf> Minutes from last week:
03:43:03 <brainycmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2023-11-30/workstation.2023-11-30-01.07.log.html
03:43:08 <brainycmurf> #endmeeting