21:00:11 <rbergeron> #startmeeting Cloud SIG
21:00:11 <zodbot> Meeting started Thu Dec 9 21:00:11 2010 UTC. The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:13 <jsmith> rbergeron: Relish!
21:00:14 <smooge> well you don't want a new one...
21:00:29 * rbergeron passes a vegan-friendly carrot to skvidal
21:00:35 <rbergeron> #meetingname Cloud SIG
21:00:35 <zodbot> The meeting name has been set to 'cloud_sig'
21:00:40 <rbergeron> #topic Roll call
21:00:45 <brianlamere> hey, I'm vegan too, where's my love?
21:00:46 <rbergeron> Yo. Who's here :)
21:00:51 <brianlamere> I'm here
21:01:00 * jforbes is here
21:01:03 * jdarcy <- present
21:01:03 * rbergeron isn't really sure that a carrot is love, it's more like "robyn's weak excuse for a vegan food"
21:01:05 * mmorsi1 is here
21:01:13 <gholms> bacon
21:01:15 <rbergeron> mgoldmann ;)
21:01:33 * rbergeron assures the vegans that she does love them, so as not to offend.
21:01:35 * jsmith is here
21:01:48 <rbergeron> hey mmorsi1.
21:01:52 * obino is here
21:01:52 <mgoldmann> uhm? :)
21:01:52 * sgordon is here
21:01:54 <mgoldmann> here!
21:01:54 <mmorsi1> rbergeron: howdy
21:01:57 <sdake> sup
21:02:10 * rbergeron waves at sdake
21:02:16 <mmorsi1> clalence can't make it today so i'm going to try and take his place
21:02:24 <mmorsi1> course noone can replace clalence ;-)
21:02:28 <rbergeron> awesome. thanks for joining :)
21:02:36 <mmorsi1> np
21:02:36 <jsmith> Cool... looks like we've got a great set of folks here :-)
21:02:44 <rbergeron> no no. you'll become addicted and you'll both want to come ;)
21:02:50 <rbergeron> jsmith: indeed.
21:02:58 <rbergeron> #topic EC2
21:03:04 <mmorsi1> hehe
21:03:06 * jsmith has been playing with EC2 a bit today :-)
21:03:23 * jgreguske waves
21:03:26 <rbergeron> jforbes, gholms, brianlamere, how goes it?
21:03:27 <jsmith> (and found that the python-boto package in updates-testing works much better)
21:03:27 <jdarcy> Too bad zaitcev isn't here. Seems to be the hero of the day.
21:03:33 <rbergeron> oh.
21:03:37 <jsmith> Oh?
21:03:40 <rbergeron> jdarcy: do tell
21:03:54 <jdarcy> Fixed a bug in euca2ools that was annoying people a bit.
21:04:00 <jforbes> Well, we have a couple of things to discuss for EC2
21:04:13 <rbergeron> jforbes: go ahead :)
21:04:16 <mgoldmann> he's here!
21:04:17 <mgoldmann> :)
21:04:17 <rbergeron> oh look. THERE's our hero.
21:04:22 <brianlamere> too bad that guy isn't here that's here
21:04:31 * rbergeron checks to see if this is a record cloud-sig meeting attendance
21:04:44 <rbergeron> #chair jforbes jsmith
21:04:44 <zodbot> Current chairs: jforbes jsmith rbergeron
21:04:48 <rbergeron> #chair gholms
21:04:48 <zodbot> Current chairs: gholms jforbes jsmith rbergeron
21:04:49 <obino> just in case this was the bug https://bugs.launchpad.net/bugs/665667
21:04:52 <jforbes> First, there has been some discussion on how we have a testable image, and avoid things like the httpd issue. Particularly since httpd isnt in the default issues
21:04:59 * rbergeron nods
21:05:03 <jforbes> err default images... reading and typing is bad
21:05:25 <brianlamere> yeah, I can tell you I ran in to the problem with far more than just httpd ;)
21:05:33 <rbergeron> jforbes: suggestions?
21:05:33 <jforbes> So I think we should discuss what we really want in the default images, perhaps there should be a basic set of services
21:05:33 <jsmith> Well, it's not so much that we want to test httpd in particular -- just test *something* to make sure we don't run into a similar issue
21:05:48 <rbergeron> jforbes: shall we do that now?
21:05:53 <rbergeron> I think we have enough people, fo sho.
21:06:02 <brianlamere> yes, stand up an entire stack, and run lots of stuff.
21:06:09 <mgoldmann> I thought it should be @core
21:06:09 <jforbes> jsmith: right, so httpd was just an example that just happened to bite us
21:06:17 <rbergeron> or at least, after you get to anytihng else you have to say :)
21:06:28 <brianlamere> Note however: this was actually an issue that is known to exist with their hypervisors, it just was known...a while back.
21:06:35 <rbergeron> #info it would be helpful to discuss a basic set of services, and what that would entail.
21:06:43 * jsmith thinks a minimal package set is the way to go, and let folks add their favorite packages on top
21:06:50 <gholms> @core is a basic set of services. Let's use that.
21:07:00 <rfelsburg> I know I'm new here, so maybe this is common knowledge, but are we using yum for package management on everything, or just the basics
21:07:03 <brianlamere> yes - truly, let it be minimal still
21:07:07 <gholms> rfelsburg: yum
21:07:11 <jforbes> mgoldmann: @core was the plan, but it brings up a good point. What is tested, how do we get this tested?
21:07:28 <brianlamere> rfelsburg: yes, it is intended to be transparent, and behave like a normal fedora install
21:07:33 <rfelsburg> are we using it for major items like apache, ssh etc.?
21:07:41 <mgoldmann> well, it seems boot isn't sufficient :)
21:07:51 <gholms> rfelsburg: Not by default, though people can certainly install it.
21:08:12 <jforbes> right, so the old criteria was boot and run yum
21:08:29 <gholms> IMO, we should install enough to let get people a shell on it and also have selinux support.
21:08:33 <jforbes> obviously ssh gets tested as well, you can't run yum if you can't ssh into it
21:08:34 <mgoldmann> we can try to define list of services users will most probably install and try to create basic test for them maybe
21:08:39 <brianlamere> rfelsburg: the only things on the image are the things you need to have on the image to install other things on the image. :) like, ssh
21:08:48 <rbergeron> mgoldmann: I agree with that.
21:08:52 <rfelsburg> brianlamere: what I was getting at, was anything more than a minimal install brings lots of dependencies that aren't always removed when the package itself is. so i would go extremely limited essentially ssh and security
21:08:58 <mmorsi1> with appropriate firewall rules presetup of course
21:08:59 <mgoldmann> apache is on the top I think :)
21:08:59 <rbergeron> jforbes: so we're looking at two things here, right?
21:09:01 <gholms> Selinux is kind of a big feature for Fedora, so having support for that out of the box would probably be a good idea.
21:09:09 <rbergeron> #1 being - What is the basic package set to install
21:09:15 <jsmith> +1 to SELinux
21:09:16 <skvidal> rfelsburg: that's fixed a lot better now in yum
21:09:18 <jforbes> So leave the images as @core, and come up with a test plan that includes installing/testing some basic services?
21:09:19 <skvidal> rfelsburg: upstream
21:09:24 <rbergeron> #2 being - what are the most likely things users will want to yum install afterwards.
21:09:25 <gholms> jforbes: +1
21:09:27 <brianlamere> rfelsburg: yup, that's what's there
21:09:28 <rbergeron> And how to test them.
21:09:29 <jsmith> jforbes: That works for me :-)
21:09:33 <mgoldmann> jforbes: +!
21:09:37 <mgoldmann> +1 even
21:09:38 <mgoldmann> :)
21:09:50 <rbergeron> #agreed leave images as @core and come up with a test plan that includes instlling/testing some basic services.
21:09:55 <gholms> yum and httpd come to mind as things one might immediately install
21:09:57 <skvidal> is it possible we could use the user_data like some other distros do with the #! check?
21:10:00 <gholms> s/install/use/
21:10:07 <rfelsburg> skvidal: fixed ala f14? cause i was still seeing some prettty large holws with regards to dependency removal in f12
21:10:19 <brianlamere> well the reality is, Fedora at EC2 will be used primarily for a relatively limited number of tasks. LAMP, etc.
21:10:21 <gholms> skvidal: The hope is to port cloud-init (the system they use) to RH-type distros.
21:10:21 <skvidal> rfelsburg: it's fixed in rawhide - it'll find it's way back to f14
21:10:26 <skvidal> rfelsburg: and you can do yum history undo
21:10:27 <mgoldmann> skvidal: yes, we can
21:10:27 <jgreguske> probably want to test stuff that isn't defined by the package set too, like selinux on/off, fs size
21:10:39 <skvidal> gholms: that'd be what I'd like to see
21:10:39 <jdarcy> For the specific case of the negative-segment-offset bug, I suspect anything which uses thread-local storage (at least) would tickle it, so we might be able to go for something lighter-weight than httpd for regression purposes.
21:10:40 <gholms> skvidal: I was going to do that but then I got bogged down in moving cross-country.
21:10:42 <brianlamere> rfelsburg: dependency hell has been getting less hell and more heck as time goes on
21:10:50 <jforbes> So anyone want to take a stab at the test plan? or even at the list of services to be tested?
21:11:02 <rfelsburg> skvidal: thanks I'll look into it.
21:11:11 <rbergeron> I think if someone wants to take a crack @ a list of services on the mailing list, that would be good.
21:11:14 <brianlamere> jdarcy: we've solved that particular issue, though - the trick is what is sufficient for finding new ones
21:11:16 <rbergeron> And we can add on as needed.
21:11:21 <jsmith> jforbes: I can give it a start
21:11:21 <gholms> skvidal: I'm not sure what goes on at a python hack-a-thon, but if that sounds like a good candidate for it then that might be a good time.
21:11:23 <rbergeron> Or alternately, we can do it now.
21:11:29 <rbergeron> jsmith: thank you sir :)
21:11:31 <rfelsburg> brianlamere: yea installing was never an issue, getting yum to remove the same deps it installed was a problem in fedora12 for me.
21:11:32 <jsmith> #action jsmith to take a first stab at a test plan
21:11:50 <skvidal> rfelsburg: http://skvidal.wordpress.com/2010/11/09/orphaned-dep-cleanup-in-yum/
21:11:54 <sloranz> is there any merit to having puppet in the base build to combine yum for package install and puppet for service/system config?
21:12:06 <mmorsi1> sloranz: you took the question right out of my mouth :-)
21:12:11 <skvidal> sloranz: puppet drags in the whole world in deps
21:12:17 <brianlamere> rfelsburg: that's more a general fedora issue however, not a fedora-cloud issue; we're a specific task group here ;)
21:12:21 <skvidal> having ruby on there feels extra heavyweight
21:12:21 <mgoldmann> for base build? -1
21:12:30 <gholms> sloranz: People who automate to that extent should really be rolling their own images based off of our stock one.
21:12:30 <mmorsi1> but makes configuring other services alot easier
21:12:34 <jdarcy> We should probably throw in any packages that are related to being in EC2, such as boto for S3.
21:12:40 <jforbes> jsmith: thanks, that would be great!
21:12:54 <rfelsburg> brianlamere: sorry that related to how minimal of an image was installed by default, im advocating for fairly minimal
21:13:04 <gholms> jdarcy: What would be the point?
21:13:10 <rfelsburg> skvidal: touchè
21:13:23 <brianlamere> when I first joined the list I did so to try to promote cloud-ish tools that would be helpful to me personally ;) so either puppet, or the openssh-ldap stuff, etc
21:13:37 <jdarcy> gholms: To test functionality that people using those images are very highly likely to use.
21:13:38 <brianlamere> rfelsburg: ah, yeah, it's really quite minimal
21:13:39 <mmorsi1> this may make building / testing these images alot harder but would it make sense to have multiple fedora images with different stacks ontop
21:13:49 <rbergeron> #info LOTS OF SUGGESTIONS for test plans / what to be tested in this meeting log.
21:13:58 <gholms> rbergeron: :P
21:14:06 <sdake> spins of specific target types are interesting but create a big test matrix
21:14:10 <gholms> jdarcy: I can see that as an argument for test cases, but not packages to go in the default install.
21:14:14 <rbergeron> gholms: just noting for people who skim the minutes ;)
21:14:17 <mmorsi1> sdake: agreed
21:14:18 <gholms> rbergeron: Yep
21:14:18 <sdake> that is essentially appliance model
21:14:25 <rfelsburg> Why not just script the installation of different server types.
21:14:32 <rfelsburg> instead of building it into the image itself.
21:14:39 <sdake> we would do well to test "one" build first :)
21:14:47 <gholms> rfelsburg: That's what boxgrinder is supposed to do.
21:14:52 <jsmith> sdake: I agree... let's get *something* tested first
21:14:54 <mmorsi1> rfelsburg: puppet might make that scripting easier
21:15:01 <mmorsi1> aight that makes sense
21:15:03 <rfelsburg> it would def. make it easier.
21:15:12 <brianlamere> just create meta-packages that create a particular type of appliance. Spin up a micro, install meta package...should be pretty fast?
21:15:14 <skvidal> if you use the cloud_init scripts
21:15:21 <skvidal> then you don't need the puppet-specificness
21:15:23 <skvidal> you can bootstrap
21:15:25 <rfelsburg> mmorsil: Thats what I do in our production environments.
21:15:25 <skvidal> from your boot
21:15:33 <jeremy> brianlamere: we have comps groups, why build meta-packages?
21:15:34 <gholms> skvidal has a good point.
21:15:47 <skvidal> jeremy: b/c wheel reinvention rocks?
21:15:51 <jeremy> skvidal: clearly.
21:16:00 <brianlamere> jeremy: because comp groups are for anaconda to use. I'm talking about unit testing post-install
21:16:06 <sdake> wheel is perfect, no point in reinventing that :)
21:16:19 * jeremy mumbles something about boxgrinder's config file format that mirrors nothing else in the world and then tries to use that to create a kickstart config
21:16:19 <gholms> brianlamere: yum groupinstall packagegroup
21:16:24 <jeremy> brianlamere: yum groupinstall dude
21:16:24 <skvidal> brianlamere: comps groups are used by ANY thing in yum
21:16:28 <skvidal> brianlamere: and can be in ANY yum repo
21:16:32 <skvidal> yum install @group too
21:16:35 <rbergeron> lol
21:16:35 <brianlamere> do comp groups really handle setting up a particular environment well? it's not just everything in a packagegroup :)
21:16:47 <rbergeron> JFORBES: anything else on ec2?
21:16:53 <gholms> Heh
21:16:54 * rbergeron tries to wrangle a bit of order to the meeting ;)
21:17:20 <mmorsi1> we need a digital conch shell (from lord of the flies)
21:17:21 <jforbes> rbergeron: not for the moment
21:17:31 <mmorsi1> but i digress ;-)
21:17:40 <rbergeron> how are the things as far as working around amazon's xen issue going?
21:18:02 <brianlamere> well, for that matter I suppose you could just install almost everything, and not worry about it ;) sorry, I guess I use the wrong tools for jobs sometimes ;) I use meta-packages because they help me pull from additional repositories. so comp groups then, sure ;)
21:18:28 <jforbes> Oh, right, amazon's issue isn't so much the issue anymore, we have a fedora issue, and I didnt get back to it until today. I think I have a workaround, just need to test it
21:18:28 <rfelsburg> gholms: yum package groups tend to be extremely encompassing, and oft quite a bit more than is needed.
21:18:44 <skvidal> rfelsburg: yum-groups-manager - make whatever you want
21:18:45 <rbergeron> jforbes: awesome. thank you
21:18:52 <gholms> jforbes: Just enabling nosegneg?
21:19:16 <mgoldmann> my vote for for testing stuff - I would execute script pushed as user_data, what we have in this script is another story
21:19:17 <jsmith> jforbes: If you'd like, send a brief description of the problem to the list, so that others can help hunt it down
21:19:18 <skvidal> brianlamere: comps groups can pull from multiple repos, too
21:19:24 <skvidal> brianlamere: it's not restricted to a single repo
21:19:46 <skvidal> mgoldmann: so put cloud_init tools in place to do that at boot?
21:20:03 <rfelsburg> skvidal: thansk
21:20:07 <mgoldmann> I'm not familiar with this, lemme take a look
21:20:09 <jforbes> gholms: that's the easy part... getting boxgrinder to work with the broken augeas in f13 is the issue, building f14 augeas for f13 seems to be the fix. Eventually (once boxgrinder is in the distro) we will need our own build images
21:20:21 <gholms> I seee.
21:20:37 <gholms> Can someone please help me look into porting cloud-init to an RH-type distro? It has a bunch of Ubuntu-specifics.
21:21:00 <rfelsburg> gholms: I can help.
21:21:14 <jgreguske> jforbes: stay in touch with fedora rel-eng, they're looking at using koji to build images
21:21:14 <sdake> jsmith if your interested in testing and having some basic idea that the system's posix apis are operating properly, might have a look at http://ltp.sourceforge.net/
21:21:24 <mgoldmann> jforbes: I'll try to build new meta-appliance based on F14 and release it shortly
21:21:33 <sdake> im sure that would have caught this http image problem
21:21:37 <rbergeron> #action rfelsburg and gholms to look into porting cloud-init to a RH-type distro
21:21:40 <mgoldmann> this should help you a lot I hope
21:21:51 <jforbes> sdake: maybe
21:21:53 * rbergeron looks around for other EC2 related hands in the air
21:22:04 <brianlamere> gholms: I could help, didn't I send you an email on it? I don't know that I got one back
21:22:14 <gholms> brianlamere: I received nothing. :(
21:22:15 <skvidal> gholms: most - but not all of what cloud_init does is in rc.local in the ami's that are listed on the fedora page
21:22:27 <brianlamere> gholms: well, I'll try again :)
21:22:29 <jforbes> sdake: the biggest problem with the httpd issue is only some hosts will show it, so luck of the draw
21:22:49 <gholms> skvidal: Basically. It would be good to get things in line with $other_popular_distro.
21:22:53 <brianlamere> jforbes: yeah, that's the issue. because some of their old hypervisors *are* patched
21:22:53 <skvidal> gholms: sure
21:23:01 <sdake> jforbes could set automated test on variety of vm types, such as xen, kvm, vmware
21:23:19 <dgilmore> jforbes: that would be me that jgreguske is refering to
21:23:20 <sdake> as part of build process
21:23:21 <rfelsburg> is there a ticket open for the httpd issue. I'm working with a prod environment in the cloud, and can maybe help.
21:23:33 <dgilmore> jforbes: id really love a kickstart file for ec2 images
21:23:44 <jforbes> dgilmore: okay, time to talk after this?
21:23:50 <dgilmore> jforbes: yep
21:23:59 <rbergeron> dgilmore: yeah, maybe we can hang on to that for later in the meeting or afterwards
21:23:59 <mgoldmann> rfelsburg: https://bugzilla.redhat.com/show_bug.cgi?id=651861
21:24:05 <gholms> .bug 651861
21:24:07 <zodbot> gholms: Bug 651861 hang in readdir64_r on i686 in EC2 - https://bugzilla.redhat.com/show_bug.cgi?id=651861
21:24:26 <brianlamere> that can realistically be tested locally, too - so that it's not really luck-of-the-draw. Perhaps just make local servers that are old, unpatched, and 32bit ;)
21:24:44 <rbergeron> #topic Boxgrinder
21:24:56 <mgoldmann> hey, that's me!
21:24:57 <rbergeron> I'm moving forward, folks, just trying to hold a lot of us together today :)
21:25:01 <brianlamere> the 64bit host machines shouldn't really (err...) have a problem ever, with the built-in virtualization
21:25:02 * rbergeron is delighted at the turnout. Thanks everyone!
21:25:12 <rbergeron> mgoldmann: How goes the BG feature?
21:25:30 <mgoldmann> almost all packages were approved
21:25:33 <mmorsi1> i was told there'd be punch and pie :-p
21:25:49 <mgoldmann> waiting for only one approval, everything else was built for F13/F14/rawhide
21:25:53 <rbergeron> mmorsi1: I'm gonna have to talk to clalance about the promises he's making you ;)
21:26:00 <mgoldmann> https://fedoraproject.org/wiki/Features/BoxGrinder#Current_status
21:26:01 <mmorsi1> hehe
21:26:10 <rbergeron> mgoldmann: does it need poking along / reviews from someone?
21:26:34 <mgoldmann> only waiting now for https://bugzilla.redhat.com/show_bug.cgi?id=652414
21:26:49 <mgoldmann> of course euca2ools needs to be solved too
21:27:07 <rbergeron> #topic need a review on https://bugzilla.redhat.com/show_bug.cgi?id=652414 for BG - last one!
21:27:12 <rbergeron> ugh
21:27:13 <rbergeron> #undo
21:27:13 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x160cb810>
21:27:29 <rbergeron> #topic Boxgrinder
21:27:32 <mgoldmann> but this is on it's own path, gholms and euva2ools are working on that
21:27:46 <obino> david is testing the fix
21:27:46 <rbergeron> #info need a review on https://bugzilla.redhat.com/show_bug.cgi?id=652414 for BG - last one!
21:27:56 <mgoldmann> thanks to zaitcev we have a patch for it
21:28:08 <mgoldmann> this will be included in upstream euca2ools
21:28:16 * rbergeron bows to zaitcev
21:28:18 <mgoldmann> next step is to release updated package in Fedora
21:28:20 <gholms> Wait, what?
21:28:26 <mgoldmann> no? :)
21:28:41 <gholms> Oh, that patch.
21:28:45 <jdarcy> Yay, Pete!
21:28:54 <mgoldmann> yes, patch :)
21:29:00 <gholms> It needs... work. When upstream merges a fix I will use that one.
21:29:18 <zaitcev> Mitch e-mailed me with: "I'm in the process of refactoring all of the euca2ools code so I will incorporate your suggestions in that new version. I'll patch the current euca2ools main, as well."
21:29:20 <mgoldmann> yes, this is what I'm trying to write :)
21:29:53 * gholms feel bad for neil, its original writer
21:30:18 <mgoldmann> so, the great news is that the euca2ools issue will be solved, finally :)
21:30:27 <obino> yes!
21:30:30 <obino> :)
21:30:31 <zaitcev> The problem is that he does not want to use tee(1). So most likelye he'll reimplement something very similar to my patch for 1.3 branch, e.g. we'll waste 2GB or 10GB of temp space per run.
21:30:32 <rbergeron> mgoldmann: very nice. thanks to all for helping, been a big team effort.
21:30:37 <mgoldmann> shortly after this - I'll submit last 3 (optional) packages
21:30:40 <gholms> #info euca2ools-1.3.1-4 should fix the bug that prevents its images from working on Amazon EC2
21:30:51 <zaitcev> He cannot use my patch as-is because I do not have Eucalyptus contributor agreement.
21:31:17 <gholms> zaitcev: He can't use it as-is anyway because it doesn't apply to the current code. No worries. ;)
21:31:47 <brianlamere> 2G to 10G per run? is that something we need to worry about? some small heads won't have 10G of tmp space avail...
21:32:11 <gholms> Otherwise I'd have given mgoldmann an interim-fixed RPM hours ago.
21:33:33 <gholms> Anyone running F13 that has a EC2 account?
21:33:36 * rbergeron looks to see if anyone has an answer to brianlamere's q before moving on :)
21:34:00 <jforbes> I have an F13 guest
21:34:05 <gholms> brianlamere: I'm more concerned about speed. That's a lot of time lost to disk writes.
21:34:33 <rfelsburg> sorry, thought that was a rhetorical questions. What's the usual swing on log disk usage
21:34:56 <jforbes> I take that back, I also have an F13 host, I just need to power it up
21:35:00 <brianlamere> maybe, but keep in mind that a micro is only starting out with 10G total ;)
21:35:09 <jsmith> gholms: I'm sure I could rustle up an F13 box (or vm)... why?
21:35:28 <brianlamere> jforbes: I could share my old F13 images to you, but I deleted them a few days ago ;)
21:35:37 <gholms> I need someone to install euca2ools-1.3.1-3 from updates-testing and make sure "euca-describe-images -a -U http://ec2.us-east-1.amazonaws.com/" works both with and without the trailing slash.
21:35:48 <gholms> The F13 package needs one more +1 to go stable.
21:35:59 <mgoldmann> gholms: do this yourself :)
21:36:10 <gholms> mgoldmann: It's bad form to +1 your own updates...
21:36:14 <gholms> .bug 658560
21:36:16 <zodbot> gholms: Bug 658560 fail with a trailing slash - https://bugzilla.redhat.com/show_bug.cgi?id=658560
21:36:20 <mgoldmann> well :)
21:36:22 <gholms> https://admin.fedoraproject.org/updates/euca2ools-1.3.1-3.fc13
21:37:14 <brianlamere> why not just use the JEOS Fedora 13 image, btw?
21:37:14 <gholms> That testing can take place offline; we don't need to wait for it here.
21:37:33 <gholms> jforbes: ^
21:38:00 <jforbes> okay, will do
21:38:14 <gholms> Thanks
21:38:18 <mmorsi1> gholms: trying right now
21:38:21 <mmorsi1> but continue on
21:38:28 <gholms> Thanks to you, too. :)
21:38:33 <zaitcev> Well, one quick "fix" is to pipe tar|gzip and store tar.gz on disk, then do gunzip|sha1. This trades CPU for disk space and I/O.
21:38:44 <mmorsi1> didn't even think you could +1 your own updates
21:39:20 <gholms> mmorsi1: The next time bodhi gets updated you won't be able to any more.
21:39:21 * mgoldmann tried this
21:39:41 <mmorsi1> ah
21:40:47 <rbergeron> okee dokee.
21:40:51 <mmorsi1> does it take a while, just sitting there?
21:40:59 * rbergeron shall move on, unless there are any other BG things
21:41:01 <mmorsi1> imagine since the ec2 image list is large it will
21:41:01 <rfelsburg> What tool are we talking about for the 2-10g disk usage
21:41:09 <mmorsi1> ah there it is
21:41:24 <mmorsi1> yes seems to work
21:41:26 <zaitcev> wife is making me eat, ttyl
21:41:36 <gholms> zaitcev: Thanks for posting that patch!
21:41:37 <mgoldmann> rbergeron: fwd
21:41:40 <rbergeron> zaitcev: have a good one :)
21:41:48 <mgoldmann> zaitcev: laters!
21:41:51 <rbergeron> mgoldmann: fwd? :)
21:41:53 <rbergeron> forward?
21:42:05 <mgoldmann> yah, next topic :)
21:42:06 <rbergeron> #topic CloudFS
21:42:06 <gholms> mmorsi1: Both with and without the trailing '/'? Could you add +1 to the update when you get a chance?
21:42:12 <rbergeron> jdarcy: speaketh :) how goes it
21:42:13 <gholms> Ooh, CloudFS!
21:42:25 <jdarcy> Churning away.
21:42:48 <jdarcy> I had some conversations with the upstream folks about repos and such, they need to get back to me.
21:42:50 <mmorsi1> gholms: http://fpaste.org/k8cq/ http://fpaste.org/nIOq/
21:42:56 <mmorsi1> that all i need to verify?
21:43:02 <mmorsi1> truncated the list
21:43:08 <rbergeron> jdarcy: we did get you a repo, right? I think ke4qqq did that.
21:43:21 <gholms> mmorsi1: Yeah. Just make sure it also works without the trailing '/' as well.
21:43:24 <rbergeron> a local one that is :)
21:43:26 <jdarcy> Yes, the Fedora repo does exist, but somehow I missed the mail-list-admin email.
21:43:37 <rbergeron> hmmm
21:43:41 <mmorsi1> gholms: ya the first one was w/out the / and the 2nd was with
21:43:41 <jdarcy> I'll start pushing up content next week probably.
21:43:51 <mmorsi1> k i'll give u the bump
21:43:55 <rbergeron> #info jdarcy will start pushing up content next week probably.
21:44:12 <gholms> Are you using repos.fedorapeople.org, or something else?
21:44:31 <rbergeron> gholms: CloudFS on fedorahosted
21:44:37 <jdarcy> http://git.fedorahosted.org/git/?p=CloudFS.git
21:45:11 <jdarcy> Also need to start putting together some web content describing the pieces.
21:45:12 <gholms> Oh for git hosting. Got it.
21:45:20 <rbergeron> jdarcy: yes plz. :)
21:45:43 <jdarcy> It's all coming along, just advancing on a broad front. ;)
21:46:11 <mmorsi1> gholms: bumped
21:46:16 <rbergeron> jdarcy: when we get closer to Beta/GA, there's also some room for marketing to come do interviews/feature profiles there.
21:46:22 <rbergeron> just as an FYI.
21:46:26 * rbergeron will put on her marketing team hat for that
21:46:36 <gholms> mmorsi1: Thanks
21:46:39 <jdarcy> That'll be good.
21:46:41 <mmorsi1> np
21:47:05 <rbergeron> #topic Deltacloud
21:47:21 <rbergeron> Anyone around still from deltacloud that might be able to talk about IF this might be going into F15?
21:47:37 <mmorsi1> rbergeron: sure, we're beginning to work on it
21:47:44 <mmorsi1> still very preliminary
21:47:47 <mmorsi1> but that is the goal
21:48:23 <rbergeron> mmorsi1: do you know if that's hoping to be on Featurelist?
21:48:30 <mmorsi1> unfortunately don't have too much to report other than that, but yes we are aiming to get this included and supported on both F15 and RHEL6
21:48:49 * rbergeron notes that feature submission deadline is 1-25
21:49:15 <mgoldmann> mmorsi1: any packages to help to test or something?
21:49:18 <rbergeron> mmorsi1: is there anything blocking anyone as far as packages, etc?
21:49:26 * rbergeron notes that mgoldmann is reading her mind
21:49:27 <mmorsi1> hrm not sure about the feature, but will add an item to my backlog to find out b4 next cloud-sig mtg
21:49:29 <rbergeron> spoooooky
21:49:31 <sdake> the prelim packages probably need a review
21:49:41 <rbergeron> #link http://fedoraproject.org/wiki/Schedule
21:49:42 * gholms hands rbergeron a tinfoil hat
21:49:47 <rbergeron> NO! that's not the link i want.
21:49:57 <rbergeron> #link http://deltacloud.org/page/Packaging_list
21:50:00 <rfelsburg> lol
21:50:00 <gholms> Undo?
21:50:01 <rbergeron> ^^^ is the link I want.
21:50:11 <rbergeron> It's okay. Having the schedule link isn't going to hurt :)
21:50:12 <mmorsi1> we do have some packages that still need some love, but afaik they are being worked on
21:50:24 <mgoldmann> rbergeron: uh, it's good you didn't pasted other link...
21:50:30 <mmorsi1> wouldn't hurt to get additional eyes to help out w/ the process tho
21:50:36 <rbergeron> mmorsi1: do you know if that list is relatively up to date?
21:50:57 <mmorsi1> also w/ ruby support on fedora in general, lot of discussion on ruby-sig pertaining to various issues
21:51:01 <rbergeron> wow, it looks like it - last updated dec. 8
21:51:11 <mmorsi1> yes that shuold be up2date
21:51:14 <rbergeron> ;)
21:51:40 <rbergeron> abadger1999: do you still have folks interested in doing ruby reviews?
21:51:44 <mmorsi1> we are making a point of not including additional dependencies w/out packaging them and getting started on teh fedora submission process first
21:51:59 <rbergeron> mmorsi1: that is good news :D
21:52:07 <brianlamere> woot! yes
21:52:17 <mmorsi1> believe me, i know ;-)
21:52:35 * rbergeron gives that 6 thumbs up
21:52:50 <mmorsi1> way to easy in the ruby world to pull in the latest greatest gem which hasn't been vetted yet, suppose thats the problem w/ being on bleeding edge
21:52:53 * rfelsburg worries that rbergeron has 6 thumbs
21:52:59 <mmorsi1> but always looking for improvements and new contributers
21:53:49 <rbergeron> mmorsi1: if you can let us know next week (since I know both you AND clalance will want to come) what thoughts are as far as F15 feature list, that would be great.
21:54:11 <rbergeron> I know that clalance was talking about cloud engine as well, but I think that is more up in the air.
21:54:19 <mmorsi1> sure thing, that is an action item of very high priority on my backlog
21:54:42 <rbergeron> #action mmorsi1 to give an update next week on deltacloud feature list intentions for f15
21:54:45 <rbergeron> thanks!
21:54:49 <mmorsi1> np
21:54:52 <rbergeron> #topic Any other business?
21:55:14 <brianlamere> what's the status on the mirrors? =D
21:55:28 <jeremy> fyi -- I'm probably going to be writing the dirt simple ami-creator script that uses python-imgcreate, takes a kickstart config and can give you an ami out the other side
21:55:40 <jsmith> jeremy: Great!
21:55:42 <jgreguske> jeremy: you should also talk with fedora rel-eng
21:55:54 <gholms> brianlamere: Anyone have a way to sync a S3 bucket with a local directory or HTTP mirror?
21:55:57 <jgreguske> or stick around with me, dgilmore and jforbes after the meeting
21:56:03 * rbergeron nods
21:56:23 <mmorsi1> clalance would be also be amiss if i didn't mention oz https://github.com/clalancette/oz
21:56:31 * rbergeron will just change the topic over to EC2 / rel-eng in a few minutes.
21:56:34 <jeremy> since, you know, we've kind of standardized on kickstart configs as a way to describe images for the world of fedora
21:56:37 <rbergeron> mmorsi1: yeah, i saw his email today.
21:56:38 <mmorsi1> don't know too much about it myself, but check it out!
21:56:51 <rbergeron> #info check out https://github.com/clalancette/oz
21:57:12 <brianlamere> gholms: I think I was supposed to do that at some point, wasn't I. Yeah. I failed; had some stuff come up
21:57:36 <gholms> brianlamere: I think it kind of stalled at that point. :-\
21:57:45 <jeremy> gholms: s3cmd can sync a local dir to a bucket, can't it?
21:57:48 <brianlamere> sowwe. Yeah, was personal stuff
21:57:52 <gholms> Yeah, that looks kind of neat!
21:58:17 <mgoldmann> I think I need to talk with clalance about oz :)
21:58:19 <gholms> brianlamere: Can s3cmd sync do it?
21:58:31 <brianlamere> jeremy: any of the tools out there tend to break if you send much through it...they also don't really do comparisons, they just copy over
21:58:54 <gholms> brianlamere: That's not what http://s3tools.org/s3cmd-sync seems to indicate.
21:59:03 <mmorsi1> mgoldmann: definetly he is it's wizard afterall ;-)
21:59:16 <gholms> brianlamere: Not sure about the stability part, mind you.
21:59:29 <jeremy> brianlamere: I've used s3cmd to sync a fair bit of stuff and it's not unconditional
21:59:32 <brianlamere> hmm...maybe so. I'll re-look at that one then. I disregarded it at some point for some reason
21:59:41 * gholms volunteers to be a lollipop kid
21:59:54 <mmorsi1> hehe
22:00:33 <rbergeron> okee dokee.
22:00:45 <brianlamere> I know that most of the pre-cooked tools didn't like doing massive amounts of data. And especially now with the new multipart upload feature on s3, any old tool is outdated as of a week or two ago ;)
22:01:15 <mgoldmann> uh, 11pm :(
22:01:17 <rbergeron> jgreguske, dgilmore, jforbes, anyone else (jsmith?) -- ec2/rel-eng discussion?
22:01:32 <jgreguske> anyone is invited I guess, this isn't a private thing
22:01:39 <jgreguske> isn't meant to be
22:01:41 <rbergeron> no, just making sure everyone is still around :)
22:01:44 <jgreguske> oh :)
22:01:50 * dgilmore is here
22:01:54 * jsmith doesn't have anything else to add, except for a complaint that his last EC2 instance took 15 minutes to launch
22:02:06 * rbergeron thought we could just do it here since we already have the bot running.
22:02:15 * dgilmore has to confess, ive never used ec2
22:02:17 <rbergeron> #topic EC2/rel-eng discussion
22:02:27 <rbergeron> #chair dgilmore jgreguske
22:02:27 <zodbot> Current chairs: dgilmore gholms jforbes jgreguske jsmith rbergeron
22:02:28 <brianlamere> jsmith: to launch? is that from active state to launch, or 15 minutes to become active?
22:02:40 <jgreguske> dgilmore: so I checked out clumens' patch to pykickstart and it seems to work ok
22:02:42 <jeremy> jsmith: that happens sometimes
22:02:56 <jgreguske> dgilmore: it's been committed but no build yet
22:03:00 <dgilmore> jgreguske: cool, i need to get my test koji up
22:03:03 <brianlamere> one is instance fulfillment, another might be something odd in sysinit or something
22:03:15 <jsmith> brianlamere: I launched a new instance (using boto), and it stayed in the "pending" state for 15 minutes
22:03:21 <jgreguske> dgilmore: yeah I'm doing the same, should have it up tomorrow
22:03:40 <jgreguske> dgilmore: is that the only thing blocking use of koji for image-building?
22:03:59 <dgilmore> jgreguske: well if its commited ill get it built
22:04:06 <jforbes> So how do we do EBS images with koji?
22:04:15 <brianlamere> jsmith: ah, that's just instance fulfillment. If it was no longer pending (ie, active) but it took 15 minutes to be able to log in...that would be our problem. Instance-fulfillment is just slow sometimes, that's amazon's deal
22:04:19 <gholms> jforbes: That's a problem. You can't.
22:04:35 <jforbes> right
22:04:38 * gholms glares at Amazon
22:04:39 <jgreguske> jforbes: no plans (at present) to add any functionality to koji that automatically uploads content to ec2 (or whatever)
22:04:42 <mgoldmann> the only way is to run koji on EC2
22:04:53 <jsmith> brianlamere: Yeah... that's what I thought...
22:05:01 <jgreguske> jforbes: but you can build the disk image offline and then dd it to a volume
22:05:10 <jgreguske> in the cloud
22:05:21 <dgilmore> jgreguske: we should be able to script the upload of images
22:05:30 <gholms> Koji would then have to be able to instantiate stuff on EC2. :-\
22:05:34 <jgreguske> dgilmore: agreed, I have that done already for rhel, be happy to share that
22:05:51 <jgreguske> gholms: yeah that gets beyond koji's scope imo
22:06:00 <dgilmore> the tooling for uploading images belongs outside of koji
22:06:14 <brianlamere> you *can* do it, by grabbing the metapackage from the S3-backed instance, the dd'ing that to an EBS
22:06:16 <dgilmore> inside koji we will only make the images
22:06:52 <brianlamere> it doesn't have to be as awkward as that sounds. but yes, an S3 AMI can be converted to an EBS AMI. You just can't upload straight to EBS initially
22:07:03 * rbergeron is trying to get a grip on a list of tasks for what we need to do to, what information dgilmore needs that we can provide, and vice versa (what cloud-sig needs to know from rel-eng to make their lives easier).
22:07:06 <dgilmore> jforbes: where are the kickstarts that you have been using for image creation?
22:07:08 <gholms> brianlamere: It can?
22:07:34 <brianlamere> gholms: yeah, so long as you have access to the metadata of the ami. IE, for AMIs you actually own
22:07:49 <jgreguske> does Fedora plan to release S3 and EBS images side-by-side?
22:07:50 <gholms> brianlamere: How does that work?
22:07:59 <brianlamere> being "public" isn't enough
22:08:01 <gholms> jgreguske: We sort of have to.
22:08:08 <jgreguske> gholms: why?
22:08:26 <brianlamere> there's a howto I spotted at some point, I followed it and it worked. I don't need it now, so I haven't used it recently, but it does work. sec, I'll find it
22:08:29 <jforbes> dgilmore: http://fpaste.org/uDMJ/
22:08:52 <jgreguske> brianlamere: is it the 'rsync a live S3 instance' way?
22:09:01 <gholms> jgreguske: Mostly because people keep asking for it. Micro instances only work on EBS instances.
22:09:06 <skvidal> jforbes: that'sa kickstart? :)
22:09:13 <jgreguske> gholms: right so why keep S3?
22:09:16 <brianlamere> jgreguske: no
22:09:17 <jforbes> dgilmore: and the 32bit just changes kernel to kernel-PAE and adds the nosegneg bit
22:09:20 <mgoldmann> skvidal: it's BG apliance definition
22:09:27 <brianlamere> EBS is also faster ;)
22:09:39 <skvidal> mgoldmann: right - that's not a kickstart :)
22:09:39 <jforbes> skvidal: nope, got away from doing it the old way, and switched to boxgrinder since it can do direct to EBS and such
22:09:44 <dgilmore> jforbes: ok.
22:10:09 <gholms> I use S3 images when I have multiple instances that don't need persistence.
22:10:33 <brianlamere> http://coderslike.us/2009/12/07/amazon-ec2-boot-from-ebs-and-ami-conversion/
22:10:44 <dgilmore> jforbes: so, we need to either get that in the spins-kickstarts git repo. or set up a appliance-kickstarts git repo
22:10:50 <jforbes> skvidal: but it is very easy to convert that back
22:10:52 <dgilmore> id prefer the former
22:11:15 <jgreguske> so it looks to me that we have parallel efforts going on here
22:11:16 <jforbes> dgilmore: we actually ahve a repo, but happy to add it to spins-kickstarts as well... though like I said, it isnt a kickstart at the moment
22:11:18 <brianlamere> basically, when you make an S3 backed AMI, you create manifests that can then be downloaded. It's an image that hasn't been run. Then, DD that image
22:11:36 <jgreguske> and I think we should reconcile that
22:11:40 <dgilmore> jforbes: we need a kickstart to build the image in koji
22:12:23 <brianlamere> DD it to an unmounted EBS, then snapshot the EBS. et viola, you're mostly there; register an AMI with whatever AKI, and tada
22:12:24 <jforbes> dgilmore: right, so I will have to convert it back to a kickstart, and add all the EC2 crap the bg does for you again
22:12:38 <mgoldmann> dgilmore: but koji doesn't support creating EC2 images, dos it?
22:13:07 <jgreguske> mgoldmann: it creates disk images which can be uploaded as-is
22:13:10 <jforbes> which brings us back to the point, of why not use BG to do the whole thing, it will actually be much faster than koji
22:13:12 <dgilmore> mgoldmann: it supports creating appliance images, jgreguske im sure wrote it to support the format needed for ec2
22:13:49 <mgoldmann> jforbes has a good here
22:13:56 <jgreguske> jforbes: because rel-eng for officially released content it should go through rel-eng tools
22:14:12 <jgreguske> err for officially release content it should come from rel-eng tools
22:14:14 <gholms> mgoldmann: Can BG please support kickstarts? Pretty please?
22:14:16 <dgilmore> jforbes: that means we would have to add another thing to fedora infrastructure. for composition. im trying to simplify and consolodate that all right now
22:14:35 <gholms> "Hey, look, it's almost a kickstart, but it's not a kickstart!"
22:14:43 <mgoldmann> gholms: I think it's possible
22:14:52 <skvidal> mgoldmann: quick question - the virtue of BG's format is that it isn't fedora/rhel specific, right?
22:15:05 <mgoldmann> yes
22:15:08 <skvidal> mgoldmann: but since we work on fedora here - that's not a feature
22:15:15 <jforbes> dgilmore: sure, but it handles composition -> publish in a single step vs koji compose, and 10 more minutes of work to get the images pushed
22:15:16 <skvidal> that's just extra functionality we can't use
22:15:50 * jforbes agrees completely with the kickstart bit, it really should use kickstarts
22:15:58 <dgilmore> jforbes: that work can be automated.
22:15:59 <brianlamere> isn't BG mostly redhat-centric? is it not actually?
22:16:09 <skvidal> everything else that fedora/rhel does is using a kickstart
22:16:11 <brianlamere> on it's home page it mentions redhat, fedora, and centos
22:16:21 <mgoldmann> brianlamere: it is
22:16:33 <mgoldmann> just with cleaner format
22:16:37 <skvidal> mgoldmann: so what does that abstraction get us here in fedora?
22:16:37 <mgoldmann> hiding all the crap
22:16:43 <skvidal> mgoldmann: cleaner than a kickstart?
22:16:44 <mgoldmann> not necessary crap
22:16:56 <mgoldmann> skvidal: I think so
22:16:57 <brianlamere> so yeah, why doesn't it just have a kickstart file it uses, plus an extra config for whatever else? that should be a minor change, right? (kidding)
22:17:10 <jforbes> dgilmore: note I am not complaining here, if you guys would rather use koji, I am all for anything that gets it out of my lap
22:17:11 <skvidal> mgoldmann: we use kickstarts EVERYWHERE ELSE
22:17:16 <jeremy> mgoldmann: if I had a dollar for every "cleaner than a kickstart" format someone dreamed up, I would be a rich man at this point
22:17:19 <brianlamere> can't get cleaner than kickstart; it's what everything uses
22:17:35 <dgilmore> jforbes: from a releng point of view koji is the path to go.
22:17:40 <brianlamere> there's nothing cleaner than a constiant, organized house ;)
22:18:03 <dgilmore> jforbes: if koji down the road can integrate doing it by using boxgrinder that would be ok
22:18:09 <rbergeron> jforbes: :)
22:18:10 * jforbes notes that you aren't hiding a bunch of crap, but are making post a lot more of a pain in the ass
22:18:10 <rbergeron> lol
22:18:11 <gholms> Yes, please!
22:18:27 <jgreguske> yes that isn't out of the question (koji + bg)
22:18:28 <skvidal> jforbes: for example?
22:18:40 <skvidal> jforbes: what's the %post stuff that's a lot more of a pain in the ass?
22:18:59 <jforbes> skvidal: have you looked at post on the appl file I linked?
22:19:07 <skvidal> can you relink it?
22:19:15 <gholms> if... then... else... fi becomes harder to read when it's all on one line.
22:19:18 <skvidal> b/c I apparently did not?
22:19:19 <jforbes> skvidal: http://fpaste.org/uDMJ/
22:19:36 <mgoldmann> jforbes: you can use blocks and paste the whole script
22:19:38 <skvidal> jforbes: 3 lines?
22:19:46 <brianlamere> isn't the real key that we should be able to hand a kickstart.cfg file from someone's spacewalk server over to a tool, and that tool makes that image?
22:19:55 <skvidal> jforbes: sorry 4 lines is hard in post?
22:20:02 <skvidal> brianlamere: +1
22:20:10 <gholms> brianlamere: +1
22:20:17 <brianlamere> because in the end, corporate america uses images they bless and get happy with. that image will be made by a particular kickstart file
22:20:18 <gholms> skvidal: if... then... else... fi becomes harder to read when it's all on one line.
22:20:34 <jforbes> skvidal: not the size of that one, the adding additional formatting and bits to encase shell, all unnecessary in kickstart
22:21:00 <gholms> mgoldmann has a point, though: you can use blocks to sort of deal with that.
22:21:03 <skvidal> jforbes: oh
22:21:09 <skvidal> jforbes: I see - I misunderstood you before
22:21:21 <skvidal> you were saying %post is harder in boxgrinder's specification
22:21:27 <jforbes> yes
22:21:29 <skvidal> I thought you were saying using bg makes %post's easier
22:21:34 <gholms> Heh
22:21:45 <skvidal> and I couldn't comprehend it at all
22:21:58 <skvidal> mgoldmann: do you understand where we're coming from here?
22:22:13 <skvidal> mgoldmann: fedora/rhel/centos/rhn/livecd-tools all of it have ONE thing in common
22:22:17 <skvidal> kickstart
22:22:25 <skvidal> they all adhere to the same system
22:22:30 <mgoldmann> ok, I'm not fighting with that :)
22:22:31 <jforbes> Anyway, it seems at this point, we are not going to be using boxgrinder for the F15 images... If that changes, we can readdress it
22:22:38 <skvidal> if boxgrinder wants to be seriously accepted then it has to do the same
22:22:45 <skvidal> alternatively you can stick with your own format of things
22:22:59 <jgreguske> mgoldmann: skvidal's suggestion would make future koji integration easier too
22:23:07 <skvidal> but I can assure you you'll just end up being sidelined by even a half-ass implementation that uses kickstarts
22:23:11 <mgoldmann> I'm jsut telling, that a bunch of people are interesting in some other format that makes it easier for them to create appliances for the cloud
22:23:12 <jforbes> dgilmore: so you need the kickstart, with all of the EC2 bits added
22:23:19 <mgoldmann> therefore BG was invented
22:23:25 <dgilmore> jforbes: correct, from a releng perspecteive we want kickstarts to work with.
22:23:29 <dgilmore> jforbes: please
22:23:30 <mgoldmann> with a plugin arch where you can plug what you need
22:23:31 <skvidal> mgoldmann: yes - but the only platform we care about is fedora
22:23:49 * mmorsi1 thinks the tools thats right for the job should be chosen, not the one thats used everywhere else (tho what is supported is a consideration in determining which is the right tool for the job)
22:23:56 <jforbes> dgilmore: since I need to recreate the ec2 bits, is there a way for me to kick off builds in koji and test?
22:24:03 <sdake> off to pick up kids from school bbl
22:24:04 <skvidal> mmorsi1: kickstart is the right tool for the job
22:24:05 <mgoldmann> the goal was of course not to close on one distro
22:24:09 * gholms thinks kickstart is the right tool for the job
22:24:10 <skvidal> mmorsi1: and it is the tool we use EVERYWHERE ELSE
22:24:17 <skvidal> mmorsi1: neat synergy
22:24:23 <skvidal> mgoldmann: well fedora only cares about one distro
22:24:30 <dgilmore> jforbes: i can set you up with perms and the command you would need to run to make an image
22:24:41 <jforbes> dgilmore: I would appreciate it
22:24:52 <mgoldmann> I know, but this is the same thing like: euca2ools only cares about Eucalyptus
22:24:53 <brianlamere> mgoldmann: absolutely. couldn't agree more. but, I want to be able to pass a blessed kickstart file around. it's the one I spent (hypothetically) tens of thousands in QA testing to be passed for security auditors, and run my applications well
22:25:01 <mgoldmann> no it does not
22:25:16 <mgoldmann> it cares about other cloud (read distro) too
22:25:21 <dgilmore> mgoldmann: sadly that seems to be due to the immaturity of the whole cloud concept
22:25:27 <dgilmore> there is no standards
22:25:37 <dgilmore> and everyone is doing it their own way
22:25:39 <skvidal> kickstart is a standard for all red hat-family products
22:25:48 <mgoldmann> so, please open an issue for supporting raw kickstart files and I'll add it :)
22:26:17 <gholms> If you're able and willing to support both formats then that would work for me.
22:26:28 <mgoldmann> gholms: sure
22:26:29 <brianlamere> are transitioning to an openstack conversation yet?
22:26:29 <brianlamere> heh
22:27:06 <gholms> brianlamere: It came and (quickly) went. Do you have anything to say?
22:27:41 <gholms> Anyone willing to take an action item for filing a "plz use ks" bug against boxgrinder?
22:27:52 * skvidal is doing it now
22:28:02 <skvidal> once his frelling jboss account info goes thrrough
22:28:18 <jgreguske> thanks skvidal
22:28:31 <gholms> #action skvidal will file a RFE for kickstart support in BoxGrinder
22:28:43 <mgoldmann> https://issues.jboss.org/browse/BGBUILD
22:29:06 <skvidal> mgoldmann: yes
22:29:08 <mgoldmann> more specific https://issues.jboss.org/secure/CreateIssue.jspa?pid=12310920&issuetype=2 :)
22:29:10 <mgoldmann> ok
22:29:15 <gholms> #topic Open floor
22:29:16 <skvidal> mgoldmann: it's where I was - but I need an account
22:29:17 <rbergeron> frelling?
22:29:28 <skvidal> rbergeron: google is your friend
22:29:28 <mgoldmann> skvidal: I'll create the issue
22:29:34 <brianlamere> gholms: I was only mentioning it because of the bit about cloud providers being inconsistent
22:29:45 <gholms> brianlamere: Gotcha
22:29:57 <mmorsi1> google always wants to do away w/ caps lock key :-p
22:29:59 * mmorsi1 ducks
22:30:02 <jgreguske> so dgilmore I guess that leaves us with testing out the pykickstart thing. If that is good to go we should try building from jforbes ks file
22:30:05 <rbergeron> skvidal: frakin tv shows, always coming up with their own versions.
22:30:13 * gholms steals mmorsi1's keyboard
22:30:17 <skvidal> rbergeron: you should watch your gorram mouth
22:30:20 <mmorsi1> lol
22:30:26 * mmorsi1 invents brain to computer interface
22:30:34 <gholms> D:
22:30:58 <gholms> jgreguske: Can we make that into an action item somehow?
22:30:58 <mgoldmann> https://issues.jboss.org/browse/BGBUILD-112
22:31:15 <brianlamere> oh, quick question on last topic: would it be slander to suggest adding a new section or two to the kickstart spec? ie, sections that can handle platform-specific needs?
22:31:18 <dgilmore> jgreguske: yep
22:31:27 <jgreguske> #action dgilmore and jgreguske to test out pykickstart fix and attempt image builds from jforbes' ks file(s)
22:32:01 <rbergeron> dgilmore: do you have a timeline that you're looking at to get this functioning?
22:32:04 <gholms> brianlamere: It would be an uphill battle, but if your point has a huge amount of merit you have a chance.
22:32:26 <dgilmore> rbergeron: befor fudcon
22:32:30 <dgilmore> before
22:32:40 <gholms> skvidal: https://issues.jboss.org/browse/BGBUILD-112
22:32:43 <skvidal> nod
22:32:45 <skvidal> I saw it
22:32:46 <dgilmore> i want to have the tools in place and have it working for F-15 alpha
22:32:58 <skvidal> gholms: my account info still hasn't come in :)
22:33:20 <gholms> Just wanted to ensure you didn't file a dupe. :)
22:33:32 <skvidal> hmm https://issues.jboss.org/browse/BGBUILD-73
22:33:42 <gholms> Hah!
22:33:43 <mgoldmann> ha :)
22:33:57 <mgoldmann> I knew there was something :)
22:35:07 <gholms> [Everyone stares at rbergeron]
22:35:24 <mmorsi1> quick start the hold music!
22:35:47 <gholms> Here you go: http://www.youtube.com/watch?v=UcCHRW8G9yY
22:35:49 <mgoldmann> ok, this will be the issue: https://issues.jboss.org/browse/BGBUILD-73 just rescheduled
22:36:08 <mmorsi1> gholms: nice :-)
22:36:15 <gholms> mgoldmann: Any chance of that landing before release?
22:36:24 <gholms> Or, better yet, alpha?
22:36:34 <mgoldmann> before 0.7.0?
22:36:45 <gholms> F15's release
22:36:52 <mgoldmann> of course!
22:36:59 <gholms> Awesome
22:37:08 <mgoldmann> I'll take a look at this tomorrow
22:37:17 <gholms> Thanks
22:37:20 * jsmith reminds everything that the feature deadline is right after FUDCon
22:37:23 <mgoldmann> with some luck you'll have 0.6.6 with it released
22:37:25 <jsmith> s/everything/everyone/
22:37:52 <gholms> Who here will go to FUDCon? We should meet and discuss cloudy stuff.
22:37:57 * gholms pokes rbergeron
22:37:58 <rbergeron> gholms: I think that is the plan.
22:38:08 <rbergeron> from here: let's see.
22:38:14 * mgoldmann will be there
22:38:21 <rbergeron> jdarcy, zaitcev, gholms, rbergeorn, jsmith, dgilmore, mgoldmann.
22:38:26 <rbergeron> wow, you'd think i could type my own name.
22:38:27 * jforbes will be there
22:38:47 <rbergeron> jforbes, sdake.
22:38:55 <rbergeron> clalance and lutter are maybes, depending on finding moneys.
22:39:03 <gholms> How much of releng will be around?
22:39:15 * skvidal will be in tempe
22:39:51 <brianlamere> I wanna go, but...man, who knows
22:39:58 <rbergeron> skvidal, dgilmore, i know 0xf13 and mmcgrath are coming (though technically they are moving on to other things, THEY STILL LOVE US)
22:39:59 <brianlamere> is it still possible to register?
22:40:03 <rbergeron> rackerhacker is coming.
22:40:09 <rbergeron> and some other folks from openstack.
22:40:09 <skvidal> rbergeron: no they don't
22:40:13 <skvidal> rbergeron: would you? :)
22:40:15 <rbergeron> brianlamere: OH YES
22:40:43 <rbergeron> skvidal: don't make me answer that ;)
22:40:46 <brianlamere> maybe if I come and meet people in person, I'll stop being sent to the spam folders when I email them =D
22:40:49 <rbergeron> lol
22:40:50 <skvidal> rbergeron: right
22:40:50 <mgoldmann> brianlamere: http://fedoraproject.org/wiki/FUDCon:Tempe_2011#Pre-registration
22:41:03 <rbergeron> i heard some dude named jsmith is coming too, lol
22:41:09 <brianlamere> (though, I didn't find the email I had thought I sent to gholms about cloud-init before....)
22:41:27 <jsmith> rbergeron: Well, that's the plan -- assuming I don't get lost somewhere in the 30+ hours of flying from LCA to Phoenix
22:41:34 <gholms> brianlamere: Obvious cause is obvious.
22:42:16 <brianlamere> you're right; clearly, google lost the email during one of their blackouts. gmail is beta still, after all... ;)
22:42:30 <rbergeron> jsmith: don't do that
22:42:35 <gholms> Not any more! Though it has no SLA.
22:42:40 <rbergeron> gholms: there are already some cloud things proposed.
22:42:47 <mmorsi1> ya it hasn't been beta for a while
22:42:50 <rbergeron> gholms: but having some bigger discussions would be good as well.
22:42:59 * gholms nods
22:43:41 <gholms> I'm not sure what a hackfest is, but if a bunch of people can sit down and work on porting a python app (cloud-init) to fedora at one that might be rather nice.
22:44:05 <jsmith> gholms: That's exactly what a hack-fest is :-p
22:44:08 <rbergeron> boxgrinder, cloudFS, sheepdog already have presentations.
22:44:15 <rbergeron> And gholms can add that to the hackfest list :)
22:44:38 <rbergeron> matahari is getting a presentation too, though i'm still cloudy (ha ha ha) on how closely related that will be.
22:44:50 <rbergeron> i think it's more virt-y than cloud-y.
22:45:11 <rbergeron> oh, zaitcev has one on cloud storage too.
22:45:21 <jsmith> Nice
22:45:40 <zaitcev> I was going to talk about Hail there, but I dunno, if someone wants to include OpenStack, that would be good.
22:45:45 <rbergeron> I suspect we could almost have a whole room to ourselves for a day for all the stuff we have proposed, and then a good hackfest on top of that.
22:45:58 <rbergeron> zaitcev: i think dendrobates is coming, he was last time I had talked to him.
22:45:59 <zaitcev> Or, actually, Swift, because of storage tilt.
22:46:13 <rbergeron> rackerhacker could probably talk to it as well.
22:46:40 <mgoldmann> girls, guys, I think I need to check if I'm not in the bed already :)
22:47:07 <gholms> Anyone else have stuff to say?
22:47:07 <rbergeron> zaitcev: i haven't had a chance to poke jeff garzik about fudcon, and i haven't harassed him lately about hail as a feature
22:47:07 <mgoldmann> thanks for meeting, and cu!
22:47:13 <rbergeron> mgoldmann: thanks for staying up so late :)
22:48:05 <zaitcev> rbergeron: Between Jeff and I, we can keep Hail acceptably maintained as long as necessary (e.g. switch to systemd). But the question is what next.
22:48:40 <rbergeron> zaitcev: we can always talk about "what is next" at fudcon ;)
22:48:57 <rbergeron> unless you guys already have it baking in your brains, which i suspect is the case
22:49:23 <gholms> The list is always open.
22:49:35 * rbergeron nods.
22:49:44 * rbergeron notes we sort of went 50 minutes over our time slot ;)
22:49:53 <mmorsi1> good meeting :-)
22:50:14 <skvidal> gholms: wow - cloud-init is a monument to NIH
22:50:15 <rbergeron> mmorsi1: glad you could join us.
22:50:26 <gholms> skvidal: Ohhh yeah. :-\
22:50:38 <mmorsi1> glad i could be here, will be here again next week
22:50:43 <skvidal> gholms: I hadn't looked at it in detail but all you really need is "Take user_data and if it looks like a script - run it"
22:50:59 <rbergeron> mmorsi1: awesome. we got u hooked!
22:51:06 <gholms> skvidal: It does a metric ton of other stuff, too.
22:51:15 * rbergeron is gonna close out the meeting - dgilmore, did you get everything you need?
22:51:22 <skvidal> gholms: like half a cfg mgmt system - for no good reason
22:51:30 * gholms nods
22:51:39 <mmorsi1> haha can't keep me away :-)
22:52:22 * gholms yawns
22:52:25 <skvidal> gholms: seriously - feels like porting cloud_init is just asking for bogons for no reason
22:52:35 <gholms> skvidal: You really think so?
22:52:52 <mmorsi1> but i do have to mosey off now (haha get it mo-sey)
22:52:52 <skvidal> gholms: we havea cfg mgmt system - hell we have 3: cfgengine, puppet, and bcfg2
22:52:57 <mmorsi1> tt ya'll later
22:53:25 <rbergeron> lol
22:54:04 <rbergeron> skvidal, gholms: do you guys need me to continue logging or can i close it out?
22:54:05 <skvidal> gholms: why write a subroutine to handle adding cron jobs and running puppet when we can just RUN puppet
22:54:12 <skvidal> rbergeron: you can probably close it out
22:54:17 <skvidal> gorram-it
22:54:21 <dgilmore> rbergeron: i think i did
22:54:27 <brianlamere> I think the idea is a tool that does things unique to the cloud ;) And it can be useful to people who don't want puppet
22:54:42 <rbergeron> #endmeeting