#ansible-community: Community Working Group
Meeting started by felixfontein at 18:04:39 UTC
(full logs).
Meeting summary
- versioning and releasing community.general and community.network (felixfontein, 18:05:45)
- collections should be released from release
branches see
https://github.com/ansible/community/issues/539#issuecomment-640034934
for details (samccann,
18:08:49)
- open questions
https://github.com/ansible/community/issues/539#issuecomment-640040115
(samccann,
18:09:04)
- deprecation cycle for community.general/community.network (felixfontein, 18:11:04)
- collections should be released from release
branches see
https://github.com/ansible/community/issues/539#issuecomment-640034934
for details (abadger1999,
18:11:53)
- open questions
https://github.com/ansible/community/issues/539#issuecomment-640040115
(abadger1999,
18:11:59)
- original ansible/ansible deprecation was 4
versions, which was about a year or so (samccann,
18:14:11)
- that has stretched to close to 2 years now,
since the releases have slowed down. (samccann,
18:14:42)
- whatever is decided, we need clear docs on how
to write changelog/fragments wrt `breaking_changes` (gundalow,
18:30:42)
- AGREED: the
deprecation cycle should be at least two major versions. maintainers
can decide to choose a longer one, but not a shorter one.
(felixfontein,
18:33:01)
- AGREED: mapping for
old deprecation version numbers (from ansible): 2.11, 2.12 ->
2.0.0, and 2.13, 2.14 -> 3.0.0. old version should be kept as a
comment (felixfontein,
18:47:43)
- changelogs (felixfontein, 18:48:56)
- AGREED: a) we have
one changelog per major verion, and b) fragments are removed after a
version is released (contents are in changelog.yaml) (felixfontein,
19:05:09)
- AGREED: version 0.2.0
to be released next, a couple of days after ansible-base 2.10 beta
is released. with changelog and correct version_added and
deprecation versions. version after that will be 1.0.0. (felixfontein,
19:18:32)
- AGREED: will be
released directly from master, i.e. no release branch, and no
backporting until 1.0.0 is out (felixfontein,
19:18:38)
Meeting ended at 19:21:25 UTC
(full logs).
Action items
- (none)
People present (lines said)
- felixfontein (130)
- abadger1999 (42)
- samccann (31)
- andersson007_ (23)
- cyberpear (16)
- gundalow (12)
- zodbot (7)
- bdodd (0)
Generated by MeetBot 0.1.4.