#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by acozine at 15:00:34 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:00:43)
  2. version-specific links in docs and PR 74245 (acozine, 15:08:15)
    1. see https://github.com/ansible/ansible/issues/74688 for a quick summary of some aspects of this issue (acozine, 15:08:42)
    2. ansible-doc in 2.11 doesn't understand L() relative links at all so will return a relative path that is 404 for a user (samccann, 15:46:00)
    3. https://docs.ansible.com/ansible/become.html will not work in any version (acozine, 15:46:07)
    4. there are a scattering of error messages within module python code that have hard-coded urls to latest. Some of these have been changes to use relative links base on these PRs (samccann, 15:49:20)
    5. ansible-doc in 2.11 doesn't understand L() relative links at all so will return a relative path that is 404 for a user (samccann, 15:51:56)
    6. we have a scattering of errorr messages within module python code that uses the relative link function. This is broken in 2.11 since ansible/2.11 does not exist anymore. (samccann, 15:52:32)
    7. AGREED: we want any links to go to /ansible/ not /ansible-core/ (samccann, 15:58:34)
    8. if we revert PR 74245 and leave PR 74665, then backport 74665, that should fix the error message output (acozine, 16:03:06)
    9. since also AH and antsibull-doc need to implement the compatible solutions, any solution needs to be discussed and agreed by all three parties first (samccann, 16:09:08)
    10. AGREED: 1. add a redirect for 2.11 => latest as a temporary fix, 2. revert 74245, 3. backport 74665 to 2.11 when we can (remembering that it may take some time to propagate, since folks don't upgrade quickly), 4. create an issue that covers all the aspects of Version-Sensitive Docs Links before we try to fix it again (acozine, 16:25:52)

  3. open floor (acozine, 16:27:15)


Meeting ended at 16:31:13 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. acozine (117)
  2. bcoca (112)
  3. samccann (73)
  4. abadger1999 (41)
  5. felixfontein (30)
  6. zodbot (13)
  7. lmodemal (3)
  8. tadeboro (2)
  9. gundalow (1)
  10. dericcrago (1)


Generated by MeetBot 0.1.4.