16:01:37 <roshi> #startmeeting F21-blocker-review
16:01:37 <zodbot> Meeting started Mon Oct 27 16:01:37 2014 UTC. The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:37 <roshi> #meetingname F21-blocker-review
16:01:37 <zodbot> The meeting name has been set to 'f21-blocker-review'
16:01:38 <roshi> #topic Roll Call
16:01:47 <roshi> who's ready for some blockery goodness!
16:01:51 * pschindl is here
16:01:55 * satellit listening
16:01:58 * kparal here
16:02:18 * jskladan lurks
16:02:34 * pwhalen is here
16:03:05 <adamw> ahoyhoy
16:03:14 <roshi> sweet, good showing :)
16:03:17 <roshi> #topic Introduction
16:03:17 <roshi> Why are we here?
16:03:17 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:03:21 <roshi> #info We'll be following the process outlined at:
16:03:24 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:03:26 <roshi> #info The bugs up for review today are available at:
16:03:28 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:03:31 <roshi> #info The criteria for release blocking bugs can be found at:
16:03:33 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria
16:03:37 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria
16:03:39 <roshi> #link https://fedoraproject.org/wiki/Fedora_21_Final_Release_Criteria
16:03:55 <roshi> got 4 blockers today
16:03:57 <roshi> first up:
16:03:58 <roshi> #topic (1157657) DeviceTreeError: failed to scan disk sdb
16:03:58 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1157657
16:03:58 <roshi> #info Proposed Blocker, anaconda, NEW
16:05:06 <adamw> i asked in #anaconda about this a few minutes ago but no reply yet
16:05:17 <adamw> i'd like to see if it happens here as well at least, but it'll have to wait till after the meeting
16:07:15 <kparal> just a note: it might depend whether I used lvm or not in the layout
16:07:31 <kparal> which I don't remember :)
16:07:40 <adamw> i used lvm in my tests but didn't actually test a 'normal' install with one of the test disks after removing the fwraid
16:07:53 <adamw> i immediately turned them into an hwraid array instead, to run that test
16:08:21 <kparal> it was not with "one of them", all of them were present, I just removed the raid volume in bios
16:08:30 <kparal> and anaconda crashed on start
16:09:18 <adamw> ah, ok. i'll try the same thing and see
16:09:57 <adamw> i believe we usually reject bugs as blockers when you don't remove the raid config or connect one device of a raid set, but i think you did things correctly here so it seems at least potentially blockerish
16:10:02 <adamw> i'd say probably +1 if it's reproducible
16:10:10 <adamw> though it is the kind of thing that's a pain when it comes up late
16:10:29 <roshi> +1 if it's easy to repro...
16:11:33 <kparal> I'll try to repro once again during this meeting
16:13:54 <adamw> it'd be really nice to have input from the devs, but, nothing yet...
16:14:05 <roshi> so punt and vote in the bug?
16:15:22 * adamw takes a look at the trace just in case he can see anything
16:15:55 * kparal will need at least 15 more minutes
16:16:32 <kparal> this time I'm trying raid0
16:17:01 <adamw> kparal: did you use the updates.img for the RAID bug when testing this bit? or not?
16:17:38 <kparal> adamw: this one https://bugzilla.redhat.com/show_bug.cgi?id=1156614#c4 . but only during installation, not during the subsequent boot.
16:17:47 <kparal> now thinking about it, that was an oversight
16:18:03 <kparal> I should have applied it in both cases
16:18:22 <kparal> I'll check
16:18:26 <adamw> yeah, it'd be good to test with that
16:18:36 <kparal> good call, thanks
16:18:52 <adamw> i guess punt and vote in bug, then, though i'd really like to get things done afap :)
16:19:07 * adamw is secretaryizing
16:19:53 <roshi> proposed #agreed - 1157657 - Punt - This requires more testing before voting. Please test and vote in bug.
16:20:11 <kparal> ack
16:21:36 <adamw> ack
16:21:37 <roshi> #agreed - 1157657 - Punt - This requires more testing before voting. Please test and vote in bug.
16:21:41 <roshi> #topic (1157685) Anaconda does not identify Workstation Live Beta image as neither Beta, nor Workstation
16:21:44 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1157685
16:21:47 <roshi> #info Proposed Blocker, anaconda, NEW
16:22:03 <adamw> as mentioned in the bug, -1 on this
16:22:12 <roshi> same here
16:22:14 <roshi> -1
16:22:35 <roshi> I'd be +1 if it identified itself incorrectly though, claiming to be Ubuntu or something crazy
16:23:40 <roshi> votes?
16:23:43 <kparal> well, I reported this because I was confused to see "welcome to Fedora 21" instead of "welcome to Fedora 21 Beta". so I think it is confusing. but hey, nothing serious
16:23:57 <roshi> pschindl: jskladan pwhalen ?
16:24:15 <kparal> I was so used to the beta screen that I've found weird the that "Beta" word suddenly disappeared :)
16:24:30 <pschindl> I don't think it has to be blocker.
16:24:37 <pschindl> But it is confusing.
16:24:49 <pschindl> -1
16:25:05 <kparal> what about missing Workstation, that is also not against the spirit of the criterion?
16:25:29 <pwhalen> -1, whats needed to fix?
16:26:11 <roshi> proposed #agreed - 1157685 - RejectedBlocker - While this bug is slightly confusing, it doesn't directly violate any criteria.
16:26:24 <pschindl> ack
16:26:33 * jskladan yay for quite carefull wordings :)
16:27:01 <jskladan> ^^ack
16:27:07 <roshi> I didn't find it confusing, fwiw
16:27:26 <pwhalen> ack
16:27:35 <adamw> ack
16:27:40 <roshi> #agreed - 1157685 - RejectedBlocker - While this bug is slightly confusing, it doesn't directly violate any criteria.
16:27:49 <roshi> #topic (1154347) Anaconda fails to recognize local standard SATA disks after secure-erase
16:27:52 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1154347
16:27:55 <roshi> #info Proposed Blocker, device-mapper-multipath, NEW
16:29:36 <roshi> these comments are blog post length
16:30:51 <adamw> you can ignore 'em
16:31:11 <adamw> it boils down to, multipathd erroneously decides his disks are part of a multipath config and no-one knows why yet.
16:31:18 <adamw> we're waiting to hear back from the multipath maintainer
16:31:25 <roshi> has anyone else run into it yet?
16:32:24 <adamw> haven't heard from anyone, but it's not a traceback so we can't rely on other reports being automatically duped
16:32:38 <adamw> we'd have to look through other bugs of the same general type and try to spot erroneous multipath in the description or logs
16:33:20 * roshi isn't sure how to vote on this without some form of reproduction
16:33:41 <adamw> if push came to shove i'd be -1 at this point, but i'd really like to hear from the multipath guy
16:33:50 <adamw> i'll try emailing him directly today
16:34:05 <roshi> works for me
16:34:32 <adamw> cmurf did file: https://bugzilla.redhat.com/show_bug.cgi?id=1114770
16:34:33 <roshi> is this something we can defer until wednesday? or should we vote now?
16:34:37 <adamw> which looks sort of up the same alley
16:35:25 <adamw> i'd really want to have determinations on as many bugs as possible today or at least tomorrow, but this one is in the category where it probably makes sense to spin even if we don't get a fix as it may well be fudgable
16:35:42 <roshi> yeah
16:36:17 <roshi> I'd like to get as many id'd today too
16:36:49 * roshi leans -1 since there's no traceback or reproducers at this point
16:37:03 <jskladan> I'd either skip this one, or be -1 now - since it does not seem like we have enough information to say what is actually happening and why (as far as I understand it)
16:37:25 <roshi> it does feel related to 1114770 though
16:37:29 <roshi> they have the same smell
16:37:51 <adamw> yeah
16:38:00 <adamw> note a comment in 1114770: "Also sometimes causes anaconda to bogusly claim no disks are found: see dup bug 1114783 for that manifestation.:
16:39:39 <kparal> are we allowed to have mdadm crashes and selinux denials during installation? I just received one
16:41:39 <adamw> installer runs in permissive mode so it's not unusual for denials to happen, shouldn't cause any problems
16:41:50 <kparal> ah, good
16:42:05 <adamw> in general just seeing something 'weird' in logs in installer will never be a blocker per se, it's always functional
16:42:29 <adamw> so if the mdadm crash causes something in the criteria to actually not work, that's bad, but in itself it doesn't mean blocker
16:42:37 <roshi> so, I'm counting I think 3 -1's
16:43:04 <adamw> well, cmurf's bug sure looks like a reproducer or at least another case of d-m-multipath erroneously finding a multipath device
16:43:14 <adamw> so i'm much less -1, though would still like some input from the devs
16:43:49 <roshi> I'm not a hard -1 by any means
16:45:22 <adamw> "no disks detected" site:bugzilla.redhat.com isn't finding any other candidates atm
16:45:29 <adamw> but that's a fairly rough guess
16:46:19 <roshi> if we count cmurf's issue as a reproducer, it means I much more likely to vote +1
16:47:48 <adamw> i *really* want to hear from the dev before voting on this :/ i think i'm gonna say punt till we get some input
16:47:59 <roshi> yeah
16:48:09 * roshi is uneasy voting with such little info
16:48:11 <pschindl> +1 for punt.
16:48:52 <roshi> proposed #agreed - 1154347 - Punt - We need some more information from the developers before we can vote on this bug as a blocker.
16:49:40 <kparal> roshi: we can then go back to 1157657, I added new info
16:49:50 <roshi> kk
16:50:01 <roshi> acks?
16:50:23 <pschindl> ack
16:51:12 <adamw> ack
16:51:38 <roshi> #agreed - 1154347 - Punt - We need some more information from the developers before we can vote on this bug as a blocker.
16:52:07 <roshi> and kparal had new info for this bug, so going back
16:52:08 <roshi> #topic (1157657) DeviceTreeError: failed to scan disk sdb
16:52:08 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1157657
16:52:08 <roshi> #info Proposed Blocker, anaconda, NEW
16:52:19 <adamw> new info is that it's not easily reproducible, basically?
16:52:32 <adamw> i'll still try it here and see if i can hit the bug, but based on current data i'm -1 if it can't easily be reproduced
16:53:04 <roshi> yeah
16:53:20 <roshi> -1 for this
16:53:41 <kparal> yes, that's the new info
16:54:04 <roshi> we can still vote in bug after adamw tests it (unless you're not plannning on it now)
16:54:21 <pwhalen> -1 based on last comment
16:54:33 * pwhalen is having connection issues, apologies
16:54:37 <pschindl> -1
16:55:02 <adamw> i'll vote -1 for now, kparal or me can always call for a re-vote if we come up with new data
16:55:08 <roshi> wfm
16:55:50 <roshi> proposed again #agreed - 1157657 - RejectedBlocker - This bug doesn't seem to be reproducible. If it turns out otherwise, please repropose.
16:56:19 <pschindl> ack
16:56:33 <pwhalen> ack
16:57:29 <roshi> #agreed - 1157657 - RejectedBlocker - This bug doesn't seem to be reproducible. If it turns out otherwise, please repropose.
16:57:33 <roshi> #topic (1156614) mdraid set name different between anaconda and installed system - causes failure of installed system to boot
16:57:37 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1156614
16:57:39 <roshi> #info Proposed Blocker, mdadm, NEW
16:58:21 <adamw> +1 blocker, this is the 'one more fwraid' bug kparal and I both hit in RC12
16:58:23 <adamw> RC1*
16:58:31 <adamw> dlehman has a fix, and we both confirmed that fix too
16:58:59 <roshi> +1
16:59:00 <kparal> +1
16:59:07 <roshi> great that a fix is there already too
16:59:08 <pwhalen> +1
16:59:12 <pschindl> +1
17:00:02 <roshi> proposed #agreed - 1156614 - AcceptedBlocker - This bug clearly violates the FirmwareRAID Beta Criteria: "The installer must be able to detect and install to hardware or firmware RAID storage devices."
17:01:06 <pwhalen> ack
17:01:25 <pschindl> ack
17:01:36 <jreznik_pp> ack
17:01:38 <roshi> #agreed - 1156614 - AcceptedBlocker - This bug clearly violates the FirmwareRAID Beta Criteria: "The installer must be able to detect and install to hardware or firmware RAID storage devices."
17:01:46 * pschindl has to leave now. So have a nice day.
17:01:50 <roshi> that's it for proposed blockers
17:02:00 <roshi> have a good evening pschindl thanks for coming :)
17:02:15 <pschindl> roshi: thanks
17:02:31 <roshi> there's one proposed FE
17:03:10 <adamw> sure
17:03:14 <roshi> do we want to endmeeting and get to testing, or complete the rest of the stuff we typically do?
17:03:27 * roshi thinks do the one FE and then get to testing
17:05:20 <roshi> alright, the FE
17:05:25 <roshi> #topic (1141414) persistently boots original installed kernel by default, even after kernel updates
17:05:28 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1141414
17:05:30 <roshi> #info Proposed Freeze Exceptions, anaconda, NEW
17:05:49 <adamw> oh, hey, i proposed this one
17:06:04 <roshi> +1
17:06:10 <adamw> i think it kinda got lost in pjones' shuffle, it'd be really nice to get the fix into beta if we can
17:06:14 <roshi> I thought we had this fixed already...
17:06:27 <adamw> i think it's quite unlikely the fix would make anything *worse*, i think the worse a sensible fix could do is not actually fix it
17:06:35 <adamw> i'll have to poke pjones about it
17:06:56 <roshi> works for me
17:07:00 <roshi> other votes?
17:07:43 <pwhalen> +1
17:08:01 * kparal needs to go, bye
17:08:08 <jreznik_pp> /me is reading
17:08:41 <adamw> it's the bug where when you update kernel, the old kernel is still the default in the boot menu
17:09:14 <jreznik_pp> Yeah, I see it now
17:09:48 <jreznik_pp> +1 FE makes sense for Beta
17:11:51 <roshi> proposed #agreed - 1141414 - AcceptedFreezeException - Please apply the fix so we can pull it in for the next compose.
17:12:03 <roshi> (man, that's the easiest bz number to type)
17:12:41 <adamw> ack
17:12:48 <pwhalen> ack
17:13:00 <adamw> there isn't a fix yet :( i'm just putting it on the list in case pjones can write one quick or has it lying around forgotten
17:13:07 <adamw> it'll only get pulled in if it seems safe
17:13:22 <roshi> I can patch to reflect that
17:14:07 <roshi> proposed #agreed - 1141414 - AcceptedFreezeException - A fix for this will be considered if it's completed in time for the next compose.
17:14:52 <jreznik_pp> ack
17:15:41 <adamw> ack
17:15:48 <roshi> #agreed - 1141414 - AcceptedFreezeException - A fix for this will be considered if it's completed in time for the next compose.
17:16:02 <roshi> well, I'm for endmeeting and test
17:16:07 <roshi> any complaints with that plan?
17:16:31 <pwhalen> wfm
17:17:37 <roshi> #topic Open Floor
17:17:41 * roshi sets the fuse...
17:20:25 <roshi> thanks for coming folks!
17:20:29 <roshi> #endmeeting