19:00:48 <jreznik> #startmeeting F21 Final Readiness Meeting
19:00:48 <zodbot> Meeting started Thu Dec 4 19:00:48 2014 UTC. The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:50 <jreznik> #meetingname f21-final-readiness-meeting
19:00:50 <zodbot> The meeting name has been set to 'f21-final-readiness-meeting'
19:00:56 <jreznik> jzb: now we are :)
19:01:00 <jzb> jreznik: woot
19:01:48 <jreznik> magic!
19:01:57 <jreznik> #topic Purpose of this meeting
19:01:59 <jreznik> #info "Before each public release all of the groups participating the development of Fedora's next release meet to make sure the release is well coordinated."
19:02:00 <jreznik> #link https://fedoraproject.org/wiki/Release_Readiness_Meetings
19:02:09 <sesivany> .fas eischmann
19:02:11 <zodbot> sesivany: eischmann 'Jiri Eischmann' <eischmann@redhat.com>
19:02:20 <jzb> .fas jzb
19:02:21 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com> - jzbl 'Denise Gant' <denise2gant@gmail.com>
19:02:34 <jzb> .hellomynameis jzb
19:02:37 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:02:40 * danofsatx-work is back
19:02:41 <jreznik> #topic Current Status
19:02:45 <rkratky> .fas rkratky
19:02:46 <danofsatx-work> .hello dmossor
19:02:46 <zodbot> rkratky: rkratky '' <rkratky@redhat.com>
19:02:49 <zodbot> danofsatx-work: dmossor 'Dan Mossor' <danofsatx@gmail.com>
19:03:11 * jreznik is going to skip roll call as we have own call for each topics :)
19:03:34 <roshi> .hello roshi
19:03:38 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:03:47 <jreznik> #info Fedora 21 was declared gold earlier today, RC5 is winner; GA on Dec-09
19:03:51 <jalalsfs> Hello
19:03:51 <roshi> right as you said to skip roll call...
19:03:59 <jreznik> and hello all!
19:04:14 <mattdm> hello!
19:04:17 <jreznik> #topic Ambassadors
19:04:38 <jreznik> sesivany: :)
19:04:56 <sesivany> I think ambassadors are ready.
19:05:07 <sesivany> the call for release events is out.
19:05:17 <sesivany> now it's on regions.
19:05:20 <jreznik> #info ambassadors are ready
19:05:28 * nirik is here, but also in another meeting... ping if you need me
19:05:33 <sesivany> I've already sent an ISO to a producer of DVDs for EMEA and APAC.
19:05:51 <jreznik> #info call for release events is out, ISO sent to producer for EMEA and APAC regions
19:06:03 <randomuser> oh, a meeting!
19:06:30 <jreznik> meet-me-ing
19:06:34 <jreznik> #topic Design
19:06:58 <jreznik> gnokii: do you have anything for design team?
19:07:20 <gnokii> jreznik: not really, I have no idea what status is
19:07:43 <jreznik> ok, I'll check offline or later today with the team
19:07:45 <jreznik> thanks
19:08:25 <jreznik> #action jreznik to check with Design team offline/later
19:08:28 <jreznik> #topic Documentation
19:08:37 <jreznik> randomuser, rkratky: anything from docs?
19:08:59 <randomuser> Actually, yes
19:09:11 <jreznik> go ahead
19:09:37 <randomuser> I'm rolling draft release notes out to https://fedorapeople.org/groups/docs/release-notes/ and it would be great if people could look them over
19:09:55 <randomuser> I had intended to send some sort of mail out, but hopefully this will work instead
19:10:24 <randomuser> especially regarding the coverage of Products
19:10:31 <jzb> randomuser: do you have a git repo or other area where edits should be sent?
19:11:06 <randomuser> https://git.fedorahosted.org/cgit/docs/release-notes.git is the repo, but a casual yell would be sufficient
19:11:16 <jreznik> #info draft release notes rolling out to https://fedorapeople.org/groups/docs/release-notes/
19:11:43 <jreznik> #info docs team is asking for final review, especially for Product coverage
19:11:51 <randomuser> in other news, we have a completely rewritten installation guide (still some TODO there) that I'm told has been integrated into anaconda
19:11:53 <jreznik> randomuser: I think email is not that bad idea
19:11:59 <jzb> randomuser: OK. I usally like to send patches if possible rather than long emails with "replace 'teh' with 'the' in the 4th paragraph"
19:12:43 <jreznik> #info installation guide was rewritten (still some TODOs) and integrated into anaconda
19:12:51 <randomuser> jzb, hey, I like patches - but I don't want someone to read and think "it would be better if this topic was expanded more in this direction, but I don't have time for a patch, so I'm not going to say anything at all"
19:12:53 <adamw> randomuser: it might be worth having something about how you should use the Server netinst for Workstation network installs (and generally that the 'Server' netinst is really generic)
19:13:08 <adamw> randomuser: anaconda has grown a whole bunch of Help screens, yup.
19:13:13 <adamw> nice job on that
19:13:16 <randomuser> adamw, if that's not in there, I need to refresh
19:13:26 <adamw> randomuser: it may be, i didn't look yet
19:13:31 <adamw> just the first thing that came to mind
19:13:39 <randomuser> the help screens are all from pbokoc, who has been a juggernaut this release
19:14:02 <jzb> randomuser: ack
19:14:28 <jreznik> thanks for all work randomuser and rest of the team, anything else?
19:14:55 <randomuser> thanks, and nothing else from me
19:15:12 <jreznik> #topic FESCo
19:15:23 <danofsatx-work> section 2.2.2 - it reads "Fedora Documentation Server", it should read just "Fedora Server"
19:15:28 <jreznik> nirik, sgallagh, mattdm: anything from FESCo?
19:15:42 <nirik> nope. we should be all good to go.
19:15:54 <randomuser> danofsatx-work, -docs would be better, but thanks
19:16:01 <danofsatx-work> np
19:16:14 <sgallagh> I have nothing
19:16:21 <jreznik> #info FESCo is all good to go
19:17:31 <jreznik> I'm going to skip Fedora Engineering Manager, stickster is off-site today
19:17:41 <jreznik> #topic Fedora Project Leader
19:17:52 <jreznik> mattdm: anything from FPL for F21 release?
19:18:08 <jreznik> I expect release announcement for you will be ready on Monday
19:18:31 <jzb> jreznik: that's correct, but that's under mktg, yeah? ;-)
19:18:49 <jreznik> jzb: it is, just heads up for mattdm
19:19:46 <jreznik> other question I have are elections, we're now almost post release but I'm not sure it makes sense to start it before holidays, Jan seems more doable
19:19:58 <mattdm> me wakes up :)
19:20:07 <jreznik> good morning sir!
19:20:08 <jzb> jreznik: didn't we just have one?
19:20:09 <mattdm> Yes I think the announcement is in hand.
19:20:18 <mattdm> also reviewing red hat press release
19:20:31 <jreznik> good idea
19:20:37 <sgallagh> jzb: There was a Council election, but FESCo and others are still upcoming
19:20:43 <jzb> ah, right
19:20:49 <jreznik> jzb: council but we have fesco, fosco and env and stacks coming
19:20:50 <jzb> mattdm: I'm butchering it as well, er reviewing
19:20:54 <mattdm> I think january makes sense for fesco and famsco (possibly fosco?)
19:21:12 <mattdm> jzb: cool. I was mostly concerned with the fpl quote :)
19:21:35 <jreznik> we are usually tight to release + max one month but it this case I'd say let's start early Jan (also to have a gap between council and this elections)
19:21:51 <jreznik> anything else mattdm?
19:23:19 <mattdm> I don't think so
19:23:30 <jreznik> thanks, moving on
19:23:33 <mattdm> but if anyone has something they want me to do or know, please tell me :)
19:23:44 <jreznik> #topic Design
19:23:51 <jreznik> omzim: thanks for coming!
19:23:58 <omzim> sorry about my time zone issues
19:25:08 <jreznik> omzim: np, tz are standard meetings killer
19:25:15 <omzim> the only design issues that were of any risk or concern that im aware of was the product specific branding (Bz 1155228) which looks like it's resolved as of rc1
19:25:22 <omzim> the other was the wallpaper, which is more complicated
19:25:52 <omzim> so there is this one on the wallpaper, which should be fixed 1143981
19:25:58 <jreznik> omzim: I can confirm RC5 looks good, there were some issues with colors and usability but sgallagh was able to fix it
19:26:04 <omzim> then there was the one where we're overlaying the logo on top of the wallpaper via a gnome shell plugin
19:26:09 <omzim> i dont know the status of that
19:26:16 <sgallagh> omzim: Actually, there's one issue with 32-bit, but we decided to run with it anyway
19:26:37 <sgallagh> For some reason, the 32-bit Server installer is using the "generic" Fedora branding, rather than the Fedora Server branding.
19:26:38 <omzim> jreznik, sgallagh - does the fedora logo appear on the wallpaper in rc5?
19:26:44 <omzim> sgallagh, ugh that's annoying
19:26:49 <omzim> sgallagh, any idea why?
19:27:11 <sgallagh> We haven't figured it out yet. We're not heavily promoting the 32-bit version, so it's low-priority.
19:27:17 <sgallagh> We assume a compose hiccup of some sort
19:27:32 <omzim> makes sense
19:27:39 <omzim> other than that, i've got nothing to report :)
19:27:40 <sgallagh> The 64-bit works fine, so...
19:28:02 <jreznik> omzim: I tried only kde image, no extension and for generic theming I have one issue - black title on top of dark blue background is hard to read
19:28:13 <adamw> did anyone try 32-bit live, btw?
19:28:24 <roshi> I did
19:28:31 <roshi> worked fine, installed fine
19:28:41 <smccann> I did on RC2 I think
19:28:44 <sgallagh> roshi: Did it have the Product branding?
19:28:46 <omzim> jreznik, i dont nkow who maintains / selects the kde theming? but design team doesn't
19:28:46 <roshi> saw no issues - and I think satellit did as well for RC5
19:28:53 <roshi> iirc it did
19:28:55 <omzim> jreznik, was this an issue in anaconda or kde?
19:28:59 <jreznik> omzim: I mean in anaconda
19:29:00 * roshi checks - still has the vm
19:29:25 <omzim> there shouldn't be titles on top of the theme artwork for anaconda
19:29:29 <jalalsfs> I tried RC5 Could version 64, all the desktops and options available there, not like Server version.
19:29:35 <roshi> "Fedora" is on the desktop
19:29:42 <jalalsfs> *Cloud
19:29:48 <omzim> "fedora" is on the desktop but we're talking about anaconda right?
19:29:52 * omzim is very confused now
19:29:54 <jreznik> #info product specific branding (Bz 1155228) is fixed with some sort of issues in 32 bit server
19:30:39 <roshi> branding looks good in 32bit anaconda as well
19:30:46 <roshi> does that answer the questions?
19:30:49 <adamw> 32-bit live workstation does have the branding, just 32-bit server dvd/netinst that doesn't. huh.
19:30:51 <jreznik> omzim: I mean titles/labels in spokes (there's blue background in header)... I don't have screenshot and that's not a big deal, with generic fedora branding on kde live
19:31:01 <mattdm> we're going to work with releng and anaconda team to solve this in a better way for f22 so whatever went wrong with 32 bit server is academic at this point.
19:31:10 <jreznik> yep
19:31:20 <omzim> jreznik, ohhhh weird. that's probably a css issue, easy to fix, is there a bug for it?
19:31:29 <jreznik> anyone can confirm logo overlay went into gnome?
19:31:32 <omzim> obvs not a blocker but we should get it fixed at some point
19:31:35 <jreznik> omzim: I'll report it tomorrow
19:31:38 <roshi> did for me jreznik
19:31:41 <roshi> 32bit
19:31:49 <jalalsfs> adamw, Even 64 it doesn't have.
19:32:12 <adamw> jalalsfs: i don't think you're talking about the same thing as the rest of us.
19:32:13 <mattdm> adamw: workstation/server difference is easy to explain because the livecd is an entirely different (kickstart hack!) process
19:32:20 <adamw> mattdm: ah, k.
19:32:57 <mattdm> _that_ one turned out to be the easy one-liner I was expecting. server/cloud turned out to be hellish rabbit hole
19:33:25 <jreznik> so we still have some work to polish branding for f22 but it's mostly there and looking great
19:33:55 <jreznik> anything else that's still needed from design team as last minute call?
19:34:22 <omzim> anyone? bueller? bueller?
19:34:32 <mattdm> task add "file f22 feature for improving differentiated branding (lorax, pungi, anaconda, design team, working groups, oh my)"
19:34:51 <jreznik> that's a good task
19:35:08 <adamw> deadline: alpha.
19:35:50 <jreznik> #action file f22 feature for improving differentiated branding (lorax, pungi, anaconda, design team, working groups, oh my) with alpha deadline
19:36:06 <jreznik> ok, if there's nothing else, I'll move on, thanks omzim
19:36:12 <omzim> o/
19:36:16 <omzim> sure
19:36:29 <jreznik> #topic Marketing
19:36:34 <jreznik> jzb: your turn
19:36:38 <jzb> woot
19:36:56 <jzb> Release announcement is pretty much done. Need to formatize it for Fedora Magazine and email
19:37:20 <jzb> We should try to produce a cloud, server, and workstation article for Fedora Magazine as well
19:37:29 <jreznik> #info release announcement is pretty much done. Need to formatize it for Fedora Magazine and email
19:37:38 <jzb> not necessarily for F21 release date but in the following week
19:38:06 <jzb> so we are all green on the mktg side unless there's something I'm forgetting.
19:38:09 <jzb> EOF
19:38:38 <jreznik> jzb: do you want to do the magazine post or do you want me to do it?
19:38:53 <jzb> jreznik: I'll take care of it - I'm sure you have enough on your plate :-D
19:39:09 <jreznik> jzb: thanks!
19:39:28 <jreznik> moving on
19:39:29 <jreznik> #topic Infrastructure
19:39:41 <jreznik> nirik: are you around? I expect infra is ok
19:40:10 <roshi> some of them are in the FAD now
19:40:20 <roshi> iirc
19:40:23 <nirik> jreznik: yep. we are ready
19:40:29 * nirik is at a FAD, but around. ;)
19:40:36 <jreznik> #info infra is ready
19:40:51 * jreznik is already travelling to another FAD, everyone to FADs!
19:41:03 <jreznik> #topic QA
19:41:23 <jreznik> adamw, roshi: you? common bugs, anything else?
19:42:08 <roshi> not sure on common bugs, one specifically needs checked
19:42:23 <adamw> ahoj
19:42:27 <adamw> common bugs needs doing of course
19:42:28 <roshi> I can check that quickly after the meeting
19:42:35 <roshi> we're good afaik
19:42:36 <adamw> it won't be quick :P
19:42:43 <roshi> I said "check"
19:42:45 <adamw> nah, there's a ton of new ones to add, there always are.
19:42:49 <roshi> nothing to do with fixing :p
19:42:59 <adamw> i usually pencil it in for friday/monday
19:43:02 <roshi> I check, then we have danofsatx-work do the work
19:43:10 <roshi> I mean, work is in his *nick*
19:43:11 <adamw> aside from that i don't think we have any specific action items, no post-release fedup emergencies or anything
19:43:13 <adamw> haha
19:43:30 <adamw> need to get spin-kickstarts pushed stable and do the housekeeping on tracker bugs and blah, nothing interesting
19:43:32 <jreznik> #info common bugs has to be processed, tons of new bugs proposed to be included
19:43:50 <jreznik> #info need to get spin-kickstarts pushed stable and do the housekeeping on tracker bugs
19:43:53 <jreznik> ok thanks!
19:44:20 <randomuser> adamw, if there isn't one, supposedly 32bit efi netbooks are getting sold - coommonbugs might be a good place to throw out a warning that we don't do that
19:44:27 <jreznik> #topic Websites
19:44:30 <randomuser> on 64bit CPUs, no less
19:44:34 <jreznik> robyduck: are you around?
19:44:42 <robyduck> jreznik: I am
19:44:49 <pjones> yeah, I really should get one of those and finish making it supported.
19:44:51 <adamw> randomuser: you know, i think i read some stuff about that on some dude's blog
19:44:53 <jreznik> how does websites look for GA?
19:45:00 <adamw> randomuser: ooh, that's right. https://www.happyassassin.net/fedlet-a-fedora-remix-for-bay-trail-tablets/
19:45:07 <robyduck> so we had some bugs to fix, because our scripts didn't work as expected on the new website, but we should be done now (hopefully). We are still working on it but I'm sure all bits will be in place for tuesday ;)
19:45:13 <pjones> (as opposed to adamw's fine work figuring out how to do it outside of the distro itself.)
19:45:21 * adamw looks at the 'make an f21 final-ish release of fedlet' item on his personal todo list
19:45:34 <randomuser> oh come on, adamw, you cant expect me to keep up with every joe's blog
19:45:41 <adamw> pjones: that's an insult to all fine things.
19:45:54 <pjones> adamw: I think I'm okay insulting all fine things.
19:46:11 <adamw> i didn't get to testing the 32-on-64 stuff yet :( hopefully i'll be able to slot it into the pre-f22 'quiet' time.
19:46:15 <randomuser> adamw, joking aside, I do regularly refer these kind of questions to your blog
19:46:17 <adamw> er, 64-on-32.
19:46:17 <jzb> randomuser: hey
19:46:20 <adamw> ykwim.
19:46:22 <jreznik> #info websites had some bugs to fix, because our scripts didn't work as expected on the new website, but we should be done now (hopefully). We are still working on it but I'm sure all bits will be in place for tuesday ;)
19:46:43 <robyduck> didn't check docs
19:46:49 <jreznik> robyduck: any help you need?
19:46:51 <adamw> randomuser: and yeah, seriously, it's a candidate, though that's the kind of one that falls in a grey area between release notes and commonbugs for me
19:46:52 <Corey84-> sorry im late
19:47:14 <robyduck> jreznik: I think not, it's the usual thing now
19:47:24 <randomuser> adamw, ack - it can go in RNs too/instead
19:47:24 <robyduck> randomuser: are docs in place?
19:47:32 <robyduck> IG for example?
19:47:55 <adamw> sorry if i'm playing catch up, but one thing i really wanted to make sure - is there a good communication plan for 'use the Server netinst for Workstation and non-Product netinsts'?
19:47:57 <randomuser> robyduck, it will be - but you're using the redirect, right, so our publishing shouldn't hold you up
19:48:18 <robyduck> aha, ok thx
19:48:22 <robyduck> then we are ok
19:48:23 <randomuser> adamw, https://fedorapeople.org/groups/docs/release-notes/#sect-Products
19:48:41 <randomuser> robyduck, if you find someplace that doesn't apply, let's do talk about it
19:48:41 <adamw> randomuser: i was thinking more on the Download pages side
19:48:49 <adamw> when you go click on 'download Fedora'
19:48:55 <randomuser> oh, good call
19:48:57 <Corey84-> randomuser, ill take a look again like i did on rc2 later
19:49:44 <robyduck> randomuser: ok thank you, will do
19:53:43 <Corey84-> adamw, what do you mean (not as up to speed on server stuff)
19:54:31 <adamw> Corey84-: our official line is that if you want to do a network install of Workstation - or, really, a network install of anything - just use the 'Server' network install image
19:54:32 * jreznik has to leave now, feel free to continue here (and thanks for coming)
19:54:36 <adamw> which, despite the name, can install any environment
19:54:44 <jreznik> #chair roshi adamw robyduck robyduck
19:54:44 <zodbot> Current chairs: adamw jreznik robyduck roshi
19:54:52 <jreznik> just endmeeting pls :)
19:54:55 <adamw> i just wanted to check the website pages communicate that
19:55:01 <adamw> yeah, everyone seems to have lost interest. =)
19:55:07 <randomuser> can someone please make sure robyduck is chaired?
19:55:08 <Corey84-> as in a pxe install regardless adamw ?
19:55:11 <adamw> no more groups to cover?
19:55:15 <adamw> Corey84-: no. not pxe.
19:55:16 <roshi> #chair robyduck
19:55:17 <zodbot> Current chairs: adamw jreznik robyduck roshi
19:55:24 * randomuser smirks
19:56:20 <roshi> no idea if there are more groups to cover
19:56:21 <Corey84-> nvm long morning had to reread makes sense now adamw
19:56:31 * roshi looks for the SOP for this meeting
19:56:32 <adamw> roshi: me either
19:56:50 <jreznik> or maybe I'll end meeting and you can finish it on #fedora-docs
19:57:06 <jreznik> roshi: I have SOP for go/no-go, have to finish readiness although
19:57:11 <robyduck> no we don't communicate that on the websites actually
19:57:15 <jreznik> I thought it's there, not yet
19:57:39 <jreznik> robyduck, adamw: if you can finish on -docs, -websites, I'd like to close it here unless you have anything else
19:57:55 <robyduck> jreznik: I don't have anything else
19:57:55 <jreznik> sesivany is nervous, waiting for me and see you tomorrow f2f!
19:58:05 <jreznik> ok, thanks for coming everyone!
19:58:08 <jreznik> #endmeeting