#fedora-blocker-review: F24-blocker-review
Meeting started by adamw at 16:02:11 UTC
(full logs).
Meeting summary
- Roll Call (adamw, 16:02:11)
- Introduction (adamw, 16:12:00)
- Our purpose in this meeting is to review
proposed blocker and nice-to-have bugs and decide whether to accept
them, and to monitor the progress of fixing existing accepted
blocker and nice-to-have bugs. (adamw,
16:12:00)
- We'll be following the process outlined
at: (adamw,
16:12:00)
- https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
(adamw,
16:12:01)
- The bugs up for review today are available
at: (adamw,
16:12:02)
- http://qa.fedoraproject.org/blockerbugs/current
(adamw,
16:12:04)
- The criteria for release blocking bugs can be
found at: (adamw,
16:12:06)
- https://fedoraproject.org/wiki/Fedora_24_Alpha_Release_Criteria
(adamw,
16:12:10)
- https://fedoraproject.org/wiki/Fedora_24_Beta_Release_Criteria
(adamw,
16:12:12)
- https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria
(adamw,
16:12:14)
- pschindl will secretarialize (adamw,
16:13:55)
- 8 Proposed Blockers (adamw,
16:14:29)
- 2 Accepted Blockers (adamw,
16:14:30)
- 3 Proposed Freeze Exceptions (adamw,
16:14:30)
- 4 Accepted Freeze Exceptions (adamw,
16:14:30)
- we also have 4 Proposed Blockers for
Final (adamw,
16:14:47)
- (1322909) docker-1.10.3-3.gitd93ee51.fc24 fails to run anything (adamw, 16:15:16)
- https://bugzilla.redhat.com/show_bug.cgi?id=1322909
(adamw,
16:15:17)
- Proposed Blocker, docker, NEW (adamw,
16:15:17)
- ACTION: adamw to
propose docker criteria (adamw,
16:20:27)
- https://bugzilla.redhat.com/show_bug.cgi?id=1322909#c21
(adamw,
16:23:11)
- AGREED: 1322909 -
RejectedBlocker - this is rejected for now as sgallagh's testing
indicates the current stable package is not affected and there are
no docker criteria in any case, but it may be re-evaluated if the
bug affects -4 and we add docker criteria as proposed (adamw,
16:31:44)
- (1314494) knode has unmet dependencies during dnf system-upgrade to f24 (adamw, 16:32:32)
- https://bugzilla.redhat.com/show_bug.cgi?id=1314494
(adamw,
16:32:32)
- Proposed Blocker, kdepim, ON_QA (adamw,
16:32:32)
- AGREED: 1314494 -
AcceptedBlocker (Beta) - this is a violation of "For each one of the
release-blocking package sets, it must be possible to successfully
complete a direct upgrade from fully updated installations of the
last two stable Fedora releases with that package set installed."
for the KDE package set (adamw,
16:41:28)
- (1328369) Luc doesn't reuse already downloaded image and stuck (adamw, 16:41:56)
- https://bugzilla.redhat.com/show_bug.cgi?id=1328369
(adamw,
16:41:56)
- Proposed Blocker, liveusb-creator,
VERIFIED (adamw,
16:41:56)
- AGREED: 1328369 -
AcceptedFreezeException (Beta) - this is clearly bad enough to merit
a freeze exception. We are undecided on blocker status for now, will
re-evaluate at Go/No-Go if it is not pushed stable for all releases
by then (adamw,
16:48:46)
- (1328484) liveusb-creator on Windows 10 opens diskpart.exe but does nothing (adamw, 16:49:12)
- https://bugzilla.redhat.com/show_bug.cgi?id=1328484
(adamw,
16:49:12)
- Proposed Blocker, liveusb-creator,
VERIFIED (adamw,
16:49:12)
- no evaluation needed for #1328484 as bug is
considered resolved (adamw,
16:52:09)
- (1328498) partitions are not unmounted before writing image to a device, can lead to corrupted data written (adamw, 16:52:18)
- https://bugzilla.redhat.com/show_bug.cgi?id=1328498
(adamw,
16:52:18)
- Proposed Blocker, liveusb-creator,
VERIFIED (adamw,
16:52:18)
- AGREED: 1328498 -
AcceptedPreviousRelease (22 and 23), AcceptedFreezeException (Beta)
- this violates "All release-blocking images must boot in their
supported configurations." (with the footnote about USB media) for
F22 and F23. we may also consider it serious enough to be an F24
Beta blocker if not pushed stable by go/no-go, but it is at least
freeze exception-worthy for now (adamw,
17:01:01)
- (1329532) liveusb-creator on Windows 10 doesn't write image (adamw, 17:01:20)
- https://bugzilla.redhat.com/show_bug.cgi?id=1329532
(adamw,
17:01:20)
- Proposed Blocker, liveusb-creator,
VERIFIED (adamw,
17:01:21)
- as with 1328484, this is believed resolved in
current version of Windows build, no evaluation required
(adamw,
17:03:36)
- (1329608) missing deps on F22 (adamw, 17:03:47)
- https://bugzilla.redhat.com/show_bug.cgi?id=1329608
(adamw,
17:03:47)
- Proposed Blocker, liveusb-creator,
ASSIGNED (adamw,
17:03:47)
- AGREED: 1329608 -
RejectedBlocker (Beta) - the affected luc never reached stable for
F22, so this bug does not violate the criteria (adamw,
17:19:08)
- (1329611) no image written on F22 (adamw, 17:19:17)
- https://bugzilla.redhat.com/show_bug.cgi?id=1329611
(adamw,
17:19:17)
- Proposed Blocker, liveusb-creator,
ASSIGNED (adamw,
17:19:17)
- AGREED: 1329611 -
RejectedBlocker (Beta) - the affected luc never reached stable for
F22, so this bug does not violate the criteria (adamw,
17:20:44)
- (1327615) Incorrect subnet mask shown in network spoke (adamw, 17:22:03)
- https://bugzilla.redhat.com/show_bug.cgi?id=1327615
(adamw,
17:22:03)
- Proposed Freeze Exceptions, anaconda,
POST (adamw,
17:22:03)
- AGREED: 1327615 -
RejectedFreezeException (Beta) - at this point in the Beta process
it's a bit late to poke the network screen for a purely cosmetic
fix (adamw,
17:29:57)
- (1329715) [abrt] sddm: drainMarkStack(): sddm-greeter killed by SIGSEGV (adamw, 17:30:49)
- https://bugzilla.redhat.com/show_bug.cgi?id=1329715
(adamw,
17:30:49)
- Proposed Freeze Exceptions, sddm, NEW
(adamw,
17:30:50)
- https://openqa.fedoraproject.org/tests/14439
(adamw,
17:32:18)
- AGREED: 1329715 -
AcceptedFreezeException (Beta) - if a targeted and tested fix for
this is available soon we will consider including it (as this would
be an upgrade criterion violation if i686 still blocked releases),
but will be careful not to break x86_64 (adamw,
17:36:01)
- accepted blocker update (adamw,
17:36:32)
- 1321330 - dennis and peter are actively working
on it (adamw,
17:36:45)
- 1259865 - hughsie and mclasen reported earlier
that this is also being worked on (adamw,
17:37:02)
- we will do final blocker review next week, for
now we'll prioritize beta testing (adamw,
17:42:21)
- Open floor (adamw, 17:42:27)
Meeting ended at 18:54:20 UTC
(full logs).
Action items
- adamw to propose docker criteria
Action items, by person
- adamw
- adamw to propose docker criteria
People present (lines said)
- adamw (267)
- kparal (95)
- cmurf (74)
- RaphGro (19)
- jkurik (19)
- pschindl (13)
- pwhalen (10)
- zodbot (8)
- garretraziel (4)
- nb (3)
- Amita (2)
- tflink (1)
Generated by MeetBot 0.1.4.