16:01:13 <adamw> #startmeeting F35-blocker-review
16:01:13 <zodbot> Meeting started Mon Aug 30 16:01:13 2021 UTC.
16:01:13 <zodbot> This meeting is logged and archived in a public location.
16:01:13 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:13 <zodbot> The meeting name has been set to 'f35-blocker-review'
16:01:19 <adamw> #meetingname F35-blocker-review
16:01:19 <zodbot> The meeting name has been set to 'f35-blocker-review'
16:01:20 <adamw> #topic Roll Call
16:01:28 <bcotton> .hello2
16:01:29 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:01:31 <coremodule> .hello2
16:01:32 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
16:03:27 <adamw> ahoyhoy
16:04:02 <cmurf[m]> .hello chrismurphy
16:04:03 <zodbot> cmurf[m]: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
16:04:31 <coremodule> I voted on several of the CE'
16:04:35 <coremodule> *FE
16:04:37 <coremodule> dangit
16:04:58 <coremodule> I voted on several of the FEs just a few minutes ago and marked six of them as accepted after reaching 3 votes
16:05:29 <adamw> coremodule: thanks, did you mark them in BZ as well?
16:05:40 <coremodule> negative
16:05:45 <coremodule> I will do that
16:06:17 <coremodule> its been a whole cycle since I've had to do this!
16:06:48 <adamw> hehe
16:07:07 <adamw> the app won't move them to 'accepted' until bz is updated (and we resync)
16:07:16 <adamw> let me know when you've done them all and i'll force a resync
16:07:46 <pwhalen> .hello2
16:07:47 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
16:09:41 <adamw> morning pwhalen
16:09:47 <coremodule> adamw, wilco, give me 2 more min
16:12:02 <coremodule> alright adamw, done
16:12:11 <adamw> rgr
16:14:27 <adamw> resynced
16:14:41 <adamw> that looks better!
16:14:47 <coremodule> sweet!!
16:14:48 <adamw> nice quick meeting coming up
16:14:54 <adamw> #chair pwhalen coremodule
16:14:54 <zodbot> Current chairs: adamw coremodule pwhalen
16:14:54 <bcotton> this one weird trick shortens meetings by 80%
16:15:06 <coremodule> lol
16:15:17 <pwhalen> heh
16:15:18 <adamw> impending boilerplate alert
16:15:23 <adamw> #topic Introduction
16:15:26 <adamw> Why are we here?
16:15:31 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:15:36 <adamw> #info We'll be following the process outlined at:
16:15:41 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:15:48 <adamw> #info The bugs up for review today are available at:
16:15:48 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:15:54 <adamw> #info The criteria for release blocking bugs can be found at:
16:15:58 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:16:15 <adamw> #link https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria
16:16:16 <adamw> #link https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria
16:16:17 <adamw> god I have got to find a better way to do that in matrix
16:16:28 <adamw> #info for Beta, we have:
16:16:33 <adamw> #info 1 Proposed Blockers
16:16:33 <adamw> #info 7 Accepted Blockers
16:16:42 <adamw> dang did that come through as a multiline message?
16:16:50 <bcotton> yes
16:16:51 <pwhalen> no, looks good
16:17:29 <adamw> 1 proposed blocker, 7 accepted blockers, moving on
16:17:32 <bcotton> it's definitely one message on the matrix side. did the bridge get smarter?
16:17:33 <adamw> #info for Final, we have:
16:17:48 <adamw> gah
16:17:49 <adamw> #undo
16:17:49 <zodbot> Removing item from minutes: INFO by adamw at 16:17:33 : for Final, we have:
16:17:55 <adamw> #info 1 Proposed Freeze Exceptions
16:18:00 <adamw> #info 12 Accepted Freeze Exceptions
16:18:05 <adamw> #info for Final, we have:
16:18:17 <adamw> #info 1 Proposed Blockers
16:18:20 <adamw> #info 2 Accepted Blockers
16:18:31 <adamw> alright, whew
16:18:37 <adamw> who wants to secretarialize? i volunteer coremodule
16:18:57 <cmurf[m]> the efficiency of volunteering others :P
16:18:57 <coremodule> dang I was going to not say anything when it came to this point, despite the last 5 years history
16:19:07 <coremodule> but since you insist
16:19:24 <adamw> =)
16:19:33 <adamw> #info coremodule will secretarialize
16:19:37 * mclasen lurks
16:20:04 * sgallagh is around-ish
16:20:15 <adamw> so you're sort of aoval?
16:20:29 <sgallagh> Pear-shaped
16:20:30 <adamw> thanks folks, i'm here all week
16:20:48 <adamw> alrighty, let's get started with
16:20:51 <adamw> #topic Proposed Beta blockers
16:21:03 <adamw> #topic (1998712) does not boot - bad shim signature, you need to load the kernel first
16:21:08 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1998712
16:21:14 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/415
16:21:18 <adamw> #info Proposed Blocker, kernel, NEW
16:21:24 <adamw> #info Ticket vote: BetaBlocker (+3,0,-0) (+tablepc, +coremodule, +chrismurphy)
16:21:37 <adamw> oh, this has +3 already? welp, let's have a quick looksee anyway
16:22:04 <sgallagh> Seems +1 to me
16:22:06 <pwhalen> +1 blocker
16:22:13 <sgallagh> Though it also is reportedly fixed already
16:23:08 <adamw> uh, don't we already have a bug for this?
16:24:09 <adamw> yes, https://bugzilla.redhat.com/show_bug.cgi?id=1997886#c3
16:24:51 <adamw> eh, i guess we can count it as an f35 version.
16:25:36 <bcotton> +1 blocker
16:26:13 <adamw> a kernel that should fix this is building atm, will be submitted as an update soon
16:27:52 <adamw> proposed #agreed 1997886 - AcceptedBlocker (Beta) - seems like a violation of "All release-blocking images must boot in their supported configurations", with footnote that lists secure boot as covered
16:28:44 <pwhalen> ack
16:28:52 <coremodule> ack
16:30:04 <cmurf[m]> ack
16:30:11 <adamw> #agreed 1997886 - AcceptedBlocker (Beta) - seems like a violation of "All release-blocking images must boot in their supported configurations", with footnote that lists secure boot as covered
16:30:44 <adamw> moving on to:
16:30:45 <adamw> #topic Proposed Beta freeze exceptions
16:30:45 <adamw> #topic (1936939) osbs-client fails to build with Python 3.10: E subprocess.CalledProcessError: Command '['git', 'rev-parse', 'HEAD']' returned non-zero exit status 128.
16:30:46 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1936939
16:30:49 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/404
16:30:56 <adamw> #info Proposed Freeze Exceptions, osbs-client, ON_QA
16:30:58 <adamw> #info Ticket vote: BetaFreezeException (+2,0,-0) (+adamwill, +coremodule)
16:31:20 <adamw> this is fails-to-install, not just fails-to-build, as it needs rebuilding for the python 3.10 bump
16:31:20 <adamw> so fe seems reasonable
16:31:56 <sgallagh> OSBS isn't part of any install media, is it?
16:32:15 <sgallagh> If not, why is an FE needed?
16:34:12 <adamw> the standard reason is it helps with upgrades during the freeze
16:34:33 <adamw> there's kind of a catch-all - if it's on media we want it to be installable, if it's not on media then the FE only helps with upgrades, but can't break any media. :P
16:34:58 <adamw> so we usually wind up just taking FTIs as FEs. i do check them and make sure the builds aren't introducing any huge possibly-dangerous changes though.
16:35:50 <pwhalen> +1 FE
16:36:39 <sgallagh> I'll abstain, but I generally think that the point of a Freeze is to... avoid making changes.
16:37:09 <adamw> wow, get this guy and his crazy takes
16:37:27 <bcotton> I stand with sgallagh :-)
16:37:38 <coremodule> they called him crazy until he suggested THIS
16:37:40 <sgallagh> Maybe I should stop sleeping in my car with the garage door closed.
16:37:47 <coremodule> playing off bcotton
16:39:07 <adamw> aaaanyhoo
16:39:07 <bcotton> sgallagh isn't crazy, he's just a little unwell. I know right now you can't tell. But stay awhile and maybe then you'll see a different side of he
16:39:12 <adamw> unless anyone actually wants to vote -1, we've got +3, so
16:39:51 <sgallagh> I'm 0 because this is so off on its own, but my concern has been logged.
16:39:51 <cmurf[m]> seems low risk right
16:39:52 <sgallagh> So let's move on
16:40:22 <adamw> proposed #agreed 1936939 - AcceptedFreezeException (Beta) - this is accepted as an FE as a fails-to-install issue, which we generally accept on the basis that fixing them helps upgrades work during the freeze period (without updates-testing enabled, as is commonly the case)
16:40:22 <bcotton> ack
16:40:26 <coremodule> ack
16:40:52 <sgallagh> ack
16:40:53 <sgallagh> u-t is always enabled for Beta unless a user turns it off manually, but whatever
16:41:14 <pwhalen> ack
16:41:57 <adamw> sgallagh: it's enabled for fresh installs
16:41:58 <adamw> but when you're upgrading, the upgrade process uses whatever repos are currently installed, which typically doesn't include u-t
16:41:58 <adamw> s/installed/enabled/
16:41:58 <sgallagh> ah
16:43:02 <adamw> #agreed 1936939 - AcceptedFreezeException (Beta) - this is accepted as an FE as a fails-to-install issue, which we generally accept on the basis that fixing them helps upgrades work during the freeze period (without updates-testing enabled, as is commonly the case)
16:43:03 <adamw> moving on to...
16:43:03 <adamw> #topic Proposed Final blockers
16:43:03 <adamw> #topic (1991075) time is transiently incorrect when Automatic Time Zone is enabled
16:43:03 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1991075
16:43:03 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/389
16:43:33 <adamw> #info Proposed Blocker, gnome-settings-daemon, NEW
16:43:33 <adamw> this is +3 in the ticket but i decided to put it in the meeting as i figured there may be some -1s
16:43:34 <adamw> #info Ticket vote: FinalBlocker (+3,0,-0) (+bcotton, +chrismurphy, +tablepc)
16:43:34 <adamw> i'm kinda on the fence about it, i suspect it might not pass the 'last blocker' test
16:43:51 <adamw> it could be fixed by an update without hurting much, i guess. but it is a kinda visible and embarrassing issue...
16:45:13 <cmurf[m]> we could punt this and see if more people hit it
16:46:03 <cmurf[m]> or if it's conditional on some local issue
16:46:03 <sgallagh> This would not pass the last blocker test. -1
16:46:45 <sgallagh> It'd be a firm +1 FE from me, though.
16:46:46 <adamw> yeah, i'd definitely be +1 beta FE, we should vote on that too
16:46:46 <bcotton> feels like the sort of thing that would get us raked over the coals in reviews and whatnot
16:47:15 <cmurf[m]> we're not even sure what the problem could be though either which also means no fix is on the way
16:47:15 <sgallagh> Ben Cotton (he/him/his): If only we had some process by which we could prioritize certain non-blocking bugs to be looked at...
16:47:15 <cmurf[m]> +1 beta FE
16:47:26 <bcotton> is it purely cosmetic or would it break things that rely on the clock being accurate (e.g kerberos)
16:47:50 <pwhalen> +1 beta FE
16:48:27 <bcotton> sgallagh: i think the potential harm to the release directs this more toward the blocker process instead of the prioritized bugs process
16:49:12 <bcotton> especially since the lives would have to ...live... with it
16:49:13 <cmurf[m]> i think if more than 1 or 2 people hit this bug, it's a blocker
16:49:13 <sgallagh> Ben Cotton (he/him/his): It *looks* like a timezone issue, so stuff like krb5 which uses UTC internally should be okay
16:49:55 <cmurf[m]> but for sure if lots of people hit it, it's a blocker - that's the way the criterion reads
16:50:15 <sgallagh> I guess I'd be +1 Beta FE and prefer to defer Final Blocker status to gather more information
16:50:15 <bcotton> re: krb5, that's what i thought, so i'm glad to hear i was (probably) guessing correctly. that makes me slightly less willing to argue for blocker status, but i remain a +1 final blocker
16:50:15 <cmurf[m]> it's a desktop UI/UX centric criterion
16:52:13 <cmurf[m]> if i'm the only one hitting it, oh well :P
16:53:07 <pwhalen> perhaps punt final blocker, see if others hit it and what other things it might affect?
16:53:58 <cmurf[m]> i'm ok with punt
16:55:02 <adamw> fair enough
16:55:02 <bcotton> i can live with that
16:57:59 * Eighth_Doctor is doing paperwork for pipewire atm
16:58:32 <adamw> proposed #agreed 1991075 - AcceptedFreezeException (Beta), punt (FinalBlocker) - we agreed to accept this issue as a Beta freeze exception issue as it definitely seems significant enough to fix if possible. Opinion on whether it should be a Final blocker was a bit split, and there was a consensus to punt and see if any significant consequences of the bug appear, or if it's mostly cosmetic
16:58:45 <bcotton> ack
16:58:57 <pwhalen> ack
17:00:12 <coremodule> ack
17:01:39 <cmurf[m]> ack
17:02:37 <adamw> #agreed 1991075 - AcceptedFreezeException (Beta), punt (FinalBlocker) - we agreed to accept this issue as a Beta freeze exception issue as it definitely seems significant enough to fix if possible. Opinion on whether it should be a Final blocker was a bit split, and there was a consensus to punt and see if any significant consequences of the bug appear, or if it's mostly cosmetic
17:02:40 <adamw> did that fit?
17:02:46 <cmurf[m]> yes
17:02:48 <coremodule> yeah
17:02:51 <cmurf[m]> at least on matrix
17:02:57 <coremodule> it fit on irc
17:07:36 <adamw> alrighty
17:08:41 <adamw> thus endeth the proposals part of the meeting
17:08:42 <adamw> i'll do a quick scoot through accepted blockers for the interested
17:08:42 <adamw> #topic Accepted Beta blockers
17:08:42 <adamw> #info fix for 1996223 is pending stable push
17:08:42 <adamw> #info fix for 1993238 is pending stable push
17:08:43 <adamw> #topic (1989726) [abrt] gnome-shell: cogl_texture_get_gl_texture(): gnome-shell killed by SIGSEGV
17:08:43 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1989726
17:09:34 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/399
17:09:35 <adamw> or is this more a 'graphics people' kinda ping?
17:09:35 <adamw> kalev: mclasen: do you have any info on this one?
17:09:35 <adamw> #info Accepted Blocker, gnome-shell, NEW
17:09:55 <mclasen> according to fmuellner: 'driver issue or mutter bug'
17:11:41 <adamw> those seem like two fairly distinct possiblities :) how do we figure out which?
17:12:28 <adamw> i've moved it to mutter for now at least
17:14:59 <adamw> #info this is apparently "a driver issue or mutter bug", we don't know which. need to figure that out to fix it, I guess.
17:15:12 <adamw> #topic (1998681) KDE needs to pick up F35 backgrounds
17:15:16 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1998681
17:15:20 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/414
17:15:27 <adamw> #info Accepted Blocker, kde-settings, NEW
17:15:44 <adamw> #info this should be fairly straightforward for KDE team, don't expect any issues, it's a standard thing
17:16:17 <adamw> #topic (1995817) GNOME Software updates fail with "Prepared update not found" error
17:16:20 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1995817
17:16:24 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/397
17:16:26 <adamw> #info Accepted Blocker, PackageKit, NEW
17:16:59 <adamw> this one actually got less common recently, but still happens sometimes. not 100% sure what's going on. I'll see if I can debug it any more.
17:18:05 <adamw> #info we're not yet clear on what's happening here, mcrha and I are trying to figure it out
17:18:06 <adamw> #info fix for 1997854 is pending stable push
17:18:06 <adamw> #topic (1983861) pipewire-0.3.31-4.fc35.x86_64 no audio devices found (due to no session manager user service being automatically enabled on install or update)
17:18:06 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1983861
17:18:06 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/388
17:18:26 <adamw> #info Accepted Blocker, pipewire, NEW, depends on other bugs
17:18:27 <adamw> we're kinda struggling with no response from the developer here.
17:19:07 <adamw> i guess, in the end, the issue is relatively simple so probably someone else could fix it if it becomes necessary.
17:19:27 <adamw> there's an update which suggests: wireplumber now, but i don't know if the session service is enabled by default in wireplumber...
17:19:47 <adamw> i guess i'll have to look into it
17:20:41 <adamw> #info this issue seems relatively simple but still need to check it's being properly fixed. the recent update should switch to wireplumber by default, but we still need to make sure the wireplumber session service is enabled by default
17:21:21 <bcotton> are we at the "ben, please go sit on someone's desk until they give a satisfactory answer" stage yet?
17:21:42 <adamw> maybe not quite
17:21:42 <bcotton> roger
17:21:42 <adamw> i will let you know if we get there
17:22:28 <adamw> alrighty, that's all the blockers
17:22:29 <adamw> #topic Open floor
17:22:29 <adamw> any other business, folks?
17:23:29 <Eighth_Doctor> adamw: I made fixes for this
17:23:30 <pwhalen> I have one, see the "Oh no!" screen in Workstation, similar to what we saw in F34. Initial-setup is run and works fine, system works as expected after running initial-setup
17:23:34 <Eighth_Doctor> submitted an update and comps PRs
17:23:44 <adamw> Conan Kudo: what's "this"?
17:23:53 <Eighth_Doctor> wireplumber-y/pipewire-y issues
17:23:55 <pwhalen> Looks like it affects all arches, might be more visible on aarch64
17:24:24 <Eighth_Doctor> the no session manager by default, nonworking audio, preinstall wireplumber, etc.
17:24:24 <adamw> pwhal: that's already an FE
17:24:25 <adamw> pwhalen: it can't be a blocker yet because we didn't actually approve the criterion
17:24:25 <adamw> this is why i brought it up again last week
17:24:34 <pwhalen> ah, ok. I missed it. thanks.
17:24:47 <adamw> pwhalen: https://bugzilla.redhat.com/show_bug.cgi?id=1997310 - if that's not what you're talking about, let me know
17:25:56 <adamw> Conan Kudo: uh. the update for pipewire is from wim. what update did you send?
17:25:57 <Eighth_Doctor> https://bodhi.fedoraproject.org/updates/FEDORA-2021-b87a167119
17:27:29 <adamw> that's the one from wim...
17:27:53 <bcotton> neal ninjaed an update in (from -1 to -2)
17:27:58 <pwhalen> adamw enforcing=0 makes it run a little faster but the "oh no" screen is still visible briefly
17:28:26 <adamw> ah, okay.
17:28:27 <adamw> -2 was just the mass rebuild, though
17:29:08 <Eighth_Doctor> nope
17:29:09 <bcotton> https://src.fedoraproject.org/rpms/pipewire/c/173bbb14328adeac9d361f05d38aa26b47d990bb?branch=f35
17:29:09 <adamw> oh sorry, i'm confusing pipewire and wireplumber builds, duh
17:29:23 <adamw> but still
17:29:32 <adamw> the pipewire update makes it suggest wireplumber
17:29:44 <adamw> but the key issue in this bug is making sure the service for the session manager is enabled by default
17:29:47 <adamw> whichever session manager is used
17:29:57 <Eighth_Doctor> wireplumber session manager is enabled by default in fedora-release
17:30:03 <Eighth_Doctor> the other one isn't
17:30:16 <adamw> ah, okay. that wasn't mentioned anywhere.
17:30:25 <adamw> would be helpful to point that out in the bug and/or update notes.
17:30:57 <Eighth_Doctor> I'll note it in the bZ
17:30:58 <Eighth_Doctor> *BZ
17:31:26 <adamw> thanks
17:31:52 <adamw> i don't think we need both the update and the comps change, do we?
17:31:58 <Eighth_Doctor> I'm mostly worried about pungi
17:32:05 <Eighth_Doctor> hence comps update
17:32:05 <adamw> yeah, was just thinking about that, sigh
17:32:28 <adamw> i'm trying to remember the ins and outs there
17:32:29 <adamw> oh, i think the thing it might wind up affecting is silverblue...
17:33:21 <adamw> lives are built out of Everything these days so it shouldn't affect workstation live, but i think the issue we're both thinking of is when silverblue gets built out of a tree that doesn't have a package that's Suggested
17:33:44 <Eighth_Doctor> yeah, there's a comps sync thing for silverblue
17:34:26 <Eighth_Doctor> i figure that'll cover it
17:34:49 <adamw> ok, we can chew it over more in the pr, i guess. anyhoo, thanks
17:34:54 <adamw> anything else?
17:37:12 <adamw> alrighty then, thanks for coming everyone
17:38:12 <adamw> #endmeeting