21:02:11 <gregdek-mobile> #startmeeting
21:02:12 <zodbot> Meeting started Thu Feb 11 21:02:11 2010 UTC.  The chair is gregdek-mobile. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:02:22 <gregdek-mobile> w00t
21:02:39 * gholms points gregdek-mobile to http://fpaste.org/mkI7/
21:02:51 <gregdek-mobile> ok, any objection to starting with todos?
21:03:13 * gregdek-mobile needs someone else to post them one by one for discussion :)
21:03:29 <gholms> * EC2 Spin Status
21:03:41 * gholms can't use #topic without being #chair'ed
21:03:52 <gregdek-mobile> #topic covering todos from last meeting
21:04:01 <Oxf13> somebody #chair gholms and jforbes
21:04:15 <Oxf13> s/somebody/gregdek-mobile
21:04:37 <gregdek-mobile> but it says I'm chair!
21:04:46 <gregdek-mobile> grrr @ meetbot
21:04:51 <gholms> gregdek-mobile: It can be a list.  :)
21:05:22 <gregdek-mobile> anyway.
21:05:45 <gregdek-mobile> jforbes: how's the latest kernel?  any movement?
21:06:40 <jforbes> gregdek-mobile: lots of movement, but no ETA.  Basically there are issues with .32 (granted, there are issues with .31, but it is already there, and people don't seem to like new issues even if old issues are fixed)
21:07:01 <Oxf13> make sure to use liberal amounts of #info
21:07:02 <jforbes> gregdek-mobile: issues in this context, not referring to EC2
21:07:06 <Oxf13> for the minutes
21:07:25 * gholms recommends finer-grained #topics than "todos from last meeting"
21:07:26 <gregdek-mobile> #info some progress on .32 kernel but no eta
21:08:08 <gregdek-mobile> gholms, can I chair you?
21:08:17 <gregdek-mobile> my typing is suboptimal at present
21:08:31 <gregdek-mobile> #chair gholms
21:08:32 <zodbot> Current chairs: gholms gregdek-mobile
21:08:33 <gholms> gregdek-mobile: Sure; use the #chair command
21:08:39 <gregdek-mobile> #chair jforbes
21:08:40 <zodbot> Current chairs: gholms gregdek-mobile jforbes
21:08:52 <gregdek-mobile> ok.
21:09:13 <gholms> Cool
21:09:22 <gholms> #topic EC2 Kernel
21:09:58 <gregdek-mobile> seems like we're done with kernel.... hurry up and wait, yes?
21:10:06 <gholms> Any word on documenting the aki/ari upload procesS?
21:10:13 <jforbes> correct
21:10:24 <jforbes> gholms: no, It will be documented as I do the first upload
21:10:25 <gholms> s/S/s/
21:10:47 <jforbes> Well, technically I have some documentation that just needs to be modified for Fedora
21:11:51 <gholms> I presume upload credentials for kernel maintainers are contingent on that.
21:11:58 <jforbes> I suppose at some point we need to discuss bucket labeling
21:12:06 <jforbes> gholms: Yeah, contingent on that
21:12:14 <gregdek-mobile> I think 2 buckets is sufficient.
21:12:14 <jforbes> gholms: but not holding us back at all
21:12:18 <gregdek-mobile> and we have both.
21:12:37 <gholms> Anything else kernel-related?  Next up is update mirroring.
21:12:41 <gregdek-mobile> 1 for authoritative, and 1 for all other work including test kernels.
21:12:51 <jforbes> gregdek-mobile: That's accounts
21:13:23 <gregdek-mobile> oh... right.
21:13:23 <jforbes> gregdek-mobile: I am thinking about storage buckets for the official stuff, I am guessing F#-arch would make the most sense
21:13:40 <gregdek-mobile> yeah, +1
21:13:55 <gholms> Kernels and amis in the same buckets?
21:14:08 <jforbes> gholms: might as well be
21:14:13 <gholms> Makes sense to me.
21:15:02 <gregdek-mobile> #info kernels and amis in same bucket per version
21:15:28 <gholms> Something like f12-i386 and f12-i386-testing?
21:15:54 <jforbes> gholms: testing won't appear in the official account
21:16:07 <gregdek-mobile> #info kernels and amis in same version per version-arch
21:16:30 <gregdek-mobile> dammit, I'll get it right in the wiki notes :)
21:16:57 <gholms> gregdek-mobile: If you want to try typing it again you can use #undo  ;)
21:17:04 <gregdek-mobile> heh, nah
21:17:15 <gholms> Anything else kernel-related?
21:17:16 <gregdek-mobile> I'm going slow enough as is.  :)
21:17:21 <jforbes> That's it for kernel
21:17:29 <gholms> #topic EC2 Update/Source Mirrors
21:17:37 * gholms hands gregdek-mobile a keyboard
21:17:46 <gregdek-mobile> this is gonna take a while.
21:17:55 <gholms> gregdek-mobile: How are things going with getting aki hosting on S3?
21:17:59 <gregdek-mobile> waiting on a meeting with nathan thomas to discuss.
21:18:12 <gregdek-mobile> goal is to get amazon to sponsor a mirror.
21:18:32 <gregdek-mobile> fallback is to pay, but we would need an estimate.
21:18:39 <gholms> #info goal is to get Amazon to sponsor an aki source mirror
21:18:49 <gregdek-mobile> if too high, that will be unfeasible.
21:19:13 <gregdek-mobile> so waiting on meeting, basically.
21:19:48 <gholms> For update mirrors we will need one not just in every region, but in every availability zone within each region.
21:20:01 <gregdek-mobile> yep.
21:20:09 <gregdek-mobile> it's a fair few.
21:20:17 <gregdek-mobile> but we're built for it.
21:20:29 <gholms> Do we know if Amazon has set IP ranges for each availability zone so they can get into MM?
21:21:00 <gregdek-mobile> I assume so... but we should def verify.
21:21:31 <gregdek-mobile> #action gregdek will verify that amazon can provide ip ranges for availability zones for mirrormanager
21:22:07 <gholms> We might also want to figure out how this works with hosts that use elastic addressing.
21:22:41 <gregdek-mobile> I'm guessing that mm would handle that?
21:22:47 * Oxf13 steps out
21:22:58 <jforbes> FWIW, they have done this with Ubuntu, so should know what is required for parity
21:22:59 <gregdek-mobile> rather, yum would be able to figure it out?
21:23:06 <gregdek-mobile> yeah.
21:23:41 <gregdek-mobile> that's sort of the goal: say "what you did w ubuntu, can we do the same?"
21:24:15 <gholms> I think the hard part is going to be making them not only hit the correct mirrors for the zones that they are in, but also via their internal addresses instead of their external ones.
21:24:30 <gholms> Just something to ponder.
21:24:30 <gregdek-mobile> ooooo yeah maybe.
21:24:44 <gregdek-mobile> yeah, we'll get it sorted.
21:24:50 <gregdek-mobile> what's next?
21:25:01 <gholms> #topic euca2ools and eucalyptus packages
21:25:26 <gregdek-mobile> yeah, how's that going?  any roadblocks?
21:25:41 <gholms> euca2ools is now in updates-testing.  Everyone try it out and comment in bodhi.  ;)
21:26:08 <gregdek-mobile> woooo!
21:26:25 <gregdek-mobile> we should advertise that.
21:26:32 <gregdek-mobile> s/should/will
21:26:55 <gregdek-mobile> #action gregdek advertise availability of euca2ools in bodhi
21:26:58 <gholms> There's a bug with python-boto-1.9b-1 that breaks euca-register.  It should be fixed with the next python-boto release.
21:27:09 <gregdek-mobile> ew, ok.
21:27:34 <gholms> (Meaning the bug was CLOSED NEXTRELEASE)
21:27:45 <gregdek-mobile> how bad?  does it require amazon's tools to register for now?
21:27:58 <gholms> It's completely non-functional right now.
21:28:18 <gregdek-mobile> maybe we should wait for that advertisement.
21:28:28 <gregdek-mobile> what does python-boto do?
21:28:29 <gholms> http://koji.fedoraproject.org/koji/buildinfo?buildID=155030
21:28:41 <gholms> That's the backend for EC2 and S3 that euca2ools calls into.
21:28:52 <gregdek-mobile> ah.
21:29:04 <gregdek-mobile> so beyond our control completely then.
21:29:10 <gregdek-mobile> internal to amazon?
21:29:46 <gholms> Oh, the new python-boto seems to have hit updates-testing.  So we should be good.  :)
21:29:55 <gregdek-mobile> yay!
21:30:04 <gregdek-mobile> all right then.
21:30:09 * gholms stops putting his foot in his mouth
21:30:29 <gholms> Packaging eucalyptus itself is going to be a bit of work.
21:31:08 <gregdek-mobile> right... there was some interest on cloud list. any followup?  like from mattdm for example?
21:32:36 <gholms> There have been some comments on the list that will hopefully push upstream's spec file toward meeting packaging guidelines.
21:33:16 <gregdek-mobile> anything we can/should do to move that along?
21:34:46 <gregdek-mobile> can I presume that silence is a no?  :)
21:34:50 <gholms> Graziano from upstream seems to have been very receptive to my mini package review.
21:35:02 <gregdek-mobile> oh, that's good.
21:35:07 <gholms> Maybe giving that process some more time will help get us close.
21:35:22 <gregdek-mobile> but I guess we're just waiting on them for their next submission?
21:35:53 <gholms> Looks like it.
21:35:59 <gholms> I can't test eucalyptus, so I'm hesitant to head up a packaging effort for it.
21:36:28 <gregdek-mobile> mmm hmm.
21:37:05 <gregdek-mobile> well, let's focus on getting euca2ools past the finish line and we'll keep an eye on eucalyptus for now,
21:37:46 <gregdek-mobile> anything to add re: euca-* pkging?
21:37:46 <gholms> #info euca2ools is in updates-testing for F12
21:38:19 <gholms> #info Discussion on cloud list to improve eucalyptus's spec file's compliance with packaging guidelines
21:38:27 <gholms> Anything else, anyone?
21:38:37 <gregdek-mobile> not here
21:39:03 * gregdek-mobile thinks a lot of folks are satisfied to lurk this time :)
21:39:07 <gholms> #topic IBM Cloud
21:39:57 * gregdek-mobile doesn't even remember this one.
21:40:13 <gregdek-mobile> whose todo is it?  probably mine.  lol
21:40:13 <jforbes> Unfortunately the only other person with input to the IBM cloud is gone.
21:40:19 <mmcgrath> yo
21:40:23 <gholms> :D
21:40:33 <jforbes> gregdek-mobile: it came up on the list, Oxf13 was one of the people looking into it
21:40:35 <gregdek-mobile> jforbes... who is that?
21:41:04 * gregdek-mobile clearly has not been keeping up with email well in the last couple of days...
21:41:19 <jforbes> gregdek-mobile: jkeating
21:41:20 <gregdek-mobile> what's the gist?
21:41:32 <gregdek-mobile> never mind... I'll read up.
21:41:40 <gregdek-mobile> anything actionable here?
21:42:11 <jforbes> gregdek-mobile: at this point they are looking to see what is required to have a presence there
21:42:36 <gholms> There was someone on the list who plans to meet with IBM people about it.  Make sure to send him lots of questions.
21:42:41 <gregdek-mobile> ok.  prelim investigation sort of stuff?  do we have ibm contacts?
21:42:45 <gregdek-mobile> ok.
21:43:23 * gholms doesn't know Oliver's nick
21:43:30 <gregdek-mobile> #action gregdek will meddle, likely unhelpfully, in ibm conversation
21:43:40 <jforbes> Yeah, prelims, unknown if we have contacts there
21:43:56 <smooge> meeting still going on?
21:44:01 <mmcgrath> FWIW, I've been working (and failing) to get Fedora up and running on IBM's cloud.
21:44:02 <gregdek-mobile> yep :)
21:44:18 <gregdek-mobile> just going thru open work items
21:44:35 <gregdek-mobile> anything else to say about ibm?  sounds like not...
21:44:36 * gholms notices something missing from /topic
21:44:53 <gregdek-mobile> hrm?
21:44:55 <gholms> #meetingname Fedora Cloud SIG (2010-02-11)
21:44:55 <zodbot> The meeting name has been set to 'fedora_cloud_sig_(2010-02-11)'
21:45:11 <gregdek-mobile> ah, heh, thx
21:45:20 <gholms> Dang, looks like you can only set that when you #startmeeting
21:45:33 <gholms> Anything else IBM-related?
21:45:46 * jsmith lurks
21:45:52 <smooge> what is the cloud
21:45:53 <gregdek-mobile> so why does everyone show up now?  :)
21:45:58 <gregdek-mobile> SHUT IT
21:46:03 <smooge> what is the IBM cloud and its interatction with you
21:46:03 <gholms> Because it's time for...
21:46:08 <mmcgrath> gregdek-mobile: someone put a note in #fedora-admin a bit ago :)
21:46:36 <gregdek-mobile> lemme guess: "plz troll the cloud meeting!"  :)
21:46:48 <gholms> I asked mmcgrath to show up.  ;)
21:46:50 <gregdek-mobile> smooge, is that a serious q?
21:46:57 <smooge> gregdek-mobile, sorry I hit return to quickly wasn't meaning a 'joke' more like what do you need with IBM cloud as I missed this discussion
21:47:06 <smooge> am trying to catch up
21:47:09 <gregdek-mobile> because our answer so far is "we dunno but we're gonna find out", it seems.
21:47:14 <mdomsch> gregdek-mobile, we were talking about this yesterday in -admin
21:47:15 <smooge> ah ok.
21:47:23 <mdomsch> several of us got new accounts and instances running
21:47:29 * jsmith has VMs running
21:47:30 <gregdek-mobile> can someone post meetbot log url for smooge?
21:47:46 <gregdek-mobile> mdomsch, in ibm cloud?
21:47:48 <mdomsch> yes
21:47:55 <gregdek-mobile> shiny!
21:47:55 <gholms> http://meetbot.fedoraproject.org/fedora-cloud/2010-02-11/fedora_cloud_sig_%282010-02-11%29.2010-02-11-21.02.log.txt
21:47:57 <mdomsch> it came up in the brian stevens webinar yesterday
21:48:04 <smooge> gholms, thanks
21:48:05 <gregdek-mobile> who set it up?
21:48:05 <mdomsch> so I jumped on, then mmcgrath, then jwb, ...
21:48:27 <smooge> gregdek-mobile, the next question was how could infrastructure help if any
21:49:01 <mdomsch> it looks like they're running KVM on RHEL5.4, and are heavily over-subscribed ATM
21:49:08 <mdomsch> "victim of our own success" she called it
21:49:19 <gholms> Haha
21:49:28 <gregdek-mobile> lol
21:49:37 <mmcgrath> I've had about 8 guests up and running
21:49:51 <gregdek-mobile> so how does one get accounts on the ibm cloud?
21:49:58 <mdomsch> fill out the form at ibm.com/cloud
21:50:07 <mdomsch> trivial, and free (for now)
21:50:15 <gregdek-mobile> nice!
21:50:27 <mmcgrath> took me about 30 minutes from figuring out it existed (thanks mdomsch) to me logging into a guest
21:50:36 <mdomsch> jwb laughed - we said it was so easy to do - he thought that odd coming from IBM
21:50:39 <gholms> #link http://www.ibm.com/ibm/cloud/
21:50:43 <gregdek-mobile> what flavors?  fedora 12?
21:50:49 <mdomsch> RHEL 5.4, SLES 11
21:50:51 <mdomsch> no fedora
21:50:58 <gregdek-mobile> hm.
21:50:59 <mmcgrath> gregdek-mobile: I don't see any unsupported OSes at all actually
21:50:59 <mdomsch> no RHEL repos besides base
21:51:01 <gholms> …yet.  :)
21:51:10 <gregdek-mobile> right.  :)
21:51:12 <gholms> You can add repos to running instances, though, right?
21:51:23 <gregdek-mobile> so someone needs to investigate a lot of that stuff.
21:51:26 <mdomsch> it's aimed at users of their WebSphere, DB2, and Rational development tools
21:51:34 <mmcgrath> gholms: you can, but I tried to rhn_register and got failboat
21:51:43 <gholms> :-\
21:51:54 <gregdek-mobile> ew.
21:52:10 <gholms> But you can rhn_register when you don't have any third-party repos?
21:52:10 <mdomsch> and the instances aren't persistent with disk, unless you create another volume to mount at /somewhere
21:52:22 <mmcgrath> mdomsch: actually that's not quite true.
21:52:31 <mmcgrath> I've persisted across reboots
21:52:36 <mdomsch> oh?
21:52:38 <mmcgrath> I don't know what that means exactly.
21:52:47 <gregdek-mobile> hunh.
21:52:48 <mmcgrath> yep
21:52:51 <mmcgrath> touch /test
21:52:52 <mmcgrath> reboot
21:52:54 <mmcgrath> it was still there
21:52:55 <mdomsch> that's amazon EC2-like
21:53:09 <gregdek-mobile> only if you're using ebs, I thought.
21:53:12 <mdomsch> mmcgrath, interesting.
21:54:23 <gregdek-mobile> anyway... since there's no fedora action there other than "see if we can even", shall we move on?
21:54:41 <mmcgrath> yup yup
21:54:44 <mdomsch> they claim to have APIs you can use to start a new image from scratch (boot from ISO), which is where I'd start for a Fedora image
21:55:07 <gregdek-mobile> mdomsch, oooh, we should look at that
21:55:23 <gregdek-mobile> who can look for those mystery apis?
21:55:27 * mmcgrath notes they block icmp pings which is annoying
21:55:31 <gregdek-mobile> lol
21:55:37 * gholms rolls eyes
21:55:41 <gregdek-mobile> ping is 4 punks
21:56:32 <gholms> Anything else for this topic?  Anyone able to look into their APIs and processes?
21:56:59 <gregdek-mobile> id like to assign an action, but not if no one can take it
21:57:10 <jmh> gregdek-mobile: APIs/HowTo-Wiki for IBM cloud https://www.ibm.com/developerworks/mydeveloperworks/wikis/home/wiki/Wa3175e7ea2f3_402b_9a95_c5e32ae46ac5?lang=en_US
21:57:20 <jmh> and API http://www-949.ibm.com/cloud/developer/ram/assetDetail/generalDetails.faces?guid={AE9C1E74-F8C5-A11C-DDE3-D0E6F12515FE}
21:57:31 <gregdek-mobile> jmh can you #info those?
21:57:38 <gregdek-mobile> or #link?
21:57:51 <gholms> Doesn't it pick up links on its own?
21:58:04 <gregdek-mobile> oh yes, I guess it does.
21:58:10 <gholms> Moving on...
21:58:11 <gholms> #topic Open Floor
21:58:21 * gregdek-mobile is not deeply versed in meetbot-fu.  :)
21:58:48 <gregdek-mobile> anyone?  anyone?  bueller?
21:59:27 * gholms will close in a few then
21:59:53 <gregdek-mobile> worksforme
22:00:52 <gholms> Thanks for coming, everyone.
22:00:59 <gholms> #endmeeting