13:01:57 <sochotni> #startmeeting Java SIG -- https://fedoraproject.org/wiki/SIGs/Java
13:01:57 <zodbot> Meeting started Wed Jun 29 13:01:57 2011 UTC. The chair is sochotni. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:02:02 <sochotni> #meetingname java-sig
13:02:02 <zodbot> The meeting name has been set to 'java-sig'
13:02:11 <sochotni> #topic roll-call
13:02:17 <sochotni> .fas sochotni
13:02:17 <zodbot> sochotni: sochotni 'Stanislav Ochotnicky' <sochotni@redhat.com>
13:02:22 <pingou> .fas pingou
13:02:22 <zodbot> pingou: pingou 'Pierre-YvesChibon' <pingou@pingoured.fr>
13:02:26 <jcapik> .fas jcapik
13:02:30 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
13:02:52 <overholt> hi
13:02:53 <sochotni> akurtakov: ping
13:03:05 <sochotni> mbooth: lurking mode only? :-)
13:03:07 * pingou gives a bottle-opener to akurtakov
13:03:09 <akurtakov> .fas akurtakov
13:03:09 <zodbot> akurtakov: akurtakov 'Alexander Kurtakov' <akurtako@redhat.com>
13:03:22 <akurtakov> pingou: thanks :)
13:03:36 <overholt> .fas overholt
13:03:36 <zodbot> overholt: overholt 'Andrew Overholt' <overholt@redhat.com>
13:03:42 <sochotni> ok, so let's see...
13:03:49 <sochotni> #topic Guidelines changes
13:03:55 <mbooth> Afternoon :-)
13:04:15 <sochotni> #link http://bit.ly/iyz1G7 difference between current guidelines and proposed draft
13:04:27 <sochotni> mbooth: welcome :-)
13:04:37 <sochotni> basically there are 2 things:
13:05:02 <sochotni> we start using add_maven_depmap from macros.fjava (included in recent jpackage-utils)
13:05:53 <sochotni> I added documentation for this macro directly into guidelines, I guess it's nicer for starting packagers
13:06:19 <pingou> "# second argument is optional (parent poms have no jars)" -> the second argument of ? add_maven_depmap ?
13:06:24 <sochotni> another thing is that we can stop having Requires(post): jpackage-utils and update_maven_depmap macros with it
13:06:53 <sochotni> pingou: yes, I'd actually welcome any typo or general wording improvements
13:08:01 <sochotni> we can get rid of this as soon as latest maven2 update lands in F15 stable
13:08:17 <akurtakov> to break the silence: I have been looking for these changes for so long that all I can say is +1 :)
13:08:25 <sochotni> for rawhide it already works and I've started proactively removing those things from few specfiles to test if it breaks :-)
13:09:20 <sochotni> I also updated templates not to use wildcards.
13:09:57 <sochotni> They can be useful, but they are overused currently IMO so I'd like to discourage their use by not having them in template
13:11:09 <akurtakov> everyone please note that the post/postun removal is substantial improvement - I've fixed tons of bugs with wrong usage of them/missing/added to wrong package and etc.
13:11:35 <mbooth> Indeed, thanks for the effort to make packaging Java simpler :-)
13:11:36 <sochotni> yeah, I believe this will prevent a lot of accidental bugs in the future
13:11:45 <pingou> +1
13:12:13 <sochotni> also it will be easier to explain add_maven_depmap usage I guess
13:12:42 <sochotni> since beginner packagers don't need to know that much about groupIds:artifactIds
13:12:47 <sochotni> cspike: welcome
13:12:53 * cspike is late
13:12:55 <cspike> sochotni: thanks
13:13:21 <sochotni> cspike: since you missed it: http://bit.ly/iyz1G7
13:13:33 <sochotni> those are proposed differences to guidelines
13:14:37 <cspike> sochotni: did you address the issues of jar file naming yet?
13:14:48 <sochotni> cspike: not at all
13:15:00 <cspike> ok, sorry, carry on
13:15:07 <sochotni> I didn't hear any proposal and I don't have strong enough opinion on the matter
13:15:34 <akurtakov> cspike: these are strictly maven related to remove a lot of craft and make the guidelines simpler and more in tact with maven 3.x
13:16:03 <cspike> well, david walluck suggested on the java-devel list, that name.jar is totally wrong and we should use the artifact id as name for the jar file instead
13:16:16 <sochotni> all: feel free to tweak wording in current draft, and I'll submit it at the end of the week if noone objects
13:16:20 <cspike> of course, i strongly disagree :)
13:17:23 <akurtakov> cspike: that's why we waited for you :)
13:17:35 <cspike> akurtakov: that's so nice of you :)
13:17:51 <cspike> but obviously that's a completely unrelated topic and i'm more disturbing than helping, so i'll shut it for a moment and let you guys carry on
13:18:13 <sochotni> cspike: well I'd like to figure out some good approach to this...
13:18:27 <akurtakov> ok, voting for the change in general (wording/typos fixes may arrive later):
13:18:28 <sochotni> we should brainstorm sometime (outside SIG meeting)
13:18:37 <akurtakov> +1
13:18:40 <cspike> +
13:18:40 <sochotni> +1 from me obviously :-)
13:18:45 <pingou> +1
13:18:51 <mbooth> +1
13:18:55 * overholt has no opinion being pretty ignorant of maven
13:19:02 <sochotni> overholt: :-)
13:19:02 <overholt> but I support your work, so +1 :)
13:19:10 <sochotni> haha, even better
13:19:12 <jcapik> +1
13:19:29 <akurtakov> hmm, we have an absolute agreemant
13:19:36 <sochotni> #agreed new guidelines will be submitted for approval of FPC at the end of week after corrections
13:19:43 <akurtakov> this can only mean that the current state was less than optimal
13:20:03 <sochotni> #topic FTBFSs
13:20:35 <sochotni> as Alex already wrote to java-devel, some of them will be caused by maven2 not being pulled into buildroot anymore
13:20:54 <akurtakov> I think we fixed most of these already
13:21:09 <sochotni> related to this: if you maintain a maven-X-plugin or somesuch thing...you will probably have to add few new BRs
13:21:22 <sochotni> yeah, most...but there are probably more lurking
13:21:33 <sochotni> maven2 has been split into several subpackages
13:21:48 <sochotni> maven-project, maven-toolchain, maven-model and few more
13:22:09 <sochotni> I split those that were not provided by maven-compat in maven-3.0.3
13:22:49 <akurtakov> but even if your package uses some of them please try with maven-compat from maven-3 first
13:22:50 <sochotni> long term it would be great to get rid even of those, but they are now simple artifacts if Required
13:23:02 <akurtakov> it was good enough for jetty yesterday
13:24:20 <sochotni> on that note...perhaps adding all open java FTBFs to SIG tracker bug would be nice
13:24:24 <sochotni> at least IMO
13:25:02 <akurtakov> I want to talk a bit about Eclipse plugins FTBFS
13:25:28 <sochotni> akurtakov: any specialities?
13:25:37 <akurtakov> most of the problems should be fixed by updating to Indigo versions
13:25:48 <akurtakov> emf, birt,
13:26:05 <akurtakov> dltk
13:26:08 <akurtakov> and others
13:26:17 <overholt> I started https://fedoraproject.org/wiki/EclipseIndigo as a tracking page for this work
13:26:47 <akurtakov> even p2-discovery fails to build for some reason
13:27:01 <mbooth> I should have a little time to update some of mine at the weekend
13:27:41 <akurtakov> mbooth: that would be cool, some of them like emf and dltk are blocking other updates
13:27:58 <akurtakov> mbooth: so if I fix some of them took one of mine :)
13:28:09 <mbooth> Okie dokie
13:28:40 <akurtakov> anyone here doing some eclipse work beside mbooth, overholt and me ?
13:29:28 <mbooth> Guess not :-)
13:30:00 <sochotni> not me
13:30:07 <akurtakov> ok, so we need to fix ftbfs by updating to Indigo versions
13:30:18 <akurtakov> at least emf proves it to be the case
13:30:40 <akurtakov> ftbfs because of generics being used in the platform
13:31:49 <mbooth> (at last!)
13:32:34 <sochotni> ok so...if anyone has specific problems with maven2 removal, let me know...I should be able to help you
13:32:36 <akurtakov> about the rest of the ftbfs it would be good if someone watches fnassers/pcheung packages
13:32:46 <sochotni> apart from that...anything to add to FTBFSs?
13:33:30 <akurtakov> it looks like we are way better than last time - and i have only eclipse related in my list
13:35:22 <MrGrymReaper> How good is Fedora 15 at coping with Solid State Drives (SSDs) and/or the new SATA III (6 GB/s)?
13:35:29 <sochotni> yeah, I think we'll be even better in F17 when there won't be any maven2 :-)
13:35:38 <sochotni> MrGrymReaper: wrong channel
13:35:47 <akurtakov> looks like there is nothing more for the ftbfs
13:35:58 <MrGrymReaper> Sorry.
13:36:09 <sochotni> #topic tracker bug
13:36:16 <akurtakov> if anyone has a problem with fixing his package let us know
13:36:38 <akurtakov> I want to appologize for all the staled reviews
13:36:46 <akurtakov> I'll finish them as soon as possible
13:37:34 <mbooth> Has anyone heard from Sebastian re: https://bugzilla.redhat.com/show_bug.cgi?id=675009 ?
13:37:43 <mbooth> (Speaking of reviews)
13:37:48 <overholt> I have not
13:38:12 <mbooth> Ok, I think I will send him a private email
13:38:28 <sochotni> mbooth: if he doesn't respon there is always unresponsive reviewer process
13:38:35 <sochotni> someone else can finish it up
13:38:37 <sochotni> if need be...
13:38:43 <cspike> mbooth: if you need someone to do the review, let me know
13:39:35 <sochotni> #topic open floor
13:39:47 <sochotni> anyone has anything to add: speak up :-)
13:39:52 <cspike> speaking of reviews, we should probably have a look at https://fedoraproject.org/wiki/Java_review_template
13:40:14 <sochotni> cspike: true...with new guidelines this will need to change
13:40:19 <pingou> speaking of template, what about having a maven template in rpmdev ?
13:40:26 * overholt needs to run. keep up the good work!
13:41:05 <akurtakov> pingou: I was dreaming for maven and eclipse template for years :) but never found the time to add them :0
13:41:24 <akurtakov> and I use rpmdev in my eclipse plugin
13:41:46 <akurtakov> so if someone spends the time on it I would be very thankful
13:41:53 <sochotni> I don't use templates (just copy-paste from other things :-) 0
13:42:23 <sochotni> but I agree templates are nice to have
13:42:26 <pingou> akurtakov: should be duable, it's a matter of copy/paste from guideline and opening a ticket on the trac :)
13:43:08 <akurtakov> pingou: I know, but I've exhausted all possible threads/processes in my mind :)
13:43:19 <sochotni> akurtakov: you need one more core :-)
13:44:00 <sochotni> I bet it's those familiar processes :-D
13:44:09 <karbafosss> Good day everybody! I gonna become Ambassador and my mentor advised me to take part in EMEA meeting. Will it be today at 20:00 UTC?
13:44:29 * akurtakov runs too
13:44:33 <akurtakov> bye everyone
13:44:58 <sochotni> OK, I guess we can wrap it up?
13:45:09 * mbooth has nothing more to add
13:45:30 <sochotni> pingou: if you know how to get template to rpmdev...I wouldn't mind double-checking it
13:45:42 <sochotni> so...that's about it
13:45:47 <sochotni> #endmeeting