15:05:57 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-08-02
15:05:57 <zodbot> Meeting started Tue Aug 2 15:05:57 2011 UTC. The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:24 <jreznik> #meetingname kde-sig
15:07:24 <zodbot> The meeting name has been set to 'kde-sig'
15:07:32 <jreznik> #topic roll call
15:07:59 <Kevin_Kofler> Present.
15:08:28 * rnovacek here
15:11:18 <than> present
15:11:20 <jreznik> anybody else?
15:13:19 <Kevin_Kofler> Do we have anything important to discuss?
15:13:28 <jreznik> Kevin_Kofler: qt 4.8...
15:13:38 <Kevin_Kofler> And the fallout to kde*?
15:13:43 <than> moc issue in 4.8
15:13:57 <jreznik> Kevin_Kofler: yep
15:14:05 <Kevin_Kofler> Yeah, that's a problem…
15:14:08 <jreznik> #topic Agenda
15:14:21 <Kevin_Kofler> Also because it makes the installation DVD fail the Alpha criteria: https://bugzilla.redhat.com/show_bug.cgi?id=727402
15:14:22 <jreznik> #info jreznik Kevin_Kofler rnovacek than present
15:14:51 <Kevin_Kofler> I guess we'll have to get that 4.7.0-1 build in, even if it means no Umbrello for now.
15:15:19 <jreznik> Kevin_Kofler: yep, we have to - same for kdenetwork
15:15:37 <Kevin_Kofler> Other potential things we can discuss: Verne artwork (first version now queued for stable), and this fun one: https://bugzilla.redhat.com/show_bug.cgi?id=727570
15:15:38 <jreznik> #topic qt 4.8 moc build failures
15:16:05 * jreznik was too fast
15:16:48 <Kevin_Kofler> So the crux of the issue is, the specification of QObject clearly says that it must be used only with single inheritance (Java-style), multiple inheritance is only possible with QObject + other stuff, and QObject must be first.
15:17:08 <jreznik> yep
15:17:08 <Kevin_Kofler> (The technical reason being that a QObject * is supposed to be castable to the actual type with a static or reinterpret cast.)
15:17:35 <jreznik> they can't use dynamic cast as qt build without rtti
15:17:36 <Kevin_Kofler> But there are at least 3 packages which thought it smart to use multiple inheritance with QObjects and put in a virtual inheritance on QObject.
15:17:58 <Kevin_Kofler> (At least I assume multiple inheritance is involved, otherwise the virtual inheritance makes no sense.)
15:18:10 <jreznik> kde upstream closes it as upstream bug, qt upstream closes it as kde bug
15:18:44 <than> it's a bad situation that bott closed the bug!
15:18:47 <Kevin_Kofler> The code used to build, but did it actually work properly? I suspect it didn't.
15:19:18 <jreznik> Kevin_Kofler: it could work properly but it was just good luck
15:19:31 <Kevin_Kofler> Though I'm not sure of the exact details of the implementation of virtual inheritance in g++ though.
15:19:36 <jreznik> moc could be changed in way it would not break builds and ...
15:19:44 * jreznik neither
15:19:57 <jreznik> so it's quite difficult to go through moc magic
15:20:05 <Kevin_Kofler> I guess changing the static_cast to a reinterpret_cast in the moc-generated code could fix it.
15:20:33 <jreznik> Kevin_Kofler: it just scares me to change something in moc - potentional problems could be huge
15:20:39 <Kevin_Kofler> The problem with that is that if the cast is unsafe, it will just happen anyway.
15:21:13 <jreznik> so the only possibility is to fix it in kde - by ourselfs or force upstream to do it
15:21:36 <Kevin_Kofler> reinterpret_cast instead of static_cast shouldn't change the way the code works at all.
15:21:41 <jreznik> but kdenetwork upstream bug was closed, I asked for a solution there
15:21:45 <Kevin_Kofler> It will just make the compiler silently accept unsafe casts.
15:22:07 <Kevin_Kofler> Now whether the code will actually run properly, I don't know.
15:22:49 <than> moc is critcal part, it should be fixed by upstream
15:23:29 <than> we force upstream to fix it
15:23:44 <Kevin_Kofler> Yes, one or the other upstream will most definitely have to fix their code.
15:23:51 <Kevin_Kofler> This affects ALL distros.
15:23:52 <than> if not we should revert to qt-4.7
15:24:00 <jreznik> we have two possibilities - try to fix - thiago is against fix in qt, the moc maintainer is not against but nothing happened, kde upstream does not care about qt 4.8 now... or revert to 4.7
15:24:13 <Kevin_Kofler> The problem is, reverting to 4.7 means rebuilding ALL the Qt-using packages built after 4.8 went in.
15:24:29 <jreznik> Kevin_Kofler: yep, so late before alpha...
15:24:42 <jreznik> but there are other 4.8 issues
15:24:45 <rnovacek> I think fixing it in kde is better solution
15:25:01 <Kevin_Kofler> There's also a non-KDE package which has the same problem, by the way.
15:25:06 <than> rnovacek: yes one of the should fix it
15:25:09 <jreznik> .bug 712881
15:25:11 <zodbot> jreznik: Bug 712881 qt-4.8 tracker - https://bugzilla.redhat.com/show_bug.cgi?id=712881
15:25:24 <Kevin_Kofler> sonic-visualiser
15:25:59 <jreznik> another possibility - revert latest qt 4.8 moc changes to pre 4.8 times... so just hide it for now...
15:26:16 <jreznik> but still as than said - moc is really critical component
15:26:20 <Kevin_Kofler> Not sure whether this is easily possible.
15:26:30 <Kevin_Kofler> The moc changes might be coupled to changes deep inside QObject.
15:27:41 <jreznik> Kevin_Kofler: yep
15:28:27 <jreznik> I can try to ping upstreams... it has to be fixed one day...
15:29:13 <jreznik> and for alpha - we should push kdenetwork without kopete and same for kdesdk... as otherwise we have conflicts
15:30:07 <Kevin_Kofler> Not sure about kdenetwork, but kdesdk definitely needs pushing because of the separate kate packaging.
15:31:29 <Kevin_Kofler> I'll take care of kdesdk.
15:31:45 <jreznik> I've got conflicts today while updating to f16 alpha from kde-unstable kdenetwork
15:32:00 <jreznik> unfortunatelly I don't have logs - battery is death
15:32:02 <jreznik> dead
15:33:20 <Kevin_Kofler> kdesdk taken care of. For kdenetwork, if we have no evidence that Alpha criteria are violated, it's unlikely we'll get the update onto the Alpha.
15:33:27 <Kevin_Kofler> I can make sure it goes to testing ASAP though.
15:33:39 <jreznik> ok
15:33:41 <jreznik> thanks
15:33:59 <Kevin_Kofler> FWIW, kdesdk needs 1 karma if it should go out to stable, but I guess they may wait for it to go out anyway due to the file conflicts.
15:34:01 <than> this package needs karma http://bit.ly/opywng
15:34:16 <than> it should go into stabel
15:34:50 <Kevin_Kofler> Oh, the kdenetwork build is already in testing.
15:35:01 <jreznik> so let's try to fix kdesdk now to fix alpha criterias and ping upstream about the moc issue (and find all potencial packages hit by the moc change to contact maitainers)
15:35:32 <than> jreznik: +1
15:35:43 <Kevin_Kofler> than: Hmmm, smokegen isn't on the images, is it?
15:35:50 <rnovacek> wrt moc issue: what it this virtual inheritance good for?
15:35:52 <Kevin_Kofler> So it doesn't matter all that much when it goes to stable.
15:36:16 <jreznik> same for kdeaccesibility - but I'd like to hide FTBS too
15:36:19 <than> Kevin_Kofler: we need it to build smokeqt/smokekde
15:36:27 <rnovacek> umbrello builds fine when i remove that virtual keyword
15:36:33 <Kevin_Kofler> class A : public B, public C {}; class B : public virtual QObject {}; class C : public virtual QObject {};
15:36:48 <Kevin_Kofler> Without virtual, A will have 2 copies of QObject in it (nasty!).
15:36:57 <Kevin_Kofler> But the virtual stuff isn't supported by QObject.
15:37:10 <Kevin_Kofler> You aren't supposed to use that kind of multiple inheritance with QObject at all.
15:37:13 <rnovacek> Kevin_Kofler: but thats not case of umbrello
15:37:27 <Kevin_Kofler> Well, maybe its usage of virtual is unnecessary.
15:37:29 <Kevin_Kofler> I'm not sure.
15:37:31 <rnovacek> class CodeClassFieldDeclarationBlock : public OwnedCodeBlock, public CodeBlockWithComments
15:37:45 <CodeBlock> hah, hi.
15:37:51 <jreznik> CodeBlock: hi :)
15:37:58 <jreznik> hh
15:37:58 <rnovacek> OwnedCodeBlock inherits QObject CodeBlockWithComments don't :)
15:38:06 <rnovacek> CodeBlock: sorry :)
15:38:11 <CodeBlock> :P no worries
15:38:14 <Kevin_Kofler> Then the virtual inheritance is unnecessary and should just be removed.
15:38:34 <rnovacek> I'll look on kopete too
15:38:58 <Kevin_Kofler> I guess the fix can be committed without discussion as a build fix.
15:39:06 <Kevin_Kofler> (committed upstream)
15:40:00 <jreznik> kdenetwork upstream bug https://bugs.kde.org/show_bug.cgi?id=274827
15:40:45 <rnovacek> there might be other class that inherits QObject twice and doesn't cause build to fail
15:41:08 <rnovacek> and because of it is the 'virtual' present
15:41:32 <Kevin_Kofler> Yes, unfortunately the compiler will NOT warn you if you inherit QObject twice.
15:43:14 <jreznik> in Kopete I think virtual is just useless too...
15:43:40 <Kevin_Kofler> I suspect that if it weren't useless, it'd have caused much more trouble…
15:45:40 <jreznik> ok, for now let's go with my proposal, I'll try to ping all involved parties - better to check it by upstreams
15:46:23 <Kevin_Kofler> Right.
15:46:37 <than> let revert to qt-4.7 if kde/qt upstream does not take care of this issue
15:47:59 <jreznik> it's our last chance (of course we can try to fix it by ourselves before - but it could be more dangerous than ...)
15:48:27 <jreznik> let's move now
15:48:59 <jreznik> #agreed to fix kdesdk for aplha crit. conflicts and ping involved parties to fix the issue
15:49:04 <jreznik> #topic kipi-plugins
15:49:11 <than> jreznik: i don't think it's good idea to fix it by ourselves
15:50:04 <Kevin_Kofler> I wonder if shipping F16 with 4.8 is that great an idea in the first place, considering it's still in beta and we don't know when it will be final. :-/
15:50:21 <Kevin_Kofler> But I'm a bit scared by the prospect of rebuilding all the Qt packages in a branched tree.
15:50:26 <jreznik> than: jovie and umbrello are not critical components... and we can test Kopete
15:50:36 <jreznik> Kevin_Kofler: yep, there's as always no schedule
15:50:43 <Kevin_Kofler> We may need an f16-qt47revert build tag and some rel-eng magic to mass-move tags.
15:50:45 <jreznik> last time - we made it by final
15:50:59 <jreznik> but it was just good luck
15:51:08 <than> and it's more reason to revert to qt-4.7 ;-)
15:51:19 <Kevin_Kofler> Does Qt go directly from Beta to Final or is there some RC planned?
15:51:19 <jreznik> where's the open governance? thiago promised public schedules but nokia...
15:51:32 <jreznik> Kevin_Kofler: I expect RC
15:51:37 <than> Kevin_Kofler: it's some rc before final
15:52:10 <jreznik> that just means no 4.8 in f16
15:52:18 <Kevin_Kofler> Open Governance is just an empty promise so far. :-(
15:52:22 <jreznik> but for desktop I don't think it's a big issue
15:52:26 <Kevin_Kofler> They keep pushing it back and limiting its scope.
15:52:42 <Kevin_Kofler> I think Nokia doesn't want to give up their control, unfortunately.
15:52:48 <rnovacek> kopete build with some tweaks
15:53:02 <jreznik> most changes in 4.8 are lighthouse, qt quick 1.1 and symbian support
15:53:08 <jreznik> rnovacek: and does it work?
15:53:09 <jreznik> :)
15:53:10 <rnovacek> I'll attach patches upstream and see what they say
15:53:53 <than> jreznik: i know jovie and umbrello are not critical part, but it just annoys me that upstream doesn't consider it as bug
15:54:30 <than> rnovacek: +1
15:54:54 <jreznik> rnovacek: thanks
15:55:07 <Kevin_Kofler> Oh, isn't kdeaccessibility (Jovie?) affected too?
15:55:13 <jreznik> Kevin_Kofler: yep, it is
15:55:16 <Kevin_Kofler> So far we only discussed kdenetwork and kdesdk.
15:55:29 <jreznik> I mentioned it already
15:55:51 <jreznik> but we don't have kdeaccessibility on cd, don't we?
15:56:09 <Kevin_Kofler> Nope, not on the CD. On the DVD, I don't know.
15:56:15 <Kevin_Kofler> I haven't looked at the installer DVD for ages.
15:56:31 <jreznik> Kevin_Kofler: but I'd like to build it for now withou Jovie
15:56:39 <jreznik> about to commit now
15:57:00 <Kevin_Kofler> There's not much left if you build kdeaccessibility without Jovie…
15:57:11 <jreznik> yep, I know...
15:57:23 <jreznik> rnovacek: do you have a patch for kdeaccessibility too?
15:57:45 <rnovacek> not yet, will check that too
15:58:43 <jreznik> rnovacek: it's in jovie/filters
15:58:55 <jreznik> xmltransformer
15:59:03 <jreznik> proc.cpp
15:59:59 <rnovacek> jreznik: thanks
16:02:04 <jreznik> oh crap, I have to resubmit lovelock-theme-kde... nvr problem, my fault...
16:02:23 <Kevin_Kofler> Oh?
16:03:03 <Kevin_Kofler> Ah, I see, darn.
16:03:16 <jreznik> I thought something is bad
16:03:27 <jreznik> but we can have it in alpha through nth process
16:03:28 <Kevin_Kofler> The F16 freeze override is already queued for stable, should we let it go out anyway or cancel the push?
16:03:31 <jreznik> sorry
16:03:42 <than> Kevin_Kofler: yes
16:03:58 <jreznik> cancel and use nth to have it in F16 alpha...
16:04:02 <than> we don't want to break it
16:04:21 <Kevin_Kofler> jreznik: Well, it's your update, cancel the push if you want. :-)
16:04:59 <jreznik> sorry, it was just in rush... I thought something is wrong :)
16:05:12 <Kevin_Kofler> jreznik: If you build the fixed build quickly, we may be able to get it pushed ASAP anyway.
16:06:31 <than> jreznik: it's up to you ;-)
16:06:47 <jreznik> ok, let's move back to #fedora-kde
16:06:51 <jreznik> #endmeeting