15:06:35 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-11-08
15:06:35 <zodbot> Meeting started Tue Nov 8 15:06:35 2011 UTC. The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:44 <jreznik> #meetingname kde-sig
15:06:44 <zodbot> The meeting name has been set to 'kde-sig'
15:06:54 <jreznik> #topic roll call
15:07:02 <jreznik> hi all, who's present today?
15:07:06 <rdieter> hello
15:07:41 <Kevin_Kofler> Present.
15:07:50 * rnovacek is here
15:08:03 <ltinkl> present
15:08:25 <jreznik> #chair jreznik rdieter Kevin_Kofler rnovacek ltinkl
15:08:25 <zodbot> Current chairs: Kevin_Kofler jreznik ltinkl rdieter rnovacek
15:08:37 <jreznik> #info jreznik rdieter Kevin_Kofler rnovacek ltinkl present
15:08:49 <jreznik> #topic agenda
15:10:46 <jreznik> anything else for agenda?
15:10:54 <rdieter> kde-4.7.3 status I suppose
15:11:12 <jreznik> rdieter: already there :)
15:11:19 <jreznik> ok, so lets start
15:11:25 <rdieter> hee, wiki was still loading. :)
15:11:44 <jreznik> or one more topic!
15:12:07 <jreznik> #topic fedora 16 release day celebration!
15:12:23 <Kevin_Kofler> Hooray!
15:12:24 <rdieter> oh, yeah, that.
15:12:35 <jreznik> let's party! and thanks for the amazing work goes to all!!!
15:13:00 <Kevin_Kofler> We should make a screenshot tour: Around Fedora KDE Plasma in 80 screenshots. ;-)
15:13:22 <Kevin_Kofler> (Verne FTW!)
15:13:41 * rdieter torrenting kde-live images, interesting to note the x86_64 one currently has more seeders
15:14:06 <jreznik> Kevin_Kofler: I have to prepare screenshots for fedora.cz web, so maybe :) probably tmrw :D
15:14:17 <Kevin_Kofler> rdieter: Who still uses 32-bit these days (other than me, on this ancient 32-bit-only desktop)? :-)
15:14:38 <Kevin_Kofler> (My notebook is x86_64.)
15:14:40 <jreznik> Kevin_Kofler: /me on my ancient 32 bit laptop but otherwise I'm 64 bit guy now
15:14:55 <rnovacek> I'm all 64bit
15:14:56 <rdieter> could advocate some interesting stuff for f17. considerations: ship 64bit by default, ship larger (than cd) sized images
15:15:22 <jreznik> #info fedora 16 verne was released today!
15:15:27 <Kevin_Kofler> I'm all for 64-bit by default, but I think this needs to be discussed at a larger Fedora level.
15:15:44 <jreznik> rdieter: let's start f17 feature page to talk about what we want in F17
15:15:52 <Kevin_Kofler> As for larger images, I also think this should be decided at Fedora level.
15:15:54 <rdieter> Kevin_Kofler: sure, though... we could push for it ourselves even if there isn't a larger consensus
15:15:58 <jreznik> Kevin_Kofler: same for official live medias...
15:16:34 <Kevin_Kofler> I think that if the GNOME image is much smaller than ours, this is going to come and bite us in the behind.
15:16:48 <jreznik> I'd like to have two sized medias - the reason for 700 MB one is multi desktop DVD - we can fit all spins on one DVD - great for ambassadors, events etc.
15:17:08 <Kevin_Kofler> People won't realize WHY the GNOME image is so much smaller (no office suite! etc.), they'll just notice it's smaller and so try that.
15:17:24 <rdieter> jreznik: how tight is the DVD? could we bump up 50-100mb and still be ok? or not?
15:17:32 <Kevin_Kofler> Of course, there's also the Xfce and LXDE images, but I don't think we have any chance at competing with them size-wise.
15:17:38 <Kevin_Kofler> They're much below DVD size now.
15:18:04 <jreznik> rdieter: let me check the F16 one
15:18:22 <Kevin_Kofler> rdieter: The problem with bumping to 800 MiB is that CD-R90 media aren't commonly sold in most countries as I've been told.
15:18:24 <rdieter> anyway, don't want to spend too much time on it here/now, just stuff to think about moving forward
15:18:33 <Kevin_Kofler> They're readily available in Austria, so for me it's OK, but…
15:18:33 <jreznik> rdieter: 5.8G
15:18:42 <jreznik> http://dl.fedoraproject.org/pub/alt/releases/16/Multi/
15:19:09 <jreznik> ok, let's move - we can talk about it later, today we should celebrate
15:19:10 <Kevin_Kofler> There are places where people will likely have to use a DVD even if the spin is only 800 MiB.
15:19:19 <rdieter> anyway, yeah, the multi DVD will be a factor influencing the decision-making here
15:19:26 <Kevin_Kofler> That said, personally, I'm not opposed to 800 MiB.
15:19:40 <Kevin_Kofler> Though only if it really makes a difference.
15:19:51 <Kevin_Kofler> I guess for F16 it would have allowed us to fit Digikam and kipi-plugins.
15:19:59 <Kevin_Kofler> For F15, it wouldn't have been very helpful though.
15:20:00 <jreznik> rdieter: and it's really nice DVD - it solves the problem of producing a bunch of medias, explaining people - now we say - this is biarch multi desktop DVD and it's
15:20:20 <Kevin_Kofler> So without knowing where we'll stand in F17, it's hard to predict whether 800 MiB will make any sense or not.
15:20:40 <jreznik> #info to think about bigger image and 64 bit as default arch (on Fedora level)
15:20:42 <Kevin_Kofler> For F15, even 1 GiB didn't turn out to be all that useful, and we ended up going for ~1.4-1.5 GiB.
15:20:48 <Kevin_Kofler> (for the alternate image)
15:21:01 <jreznik> #topic 4.7.3 status
15:21:45 <Kevin_Kofler> And IMHO that multispin biarch DVD for ambassadors is a great idea, we need to be careful not to sabotage it.
15:22:18 <rnovacek> I'm running f16/4.7.3 (from kde-testing), no issues so far, working nice even with akonadi/nepomuk/strigi enabled
15:22:28 <nucleo> Why nobody replied on LiveDVD question? http://lists.fedoraproject.org/pipermail/devel/2011-November/158952.html
15:22:34 <rdieter> k, kde-4.7.3 is queue'd for f16 updates-testing
15:22:51 <rdieter> nucleo: it's not something we can just decide in a week, be patient. :)
15:23:00 <jreznik> Kevin_Kofler: +1
15:23:18 <rdieter> also stuffed into f15/kde47 and f16/kde-testing repos as well
15:23:26 <nucleo> rdieter: maybe nobody seen this mail
15:23:34 <rnovacek> it's actually first time I left nepomuk stuff enabled without performance issues
15:23:47 <jreznik> #info kde-4.7.3 is queue'd for f16 updates-testing
15:24:09 <jreznik> #info rdieter stuffed into f15/kde47 and f16/kde-testing repos as well
15:24:13 <rdieter> 4.7.3 primary bugfixing was around nepomuk, indeed. strueg has been going mad with the bugfixing of late (looking for a job). :)
15:24:38 <jreznik> rdieter: so it was worth to send him a few bucks :)
15:27:15 <rdieter> that's all I have on 4.7.3. not a lot of feedback yet, but the bit I've heard has all been positive
15:27:35 <nucleo> works fine here
15:27:43 <rdieter> so I suspect the f16 update should go through without much fuss
15:28:01 <jreznik> #topic plasma active
15:28:31 <jreznik> after rdieter finished libkactivities, I started with plasma active packaging
15:28:48 <jreznik> I have prepared most of packages needed for review
15:28:53 * rdieter yays
15:29:20 * rnovacek can help with reviews
15:29:22 <jreznik> just fighting with share-like-connect build issues... one is already fixed, I'll try to fix another one tmrw
15:29:39 <jreznik> as I'd like to have all reviews in one batch (as they are quite related)
15:29:47 <jreznik> rnovacek: thanks
15:30:14 <Kevin_Kofler> I suspect it's going to take a while until we are able to provide Fedora ARM with Plasma Active as a serious alternative for mobile devices.
15:30:20 <jreznik> Jucato played with Plasma Active too - some bugs (for example app menu does not work on Fedora) - I have to dig to source code to check why it's broken
15:30:39 <jreznik> Kevin_Kofler: I don't think so, I bet it will be ready in F17 time
15:30:45 <Kevin_Kofler> Even for Fedora x86, there are quite some issues to battle with.
15:31:22 <Kevin_Kofler> That slick UI you see in the dedicated Plasma Active distros is the result of some kdelibs and kde-workspace patching which breaks plasma-desktop!
15:31:34 <jreznik> Kevin_Kofler: yeah, that leads as to the same question as with netbook ui - do we have to support it inside default fedora spin or do we want it outside?
15:31:42 <Kevin_Kofler> E.g. they've just unconditionally hidden the mouse pointer, that's entirely unacceptable in shared kdelibs.
15:32:07 <jreznik> Kevin_Kofler: that's bad and I told Jucato today they hack it extensively
15:32:10 <jreznik> at least now
15:32:20 <rdieter> Kevin_Kofler: obviously some of those patches don't make sense for us to apply, true.
15:32:22 <Kevin_Kofler> jreznik: Upstream needs to fix their crap so you can use the same kdelibs for both.
15:32:36 <Kevin_Kofler> It's supposed to be the goal, yet they do those weird hacks to kdelibs.
15:32:42 <Kevin_Kofler> (and same for kde-workspace)
15:32:56 * rdieter considers that a minor detail, growing pains will sort out quickly
15:33:14 <jreznik> Kevin_Kofler: that's bad active devels hack on top of opensuse/meego - that's something OBS allows them to do
15:33:29 <jreznik> rdieter: I think so just ^^^
15:34:13 <Kevin_Kofler> E.g. for the mouse pointer, this must be a runtime option, not a compile-time patch.
15:35:26 <jreznik> Kevin_Kofler: and thing is - when you connect mouse, it has to appear (shell does it this way)
15:35:51 <Kevin_Kofler> +1
15:36:01 <Kevin_Kofler> This needs to be detected at runtime.
15:36:08 <Kevin_Kofler> The patch is a gross hack.
15:36:36 <jreznik> Kevin_Kofler: for the first release...
15:37:03 <jreznik> #info jreznik is working on plasma active packaging, will send it for review in one batch
15:37:19 <jreznik> #action rnovacek, rdieter to help with reviews
15:37:46 <jreznik> should we have separate feature for active for f17?
15:37:52 <jreznik> it's good marketing point
15:38:00 <rdieter> jreznik: I think so
15:38:05 <Kevin_Kofler> Yes.
15:38:16 <Kevin_Kofler> That reminds me that I should file a feature page for the Plasma PackageKit stuff.
15:38:28 <Kevin_Kofler> For once a Plasma feature developed by Fedora. :-p
15:38:39 <jreznik> +1
15:38:59 * rnovacek can see the news: "Fedora is attacking mobile device market" :D
15:39:24 <jreznik> #action to prepare feature page for plasma mobile and plasma packagekit stuff
15:39:52 <jreznik> one interesting shell feature is ability to run with llvmpipe - we should try it too - could be useful for active stuff
15:40:44 <Kevin_Kofler> IIRC, after I brought this up on #fedora-kde, somebody there got KWin OpenGL to work with llvmpipe even in F16.
15:40:56 <Kevin_Kofler> But the more testing, the better. :-)
15:41:09 * nucleo got
15:41:15 <Kevin_Kofler> That reminds me: IMHO, we should enable desktop effects by default in F17!
15:41:19 <Kevin_Kofler> Upstream has been doing it for a while.
15:41:43 <rdieter> esp if llvmpipe works... can give it a shot
15:41:48 <Kevin_Kofler> I don't think this deviation from upstream is justified anymore now that GNOME got the driver situation improved.
15:41:52 * jreznik is still not sure it's the right time - maybe if we can prove llvmpipe works well with it
15:42:00 <Kevin_Kofler> For llvmpipe, I guess it'd explicitly have to be added to the default whitelist.
15:42:07 <jreznik> Kevin_Kofler: I'm not sure it's improved at all
15:42:27 <Kevin_Kofler> AFAIK, the list of drivers for which OpenGL is default is smaller than the one for which it's allowed.
15:42:28 <jreznik> or we should try opengl es backend for kwin
15:42:44 <Kevin_Kofler> jreznik: Only testing can tell.
15:42:54 <Kevin_Kofler> Upstream has been judging it good enough for a while…
15:43:14 <rdieter> opengl-es sounds promising alright
15:43:17 <Kevin_Kofler> And AFAIK they do have a whitelist, where stuff not on it won't get OpenGL by default.
15:43:30 <jreznik> Kevin_Kofler: but lets try it... it works quite well on my intel, it's working on my old ati, but really slow, it's causing problems with nouveau
15:44:29 <jreznik> #info let's consider desktop effects enabled by default for f17 after testing (llvmpipe, opengl es backend)...
15:44:36 <Kevin_Kofler> Last I tried it, it worked, but a bit sluggishly, on my Radeon 9200SE (rv280), which doesn't surprise me all that much.
15:44:44 <Kevin_Kofler> I expected it to work, I didn't expect it to be snappy.
15:45:36 <jreznik> ok, I'm +1 at least to try it
15:45:55 <rnovacek> jreznik: +1
15:46:58 <jreznik> ok, let's move on
15:47:04 <jreznik> #topic meeting time
15:47:23 <jreznik> summer->winter time change again, out of sync between eu and usa...
15:48:08 <jreznik> but before we can move kde sig meeting, we have to coordinate with board meeting (to not overlap), especially for rdieter as for me it's time :)
15:48:48 <rdieter> does anyone want to move things away from sticking with the UTC meeting time?
15:49:28 * rdieter has no preference, fine either way
15:49:38 <rnovacek> fine for me too
15:51:00 <jreznik> utc is ok for me
15:51:28 <rdieter> ok, unless there's some interesting in moving, then let's not. :)
15:51:36 <Kevin_Kofler> We can stick to 15:00 UTC.
15:52:01 <Kevin_Kofler> I have a seminar at the university until 14:30 UTC, but worst case I can attend from the university if I don't manage to get home first.
15:52:27 <Kevin_Kofler> I was just worried because both last week and today we started late, waiting for people.
15:52:55 <than> 15:00 UTC is fine
15:53:02 <Kevin_Kofler> (and I also wonder whether we'd get a different answer if we asked in 7 minutes ;-) )
15:53:31 <jreznik> looks like we agreed on utc
15:53:38 <Kevin_Kofler> Yes, 15:00 UTC it is.
15:53:54 <jreznik> #agreed to meet at 15:00 utc
15:54:05 <jreznik> #topic open floor
15:54:09 <jreznik> anything else?
15:56:17 <Kevin_Kofler> I wonder if it'd be possible to get the KDE stuff removed from critpath again.
15:56:24 <Kevin_Kofler> It had been forgotten for years without any issues.
15:56:35 <rdieter> Kevin_Kofler: sure, we just remove stuff from comps critical-path-kde group
15:56:55 <rdieter> currently contains: kdelibs, kdm
15:56:58 <Kevin_Kofler> This critpath thing is just unhelpful and we aren't getting anywhere near the required karma.
15:57:29 <Kevin_Kofler> For all this time, the KDE stuff hasn't actually been critpath because it got forgotten somewhere and we had no issues at all due to that.
15:57:35 <Kevin_Kofler> (quite the opposite)
15:58:54 * rdieter is willing to give the process a little more time before deciding to ditch it or not
15:59:34 <jreznik> crit patch is good idea just implementation sucks in this time
15:59:40 <rdieter> or consider even scaling it back some (to include only qt for example)
15:59:46 <jreznik> ok, let's close the meeting, thanks guys!
15:59:52 <rdieter> yeah, out of time.
15:59:57 <jreznik> #endmeeting