15:01:07 <jreznik> #startmeeting kde-sig -- https://fedoraproject.org/wiki/SIGs/KDE/Meetings/2012-07-17
15:01:07 <zodbot> Meeting started Tue Jul 17 15:01:07 2012 UTC. The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:14 <jreznik> #meetingname kde-sig
15:01:14 <zodbot> The meeting name has been set to 'kde-sig'
15:01:23 <jreznik> #topic roll call
15:02:19 <Kevin_Kofler> Present.
15:02:41 * ltinkl present
15:03:17 * jreznik is here
15:03:38 <than> present
15:03:45 <jgrulich> * jgrulich present
15:04:24 <jreznik> #chair Kevin_Kofler ltinkl than jgrulich
15:04:24 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik ltinkl than
15:05:45 <jreznik> #info Kevin_Kofler jgrulich jreznik ltinkl than present
15:05:54 <jreznik> #topic Agenda
15:06:09 <Kevin_Kofler> Uhm, who's jgrulich?
15:06:28 <jgrulich> I'm new intern in RH
15:06:38 <ltinkl> our new slave^H colleague :)
15:06:43 <Kevin_Kofler> Welcome! :-)
15:06:52 <ltinkl> and as the first topic today, he should introduce himself :)
15:06:56 <jreznik> ok, first topic :)
15:07:06 <jreznik> ltinkl: first let's collect agenda
15:07:20 <rdieter> hi, sorry I'm late
15:07:43 * jreznik is taking care of his new feature wrangler duties - there are a few interesting features from our POV
15:07:46 <jreznik> rdieter: hi!
15:07:56 <jreznik> #info rdieter present too
15:08:01 <jreznik> #chair rdieter
15:08:01 <zodbot> Current chairs: Kevin_Kofler jgrulich jreznik ltinkl rdieter than
15:09:06 <ltinkl> jreznik: you mean new interesting features for F18?
15:09:19 <jreznik> ltinkl: yep
15:09:42 <jreznik> anything else?
15:11:28 <jreznik> ok, let's start
15:11:47 <jreznik> #topic Introduction of a new KDE SIG team member (jgrulich)
15:11:54 <jreznik> jgrulich: your turn :)
15:12:50 <jgrulich> My name is Jan Grulich, i'm new intern in RH and i'm studying at Palacky University Olomouc :)
15:13:16 <jreznik> jgrulich: tell guys about your upstream contributions :)
15:14:10 <rdieter> jgrulich: welcome
15:14:24 <jreznik> and yep, welcome :)
15:14:37 <Kevin_Kofler> As I already said: Welcome on board!
15:15:01 <jreznik> #link http://grulja.wordpress.com/
15:15:26 <jgrulich> i'm workin on google plasmoids. It was my bachelors work.
15:17:44 <jreznik> and btw. as you all know, I'm now the fedora program manager, it means less Fedora KDE work from my side (as a job), more as a contributor :) so I'm still here, still around! and we have jgrulich, so everything is fine :)
15:18:32 <jreznik> #info please welcome Jan Grulich (jgrulich) as a member of KDE SIG team
15:19:45 <Kevin_Kofler> jgrulich: Looking at your blog, those are actually general Akonadi plasmoids with an option artificially restricting them to Google services by default, aren't they? I'd suggest defaulting ALL_COLLECTIONS to ON now that your thesis is complete unless there's a strong technical reason not to.
15:21:10 <jgrulich> ALL_COLLECTIONS=ON is now default option, but i want rewrite this plasmoids to QML in future without dependency on Google
15:21:51 <jreznik> another QML into face of Kevin_Kofler :)
15:22:13 <Kevin_Kofler> Why is everything being rewritten in QML? What a waste of time, rewrite to get something slower. :-(
15:22:27 <ltinkl> jreznik: :D
15:23:31 <Kevin_Kofler> But we're getting really off topic here.
15:23:34 <jreznik> ok, anything else on the topic? any task for jgrulich for the beginning? :)
15:24:20 <jreznik> #topic Features
15:24:50 <jreznik> http://fedoraproject.org/wiki/Features/KDE49 was approved on Monday's meeting, thanks guys for help with it!
15:25:39 <Caterpillar2> is it in rawide repos?
15:25:49 <jreznik> #info KDE Plasma Workspaces 4.9 approved as Fedora 18 Feature
15:26:08 <jreznik> Caterpillar2: yep, not everything, it's still WIP
15:26:20 <jreznik> but the latest bits are availabe there
15:26:22 <Kevin_Kofler> 4.9.0 isn't even released yet.
15:26:33 <rdieter> Caterpillar2: and kde-unstable repo (4.8.97 currently)
15:26:34 <Kevin_Kofler> We have the latest prerelease.
15:26:34 <Caterpillar2> ok
15:26:54 <jreznik> Kevin_Kofler: ok, pre-release but it's looking good
15:27:46 <ltinkl> it's rock solid, no problem encountered so far
15:28:10 <ltinkl> rdieter: can I ask for kde-l10n? :)
15:28:25 <rdieter> ltinkl: ftbfs
15:28:29 <ltinkl> oh
15:28:34 <ltinkl> ok, nvm
15:28:43 <Kevin_Kofler> Why is kde-l10n always broken? :-(
15:28:45 <rdieter> err, nevermind, that's calligra-l10n I was thinking of
15:29:07 <jreznik> btw what about the virtuoso issue and 4.9? we have 6.1.5...
15:29:11 <rdieter> sorry, i'll try to look at it today (unless someone else beats me to it)
15:29:15 <jreznik> rdieter: yep, calligra rc
15:31:22 <jreznik> phone call
15:32:01 <rdieter> arg, virtuoso has been available since march, and only now we hear that it has some serious regression. :(
15:32:03 <jreznik> guys, what about the virtuoso issue?
15:32:09 <jreznik> rdieter: yep, it's there
15:32:13 <jreznik> does not work at all
15:32:17 <jreznik> with 4.9
15:32:21 <ltinkl> [17:21] <afiestas> ltinkl: short, Virtuoso maintainer (developer) is asking me to connect him to the packagers of the most used distros
15:32:29 <ltinkl> from #solid
15:32:36 <rdieter> so, apparently options are to go back to 6.1.4 or wait for 6.1.6 available soon. I say wait for 6.1.6
15:32:54 <rdieter> soon = a few days, reportedly
15:33:05 <Kevin_Kofler> Wait for 6.1.6, revert to 6.1.4 with the Epoch bump if 6.1.6 doesn't come in time for F18.
15:33:18 <ltinkl> rdieter: I told afiestas to connect the virtuoso maintainer with you and to stop by #fedora-kde
15:33:44 <rdieter> i'm listening in #nepomuk-kde and #openlink-virtuoso already
15:33:54 <ltinkl> so we should hopefully hear back from him soon
15:34:15 <rdieter> ok
15:34:43 * rdieter is cloning virtuoso githum repo, to start testing a snapshot build
15:34:50 <rdieter> github even. :)
15:35:18 <Kevin_Kofler> There have been some user complaints about 6.1.5 a few days ago, it looks like the developers now acknowledge that it's broken. I wonder why it wasn't noticed sooner.
15:35:54 <rdieter> apparently it worked ok with 4.8, but 4.9 stuff tickles the regression (more?)
15:36:20 <rdieter> but that's just hearsay
15:37:28 <rdieter> ok, confirmed, folks in #nepomuk-kde just said 4.8 is fine
15:39:23 <jreznik> ok
15:39:26 * jreznik is back
15:39:45 <jreznik> Kevin_Kofler: +1 for the proposal
15:40:09 * jreznik is +1 to wait (but would like to see it before GA for proper testing - by beta max)
15:40:44 <ltinkl> a new mail about Virtuoso 6.1.5 being buggy just arrived to kde-packager
15:41:33 <ltinkl> "Virtuoso 6.1.4 is fine. And the virtuoso team have notified us that they'll be release 6.1.6 in a couple of days"
15:42:02 <Kevin_Kofler> That's why I was saying "it looks like the developers now acknowledge that it's broken". :-)
15:42:34 <Kevin_Kofler> Hopefully the "couple" of days won't be too many. :-)
15:43:18 <jreznik> so, everyone agrees with waiting for that few days (let's hope for a few days and not a few years ;-)
15:43:23 <jreznik> ?
15:43:58 <Kevin_Kofler> I already said I agree. :-)
15:44:00 <than> jreznik: +1, -1 for few years :)
15:44:09 <rdieter> else, I can work on packaging a 6.1.6 snapshot
15:44:47 <jreznik> #agreed to wait for 6.1.6, revert to 6.1.4 with the Epoch bump if 6.1.6 doesn't come in time
15:45:13 <jreznik> rdieter: let's add snapshot to the proposal
15:45:36 <jreznik> but if it will be released soon, I'm not sure it's worth investing time to create snapshot
15:46:29 <rdieter> sure, it's just insurance if a couple of days, ends up being weeks... :)
15:46:44 <jreznik> rdieter: yep
15:47:31 <Kevin_Kofler> A snapshot is an acceptable fallback solution if it actually fixes the problem.
15:47:49 <jreznik> do we have a reference commit that fixes the issue?
15:48:36 <ltinkl> I doubt it has been fixed already
15:49:11 <rdieter> no details about what is broken or what fixes it. :-/
15:49:40 <jreznik> ok, so for now - it's nonsense to create a snapshot
15:50:15 <jreznik> and back to topic - there's a new feature ready for fesco - https://fedoraproject.org/wiki/Features/AvahiDefaultOnDesktop - do we want to join the train and enable Avahi by default for our spin (how much do we use Avahi?)...
15:52:09 <Kevin_Kofler> Let everyone in your LAN (which can be a whole cable ISP or even the whole Internet in some configurations) print to your printer etc. by default? Sounds like a horrible security nightmare to me.
15:52:27 * rdieter isn't too famliliar with it, but tentative +1 to join and enable
15:53:06 <rdieter> avahi is only about discovery.... I thought
15:53:08 <jreznik> Kevin_Kofler: ...even on possibly otherwise "hostile" networks...
15:53:30 <jreznik> rdieter: but you know...
15:53:37 <Kevin_Kofler> Hmmm, avahi both exports and imports stuff, it seems.
15:53:37 <jreznik> Kevin_Kofler: read https://fedoraproject.org/wiki/Desktop/Whiteboards/AvahiDefault
15:54:08 <Kevin_Kofler> Enabling it by default will make importing "just work", but we need to be sure that things aren't shared (exported) if this hasn't been explicitly requested.
15:54:09 <jreznik> so seems like current Avahi defaults should be ok
15:54:25 <jreznik> but "should"...
15:54:40 <rdieter> jreznik: right, and if it isn't, fix it. :)
15:54:42 <Kevin_Kofler> Having discovery of services shared by other machines just work by default makes sense.
15:55:47 <ltinkl> and how does this affect KDE?
15:55:53 <jreznik> the discovery part is ok for me, it was patched to not export sensitive stuff... so...
15:56:16 <jreznik> ltinkl: that's the question how far is avahi stuff available in kde
15:56:20 * jreznik is not sure
15:56:45 <ltinkl> there is AFAIK a kio slave but that's it
15:57:06 <ltinkl> zeroconf:/
15:58:23 <jreznik> anyone volunteer to investigate what can we gain by using avahi? if it is worth or not?
15:58:26 <ltinkl> Dolphin -> Network -> Network Services
15:58:41 <ltinkl> or any Open/Save dialog
15:59:06 <ltinkl> it just prints an error message about mdnsd not running
15:59:33 <ltinkl> could be a nice research task for jgrulich :)
16:00:20 <rdieter> seems to be running on my box, Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled)
16:00:39 <Kevin_Kofler> rdieter: It's currently enabled, but firewalled, by default.
16:00:42 <rdieter> seems also to include dbus and socket activation.
16:00:49 <Kevin_Kofler> (which makes it kinda useless)
16:00:53 <rdieter> oh heh, firewall
16:01:31 <Kevin_Kofler> I wonder if the feature won't actually already enable Avahi for KDE without us having to do anything.
16:01:38 <jreznik> yep, firewall is one part of that feature
16:01:39 <Kevin_Kofler> I think the idea is to just stop firewalling Avahi when installed.
16:01:49 <ltinkl> yup
16:01:59 <jreznik> Kevin_Kofler: the feature is going to be enabled only on desktop spin
16:02:03 <ltinkl> the question how (well) it works in KDE then
16:02:04 <jreznik> by default
16:02:29 * ltinkl notes we're running out of time
16:02:50 <jreznik> so yeah, for us - it's just make sure avahi is running too and not firewalled, the rest is done by avahi guy
16:03:04 <jreznik> ltinkl: yep :)
16:03:06 <Kevin_Kofler> jreznik: It's not clear from the feature page what exactly they want to change and how.
16:03:16 <Kevin_Kofler> I guess default firewall settings, but those really should NOT be spin-specific!
16:03:28 <ltinkl> no no, the task for us is to make sure it works in KDE after having been enabled :)
16:03:35 <Kevin_Kofler> Avahi should just be trusted by default by the firewall settings if that's the goal.
16:03:53 <jreznik> Kevin_Kofler: I also think it should not be spin specific, that's why I brought it here if we want to join (in case it's going to be implemented only on desktop spin)
16:04:05 <jreznik> ltinkl: yep
16:04:11 <jreznik> ok, we are 4 minutes over...
16:04:17 <Kevin_Kofler> This feature needs to be sent back to the feature owners to ask for clarification.
16:04:33 <jreznik> I'm going to close the meeting -> #fedora-kde - thanks
16:04:58 <jreznik> Kevin_Kofler: it's up to FESCo, my job is to take a look, try to reach people but FESCo has to decide it
16:05:13 <jreznik> Kevin_Kofler: pls add it to Talk section, the best think we can do now :)
16:05:28 <jreznik> #endmeeting